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What is Remote DeskLink for Windows 95?
REMOTE DESKLINK FOR WINDOWS 95 lets you connect to a remote computer and work as if you
were directly in front of the computer, running programs and accessing files. You can also �chat�
with someone sitting in front of the remote computer during a Remote Control session. You can
connect using a modem, network, or Dial-Up Networking. Connect to other DeskLink users, or
connect to computers running LapLink for Windows.

Remote DeskLink® for Windows® 95 provides immediate connection to 
your desktop from wherever you may be. Use DeskLink to connect to 
your office computer from home in order to do some work, to access 
office files when you�re on the road, or to connect to a friend�s computer 
to help them with a computer task or work on a project.

Remote Control lets you operate another computer at a distance. After 
you connect to another computer and open a Remote Control session, 
your mouse moves the mouse pointer on the remote computer, your key-
board types characters on the remote computer, and your Remote Con-
trol window shows the remote computer�s screen.

Chat lets you �talk� with someone at another computer, exchanging 
messages in a written conversation. When you have only one phone 
line, you can chat with someone using DeskLink while you are control-
ling their computer using Remote Control.

Understanding Remote Control

You can remotely control another computer, or allow another computer 
running DeskLink or LapLink for Windows to control your computer. 
When you open a Remote Control window on your computer, you 
become a Remote Control guest, and the remote computer displayed on 
your screen becomes the host. 

■ A computer set up 
with DeskLink can act 
as either a Remote 
Control host or a 
Remote Control 
guest.

Guest  When you�re a guest, the host images appear on your screen in a 
Remote Control window within the DeskLink program. You use your 
mouse and keyboard to operate the host computer, and your work is 
done on the host computer. 

Host  When you set up your computer to be a host, you can set up secu-
rity on it so that no unauthorized users can work on your computer, and 
you can control whether the guest has exclusive use of the mouse and 
keyboard when connected.

There is no special procedure associated with becoming a host. Your 
computer need only be running DeskLink and set up to allow incoming 
connections. You do not need to be at your computer. On the other 
hand, you may want to join the guest as an observer or as an active par-
ticipant.
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Connection methods

■ You cannot open a 
connection to a 
remote computer 
unless the default 
security setup on that 
computer has been 
changed to grant you 
access. For more 
information about 
security, see page 6.

You can connect to remote computers (or allow other computers to con-
nect to you) by using a modem or connecting over a network.

You can also take advantage of the Dial-Up Networking feature of Win-
dows 95 to connect by modem to other network computers running 
DeskLink. Using this modem-to-network connection increases your 
choice of connections.

Connecting to computers running LapLink for Windows

Remote DeskLink for Windows 95 can be used to connect to computers 
running Traveling Software�s LapLink for Windows. You can connect to 
LapLink computers or let LapLink computers connect to your computer, 
and you can use Remote Control and Chat.

Connecting to DeskLink

With DeskLink, you can con-
nect to a remote computer 
(the host) and work on that 
computer as if you were in 
front of it.

If you�re remote controlling 
someone else�s computer, and 
they�re in front of the com-
puter, you can use the Chat 
feature to talk to the other user 
while controlling their com-
puter.

Host

Guest

BUZZSAW.FM  Page 3  Wednesday, October 22, 1997  11:36 AM



Remote DeskLink for Windows 95 Introduction and Installation

4

Installing DeskLink
BEFORE YOU CAN CONNECT to another computer, DeskLink must be installed and running on both
computers. When you install DeskLink, you choose between two types of installation: Express and
Custom. Choose Custom to determine exactly which ports and devices are enabled during instal-
lation. To begin installing from a CD-ROM, insert the CD-ROM and click Install Remote DeskLink
Now! To begin installing from floppy disks, double-click Add/Remove Programs in Control Panel.

Types of installation

Setup asks you which type of installation you want. There are two types:

■ Express Installs all DeskLink files, with a minimum of prompting.

■ Custom Installs according to your directions. Choose Custom to spec-
ify exactly the types of communications you want available to you in 
DeskLink.

By default, Setup automatically enables any connections by network 
(both IPX and TCP/IP), modem, and Dial-Up Networking which are 
installed on your computer. In a Custom installation, you can disable 
any network or modem connections you do not intend to use in 
DeskLink (and still leave them enabled for use in other programs).

Installing the software

■ To create floppy 
disks so that you can 
install DeskLink on 
another computer, 
click Create Setup 
Disks! on the DeskLink 
welcome screen. 

1 Insert the DeskLink CD-ROM in a CD-ROM drive.

Or if you downloaded DeskLink from the Web, double-click the 
Welcome.exe file in the folder where you downloaded DeskLink.

2 Click Install Remote DeskLink Now! on the Welcome screen.

3 Specify your serial number and computer name.

The name you give your computer will be seen by others when you 
connect to their computers and when others are connecting to yours. 
You can change the name in DeskLink anytime after installation.

4 Choose Express or Custom Setup, and follow the Setup instructions.

To install DeskLink from floppy disks:

■ To remove 
DeskLink, use the 
Add/Remove Pro-
grams feature in Con-
trol Panel.

1 Insert the first floppy disk in the drive.

2 Click the Windows 95 Start button, point to Settings, and then click 
Control Panel.

3 Double-click Add/Remove Programs.

4 On the Install/Uninstall tab, click Install. Then follow the instructions 
on your screen.
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Using Custom Setup

■ After Setup you 
can always change 
port settings in 
DeskLink by clicking 
Port Setup on the 
Options menu.

If you choose to perform the Custom Setup, you�ll have a chance to set 
up your modem and network ports, as described below.

Modems  DeskLink can communicate over any modem installed in Win-
dows 95, using the Windows 95 settings. Giving Windows 95 control of 
modems simplifies their use in different communications programs; you 
do not have to configure a modem separately for each program. 

By default, Setup makes Windows 95 modems available to DeskLink and 
gives control to Windows 95. However, you can make your Windows 95 
modems unavailable to DeskLink.

To make Windows 95 modems unavailable to DeskLink:

■ In the Port Configuration dialog box, click the Modems button. Then 
click Enable Windows Modems so that it is cleared.

■ You can use net-
work and Dial-Up 
Networking connec-
tions in DeskLink only 
if they have been 
installed in Windows 
95.

Networks  Setup automatically enables communications over any IPX 
and TCP/IP networks installed on your computer under Windows 95. 
However, you can make a network connection unavailable to DeskLink.

To make a network connection unavailable to DeskLink:

■ In the Port Configuration dialog box, click the Network button, and 
then click the appropriate network connection so that it is cleared.

Dial-Up Networking  If you have Dial-Up Networking installed on your 
computer, Setup automatically enables this feature for use in DeskLink. 
Custom Setup tells you whether Dial-Up Networking is available on your 
computer but does not let you change its status.

Configuring DeskLink connections during Custom Setup

When you perform a Custom 
Setup, you can change the types 
of connections that will be avail-
able when you run DeskLink.

In the Port Configuration dialog 
box, you see the connections 
Setup has enabled for you.

To enable or disable a connec-
tion, click the appropriate but-
ton.
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Connecting to another computer
USING DESKLINK, you can connect to another computer by network, modem, or Dial-Up Network-
ing. The other computer must be running DeskLink (or LapLink for Windows), and its security set-
tings must have been changed to allow incoming connections. After you�ve connected, you can
use Remote Control and Chat. You can open Remote Control and Chat while you connect to
another computer or after you�ve connected.

■ To connect two 
computers, DeskLink 
(or LapLink for Win-
dows) must be run-
ning on both.

Before you can connect two computers, both must be running DeskLink 
(or LapLink for Windows). You can then connect by network, modem, or 
Dial-Up Networking. Which type of connection you choose depends 
mostly on where the remote computer is. If you�re in the same company, 
you might use a network. If you�re in separate locations, not connected 
by network, use a direct modem connection or a Dial-Up Networking 
connection. You can connect in different ways at different times or even 
in the same session.

Relaxing security to allow incoming connections

Security settings must be relaxed to allow an incoming connection by 
network or modem. Initially, DeskLink allows you to make outgoing 
calls, but nobody can connect to your computer. Likewise, you can con-
nect only with remote computers that allow incoming connections.

■ See the DeskLink 
online help for infor-
mation on tightening 
security by creating a 
Log-in List.

To change the security settings:

1 Start DeskLink.

2 Click the Security button on the LinkBar.

3 On the General tab, click Anybody (Public System).

! Selecting Anybody (Public System) makes your computer and its 
files completely open to anyone who can connect to your com-
puter. 

4 Click Remote Control and Chat so that they are checked.

5 Click OK.

Making a connection

You start a DeskLink session by connecting to another computer.

To make a connection:

■ See the DeskLink 
online help for more 
information on using 
the different connec-
tion methods.

1 Click the appropriate Connect Over button on the LinkBar, or click 
one of the Connect Over commands on the Connect menu. 

2 In the Connect dialog box, under Services, click Remote Control or 
Chat so that it is checked. You must open at least one window (either 
Remote Control or Chat) in order to connect.
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Opening a Remote Control window

When you connected to the remote computer, you may have opened a 
Remote Control window. Otherwise, you can open a Remote Control 
window at any time during a connection.

■ If you prefer to dis-
play the host screen 
across your entire 
screen instead of in a 
window, press 
CTRL+SHIFT+F. For 
more information, see 
the next section.

To open a Remote Control window after opening a connection:

■ Click the Open Remote Control Window button on the LinkBar. Or 
click Open Remote Control on the Window menu.

✔ If you have more than one connection open, select the Chat window 
of the desired connection before opening Remote Control.

Opening a Chat window

■ To find out how to 
use Chat to commu-
nicate with the other 
computer, see page 
20.

When you connected to the remote computer, you may have opened a 
Chat window. If not, you can open one at any time.

To open a Chat window:

■ Click the Open Chat Window button on the LinkBar. Or click Open 
Chat on the Window menu.

✔ If you have more than one connection open, select the Remote Con-
trol window of the desired connection before opening Chat.

Relaxing security and opening connections

In Security�

Click Anybody (Public System) to 
allow access to your computer without 
password protection.

Click services to make them available 
to other users.

Connect by�
Network Dial-Up NetworkingModem

Disconnect Security

Remote Control Chat
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Controlling another computer�Viewing the host
AS A GUEST, you can alternate between two views of the host screen. Your first view appears in a
window within DeskLink. Inside the window, you control the host; outside the window, you per-
form other tasks, in DeskLink or in other applications on your computer. Switch to a full-screen
view when you want to maximize your view of the host and use Remote Control exclusively. If you
cannot see the entire host screen even in full screen, you can change the resolution of the host
screen or scale its image to fit within your view.

Devoting your entire screen to a view of the host

You can view the host screen in two ways:

■ In a window within DeskLink (the default)

■ As a full-screen display, hiding DeskLink and the rest of your Win-
dows workspace

In a window view, you have quick access to Chat, and other DeskLink 
features. You can also switch to other applications on your computer.

To maximize the area in which you view and control the host, switch to a 
full-screen view. Your entire screen is now devoted to controlling the host; 
you do not have access to your own applications. When you want to do 
something other than control the host, switch back to the window view.

To switch between window and full-screen view:

■ You can substitute 
another key combina-
tion for 
CTRL+SHIFT+F. For 
more information, 
see the next section.

■ Press CTRL+SHIFT+F.

✔ In full screen, you can also switch to a window from the copy of 
DeskLink running on the host: If DeskLink is an icon, click it to restore it 
to a window. Then click the icon representing your Remote Control win-
dow, and click Guest Full Screen to remove the check mark.

✔ To make Remote Control alternate between full screen and icon, 
bypassing the window view, click Remote Control Options on the 
Options menu. On the Guest tab, click Always Use Full-Screen so that it is 
checked.

Viewing the entire host screen at once

There are two ways to fit the host screen into your view:

■ From your computer, lower the resolution of a higher-resolution host 
screen to match that of your screen.

■ Scale the image of the host screen to fit within your view.
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■ You cannot lower 
the resolution of a 
host computer unless 
its monitor and dis-
play adapter allow the 
change without 
restarting Windows.

Temporarily changing the resolution of the host screen  When using a 
laptop to control a desktop, you normally can�t view the entire host 
screen at once, since a desktop typically operates at a higher screen reso-
lution. From your laptop, you can lower the desktop�s screen resolution 
to match your laptop�s.

You can then view all of the host screen in full-screen view. The original 
resolution is restored automatically on disconnect or at your direction.

To lower the resolution of the host screen to match that of your screen:

1 On the Options menu, click Remote Control Options.

2 On the Guest tab, click this option so that it is checked: Match Host to 
Guest.

Clicking the option again restores the host to its original resolution.

3 Click OK.

■ In full-screen view, 
you can also scale the 
image of the host 
screen by clicking the 
icon in the host�s 
DeskLink workplace 
which represents 
your connection. 
Then click Guest 
Scale to Fit.

Scaling the image of the host screen to fit  You can also view the entire 
host screen at once by scaling the image to fit your view of it. You always 
see all of the host�s screen, whether you are working in full screen or win-
dow, though the image may be distorted.

To scale the image of the host screen to fit within your view:

■ Press CTRL+SHIFT+S.

Pressing CTRL+SHIFT+S again restores the image to normal.

Alternating between a window and a full-screen view of the host

CTRL+SHIFT+F

By default, your view of the host screen 
appears in a window within DeskLink.

When you switch to full-screen view, the 
host screen occupies your entire screen, hid-

ing your local Windows 95 workspace.
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Controlling another computer

Customizing keyboard control

BY DEFAULT, Windows system keys pressed on the guest computer take effect on the host. If you
want the system keys to operate on the guest while working in a Remote Control window, click
Remote Control Options on the Options menu. Then on the Guest tab, click Execute on Guest.
Through Remote Control Options, you can also change the key combinations that control your
view of the host.

Windows system keys

■ Windows system 
keys are keys that take 
effect in Windows; 
other key combina-
tions, like CTRL+C or 
CTRL+BREAK, that 
affect DOS sessions, 
are not affected by 
DeskLink settings.

Windows system keys are key combinations that perform a variety of 
tasks. Pressing ALT+TAB, for example, switches to the program you used 
last. By default, DeskLink sends most system keys to the host during 
Remote Control: pressing ALT+TAB on the guest, therefore, switches to 
the program last used on the host.

You can make system keys work on your own computer (the guest) when 
you are working in a Remote Control window. 

✔ Windows system keys (except CTRL+ALT+DELETE) always take effect 
on the host when you are using Remote Control in the full-screen view.

■ If you intend to 
control a remote 
computer using the 
keyboard exclusively 
(without a mouse), 
set the Windows sys-
tem keys to execute 
on your computer 
(the guest). When 
you want the keys to 
execute on the 
remote computer (the 
host), switch to the 
full-screen view.

To execute Windows system keys on the guest:

1 Click Remote Control Options on the Options menu, and then click 
the Guest tab.

2 Click Execute on Guest.

3 Click OK.

✔ CTRL+ALT+DEL always takes effect on the guest, regardless of this set-
ting. To send CTRL+ALT+DEL to the host to reboot it, click the Reboot 
Host command in the Session menu during a Remote Control session. 
(You must have permission from the host in order to reboot it.)

Remote Control shortcut keys

DeskLink offers two shortcut keys to change your view of a host screen. 
Pressing CTRL+SHIFT+F switches between full-screen and window view 
of the host. Pressing CTRL+SHIFT+S switches between scaled-to-fit and 
normal view. (See the previous section for more information.)

You can change these default key combinations to certain other combi-
nations. (To avoid interference with other DeskLink and Windows short-
cut keys, you are limited in your choice of replacements.)

To change the DeskLink shortcut key combinations:

1 Click Remote Control Options on the Options menu.
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2 On the Guest tab, click in one of these boxes:

■ Full-screen Toggle Changes the shortcut key that alternates 
between full screen and window.

■ Scaling Toggle Changes the shortcut key that alternates between 
scaled-to-fit and normal view.

3 Press any of the following key combinations:

SHIFT+ALT+N (where N is a number or letter)
CTRL+SHIFT+N (where N is a number or letter)
CTRL+ALT+N (where N is a number or letter)
CTRL+SHIFT+ALT+N (where N is a number or letter)

Customizing keyboard options in Remote Control Options

When you are working in a Remote Con-
trol window, the Windows system keys 
you press on your computer (the guest) 
take effect on the remote computer.

If you prefer to have system keys take 
effect on your computer, click Execute on 
Guest.

With this option, you can change the 
shortcut key that alternates between full-
screen and window view.

With this option, you can change the 
shortcut key that alternates between 
scaled to fit and normal view.
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Controlling another computer

Locking and rebooting the host

AS A GUEST, you can ensure privacy and prevent interruptions by blanking the host�s screen, lock-
ing its keyboard, and disabling its mouse. You can also reboot the host computer. To perform any
of these operations, click the appropriate command on the Session menu. If the commands are
not available, the host computer has not granted permission to lock or reboot.

■ Permission to lock 
and reboot the host is 
granted by the host. 
For more informa-
tion, see page 16.

Locking the host

With the permission of the host computer, you can:

■ Blank the host screen The host�s screen is darkened, preventing your 
work from being viewed at the host.

■ Disable the host keyboard The host�s keyboard is locked, preventing 
anyone at the host from using the keyboard to interrupt your work.

■ Disable the host mouse The host�s mouse is locked, preventing anyone 
at the host from using the mouse to interrupt your work.

To lock the host during a remote control session:

■ On the Session menu, click one of these commands so that it is 
checked: Blank Host Screen, Lock Host Mouse, or Lock Host Keyboard.

✔ If a command is dimmed, it is not available: Either the host cannot 
perform the action, or the security setup of the host computer does not 
allow it. For more information about the security setup, see page 16.

✔ To disable locking, click the command again to remove the check 
mark.

✔ Through Address Book, you can request the kinds of locking you want 
to take effect as soon as you open a Remote Control session. Your 
requests will be honored as long as they are allowed by the host. For 
information on using Address Book to make connections, see the online 
help.

Rebooting the host

As a guest, you may want to restart a host computer to put into effect 
changes you have made on that computer. Or you may want to restart a 
host computer to ensure that no one else can call in after you disconnect.

To reboot the host from the guest:

■ On the Session menu, click Reboot Host.

You are then asked for confirmation. If you have not saved your work, 
you are asked if you want to do so before rebooting.
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✔ If Reboot Host is dimmed on the Session menu, the host has not set 
the option to allow rebooting by a guest. For more information, see 
page 16.

Locking and rebooting the host from the guest

Reboot Host restarts the host 
computer from the guest. It 
cannot be used unless the 
security setup of the host 
computer has been modified 
to allow it to be restarted.

To ensure privacy and pre-
vent interruptions at the 
host, blank the host screen 
and lock its mouse and key-
board.

A check mark beside a com-
mand means the protection 
is in effect. Clicking the com-
mand again removes the 
check mark�and the pro-
tection.

If the commands appear 
dimmed on your Session 
menu, the security setup of 
the host computer must be 
changed to allow their use.
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Hosting a Remote Control session
WHEN YOU ALLOW your computer to be remote controlled, you become the host to a guest com-
puter. For Remote Control to take place you need only be running DeskLink�you do not need to
be at your computer. Sensitive information is protected by the conditions of the connection. You
can grant greater access, or limit these conditions, through the DeskLink security system.

■ To allow other 
computers to control 
your computer by 
modem or network, 
you must relax the 
security setup estab-
lished during installa-
tion. (See page 6.) 
The only other action 
needed to prepare a 
host is to run 
DeskLink.

As a host, you have control over who can connect to your computer and 
the kinds of services the guests can use. For example, you can limit a 
guest to Remote Control only, or you can allow access to Chat as well. 
You can even allow a guest to blank your computer�s screen or disable the 
mouse and keyboard. All of these options are set in the DeskLink security 
system.

You can leave the host computer unattended, giving an authorized user 
exclusive control. Or you can stay at the computer and interact with the 
guest by trading off control. For example, the two of you could edit a 
document together, participate in a training session, or explore a new 
program.

✔ A computer can serve as a host to only one other computer at a time. 
In the meantime, other computers can open Chat connections to the 
host.

What you see as a host

■ You can make the 
DeskLink workplace 
remain a window 
when a guest con-
nects: click Remote 
Control Options on 
the Options menu, 
and then click the 
Host tab. Click this 
option so that it is 
cleared: Minimize 
when this computer is 
a host.

When a guest connects to your computer and begins Remote Control, 
your DeskLink workplace is minimized. When you double-click the icon, 
the DeskLink workplace is restored to a window.

At the bottom of the restored DeskLink workplace, you see an icon for 
the incoming Remote Control connection. The icon is identified by the 
name of the remote computer. Clicking this icon displays a Windows 
menu with standard commands. Clicking Close closes the Remote Con-
trol connection.

Reversing a Remote Control session

There may be times when the guest and you want to switch roles so that 
you become the guest controlling the remote computer.

To reverse the direction of Remote Control, the current Remote Control 
connection must be broken on either computer. Then, as the prospective 
guest, you open a Remote Control window and begin controlling the 
other computer.
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To reverse a Remote Control session:

■ DeskLink only 
closes a connection if 
all services running 
over that connection 
are closed. Opening a 
Chat window pre-
vents the connection 
from being closed.

1 Open a Chat window to the other computer, if a Chat window is not 
already open.

2 Close the Remote Control window.

3 Have someone at the other computer open a Remote Control window 
to your computer.

Hosting a Remote Control session

To prepare a computer to host a
Remote Control session, start

DeskLink and leave it running.

There is no special host setup
procedure.

To allow a computer to serve as a 
host for the first time, you must 
change the security setup.

The default setup prevents incoming 
connections by modem or network.
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Hosting a Remote Control session

Configuring a host to be locked and rebooted

BY DEFAULT, no guest can �lock� the host computer in any way�whether by blanking the screen
or disabling the keyboard or mouse. Nor can a guest reboot the host. Through the security sys-
tem on the host, you can grant guests permission to lock the host. And through the Remote Con-
trol Options command on the Options menu, you can grant guests permission to restart the
computer.

Configuring a host for locking

■ As a host, you can 
keep guests from 
changing your lock-
ing and reboot set-
tings during Remote 
Control sessions by 
setting up password 
protection for your 
security system. For 
more information, 
see the online help.

You can configure a host to determine who can lock it and how it will be 
locked. Guests cannot lock the host without your permission.

There are three kinds of locking you can permit on the host:

■ Blank the screen

■ Disable the mouse

■ Disable the keyboard

Whether you permit any kind of locking depends on how you intend to 
use DeskLink. If you want to use Chat, for example, there should be no 
locking.

Locking permission is granted by changing the security setup on the host 
computer: click the Security button on the LinkBar. You then have a 
choice:

■ Open the system to any user by clicking Anybody (Public System). 
Click Remote Control so that it is checked, and then click any of the 
three options under Locking. The permissions will apply to all guests.

■ Set up a Log-in List by clicking Log-in List (Protected System) and add-
ing one or more entries. In each entry, click any of the three options 
under Locking Permissions. The permissions will apply only to guests 
whom you provide with the appropriate log-in name and password.

For more information about changing the security setup, see page 6.

Configuring a host for rebooting

You can configure a host to allow any guest to restart it during a Remote 
Control session. You can also require that the host be restarted whenever 
a Remote Control connection is broken.

To configure a host computer for rebooting:

1 On the Options menu, click Remote Control Options.

2 Click the Host tab.
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3 Under Rebooting This Computer, click either one or both of these 
options:

■ Allow guest to reboot on command Click this option to allow guests 
to restart the host using the Reboot Host command on their com-
puters.

■ Always reboot when guest disconnects Click this option to automati-
cally restart the host whenever any guest breaks a connection or the 
connection is broken accidentally.

4 Click OK.

Ensuring access after a reboot

At the same time you are configuring a host for rebooting, you can con-
figure it so that the guest will be able to resume a DeskLink connection 
after the host is rebooted. The host will run DeskLink when Windows is 
started, allowing the guest to call back in and use Remote Control to log 
on to Windows and a network.

To configure a host to so that it automatically runs DeskLink each 
time Windows is started:

■ On the Host tab of Remote Control Options (Options menu), click this 
option so it is checked: Always start DeskLink before Windows 95 
logon.

DeskLink will now be started each time you start Windows.
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Transferring information between computers using the 
clipboard
COMPUTERS IN A REMOTE CONTROL CONNECTION share a common clipboard: You can copy or cut
information to the clipboard on one computer and paste this information on another. Only infor-
mation put in the clipboard during Remote Control is available to other computers.

■ Clipboard informa-
tion can be shared 
only in connections 
between computers 
running DeskLink or 
version 7.5 of LapLink. 
Older versions of 
LapLink do not sup-
port sharing clip-
boards.

When you cut or copy information for pasting in another document, the 
information is stored temporarily in the clipboard. Normally, clipboard 
information is transferred between documents on the same computer. 
When you use Remote Control, however, you can use the clipboard to 
transfer information from one computer to another. You can copy text or 
graphics on the host computer, for example, and paste it on the guest.

If you are controlling several computers at the same time, information 
you cut or copy on any of the linked computers can be made available 
for pasting on any of the others.

✔ Only information placed in the clipboard during Remote Control can 
be pasted on other computers. You cannot share any information copied 
or cut to a clipboard before a Remote Control connection is opened.

✔ When you clear the contents of the clipboard on one computer, you 
clear the contents of all the other clipboards as well.

Sharing information using the clipboard

To share information using the clipboard, copy it from one computer�s 
document, and paste it into a document on the connected computer.

To share information using the clipboard:

1 With a Remote Control session running, copy information from a 
document on the first computer (either on the host or the guest).

2 On the second computer, open the document where you want to 
paste the information, and use that program�s Paste command

Pasting from the clipboard during Remote Control

When you copy or cut information to the clipboard during Remote Con-
trol, only a small part of the information is transferred to the other com-
puter immediately. The rest of the information is transferred when you 
paste.

To prevent the loss of information added to the clipboard during Remote 
Control, paste the information before disconnecting.

If you are controlling several remote computers, information in the clip-
board on your computer is available to any of the remote computers. If 
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you want to transfer clipboard information from one remote computer 
to another, however, you must first paste the information into a docu-
ment on your computer; then paste it on another remote computer.

Disabling clipboard sharing

To disable clipboard sharing:

1 Open a Remote Control connection to another computer.

2 On the Edit menu, click Link Clipboards to remove the check mark.

If there is data in the common clipboard that hasn�t been transferred 
completely, you are asked whether to complete the transfer.

✔ To enable clipboard sharing again, repeat the procedure to restore the 
check mark to Link Clipboards. Only data placed in the clipboard after 
you enable this option can be shared with other computers.

Sharing clipboard information during Remote Control

Copy

Paste

When you are controlling 
another computer, the two 
computers share a common 
clipboard.

You can cut or copy text or 
graphics on either computer 
and paste it on the other.

Only information placed in the 
clipboard during a Remote Con-
trol session is available to other 
computers.
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Using Chat
CHAT LETS YOU EXCHANGE typed messages with a person sitting at a remote computer. Used with
Remote Control, or by itself, Chat is useful for exchanging brief messages and sending instruc-
tions.

Opening a Chat window

When you connected to the remote computer, you may have opened a 
Chat window. If not, you can open one now:

To open a Chat window:

■ Click the Open Chat Window button on the LinkBar. Or click Open 
Chat on the Window menu.

✔ If you have opened more than one connection, click a window for the 
desired connection before opening Chat.

Sending messages

■ A Chat window 
pops to the fore-
ground on your 
screen whenever the 
remote user sends a 
message. To keep the 
Chat window from 
activating automati-
cally, click Chat 
Options on the 
Options menu. Then 
click Restore Chat 
Window Automati-
cally so that it is 
cleared.

A Chat window consists of two parts:

■ The upper part displays the messages you have sent to the remote user 
as well as those the remote user has sent to you. Each message is iden-
tified by the name of the computer from which it was sent.

■ The lower part serves as a note pad on which you write your messages. 
It clears each time you send a message.

To send a message to the remote user:

1 Click the Chat window.

2 Type your message.

Avoid pressing ENTER until your message is complete. To start a new 
paragraph, press CTRL+ENTER.

3 Press ENTER to send the message.

Pasting text into your Chat window

Instead of typing messages while connected, you can prepare them 
ahead of time and paste them into the Chat window as necessary.

To paste text into a Chat window:

1 In Notepad or another Windows text editor, select the text and copy 
it.

2 In DeskLink, click the lower part of the Chat window.

3 Click Paste on the Edit menu.
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Copying text from your Chat window

■ To reverse your lat-
est editing action in 
the lower part of a 
Chat window, click 
Undo on the Edit 
menu.

You can copy part or all of a Chat conversation and paste it into another 
Windows program.

To copy your Chat conversation:

1 In the upper part of the Chat window, highlight part of the text, or 
select the entire conversation by clicking Select All on the Edit menu.

2 Click Copy on the Edit menu.

3 Switch to another Windows program, and paste the text into that pro-
gram.

✔ As a guest during Remote Control, you can carry on a Chat conversa-
tion with the host only by viewing the host screen in a window. (In full-
screen view, you cannot see your own Chat window.) To arrange the 
Chat window beside the Remote Control window, click Tile Side by Side 
on the Window menu.

Using Chat
Chat

Read the messages from the remote 
computer�as well as your own�in 
the upper part of the Chat window.

Type your messages in the lower 
part. Press ENTER to send.
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Getting help
WHEN YOU NEED HELP getting your work done, use the DeskLink online Help system. For instruc-
tions on working in a dialog box, simply open the dialog box. A Quick Steps window appears
automatically. (To disable Quick Steps, click Quick Steps on the Help menu.) For detailed instruc-
tions on identifying and solving problems you may encounter, consult a troubleshooter: click Help
Topics on the Help menu and open the Troubleshooting book. Through Help, you can also get
explanations of items in a dialog box and buttons on a toolbar.

Refer to Quick Steps for step-by-step instructions

■ To get Help for a 
command without 
opening its dialog 
box, open the menu, 
point to the com-
mand, and press F1.

When you click a button to make a connection or choose a command 
from one of the menus, a Help window appears beside the dialog box. 
Refer to the window for a concise, step-by-step guide though the dialog 
box.

To disable Quick Steps:

■ On the Help menu, click Quick Steps to clear the check mark.

■ Even after dis-
abling Quick Steps, 
you can get Help for a 
particular dialog box 
by clicking the Help 
button in the dialog 
box.

To enable Quick Steps again, click Quick Steps to place a check mark.

Use Troubleshooting topics when you get stuck

Answers to questions most commonly asked by users appear in the Trou-
bleshooting topics. In some cases, a Troubleshooting topic takes you 
directly to the dialog box where you can find the solution to your prob-
lem.

To use Troubleshooting:

1 On the Help menu, click Help Topics. (If you have a Help window 
open, click the Help Topics button in the window instead.)

2 Click the Contents tab.

3 Click the Troubleshooting book, and then click Open.

4 Click a topic under Troubleshooting, and then click Display.

Determine what�s what on the screen

When you�re not sure about something on the screen, you can display a 
brief explanation of what it is or does.

To find out about an item on the screen:

■ Click anywhere to 
make a pop-up expla-
nation disappear.

■ In a dialog box, click the question mark button, and then click the 
item. Or use the right mouse button to click the item, and then click 
the What�s This? command.

■ On a toolbar, place the mouse pointer over a button for a second or 
two.
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Traveling Software License Agreement
IF YOU BREAK THE SEAL OR OTHERWISE OPEN THE PACKAGE CONTAINING THE SOFTWARE PROGRAM 
MEDIA, YOU ARE BY THAT ACT AGREEING TO BE BOUND BY THE TERMS AND CONDITIONS OF THIS LICENSE 
AGREEMENT.

Ownership of Software. You acknowledge and agree that all of the computer programs and associated 
documentation contained in this package (collectively, the �Software�) are owned exclusively by Traveling 
Software and/or its licensors. The Software is protected under copyright and other intellectual property laws of the 
United States and international copyright treaties. You acknowledge and agree that the price paid by you for the 
Software is a license fee granting you only the rights set forth in this License Agreement.

License. Traveling Software grants to you, and you accept, a limited, non-exclusive and revocable license to use 
the Software, in machine-readable, object code form only. You agree to use the Software only as authorized in this 
License Agreement. This License Agreement does not convey to you any ownership rights or any other interest in 
the Software.

Scope of License. This is a single-user, multiple computer license, which means you are authorized to use the 
Software on up to a total of three personal computers that are used exclusively by you (e.g., office, laptop and 
home). A valid license must be purchased for each person who will use the Software. You may only use the Software 
to link with a computer not used solely by you if the user of that computer has a valid license.

If this software is to be installed on a network server, or more than one user can run the Software, you must 
purchase an additional license for each user or work station. Please contact the location where your purchased the 
Software and this license, or contact Traveling Software, to obtain additional licenses.

You may not copy or make any changes or modifications to the Software, and you may not translate, decompile, 
disassemble, or otherwise reverse engineer the computer program(s). You may not loan, rent, lease or sublicense 
the Software or any copy to others for any purpose. You agree to use all reasonable efforts to protect the Software 
from unauthorized use, modification, reproduction, distribution or publication. You are not permitted to make 
any uses or copies of the Software that are not specifically authorized by the terms of this License Agreement, and 
Traveling Software reserves all rights that are not expressly granted to you. Your adherence to this License 
Agreement will allow Traveling Software to continue developing innovative and useful products and providing a 
high level of customer service and support.

Term. This license will become effective on the date you acquire the Software and will remain in force until 
terminated. You may terminate this license at any time by removing the Software from your computer and 
destroying the original Software and all copies. This license will automatically terminate if you breach any of the 
terms or conditions set out in this License Agreement. You agree to remove the Software from your computer, and 
either to destroy the original Software and all copies of the Software and documentation or to return them to 
Traveling Software, upon termination of this license for any reason.

Transfer. You may transfer your license of the Software to another party by transferring the original program 
media and all applicable documentation, including the original of this License Agreement, to the recipient, who 
agrees to the terms of this Agreement. All other copies of the Software must be deleted and/or destroyed. Any 
transfer of possession of the Software terminates your license and all associated benefits under this License 
Agreement. You must notify Traveling Software in writing of such a transfer.

Archival Copy. You may make one copy of this Software and associated documentation solely for backup or 
archival purposes. Alternatively, you may transfer this Software to a single hard disk drive, provided that you keep 
the original program media and accompanying documentation in your possession for backup or archival purposes. 
Any such copies of the Software or documentation shall include Traveling Software�s copyright and other 
ownership notices. No other copies of Software or documentation may be made by you or any person under your 
authority or control.

Limited Warranty. Traveling Software warrants the physical program media and physical documentation to be 
free from defects in materials and workmanship for a period of 90 days from the date of your purchase. If you notify 
Traveling Software of defects in materials or workmanship during the warranty period, Traveling Software will 
replace the defective program media or documentation or, at its option, refund the purchase price. Your remedy 
for breach of this warranty shall be limited to replacement or refund and shall not encompass any other damages. 
No dealer, distributor, agent or employee of Traveling Software is authorized to make any modification or addition 
to the warranty and remedies stated above.
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TRAVELING SOFTWARE SPECIFICALLY DISCLAIMS ALL OTHER WARRANTIES, EXPRESS OR IMPLIED, 
INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE. TRAVELING SOFTWARE DOES NOT WARRANT THE PHYSICAL PROGRAM MEDIA, 
PHYSICAL DOCUMENTATION OR COMPUTER PROGRAM(S) OTHER THAN AS EXPRESSLY STATED ABOVE, NOR 
DOES TRAVELING SOFTWARE PROVIDE ANY WARRANTY AS TO THE OPERATION OF THE SOFTWARE OR ITS 
FITNESS FOR ANY PARTICULAR APPLICATION, USE, OR PURPOSE.

Limitations of Liability and Remedies. IN NO EVENT SHALL TRAVELING SOFTWARE OR ITS LICENSORS BE 
LIABLE FOR ANY LOSS OF PROFIT OR ANY OTHER COMMERCIAL DAMAGE, INCLUDING BUT NOT LIMITED 
TO SPECIAL, INCIDENTAL, CONSEQUENTIAL, PUNITIVE OR OTHER DAMAGES, EVEN IF TRAVELING 
SOFTWARE OR ITS LICENSORS ARE ADVISED, IN ADVANCE, OF THE POSSIBILITY OF SUCH DAMAGES. IN NO 
EVENT SHALL THE LIABILITY OF TRAVELING SOFTWARE OR ITS LICENSORS EXCEED THE PURCHASE PRICE 
PAID FOR THE SOFTWARE, LESS ALL APPLICABLE TAXES AND DUTIES. SOME STATES DO NOT ALLOW THE 
EXCLUSION OR LIMITATION OF LIABILITY FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THE 
AFOREMENTIONED LIMITATION OR EXCLUSION MAY NOT APPLY TO YOU.

U.S. Government Restricted Rights. The Software is provided with Restricted Rights. Use, duplication, or 
disclosure by the United States Government is subject to restrictions set forth in subparagraph (c)(1)(ii) of The 
Rights in Technical Data and Computer Software clause at DFARS 252.227-7013 or subparagraphs (c)(1) and (2) of 
the Commercial Computer Software�Restricted Rights at 48 CFR 52.227-19, as applicable. Contractor/
Manufacturer is Traveling Software, Inc., 18702 North Creek Parkway, Bothell, Washington 98011 U.S.A.

Updates. To receive notification of future Software updates, please complete and return the registration card. Also, 
please locate the serial number of your copy of the Software on the program media. You will need this number to 
receive updates and technical support from Traveling Software.

Trademarks. TRAVELING SOFTWARE, DESKLINK, LAPLINK and the associated logo(s) are registered trademarks 
of Traveling Software, Inc. No right or license to any trademarks owned by Traveling Software or others appearing 
in the Software or packaging is granted to you by this License Agreement.

Miscellaneous. Unless otherwise restricted by law, you agree that this License Agreement shall be construed, 
interpreted and governed by the laws of the State of Washington of the United States of America, without regard 
to the laws governing conflicts of law. If any action is brought by either party against the other regarding any 
subject matter of this License Agreement, the prevailing party shall be entitled to recover, in addition to any other 
relief granted, reasonable attorney fees and expenses of litigation. You further agree that any claim relating to this 
License Agreement shall be brought in the courts of competent jurisdiction in the State of Washington. If any term 
of this License Agreement is declared void or unenforceable by any court of competent jurisdiction, enforcement 
of the remaining terms shall not be affected. No waiver of any right under this License Agreement shall be effective 
unless in writing and signed by both parties. No waiver of any past or present right arising from any breach or 
failure to perform shall be deemed to be a waiver of any future right arising under this License Agreement. This 
License Agreement sets forth the entire agreement between Traveling Software and you with respect to all matters 
covered herein.

IF YOU HAVE ANY QUESTIONS CONCERNING THIS LICENSE AGREEMENT, PLEASE CONTACT TRAVELING 
SOFTWARE AT 18702 NORTH CREEK PARKWAY, BOTHELL, WASHINGTON 98011 U.S.A. (425.483.8088), OR 
CONTACT YOUR REGIONAL TRAVELING SOFTWARE OFFICE.

Copyright Notice: No part of this publication may be 
reproduced, transmitted, transcribed, stored in a 
retrieval system, or translated into any human or 
computer language, in any form or by any means, 
without the express written permission of Traveling 
Software, Inc., 18702 North Creek Parkway, Bothell, 
Washington, 98011, U.S.A.

Trademarks: Traveling Software, the Traveling Software 
logo, DeskLink, and LapLink are trademarks or 
registered trademarks of Traveling Software, Inc. Other 
brand and product names are trademarks or registered 
trademarks of their respective holders.

This product contains the RSA Data Security, Inc. MD5 
Message-Digest Algorithm. Copyright © 1991-2, RSA 
Data Security, Inc. Created 1991. All rights reserved
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