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Chapter 1 - Introduction

1.1. Introduction

This chapter will introduce to you to PHP Designer 2007.

1.2. Description

PHP Designer 2007 is a free/commercial Integrated Development Environment (IDE) for PHP for both beginner- and

professional developers.

One of the strength in PHP lies in the ability to embed it into- and together with other web-languages, and this is why
PHP Designer 2007 not only supports PHP but also other web-languages like HTML, MySQL, XML, CSS, JavaScript,
VBScript, Java, C#, Perl, Python and Ruby!

PHP Designer 2007 is designed to boost your productivity and enhance the process of editing, debugging, analyzing and
publishing application- and websites powered by PHP, HTML, MySQL, XML, CSS, JavaScript, VBScript, Java, C#, Perl,
Python and Ruby!

The intuitive development environment makes it also the perfect IDE for beginners by providing code-tips and contextual

help with access to more then 3000 functions on the fly.

The development environment is also ideal for LAMP and AJAX developers through the various built-in code-libraries
and the Intelligent Highlighter, which gives you the ability to automatic separate different web-languages in the same

document!

The philosophy behind PHP Designer 2007 is to make it, enjoyable to use for hours and hours for both beginners and
professional developers through an easy-to-use-, intuitive-, streamlined-, sophisticated -, customizable- and tabbed

interface!

To reflect and respect developers’ different needs and purposes, PHP Designer 2007 comes in two editions, a free

personal edition and a professional paid edition.
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1.2.1. Professional Edition

The professional edition is enjoyable and efficient with demanding beginner-, experienced- and professional developers
in mind., who needs a complete powerful integrated development environment (IDE) to accelerate the process of
learning, writing, debugging, analyzing, and publishing applications and websites powered by PHP, HTML, MySQL, XML,
CSS, JavaScript, VBScript, Java, C#, Perl, Python and Ruby!

The professional edition may be use for any commercial-, business-, educational-, institutional- and governmental

purposes!

1.2.2. Personal Edition

The personal edition is a free simplified version that contains a smaller selection of features found in the professional

edition.

Although the personal edition provides a smaller selection of features it is still a simple PHP IDE that is enjoyable and
efficient with less experienced and demanding developers in mind who will need a simple but powerful development

environment for learning writing applications and websites powered by PHP!

The personal edition gives you right to create works solely for your own personal use only. You may not use it or works

created with it for any commercial, business, governmental or institutional purpose of any kind.
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1.3. What is New in this Version?

5.0.2

September 5, 2006

* Improve bracket/brace highlighting

e  Statement highlighting, example if you select “if” then it will also highlight “else”

« Improve the speed/performance when automatic detect new classes, functions and variables is on
«  Filenames are now displayed correctly in the code inspector

« Included and required files are now displayed correctly in the code inspector

¢ Lookup keywords in the PHP Manual improved

«  SaveAll

«  File Assaciation (dbl)

e Shortcut ALT+RETURN for break line <br>

¢ Minor fixes

5.0.1

September 1, 2006

e Support for File Association through the Windows Explorer

e Support for single quotes in Echo and Print

¢ Minor fixes

5.0.0

August 21, 2006

« Improved the general performance, especially when opening multiple files

¢ A more intuitive interface

« Tabbed Document Navigation (reorders tabs on the fly, easily see if a document is modified or not, close button

on each tab and support for right-click select!)

«  Desktop Layout (saves and load different desktop layouts on the fly)

*  Popup on various panel and toolbar elements

¢ Intelligent Highlighter (PHP, HTML, CSS, XML and JavaScript)
e Syntax Highlighters on the Fly
«  Syntax Highlighter: Ruby and Python
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¢ PHP Code Inspector (classes, functions and variables)

« PHP Code Tip (get help to complete user-defined functions in the document and from included documents)

«  PHP Contextual Help (get help to more then 3000 functions on the fly, requires the free php manual)

¢« PHP Classes and Function Navigation Toolbar

e Convert to PHP

. Contextual Search with Google, MSN, Yahoo, AltaVista, Wikipedia and Koders

. Code Libraries (PHP, phpDocumentor, Smarty, SQL, HTML, XML, CSS, JavaScript, VBScript, Java, C#, Perl,
Python & Ruby)

« Code Suggestions (insert user-defined functions, variables, HTML, Smarty and phpDocumentor)

¢ Code Auto Complete Wizard

¢ Access Code Type Information on the Fly

¢ Application Manager

«  HTML Tidy

*  File Browser (support for SVN and CVS icons)

*  Project Manager

e ToDo Manager

e  Bug Manager

¢ Inline ToDo Manager

¢ Inline Bug Manager

¢ Template Manager

« Code Snippet Manager (support for categories, drag & drop and easy conversion of text to code snippet)

«  Preview (automatic deletes auto-generated temporarily files)

*  Debug (automatic deletes auto-generated temporarily files)

¢ Localhost (automatic deletes auto-generated temporarily files)

« Extended Search and Replace

e Searchin Files

¢ Quick Search

e Search Result Panel

. Search for PHP Classes, Functions and Variables

« Database Browser (phpMyAdmin)

« Database Connection Manager (MySQL, PostgreSQL and DBX)

e FTP Manager

¢ phpDocumentor Wizard

¢ phpDocumentor

e Smarty

e SSI

e JavaScript

¢ Doctype for XHTML 1.1 and XHTML 2.0

e Auto Indention

¢  Select Matching Brace/Brackets

¢ Jump to Matching Brace/Brackets

¢« Change Case (lowercase, uppercase and tags)

* Remove Empty Spaces
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*  Bookmarks (click on the gutter)

« Data Folder

¢ Show all supported file formats in the Open/Save dialog
¢ Duplicate File

e Print

e Support for the new Windows® Vista platform

¢ Numerous internal tweaks and trivial fixes!

- 10 -
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1.4. Features

Interface

Personal

MPSOFTWARE

Professional

Native Themes and Windows XP Visual Styles

Tabbed Document Navigation

Drag- and Floatable Toolbars/Panels

Personalize - Fully-Customizable Workspace!

Desktop Layout Navigation
Advanced Editing

Syntax Highlighters: PHP, SQL, HTML, XML, CSS,
JavaScript, VBScript, Java, C#, Perl, Python & Ruby

Intelligent Highlighter (PHP, HTML, CSS, XML & JavaScript)

Code Tip & Inspector

AutoComplete & AutoCorrect

Highlight Matching Brace/Brackets

Automatic Close- & Indent Brace/Brackets

Bookmark Navigation

Advanced Printing

Extended Search and Replace
PHP

Convert to PHP: Enclose with single- and double quotes, with
linefeed, carriage return and tabs

PHP Statements (if, else, then, while...)

PHP Server Variables
HTML
Link, Image, Table, List, Meta, Forms, Font & Flash Editor

Formattings

Color Editor and Picker
Debug & Preview
Debug with the PHP Interpreter

Preview Localhost

Preview with Internet Explorer, Firefox, Netscape & Opera
Tools

Code Libraries: PHP, phpDocumentor, Smarty, SQL, HTML,
XML, CSS, JavaScript, VBScript, Java, C#, Perl, Python &
Ruby

Code Snippets & Templates

Contextual Help (get help to more then 3000 functions on the fly)

Contextual Search (Google, MSN, Yahoo, AltaVista, Wikipedia, Koders)

File & FTP Browser

-11 -
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Database Browser (phpMyAdmin) & Connection Manager

Project Manager

ToDo & Bug Manager

Inline ToDo & Bug Manager

Application Manager

Date & Time Manager

Code Type Information

phpDocumentor

Smarty

SSI

CVS/SVN

HTML Tidy

Export to HTML, RTF and LaTeX

Conversion Tools
Services

Free Updates (Hot Fixes)

14 Days Installation E-Support

3 Months Technical E-support
Purposes

Non-Commercial and Educational use ONLY!

Commercial, Business, Educational, Institutional and
Governmental Purposes!

-12 -
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1.5. System Requirements

e Microsoft Windows® 2000, NT, XP, XP2 & Vista
e Pentium 300 MHz+

¢ 256MB RAM or higher

¢ 10MB Hard disk space

«  PHP

¢ Microsoft Internet Explorer 4+ (for internal preview)

- 13 -
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1.6. End-User License Agreement — The Professional Edition

By installing, copying or otherwise using the software, you agree to be bound by the terms of this end-
user license agreement. If you do not agree to the terms of this end-user license agreement, do not
install, copy or use the software. Using any part of the software indicates that you accept these terms.

This software may be use for ANY Commercial, Busine ss, Educational, Governmental and

Institutional purposes.

DEFINITIONS
“Software” refers to “PHP Designer 2007 - Professional” provided to you by MPSOFTWARE.

SCOPE OF LICENSE

The software is licensed, not sold. This end-user license agreement only gives you some rights to use the
software. MPSOFTWARE reserves all other rights. You must treat this software like any other
copyrighted material. Unless applicable law gives you more rights despite this limitation, you may use the

software only as expressly permitted in this end-user license agreement.

EVALUATION VERSION

This license gives you right to use this software for 30 days evaluation purposes without any fee.

You are encouraged very much to use this opportunity to make sure, that the software runs without any

problems on your computer and that the software meets your expectations before ordering it!

You are required to order your copy of the software if you wish to continue using the software after the

evaluation period has ended. Otherwise, you must delete or uninstall the software from your computer.

When your order has been received, approved and the registration email with your username and

registration-key has been sent to you, the order will be binding to you!

You can order your copy of the software at www.mpsoftware.dk

During the evaluation period, you may use the software on as many different computers as you like.

REGISTERED VERSION

This software may be use for ANY Commercial, Business, Educational, Governmental and Institutional
purposes. You may use the software on that numbers of computers for which you have paid the
corresponding number of licenses, and the primary user of each computer for which you have paid a

separate license fee may use the software on his or her portable computer and at home.

If the registered copy of the Software is installed on a network server or other storage device, you must

pay a license fee for each separate computer on which the software is used.

- 14 -
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DISCLAIMER OF WARRANTIES

You expressly understand and agree that:

a. Your use of this software is at your sole risk. This software is provided on an "as is". MPSOFTWARE
expressly disclaims all warranties of any kind, whether express or implied, including, but not limited to the

implied warranties of merchantability, fitness for a particular purpose and non-infringement.

b. MPSOFTWARE makes no warranty that (i) the service will meet your requirements, (i) this software
will be uninterrupted, timely, secure, or error-free, (iii) the results that may be obtained from the use of this
software will be accurate or reliable, (iv) the quality of this software will meet your expectations, and (v)

any errors in the software will be corrected.

c. This software is on you own risk and that you will be solely responsible for any damage to your

computer system or loss of data that results from the software.

d. No advice or information, whether oral or written, obtained by you from MPSOFTWARE or through or

from this software shall create any warranty not expressly stated in the license agreement.

e. You expressly understand and agree that MPSOFTWARE or the author shall not be liable for any
direct, indirect, incidental, special, consequential or exemplary damages, including but not limited to,
damages for loss of profits, goodwill, use, data or other intangible losses (even if you has been advised of
the possibility of such damages), resulting from: (i) the use or the inability to use of this software; (ii) the
cost of procurement of substitute goods and services resulting from any goods, data, information or
services purchased or obtained or messages received or transactions entered into through or from the
service; (iii) unauthorized access to or alteration of your transmissions or data; (iv) statements or conduct

of any third party on the service; or (v) any other matter relating to the service.

f. You may not decompile, reverse engineer, disassemble or otherwise reduce this software to a human

perceivable form.

DELIVERY
You will receive your unigue registration-code by e-mail within a few days once your payment for the
registered version is received. When first the registration-code has been sent to you, you cannot get your

money back.

DISTRIBUTION
Permission from MPSOFTWARE is necessary to include this software on CD-ROM with any books,
magazines, software packages or other publications.

SOFTWARE MAINTENANCE
MPSOFTWARE is not obligated to provide maintenance or updates to you for the software. However,
MPSOFTWARE may, in its sole discretion, provide updates and/or supplements of the software and/or

related information to you hereunder, in which case such updates shall also be deemed to be included in
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the software and therefore governed by this license agreement.

LEGAL EFFECT
This license agreement describes certain legal rights. You may have other rights under the laws of your
country. This agreement does not change your rights under the laws of your country if the laws of your

country do not permit it to do so.

TERMINATION
This license agreement terminates if you fail to comply with its terms and conditions. If your license

terminates, you must destroy all copies of the software you have.

© 1998-2006 MPSOFTWARE. ALL RIGHTS RESERVED.
Internet: http://www.mpsoftware.dk

Email: mpsoftware @mpsoftware.dk
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1.7. End-User License Agreement — The Personal Edit ion

By installing, copying or otherwise using the software, you agree to be bound by the terms of this end-
user license agreement. If you do not agree to the terms and conditions of this agreement, do not install,

copy or use the software. Using any part of the software indicates that you accept these terms.

This software is FREE for PERSONAL and EDUCATIONAL use O NLY, and may NOT be use for any
Commercial, Business, Governmental or Institutional purposes of any kind! No money is charge

to the person receiving this software.

DEFINITIONS
“Software” refers to “PHP Designer 2007 - Personal’ provided to you by MPSOFTWARE.

SCOPE OF LICENSE

The software is licensed, not sold. This end-user license agreement only gives you some rights to use the
software. MPSOFTWARE reserves all other rights. You must treat this software like any other
copyrighted material. Unless applicable law gives you more rights despite this limitation, you may use the

software only as expressly permitted in this end-user license agreement.

GRANT OF LICENSE
MPSOFTWARE grants you a free personal, non-exclusive license to make and use copies of the software

and install such software on any number of your computers.

PERSONAL USE
You may create works solely for your own PERSONAL USE ONLY. You may NOT use the software or
works created with the software for any Commercial, Business, Governmental or Institutional purpose of

any kind!

EDUCATIONAL USE

You may create works solely for your own personal use in providing or receiving instruction within the
computer programming and/or software training courses in which you are a direct and personal
participant, either as student or instructor. You may only reproduce, distribute and use works to other
participants of the courses and then only for educational or training purposes. You may not use the
software or works created with the products for any commercial, business, governmental or institutional

purpose of any kind, except to the extent you are an instructor teaching a course.

DISCLAIMER OF WARRANTIES

You expressly understand and agree that:

a. Your use of this software is at your sole risk. This software is provided on an "as is". MPSOFTWARE
expressly disclaims all warranties of any kind, whether express or implied, including, but not limited to the
implied warranties of merchantability, fitness for a particular purpose and non-infringement.
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b. MPSOFTWARE makes no warranty that (i) the service will meet your requirements, (ii) this software
will be uninterrupted, timely, secure, or error-free, (iii) the results that may be obtained from the use of this
software will be accurate or reliable, (iv) the quality of this software will meet your expectations, and (v)

any errors in the software will be corrected.

c. This software is on you own risk and that you will be solely responsible for any damage to your

computer system or loss of data that results from the software.

d. No advice or information, whether oral or written, obtained by you from MPSOFTWARE or through or

from this software shall create any warranty not expressly stated in the license agreement.

e. You expressly understand and agree that MPSOFTWARE or the author shall not be liable for any
direct, indirect, incidental, special, consequential or exemplary damages, including but not limited to,
damages for loss of profits, goodwill, use, data or other intangible losses (even if you has been advised of
the possibility of such damages), resulting from: (i) the use or the inability to use of this software; (ii) the
cost of procurement of substitute goods and services resulting from any goods, data, information or
services purchased or obtained or messages received or transactions entered into through or from the
service; (iii) unauthorized access to or alteration of your transmissions or data; (iv) statements or conduct

of any third party on the service; or (v) any other matter relating to the service.

f. You may not decompile, reverse engineer, disassemble or otherwise reduce this software to a human

perceivable form.

DISTRIBUTION
Permission from MPSOFTWARE is necessary to include this software on CD-ROM with any books,

magazines, software packages or other publications.

SOFTWARE MAINTENANCE

MPSOFTWARE is not obligated to provide maintenance, technical support or updates to you for the
software. However, MPSOFTWARE may, in its sole discretion, provide technical support, updates and/or
supplements of the software and/or related information to you hereunder, in which case such updates

shall also be deemed to be included in the software and therefore governed by this license agreement.

LEGAL EFFECT
This license agreement describes certain legal rights. You may have other rights under the laws of your
country. This agreement does not change your rights under the laws of your country if the laws of your

country do not permit it to do so.

TERMINATION
This license agreement terminates if you fail to comply with its terms and conditions. If your license

terminates, you must destroy all copies of the software you have.

© 1998-2006 MPSOFTWARE. ALL RIGHTS RESERVED.
Internet: http://www.mpsoftware.dk | Email: mpsoftware @mpsoftware.dk
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1.8. Installation & Technical E-Support

PHP Designer 2007 - Professional includes installation and technical e-support available by:

¢ Website: www.mpsoftware.dk

. Email: mpsoftware@mpsoftware.dk

Please include the following information when requesting e-support:

¢ Your username and email (from registration mail)

¢ Afull description of the problem

Before requesting any e-support, please ensure that you are using the latest version available at www.mpsoftware.dk.
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1.9. About

MPSOFTWARE is an abbreviation of Michael Pham Software , started back in 1998, as a hobby for me trying to learn

developing useful software products for web-developers.

The goal is to design and develop enjoyable, yet powerful, intuitive and good-looking software products that improve and

accelerates the productivity for both beginner- and professional web-developers all around the world.

Today, 8 years later and still privately held in Denmark (Scandinavian), things have evolved quite a bit farther, with

millions of downloads worldwide with a market penetration in more than 125 countries!

The flagship product is PHP Designer 2007, a powerful development IDE for PHP and other web-languages.

The first release of PHP Designer was back in 2003. Today, it has evolved into being the flagship product and one of the
most popular products for developing application- and websites powered by PHP by meeting both beginners’ and
professional developers’ growing expectations and needs!

In June 2006, | finished my BSc in Business Economics and Computer Science at Copenhagen Business School.

| then had to decide what | wanted to do with my life now... and during the last 8 years it has always been a dream of

mine to make a career out of developing and maintaining a software product like PHP Designer 2007!

What could be better than that?
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1.10. Third Parties

PHP Designer 2007 includes software components developed by the following third parties:

¢ SynEdit (Unicode) developed by Martin Waldenburg and its contributors
Mozilla Public License 1.0

http://synedit.sourceforge.net

e JEDI Visual Component Library developed by the JVCL Te  am
Mozilla Public License 1.0

http://homepages.borland.com/jedi/jvcl

¢ Toolbar2000 developed by Jordan Russell
Shareware / GNU General Public License (GPL)
http://www.jrsoftware.org/tb2k.php

¢ TBX developed by Alex A. Denisov
Freeware
http://www.g32.org/tbx/index.html

¢ TBX Themes developed by Roy Magne Klever
Freeware

http://www.rmklever.com

¢ SpTBXLib developed by the Silverpoint Development
Mozilla Public License 1.0

http://club.telepolis.com/silverpointdev

¢ MXS Color Lib Pack developed by Marko Binic
Freeware

http://mxs.bergsoft.net

¢ VirtualShellTools by Jim Kueneman
Mozilla Public License 1.1

http://www.mustangpeak.net

¢ TmxWebUpdate developed by the MaxComponents
Freeware

http://www.maxcomponents.net

Thanks to the groups and individuals above for their contributions!
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Chapter 2 - Registration

2.1. Introduction

This chapter will introduce you how to order PHP Designer 2007 - Professional.

2.2. Purchasing

You may try PHP Designer 2007 - Professional free for 30 days!

You are encouraged very much to use this opportunity to make sure, that PHP Designer 2007 - Professional

runs without any problems on your computer and that it meets your expectations before ordering it!

You are required to order and register your copy of PHP Designer 2007 - Professional if you wish to continue using the

software after the evaluation period has ended.
Otherwise, you must delete or uninstall PHP Designer 2007 - Professional from your computer.

After you have successfully completed the purchase, payment and verification process, you will receive an e-mail within

1-5 business-days (normally 1-2 business-days!) containing:
«  Your username and registration-key to unlock PHP Designer 2007 - Professional
¢ A guide to unlock PHP Designer 2007 - Professional with your username and registration-key
¢ Invoice

Your order is binding to you when:

¢ You have successfully completed the purchase, payment and verification process

« The registration e-mail is sent to you, containing your username and registration-key

You can order you copy of PHP Designer 2007 - Professional securely online at www.mpsoftware.dk.

All payments are handling through PayPal - The global leader in online payment solutions with 100 millions account

members worldwide! This is your guarantee for a safe and secure order!

Your order will help maintain, improve and develop new features in the future!
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2.3. Pricing

All information about pricing is always available online at www.mpsoftware.dk.

2.4. Payment and Delivering

All payments are handling through PayPal - The global leader in online payment solutions with 100 millions account

members worldwide! This is your guarantee for a safe and secure order!

After you have successfully completed the purchase, payment and verification process, you will receive an e-mail within

1-5 business-days (normally 1-2 business-days!) containing:

e Your username and registration-key to unlock PHP Designer 2007 - Professional
e A simple guide to unlock PHP Designer 2007 - Professional with your username and registration-key

e Invoice
Your order is binding to you when:

¢ You have successfully completed the purchase, payment and verification process

e The registration e-mail is sent to you, containing your username and registration-key

2.4.1. PayPal

PayPal, the trusted leader in online payments, enables buyers and businesses to send and receive money online.

PayPal has over 100 million member accounts in 55 countries and regionsl.

2.4.2. PayPal accepts the following cards/payments:

¢ VISA
e MasterCard
¢ American Express

. Discover

e PayPal

L source: http://www.paypal.com/cgi-bin/webscr?cmd=p/gen/about-outside
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2.4.3. What is the benefit of using PayPal?

It's Fast
Payments are made immediately, quicker than sending checks or money orders.

It's Private

PayPal does not reveal your financial information to sellers.

It's Global

PayPal is accepted worldwide, and can be used to make payments locally or internationally.

It's Easy

Send money to anyone in just a few clicks.

It's Trusted

Industry-leading fraud prevention keeps you safe and secure.

It's Cost-Effective
It's free to send money, and PayPal is affordable for businesses of all sizes.

24 -
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Chapter 3 - Environment

3.1. Introduction

This chapter will introduce you to the environment in PHP Designer 2007.

3.1.1. The Getting Started Window

The Getting Started window enables you to get started easily on new and existing documents and projects.

Bl PHP Desi E@@

New Document Open Existing Bocument(s)

2@ .Dn(umtnl Types
[ pre

Recent Files:

|] Gi\bBlog\bblog\xmirpc.php
{3 C:ibBlosibbiogitrackback.pho
lbelogibblog\make_bookmarklet. php

lbElogibbioginstall. php

:bBlagibbioglindex.phe

+bBiogibblogicp.css

Ibeiog|bblog|confia.php

lbelogibbiog|bblog. css

fa
fa

(5]
o

Templates

(3 General Right-cick beiow to see mors options.
1 PHP e 2
=T Q [B]
acss CloseDB createDB
[ o8
Caset
| [ Javascript
[ WBSeript

[ 3ava
C A ped

e
|3 Pthon

[ Ruby

[] triosce

Projects

Change Upstart?

MPSOFTWARE belog

The Getting Started Window consists of the following elements:

1. Create a new empty PHP, HTML, SQL, XML, CSS, JavaScript, VBScript, Java, C#, Perl, Python or Ruby
document

Browse and open an existing document on your file system

An overview over the last 20 opened documents

Create a new document based on a template

o k w DN

An overview over available projects
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3.1.2. The Edit Window

The Edit Window enables you to edit new and existing documents.

PHP Desipr * 2007 - Professional - [C:\bBlog\bblogbmirpe. php]
(S5 JavaSoript SSD Tooks Window Help Order Now!
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Edit ~ | Debug ~ | locshest ~ PHR~ Unicode % | Tool Panel : PHP Code Inspector x
- . - PHP = [ 3

= )  Manual ~l =

227 ob_starc(); A e
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The Edit Window consists of the following elements:
1. The Menus gives you access to all procedures
2. The Toolbars gives you access to common procedures.
3.  Open multiple documents with tabbed browsing. Each tab represents an open document and the colored button
next to filename indicates if the document is modified or not. Re-order the tabs by simply drag them to the new
position!

4. Change mode and document options on the fly

5. The gutter indicates the line numbers and word-wraps in the document. This feature can be turn off in the

preferences

6. The current active line is highlighted with a different color then the rest of the document. This feature can be
turn off in the preferences

7. The syntax coloring of your code makes it easier to edit and understand
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8. You can access contextual help on the fly (only PHP). This feature requires that you download the free PHP

manual from http://www.php.net/download-docs.php

9. The Tool Panels consist of seven different panels:

«  PHP Code Inspector
*  Code Libraries

e Code Snippets

*  File Browser

e Projects

«  Templates

. Database Connections

The Tool Panels is dockable. To dock or undock the Tool Panels, click on the title bar and drag it.

10. The Status Bar indicates, if the document is modified, the current cursor position, the current code attribute, if a

project is loaded or not and the document path.
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3.2. Toolbars

The toolbars gives you access to common procedures. All toolbars is dockable. To dock or undock a toolbar, click on the

title bar and drag it. To close a toolbar, click on the cross in the title bar.

3.2.1. Standard

Create a new document.

Open an existing document.
Save document.

Print document.

Undo

Redo

2 T L

3.2.2. Clipboard

1. Cut selected text to the clipboard.
2. Copy selected text to the clipboard.

3. Paste text from the clipboard into the document.

3.2.3. Search

Search b4

i MEED | 2

1. Enter the text you would like to search for or access the search history by clicking the on the drop-down button.

Press Enter to begin your search.

Click this button to begin your search. You can customize the search by clicking on the drop-down button.

3.  Open the replace text dialog.
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3.2.4. PHP

© N o gk~ w N PR

Insert a PHP define tag: <?php ?>

Comment — Insert or mark the selected text with /* */
Comment — Insert or mark the selected text with //
Insert a variable

Insert a class

Insert a function

Click on the drop-down button to insert a statement

Click on the drop-down button to convert text to PHP

3.2.5. HTML

1.
2.
3.
4.
5.

3.2.6. Forms

Insert a hyperlink
Insert a picture
Insert a table
Insert a list

Insert a layer

© © N o g A~ DR

el o el =
w N P O

Insert a form

Insert a text field
Insert a text area
Insert a password field
Insert a push button
Insert a submit button
Insert a reset button
Insert a image button

Insert a radio button

. Insert a check button
. Insert a combo box
. Insert a insert file upload field

. Insert a hidden field
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3.2.7. Format
Format x
Marmal * | TimesNewR v | B I W T | A -

1 2 3456 7

Format style
Font name
Bold

Italic
Underline

Font editor

No g s~ e Dn e

Color editor and color picker

3.2.8. Paragraph

Paragraph =

1. Leftalignment
2. Center alignment
3. Right alignment
4. Justify alignment
5. Paragraph
3.2.9. Window
Window X

Previous document
Next document
Tile documents horizontal

Tile documents vertical

1.
2.
3.
4.
5.

Arrange documents
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3.2.10. Desktop Layout

Enesktup Layou »
| Drezkiop 1r

k

1. Use the drop-down button to select and set stored desktop layout

2. Save current desktop layout

3.2.11. Document Mode and Options on the Fly

Edit Previgw = Debug = Localhest = Intelligent Highlighting = | Unicods *

1 2 3 4 5 6 7

1. In Edit mode, you can edit your document.

2. In Preview mode, you can preview your files in the internal browser or use the drop-down button preview your

document in an external browser. These browsers are Internet Explorer, Firefox, Opera and Netscape.
Note! The Preview mode is typical used for HTML and XML files.

3. In Debug mode, you debug and see the result of the debug. This feature requires the PHP interpreter from the
PHP installation.

Note! The Debug mode is only for PHP files.
4. In Localhost mode, you can preview your files stored documents in your localhost directory or use the drop-
down button preview your document in an external browser. These browsers are Internet Explorer, Firefox,

Opera and Netscape.

Note! The Localhost mode requires a local web server.
Note! The Localhost mode is typical used PHP files.

5. Change the document syntax highlighter on the fly. The following syntax highlighters are supported:

- Intelligent Highlighter (PHP, HTML, XML and JavaScript)
«  PHP, HTML, SQL, XML, CSS, JavaScript, VBScript, Java, C#, Perl, Python or Ruby

6. This button indicates and enables you to store the document in the Unicode format. The default format is ANSI.
Note! The debug (The PHP Interpreter, PHP > 5) does not support documents in Unicode format.

7. Close the current document.

-31-



PHP Designer 2007 MPSOFTWARE

3.3. Panels

The Tool Panels consist of seven different panels that you can access on the fly. The Tool Panels is dockable. To dock

or undock the Tool Panels, click on the title bar and drag it.

3.3.1. PHP Code Inspector

The PHP Code Inspector panel enables you to open included and required files, navigate to classes, functions and

variables within your PHP files. The included files, classes, functions and variables can be stored in the following modes:

« Hierarchically as they appear in the document

¢ Alphabetic sorted

On the View menu, click Panels and then PHP Code Inspector (shortcut: Shift + F2)

Tool Panel :: PHP Code Inspector X
s [ty =
= xmirpc:php
= [ include
: @ config.php 4
&= libsrpe php
- | include_once
[ require
[ require_once

susssaiss

| 6 - |

| = ] =mirpe.php A
o Classes i
[= [ Functions
. blogaer_getUsersBlogs(fparams)
blogger_deletePost( $params)
blogaer_getPostSparams)
blogger_getRecentPosts($params)
metawveblog_getRecentPosts($params)
metavyeblog_newwPost§params)
metatvizblog_editPost($params)
metsisblog_getPosti$params)
metatvizblog_getCategories(Fparams)
mt_getCategaryList{Eparams)
mt_getPostCategories($params)
mt_setPostCategories(Sparams)
H - mt_publishPostfparams)
=[] Wariakles
< & Fumirpo_methods
< & fumlrpo_recquest
- % $methodMame o

LSy « »

The PHP Code Inspector panel consists of the following elements:

Refresh the PHP Code Inspector

Automatic detect new classes, functions and variables in the document

Sort listed items, expand variables, include all variables and only include assigned variables
Included and required files in the document, open these files by clicking on them

Classes, functions and variables in the document, click on the elements to navigate to them.

2 T o

Search for classes, functions and variables in the document
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3.3.2. Code Libraries

The Code Libraries panel enables you to access functions, constants and reserved keywords for the following libraries:
PHP, phpDocumentor, Smarty, HTML, CSS, JavaScript, VBScript, SQL, Perl, Java, C#, Python and Ruby

On the View menu, click Panels and then Code Libraries (shortcut: Shift + F3)

Tool Panei Code Libraries x
PHP ~
oo
= ZiPHPS Al
#C70 Array
- aspel

=7 BCMath Arbitrary Precision Mathematics
#- "] Bzip2 Compression

®-=7 Calendar

T covs AP

® 7] COM Oindones]

# =71 ClassiObject

- ClibPDF

T Crack

i j CURL, Client URL Library

& 7] Cybercash Paymert

-7 Cyrus IMAP Administration

=+ ':] Character Type

-] Databaze (dbm-style) Abstraction Layer
=7 Date and Time

=" dBase

® 7] DBM [deprecated]
®-27 oex

= ': DB++

[ el

-4} dbplus_agl
- A} doplus_chdir
-4} doplus_close
A} doplus_curr
-4} dbplus_errcode
-4} dbplus_errno
- A} doplus_find
A} diplus_first
oA} doplus_flush z

The Code Libraries window consists of the following elements:
1. Select the code library

2. Search the code library

3. The code library, click on the functions, constants or reserved keywords to insert it into your document.
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3.3.3. Code Snippets

The Code Libraries panel enables you to create and insert code snippets directly into your document.

MPSOFTWARE

You can categorize the code-snippets in the following categories: General, PHP, HTML, CSS, XML, SQL, JavaScript,

VBScript, Java, Perl, C#, Ruby and Python.

On the View menu, click Panels and then Code Snippets (shortcut: Shift + F4)

Tool Panel :: Code Snippets

Eh IR

| General
- [arHP
[ HTML
[ €55
O L 2
s
! | JawaScripk
[ ¥BScript
; [ Java
! 1 Perl
gt
i [ Pwthan
: [ Ruby

=
’SEDB CORNEC...

3

>

The Code Snippets panel consists of the following elements:

1. Buttons: Create code snippet, insert code snippet, edit code snippet and delete code snippet

2. Code snippet categories

3. Code snippet in the selected category

- 34 -



PHP Designer 2007 MPSOFTWARE

3.3.4. File Browser

The File Browser panel enables you to access your file system and open existing document.

On the View menu, click Panels and then Code Snippets (shortcut: Shift + F5)

Note! The File Browser does also display icons for SVN and CVS!

Tool Panel :: File Browser X
@ Skrivebard
==} |f_"| Dokumenter
@ 1y Denne computer
G- W Metvasrkssteder
@ Papirkury 2
& |_'3 Mine telefaner
= 3 website
) images
;31 () mirror

i e
Mavn Starrelse Type
() Dakumerter Systetmir
sj Denne computer Systemm
\'..j Metveerkssteder Systemm
@) Papirkury Systemm|
{_3 Mine telefoner Systemim
) website Filmappe |
[Z] bugstxd 2KE  Tekstook
|'_é_°_'] bodho 1t 3 14 KB Tekstdok
< I | gl
o5y i [T P

The File Browser window consists of the following elements:
1. Buttons: Open selected file, insert filename, favorite directory and file display options.

2. Directories
3. Directories and files
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3.3.5. Projects

The Projects panel enables you to access and manage your projects.
On the View menu, click Panels and then Projects (shortcut: Shift + F6)

Note! The Project Browser does also display icons for SVN and CVS!

Tool Panel :: Project »

Fa =N S
£ hblog
& () hBlog_plugine
= [3) cache
|5 compiled_templates
| docs 2
[ images
|y ine
|y install
3 libs
|3 =soript
5 b
<) smarty_plugins

) stvle
- ) templates

R O

2 R

]

E] config.php
EJ Cp.css

[Z] index php

Z] irstall php 3
[Z] make_bookmarkist php

@ trackback php

E_'] xmirpc kg

BlTEE e EE]

The Projects panel consists of the following elements:

1. Buttons: Manage your projects, import folder(s) and file(s) to the project, selected file, insert filename and file
display options.
Directories

Sub-directories and files
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3.3.6. Templates

The Templates panel enables you to create new documents based on your own templates.

You can categorize the templates in the following categories: General, PHP, HTML, CSS, XML, SQL, JavaScript,
VBScript, Java, Perl, C#, Ruby and Python.

On the View menu, click Panels and then Templates (shortcut: Shift + F7)

Tool Panel :: Templates x

| General
[ PHP
A HTML
i o
o EmL 2
- sqL

j -4 JavaScript
[ ¥BScript
[ Java

: -1 Perl
SER

: - Pwthon

- - Ruby

B B

ClozeDB  cresteDB 3

;EE‘[J |« »-

oy o e |

The Templates panel consists of the following elements:

1. Buttons: Create a new template, create a new document based on the selected template, edit
template, and delete template and Unicode enable/disable.
2. Template categories

Templates in the selected category
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3.3.7. Database Connections

The Database Connections panel enables you to insert a connection code to your databases in the following formats:
MySQL, PostgreSQL and DBX.

On the View menu, click Panels and then Database Connections (shortcut: Shift + F8)

Tool Panel :: Database Connections *
€y BYMCAIRY |
0 0 0

dhllzer  dbAdmin bl

2

OSSR o s

The Database Connections panel consists of the following elements:

1. Buttons: Create a new database connection, edit database connection, insert connection code to selected

database and delete database connection.

2. An overview over your database connections
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3.3.8. PHP Manual

If you have downloaded the PHP manual from http://www.php.net/download-docs.php you can contextual access this

manual inside PHP Designer 2007.

You can contextual access the PHP manual by:

¢ Press F1 on the word you like to lookup

¢ Right-click on the word you like to lookup in the edit window and select “Lookup function...”

On the View menu, click PHP Manual (shortcut: Shift + F9)

PHP Manual x

e | &

PHP Manual L

array

(PHP 3, PHP 4 )
array -- Create an array

Description
array array ( [mized ...])

Returns an array of the parameters. The parameters can be given an index with the => operator,
Read the section on the array type for more information on what an array is.

Mote: array() is a language construct used to represent literal arrays, and not a
regular function,

Syntax "index =» walues", separated by commas, define index and values. index may be of type
=tring or numeric. When index is amitted, an integer index is automatically generated, starting at O,
If index is an integer, next generated index will be the biggest integer index + 1, Note that when
two identical index are defined, the last overwrite the first,

The following example demonstrates how to create a two-dimensional array, how to specify keys
for associative arrays, and how to skip-and-continue numeric indices in normal arrays.

Example 1. array() example

< ?php
ffruits = array |
Tfraital =oaorperay el oes UTorgnoef.. NgH o eo. Nhapapaf . Tefoes Tapplef).
s g b e s e i I B R L
"holea™ ecnpray (PELeabfo - Boes: Tagooayd® o Tehicg)
]
T o
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3.3.9. ToDo Manager

You can use the ToDo Manager to manage your workload and set schedules for your documents and projects.

The ToDo Manager is dockable. To dock or undock the ToDo Manager, click on the title bar and drag it.

On the View menu, click ToDo Manager (shortcut: Shift + F11)
On the Tools menu, click ToDo Manager (shortcut: Shift + F11)

Note! You can right-click on the ToDo Manager to see more options.

Todo X
MName Project Skatus Start: End Descripkion Filename Friority Complete %
Debug bElag In Progress 0z-05-2006 03-05-2006 Debug Function blogger_getUsersBlo...  CiibElogibbloghxmirpe.php Morrnal 40

Todo | Infing Toda ! xmlrpc.bhp
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3.3.10. Inside ToDo Manager

The Inside ToDo Manager enables you to insert special formatted comments inside your documents so you can easily
manage your workload and navigate to these comments. The comments have the following formats:

« //TODO: Description goes here... (PHP)
¢« <I--TODO: Description goes here... --> (HTML)

The Inside ToDo Manager is dockable. To dock or undock the Inside ToDo Manager, click on the title bar and drag it.

On the View menu, click Inside ToDo Manager

On the Tools menu, click Inside ToDo Manager

Note! You can right-click on the Inside ToDo Manager to see more options.

Bl PHP Designer 2007 - Professional - [C:\bBlogkbbloghxmlrpe. php®]

/Bl Edit Ssarch UVew Forms: PHP HIML £55 JavaSeript SST ook MWindow Help | Buy Now! -8 %
A e S5 W= L S o REW'S —g_g}gl:_ aldal E‘lanl e e = e = = o o | |
] [z] 9 wmlrpe.php
| Edit || Preview = | Debug | Lacahost x| Inteligent Highliahting = | Unicode | %
L jelse! ~
56 figall the me d |
£7 fumlrpe methods[ $wethodiame] ($params) ;
58}
-]
&0
&1
-4
3
64
&5 Jftoda: delbug
&6 function blogger getUsersBlogs (fparams) {
67 Global $bElog:
1 $hlogr=array();
63 if (${bBlog-»userauth ({params[1] , $params[2]1] |
70 $hilog['url'] = ¢_BLOGURL;
71 $hlog['bloghame '] = C_BLOGNAME:
7z $hlog['blogid'] = 1:
73 $hlogr[]=3blog:
T4 HMLRPC_response (XMLRPC_prepare ($hlogr), WEBLOG_XMLPRPC_USERAGENT) ;
75 ¥ else {
76 EMLRPC error ("301", "The usernsme and password you entered was not accepted. Please try again.”, ~
E::; Line Commert
Sl 45 nesw function!
debiug!
x T‘?F‘;? Inline Todo :: xmirpc.php |
MPSOFTWARE  [odfied  Ln 85 Col 1 bBlog CribElogibblagy |

- 41 -



PHP Designer 2007

3.3.11. Bug Manager

MPSOFTWARE

You can use the Bug Manager to manage your workload and set schedules for bugs in your documents and projects.

The Bug Manager is dockable. To dock or undock the Bug Manager, click on the title bar and drag it.

On the View menu, click Bug Manager (shortcut: Shift + F12)
On the Tools menu, click Bug Manager (shortcut: Shift + F12)

Note! You can right-click on the Bug Manager to see more options.

Hame Project Status Description Resolution History Filename Version Pricrity Severity
error belog INFROGREESS thereis aerror ... nja ci\bBlog|bblogl... 2 High Significant

<
Bug | Inline Bug i xmirpe.php

Platform
Al (cross-platfo. .

Operating Syst...

Assigned to
Deferred

Milestone
nja

x
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3.3.12. Inside Bug Manager

The Inside Bug Manager enables you to insert special formatted comments inside your documents so you can easily
manage your bugs and navigate to these comments. The comments have the following formats:

« //Bug: Description goes here... (PHP)
« <I--BUG: Description goes here... --> (HTML)

The Inside Bug Manager is dockable. To dock or undock the Inside Bug Manager, click on the title bar and drag it.

On the View menu, click Inside Bug Manager
On the Tools menu, click Inside Bug Manager

Note! You can right-click on the Inside Bug Manager to see more options.

"ﬂj

1 wmlvpe.php |

| Preview v Dby | % ToolPanels x|

(=[] xmirpe php

247 function metalehblog nevPost (§params) {

= [ include
z48  Global §bBlog; & configphp
245 if ($bBlog->userauth($params[1], $params[2])) { & lbs\rpcphp
250 /¢ passwor =cl - [ include_nnce
281 $sectionid = $hBlog->_get_section id(§params[3]['categories'][0]); [ recuire
z52 - recuire_once
£53 fnevpost-rtitle = addslashes(stripslashes(fparams[3]['ticle'])):
zE4 $newpost—rbody = addslashes (stripslashes(§params(3] [ description']));
288 if (§sectionid > 0) $newpost->sections = array(O=>§sectionid): |/ 500: e
256 fnewpost-»status = C_DEFAULT STATUS: // in the fucurs chis will be oh the Mpost” or Mpost and e — T —

287 $newpost—>modifier = C_DEFAULT MODIFIER; ‘ I‘ i |
esg §postid = {bElog-»new postifnewpost): = i
258 if ($postid > 0) ¢ ERRE |
260 ENLRPC_response (EMLEPC prepare{$postid), UEELOG_XMLPRPC USERAGENT) ; (3 Classes

251 /4 Ping weblogs.com - - = [ Functions

o blogoer_deletePost (foarams)
blogger_cetPost ($params)
biogger_oetRecentPosts ($params)
biogger_getlisersBlogs (Fparams)
meta\eblog_editPost (Jparams)
metasblog_getCategaries (params)
metalveblog_getPost ($params)
metaweblog_getRecertPosts (Bparams)
metaleblog_newPost (Bparams)
mi_getCategoryList(Sparams)
mt_getPostCateyoriest Sparams)
mt_publishPost($params)

o mt_setPostCategories(3params)

", "uehloglpds

273 went grong add an i §o [ Verisbles

274

275

278 i

237 }oelse ¢

278 IMLRPC error("500", "sowething went wrony adding entry.”, WEBLOG XMLRPC USERAGENT) .

279

280 ¥ B sz
F Comment
&

x: Bug  Inline Bug :: xmlrpc.php

MPSOFTWARE  fiodfied  Ln 25560l 1 Commare bilog
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3.3.13. Debug

Debug your PHP files for any syntax errors and preview the output with the PHP Interpreter. The debug feature requires
that you have the PHP installed on your computer available free at www.php.net.

XAMPP and EasyPHP are both easy ways to install Apache with PHP and MySQL on your computer!

XAMPP: http://www.apachefriends.org/en/xampp.htmi

EasyPHP: http://www.easyphp.org

Debug and view the result of your documents in the internal web-browser or in your favorite web-browser by either:

On top of the Edit window , click the Debug Tab (shortcut: F5)
On the Tools menu, click Debug (shortcut: F5)

If you like to debug with other parameters then the standard parameters do the following:

On the Tools menu, click Debug with parameters... and enter your parameters. More information about the supported

parameters can be found in the documentation that comes with the PHP package.

If the compiler and debugger found any errors in a document, all errors will be listed in the Debug Panel.

1. Inthe Debug Panel, select the error to solve or navigate too.

2. Double-click or press Enter to jump to the current error in the document.

Note! The Debug Panel is dockable. To dock or undock the Debug Panel, click on the title bar and drag it.
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3.3.14. Search Results

The result of the extended search, search and replace and find in files will be displayed in the Search Result Panel.

On the View menu, click Search Result

Note! The Search Result Panel is dockable. To dock or undock the Search Result Panel, click on the title bar and drag it.
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3.3.15. Database Browser

Browse and execute database(s) directly within the program with the embedding of the phpMyAdmin.
On the Tools menu, click phpMyAdmin...

In order to use the embedded phpMyAdmin you must configure PHP Designer 2007 to work with it.
On the Tools menu, point to Preferences (CTRL+E)

Use the left menu and navigate to Integration

Type in the URL, to the your phpMyAdmin
Click Ok.

0D PR

PhpMyAdmin is available free at www.phpmyadmin.net

Note! The Search Result Panel is dockable. To dock or undock the Search Result Panel, click on the title bar and drag it.
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Chapter 4 - Working with Files

4.1. Introduction

This chapter will introduce you to work with files in PHP Designer 2007.

4.2. Start a New File

Create a new file from scratch or form your own templates. You can create the following file types in PHP Designer
2007:

« PHP
. sQL
. HTML
« XML
. CsSs

e JavaScript

« VBScript
e Java

e C#

e Perl

e« Python

« Ruby

4.2.1. Create a New File

On the File menu, click New... (shortcut: CTRL+N)
Select the type of the file
If you like to have the file format as Unicode, then check the Unicode box otherwise the default format is
ANSI
4. Click OK

4.2.2. Create a New File based on a Template

=

On the Getting Started window, select the type of the file in the category/folder
2. If the selected category/folder contains one or more templates then double-click on that template you wish to

use for a new document
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4.2.3. Open an Existing Local File

File menu:
1. On the File menu, click Open... (shortcut: CTRL+O)
2. Browse your local system for the file(s) you wish to open
3. Click OK
Tool Panel:
1. Onthe Tool Panels , select the File Browser tab
2. Browse your local system for the file(s) you wish to open

3. Double-click on the file you wish to open

Getting Started:

1. Inthe Getting Started window, click the button Browse...

2. Browse your local system for the file you wish to open
3. Double-click on the file you wish to open

Drag-and-drop:

1. Select the file(s) from your file system (e.g. from Windows Explorer)

2. Drag and drop the file(s) inside PHP Designer 2007

4.2.4. Open a Recent File

1. Inthe Getting Started window, select the recent file you wish to open

2. Double-click on the recent file you wish to open
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4.3. Working with Templates

You can create a hew document based on your own templates in the Getting Started window and in the Tool Panels.

You can categorize the templates in the following categories:

e General
«  PHP

e HTML

e CSS

« XML

e SQL

e JavaScript
e VBScript
e Java

«  Perl

e C#

¢ Ruby

e Python

On the View menu, click Panels and then Templates (shortcut: Shift + F7)

4.3.1. Create a New Template

Getting Started:

1. Inthe Getting Started window, select the category for the new template and then right-click in the area below
the label that says “Right-click below to see more options " and select “Create a New Template...”
In the Name, type in the name for the new template
In the Content , type in the content of the new template
Click Ok

Tool Panels:

1. Inthe Tool Panels - Templates , select the category for the new template and then right-click and select
“Create a New Template...”

2. Inthe Name, type in the name for the new template
In the Content , type in the content of the new template

4. Click Ok
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4.3.2. Edit an Existing Template

Getting Started:
1. Inthe Getting Started window, select the category where the existing template is stored and then right-click in
the area below the label that says “Right-click below to see more options " and select “Edit Template...”
In the Name, type in the new name for the existing template
In the Content , type in the content of the existing template
Click Ok
Tool Panels:
1. Inthe Tool Panels - Templates , select the category where the existing template is stored and then right-
click and select “Edit Template...”
In the Name, type in the new name for the existing template

In the Content , type in the content of the existing template
Click Ok

4.3.3. Start a New File from a Template

Getting Started:

1. Inthe Getting Started window, select the category where the existing template is stored

2. Double-click on the existing template you wish base the new file on

Tool Panels:

1. Inthe Tool Panels - Templates, select the category where the existing template is stored

2. Double-click on the existing template you wish base the new file on

4.3.4. Delete an Existing Template

Getting Started:

1. Inthe Getting Started window, select the category where the existing template is stored
2. Right-click on the existing template you wish to delete and select “Delete Template... ”

Tool Panels:

1. Inthe Tool Panels - Templates , select the category where the existing template is stored

2. Right-click on the existing template you wish to delete and select “Delete Template... ”
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4.4. Working with Projects

Working with projects enables you to define a working workspace using your file system. You can access your project

through the Getting Started window and in Tool Panels.

On the View menu, click Panels and then Projects (shortcut: Shift + F6)

4.4.1. Create a New Project

Getting Started:

In the Getting Started window, right-click in the project area, and select “Project Manager...”

Click the button “New...”

In the Project name , type in the name for the new project.

In the Project Root Folder , type in the path for the project root, or click the Browse button to locate the path.
In the File, type in the file filters for the project

Click Ok.

o g kM w NP

Tool Panels:

In the Tool Panels = Projects , right-click and select “Project Manager...”

Click the button “New...”

In the Project name , type in the name for the new project.

In the Project Root Folder , type in the path for the project root, or click the Browse button to locate the path.
In the File, type in the file filters for the project

Click Ok.

I o
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4.4.2. Edit an Existing Project

Getting Started:

1. Inthe Getting Started window, right-click in the project area, and select “Project Manager...”

2. Select the project you wish to change

3. Click the button “Edit...”

4. Inthe Project name , type in the new name for the new project.

5. In the Project Root Folder , type in the new path for the project root, or click the Browse button to locate the
path.

6. Inthe File, type in the new file filters for the project

7. Click Ok.

Tool Panels:

1. Inthe Tool Panels -» Projects , right-click and select “Project Manager...”

2. Select the project you wish to change

3. Click the button “Edit...”

4. Inthe Project name , type in the new name for the new project.

5. In the Project Root Folder , type in the new path for the project root, or click the Browse button to locate the
path.

6. Inthe File, type in the new file filters for the project

Click Ok.
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4.4.3. Open Project

Getting Started:

1. Inthe Getting Started window, in the project area, select the project you wish to open

2. Double-click on the project to open it

Tool Panels:

1. Inthe Tool Panels -> Projects , in the project area, select the project you wish to open

2. Double-click on the project to open it

4.4.4. Delete Project

Getting Started:
1. Inthe Getting Started window, right-click in the project area, and select “Project Manager...”
2. Select the project you wish to delete
3. Click the button “Delete...” and confirm
Tool Panels:
1. Inthe Tool Panels -> Projects , right-click and select “Project Manager...”

2. Select the project you wish to delete

3. Click the button “Delete...” and confirm
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4.5. Data Folder

This is the folder where all your personal settings for PHP Designer 2007 are stored.

On the File menu, click Data Folder...

4.6. File Format

Files can be stored in the following file format:
¢ Windows
e Linux

. Macintosh

On the File menu, click File Format and select Windows, Linux or Mac

4.7. Duplicate File

Duplicate a full copy of the current file.

On the File menu, click Duplicate File
On the Tab menu, right-click and select Duplicate File

4 .8. Revert File

Revert the current file, if the file has been changed since it has been loaded you will be ask if these changes should be

saved.

On the File menu, click Revert File

4.9. Rename File

Rename the name of the current file and its file extension.

On the File menu, click Rename File

-54 -



PHP Designer 2007 MPSOFTWARE

4.10. Export to HTML, RTF or LaTeX

Export the current file with syntax coloring schemes to the following formats:

«  HTML
. RTF
«  LaTeX

On the File menu, click Export to HTML..., Export to RTF... or Export to LaTeX...

4.11. FTP Browser

The FTP Browser enables you to browse files and directories on a FTP server account.

To see more options, right-click in on the FTP browser. If you wish to upload, any files simply drag and drop them from

the File Browser in to the FTP Browser.

On the Tools menu, click FTP Browser (built-in)...

4.12. Application Manager

Open your documents in PHP Designer 2007 with external programs.

On the Tools menu, click Application Manager...
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Chapter 5 - Working with Tools

5.1. Introduction

This chapter will introduce you how to work with tools available in PHP Designer 2007.

5.2. Tools

It is recommended that you setup and configure the following tools on your computer and in the editor preferences to get
the most out of PHP Designer 2007:

¢ Web Browsers

Preview your documents in different web browsers

¢« Compile and Debug
Compile and preview the result of your documents or debug your documents for any syntax errors. This feature
requires that you have the PHP package installed local on your computer available free at http://www.php.net.

e Localhost
Preview your documents in your Localhost. This feature requires that you have a web service, for example.
Apache with at least the PHP package installed.

XAMPP and EasyPHP are both easy ways to install Apache with PHP and MySQL on your computer!

XAMPP: http://www.apachefriends.org/en/xampp.htmi

EasyPHP: http://www.easyphp.org

¢ Help Manuals
Access the contextual help with access to more then 3000 methods on the fly! This feature requires that you

have the PHP manual available free at http://www.php.net/download-docs.php.

¢ Online Search Engines

Rapidly lookup a word or a function while programming on the Internet using your favorite search engines.
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5.3. Web Browsers

Preview your documents in the following external web-browsers:

Internet Explorer
Firefox

Netscape

A

Opera

5.3.1. Configure the web-browser(s)

Before previewing any documents in any external web-browser, the current web-browser must be installed on your

computer and configure PHP Designer 2007 to work with these web-browsers.

On the Tools menu, point to Preferences (CTRL+E)

Use the left menu and navigate to Preview -> Browsers

Type in the path of the .exe file for the web-browser , or click the Browse button to locate the file
Click Ok

d w0bd P

Hint! PHP Designer 2007 will automatic try to detect your installed browsers, and configure itself to work with these

browsers.

5.3.2. Previewing documents in your favorite web-br  owser
Preview documents in your favorite web-browsers by using the submenu on the following tabs on top of the Edit window:
e Preview

« Debug

. Localhost

5.3.3. More information

Internet Explorer: http://www.microsoft.com/windows/ie/default.mspx

Firefox: http://www.mozilla.com/firefox/

Netscape: http://www.netscape.com/

A w0 DR

Opera: http://www.opera.com/
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5.4. Preview

The preview feature enables you to preview your file, typical your HTML-files, either in the internal- or in your favorite

external web-browser(s).

5.4.1. Preview Document

In order to preview a document, click the preview tab , located on top of the Edit window.

5.4.2. Preview Document in your favorite web-browse r

In order to preview a document in your favorite web-browser, click the submenu on the preview tab , located on top of

the Edit window.
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5.5. Introduction to the compiler and debugger

Debug your PHP files for any syntax errors and preview the output with the PHP Interpreter. The debug feature requires

that you have the PHP installed on your computer available free at www.php.net.
XAMPP and EasyPHP are both easy ways to install Apache with PHP and MySQL on your computer!

XAMPP: http://www.apachefriends.org/en/xampp.html

EasyPHP: http://www.easyphp.org

5.5.1. Configure the compiler and debugger

Before compiling or debugging your documents, you must have the PHP package installed on your computer and

configure PHP Designer 2007 to work with this package (php.exe or win-php.exe).

1. Onthe Tools menu, point to Preferences (CTRL+E)
Use the left menu and navigate to Preview - Debug & Preview

3. Type in the path of the .exe file for the PHP Interpreter (normal |y php.exe or win-php.exe) , or click the
Browse button to locate the file

4. Click Ok

5.5.2. Compiler and debugger settings

You can compile and debug your documents with the settings that the PHP package comes with.

1. Onthe Tools menu, point to Preferences (CTRL+E)

Use the left menu and navigate to Preview - Debug & Preview

3. Type in the path of the .ini file for the setting file (normall y php.ini) , or click the Browse button to locate the
file
4. Click Ok
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5.5.3. Compile and debug a document

In order to compile and debug a document, click on the Debug tab on the top of the Edit window.

If there is, no error in the document the result will be displayed in the internal web browser.

5.5.4. Compile and debug your documents in your fav  orite web browser

In order to compile and debug a document, and previewing the result in your favorite web browser you can use the

submenu on the Debug tab located on top of the Edit window.

If there is, no error in the document the result will be displayed in your favorite web-browser.

5.5.5. Error(s) in a document

If the compiler and debugger found any errors in a document, all errors will be listed in the Debug Panel.

1. Inthe Debug Panel, select the error to solve or navigate too.

2. Double-click or press Enter to jump to the current error in the document.

5.5.6. More information

XAMPP and EasyPHP are both easy ways to install PHP, MySQL and Apache on your computer!

1. PHP: http://www.php.net

2. XAMPP: http://www.apachefriends.org/en/xampp.html

3. EasyPHP: http://www.easyphp.org

- 60 -



PHP Designer 2007 MPSOFTWARE

5.6. Localhost (Apache etc.)

The Localhost feature enables you to preview your files, typical your PHP-files located in your in your localhost directory

either in the internal- or in your favorite external web browsers.

5.6.1. Configure the Localhost

In order to use the Localhost feature, it is required that a web-server like Apache is installed and that you have configure
PHP Designer 2007 to work with the Localhost.

On the Tools menu, point to Preferences (CTRL+E)

Use the left menu and navigate to Debug & Preview

Type in the server path , typical “http://localhost”

Type in the path of the .exe file for the web browser , or click the Browse button to locate the file.
Click Ok.
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XAMPP and EasyPHP are both easy ways to install PHP, MySQL and Apache.
“Many people know from their own experience that it's not easy to install an Apache web server and it gets harder if you
want to add MySQL, PHP and Perl. XAMPP is an easy to install Apache distribution containing MySQL, PHP and Perl.

XAMPRP is very easy to install and to use. 2

XAMPP: http://www.apachefriends.org/en/xampp.htmi

EasyPHP: http://www.easyphp.org

2 Source: http://www.apachefriends.org/en/xampp.html
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5.6.2. Preview a document located Localhost

In order to preview a document in the Localhost directory the document must be stored in the Localhost directory. Click
the Localhost tab , located on top of the Edit window.

5.6.3. Preview a document located Localhost usingy  our favorite web-browser

In order to preview a document in the Localhost directory the document must be stored in the Localhost directory. Click

the submenu on the Localhost tab , located on top of the Edit window.

5.6.4. More information

XAMPP: http://www.apachefriends.org/en/xampp.htmi

2. EasyPHP: http://www.easyphp.org

Apache: http://httpd.apache.org/

PHP: http://www.php.net

MySQL: http://www.mysql.com/
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5.7. Help Manuals

The help feature enables you too easily launch any help manual available on your computer and contextual access more
then 3000 PHP methods on the fly!

This feature requires that you have the PHP manual available free at http://www.php.net/download-docs.php.

5.7.1. Configure the PHP Manual (contextual help)

In order to access the contextual help with access to more then 3000 PHP methods on the fly you must download the

PHP manual available free at http://www.php.net/download-docs.php and configure PHP Designer 2007 to work with this

manual.

On the Tools menu, point to Preferences (CTRL+E)
2. Use the left menu and navigate to Help Manuals
In the PHP Manual, type in the path of the .chm file for the PHP manual , or click the Browse button to locate
the file.
In the PHP Manual Language , set the language for the PHP manual.
Click Ok.

5.7.2. Access contextual help on the fly

In order to access the contextual help with access to more then 3000 PHP methods on the fly, right-click on the word you

like to lookup and select “Lookup function... " or press F1 on the word.

The contextual help will be displayed in the Help panel, if the selected word could be found the “Function Reference”

page will be displayed.

5.7.3. Configure the HTML, CSS, SQL or PEAR manual

In order to open the HTML, CSS SQL or PEAR manual from inside PHP Designer 2007 you must first download these

manuals and configure PHP Designer 2007 to work with these manuals.

1. Onthe Tools menu, point to Preferences (CTRL+E)
Use the left menu and navigate to Help Manuals
In the HTML, CSS, SQL or PEAR Manual , type in the path of the file for the manuals , or click the Browse
button to locate the file

4. Click Ok
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5.7.4. Open the HTML, CSS, SQL or PEAR manual

In order to open HTML, CSS SQL or PEAR manual from inside PHP Designer 2007, click Help = Manuals > HTML,
CSS, SQL or PEAR.

5.7.5. More information

PHP Manual: http://www.php.net/download-docs.php

HTML Manual: http://www.w3.org/TR/html4/

CSS Manual: http://www.w3.0rg/TR/2004/CR-CSS21-20040225/
SQL Manual: http://dev.mysqgl.com/doc/
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PEAR Manual: http:/pear.php.net/manual/index.php
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5.8. Online Search Engines

You can rapidly lookup a word or a function while programming on the Internet using your favorite search engines.

PHP Designer 2007 supports the following online search engines:

¢ Google

¢ MSN

¢ Yahoo!

e AltaVista
¢ Wikipedia
e Koders

5.8.1. Configure the Online Search Engines

If you need to re-configure the path to the above search engines, do the following:

On the Tools menu, point to Preferences (CTRL+E)

2. Use the left menu and navigate to Integration - Online Search Engines
In the Google, MSN, Yahoo!, AltaVista, Wikipedia or Koders , type in/change the path of the for the current
online search engines

4. Click Ok

5.8.2. Using the Online Search Engines

In order to lookup a word or a function while programming on the Internet using your favorite search engines, right-click
on the word you like to lookup and select Online Search Engines then select either Google, MSN, Yahoo!, AltaVista,

Wikipedia or Koders.

The result will appear in an external web-browser.

5.8.3. More information

Google: http://www.google.com

MSN: http://search.msn.com

Yahoo!: http://www.yahoo.com

Altavista: http://www.altavista.com

Wikipedia: http://www.wikipedia.com
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Koders: http://www.koders.com
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Chapter 6 - The Edit Window

6.1. Introduction

This chapter will introduce the Edit Window in PHP Designer 2007.

6.2. Tabbed Navigation

The tabbed navigation lets you create and edit documents in separate tabs, so you can jump between them quickly and

easily by right- or left click the current tab.
Every tab consists of the following elements:

¢ The document number
¢  The filename of the document
« Ifthe tabicon is red then the document is modified and the changes have been saved yet otherwise the tab icon

is black.

You can reorder the tabs as you like, simply drag and drop the current tab to a new position on the same tab-bar.

6.3. Syntax Highlighters

One of the strength in PHP lies in the ability to embed it into- and together with other web-languages, and this is why
PHP Designer 2007 not only supports PHP but also other web-languages like HTML, MySQL, XML, CSS, JavaScript,
VBScript, Java, C#, Perl, Python and Ruby!

Change the document syntax highlighter on the fly:

1. On top of the Edit Window , change the syntax highlighter to PHP, HTML, SQL, XML, CSS, JavaScript,
VBScript, Java, C#, Perl, Python or Ruby

In the preferences, you can change the style and colors etc. for each syntax scheme.

On the Tools menu, point to Preferences (CTRL+E)

Use the left menu and navigate to Editor - Syntax Highlighter
Select the syntax scheme and attribute if you like to change
Click Ok
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6.4. Intelligent Highlighter

The Intelligent Highlighter gives you the to automatic separate PHP, HTML, XML and JavaScript syntax schemes in the

same document.

Let us say you have a document with PHP, XML and HTML codes and while editing the PHP both the XML and HTML

part of the code will be dimmed.
1. On top of the Edit Window , change the syntax highlighter to Intelligent Highlighter
The following tags define the syntax schemes in Intelligent Highlighter:

e PHP:<?7?>

e PHP: <?php ?>

e HTML: (default)

¢ CSS: <style type="text/css"></style>

« JS: <script type="text/javascript" language="javascript"></script>

e XML: <?xml ?>

In the preferences you can automatic apply the Intelligent Highlighter on PHP, HTML, XML, CSS, and JavaScript

documents.
5. Onthe Tools menu, point to Preferences (CTRL+E)
6. Use the left menu and navigate to Editor - Syntax Highlighter
7. In the Intelligent Highlighter, check the checkbox
8. Click Ok
6.5. Code Tip

The Code Tip helps you complete predefined and user-functions easily by automatic showing the expected parameters

for the current functions.

In the preferences, you can enable/disable the Code Tip

On the Tools menu, point to Preferences (CTRL+E)
Use the left menu and navigate to Editor

In the Code Tip, check or uncheck the checkbox
Click Ok

A
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6.6. Code Suggestion

The Code Suggestion reduces the amount of typing, by offering a list of elements you can insert directly into your

document with a single mouse click or by pressing the Enter key.
The elements in the Auto Complete are:
HTML (elements, attributes and events)

PHP (functions, user-functions, included functions and user-variables)

phpDocumentor

R

Smarty

You can access the list of elements in the Auto Complete by pressing CTRL + SPACE and close it again with ESC key.

6.7. Auto Complete

The Auto Complete reduces the amount of typing, by automatic finish what you are typing just press CTRL+J.
In the preferences, you can manage the list of elements in the Auto Complete
1. Onthe Tools menu, point to Preferences (CTRL+E)

2. Use the left menu and navigate to Editor - Auto Complete
3. Click Ok

6.8. Auto Correct

If you have often type, a word wrong the Auto Correct can help you correct it automatic.
In the preferences, you can manage the list of elements in the Auto Correct
4. Onthe Tools menu, point to Preferences (CTRL+E)

5. Use the left menu and navigate to Editor - Auto Correct
6. Click Ok
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6.9. Gutter

The Gutter on the left, gives you the following information:

. Line numbers in the document
¢ Ifalineis wrapped or not

¢ If there are any bookmarks placed in the document

In the preferences, you can enable/disable the left Gutter

On the Tools menu, point to Preferences (CTRL+E)
Use the left menu and navigate to Editor

In the Show Guitter , check or uncheck the checkbox
Click Ok
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6.10. Bookmarks

The bookmark feature marks a current position in your documents. You can access your bookmarks by either right-click
or click the Gutter.
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6.11. Highlight Brackets

This feature visually marks the pair of brackets nearest to the caret.
In the preferences, you can enable/disable the bracket-highlighting feature

On the Tools menu, point to Preferences (CTRL+E)

Use the left menu and navigate to Editor

In the Highlight Brackets , check or uncheck the checkbox
Click Ok
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6.12. Remove Empty Lines

Remove selected or all empty lines in your document.

1. Onthe Tools menu, point to Remove Empty Lines
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Chapter 7 - Print

7.1. Introduction

This chapter will introduce the print features in PHP Designer 2007.

7.2. Print Preview

To see how the page will look when printed, on the File menu, click Print... .

7.3. Print Range

Define the print range, on the print toolbar, click Page: Range All or Page Range: Selected .

7.4. Print Navigation

If the document contains more then just one page, you can navigate through the document either by using the arrows on

your keyword or by clicking on the print toolbar:

e >:Next page

e <& : Previous page
e | :Last page

e | € : First page

7.5. Print Settings

Change the print settings, click the settings button on the print toolbar and define:

«  Printtitle (define the title on every page in the print)

« Header and Footer (define the header and footer on every page in the print)
«  Printin black and white (if not checked then the print will be in colors)

« User the current syntax highlighter

e Print line numbers

¢ Wrap long lines
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Chapter 8 - Search and Replace

8.1. Introduction

This chapter will introduce the search and replace features in PHP Designer 2007.

8.2. Search

To search for text in your document do:
1. Onthe Search menu, point to Search (CTRL+F)

2. Set search options
3. Click Ok

8.3. Search Again

Search for the same text again

1. Onthe Search menu, point to Search Again (F3)

8.4. Replace

To replace a text in your document do:
1. Onthe Search menu, point to Replace (CTRL+H)

2. Setreplace options
3. Click Ok
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8.5. Extended Search

To search for text in your open documents do:

1. Onthe Search menu, point to Extended Search
2. Set search options
3. Click Ok

8.6. Extended Replace

To replace text in your open documents do:

1. Onthe Search menu, point to Extended Replace
2. Set search options
3. Click Ok

8.7. Search in Files

To search for text in files do:
1. Onthe Search menu, point to Search in Files

2. Set search options
3. Click Ok

8.8. Search Options

The following will be an introducing to the search options available in PHP Designer 2007.

8.8.1. Selected Text Only

The search will only search within the selected text.

8.8.2. Whole Words Only

The search will searches for whole words only.

8.8.3. Case Sensitive

The search will distinguish between uppercase (capital) and lowercase (small) letters
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8.8.4. Regular Expression

Use Regular expressions to search for advanced patterns in the file. These are some of the recognized special

characters that can be used:

LI
o+
< [l
M
[
< {3

A circumflex at the start of the string matches the start of a line.*

A dollar sign at the end of the expression matches the end of a line.*

A period matches any character. An asterisk after a string matches none or any characters.*

A plus sign after a string matches any number of occurrences of that string followed by any characters.*
Characters in brackets match any one character that appears in the brackets, but no others.*

A circumflex at the start of the string in brackets means NOT.*

A hyphen within the brackets signifies a range of characters. For example, [a-z] matches any character
from a through z. *

Braces group characters or expressions. *

*Source: http://www.optistic.com/index.php?id=32
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Chapter 9 - Debug, Analyze & Preview

9.1. Introduction

This chapter will introduce the debug, analyze and preview features in PHP Designer 2007.

9.2. Debugger

Debug your PHP files for any syntax errors and preview the output with the PHP Interpreter. The debug feature requires
that you have the PHP installed on your computer available free at www.php.net.

XAMPP and EasyPHP are both easy ways to install Apache with PHP and MySQL on your computer!

XAMPP: http://www.apachefriends.org/en/xampp.htmi

EasyPHP: http://www.easyphp.org

9.2.1. Configure the compiler and debugger

Before compiling or debugging your documents, you must have the PHP package installed on your computer and
configure PHP Designer 2007 to work with this package (php.exe or win-php.exe).

On the Tools menu, point to Preferences (CTRL+E)

6. Use the left menu and navigate to Preview - Debug & Preview
Type in the path of the .exe file for the PHP Interpreter (normal ly php.exe or win-php.exe) , or click the
Browse button to locate the file

8. Click Ok

9.2.2. Compiler and debugger settings

You can compile and debug your documents with the settings that the PHP package comes with.

On the Tools menu, point to Preferences (CTRL+E)
Use the left menu and navigate to Preview - Debug & Preview
Type in the path of the .ini file for the setting file (normall y php.ini) , or click the Browse button to locate the
file
8. Click Ok
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9.2.3. Compile and debug a document

In order to compile and debug a document, click on the Debug tab on the top of the Edit window.

If there is, no error in the document the result will be displayed in the internal web browser.

9.2.4. Compile and debug your documents in your fav  orite web browser

In order to compile and debug a document, and previewing the result in your favorite web browser you can use the

submenu on the Debug tab located on top of the Edit window.

If there is, no error in the document the result will be displayed in your favorite web-browser.

9.2.5. Error(s) in a document

If the compiler and debugger found any errors in a document, all errors will be listed in the Debug Panel.

3. Inthe Debug Panel , select the error to solve or navigate too.

4. Double-click or press Enter to jump to the current error in the document.

9.2.6. More information

XAMPP and EasyPHP are both easy ways to install PHP, MySQL and Apache on your computer!

4. PHP: http://www.php.net

5. XAMPP: http://www.apachefriends.org/en/xampp.html

6. EasyPHP: http://www.easyphp.org

9.3. Preview

The preview feature enables you to preview your file, typical your HTML-files, either in the internal- or in your favorite

external web-browser(s).

9.3.1. Preview Document

In order to preview a document, click the preview tab , located on top of the Edit window.

9.3.2. Preview Document in your favorite web-browse r

In order to preview a document in your favorite web-browser, click the submenu on the preview tab , located on top of

the Edit window.
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9.4. Localhost (Apache etc.)

The Localhost feature enables you to preview your files, typical your PHP-files located in your in your Localhost directory

either in the internal- or in your favorite external web browsers.

9.4.1. Configure the Localhost

In order to use the Localhost feature, it is required that a web-server like Apache is installed and that you have
configured PHP Designer 2007 to work with the Localhost.

On the Tools menu, point to Preferences (CTRL+E)
Use the left menu and navigate to Debug & Preview

6
7.
8. Type in the server path , typical “http://localhost”
9

Type in the path of the .exe file for the web browser , or click the Browse button to locate the file.
10. Click Ok.
XAMPP and EasyPHP are both easy ways to install PHP, MySQL and Apache.
“Many people know from their own experience that it's not easy to install an Apache web server and it gets harder if you

want to add MySQL, PHP and Perl. XAMPP is an easy to install Apache distribution containing MySQL, PHP and Perl.

XAMPRP is very easy to install and to use. %

9.4.2. More information

1. PHP: http://www.php.net

2. XAMPP: http://www.apachefriends.org/en/xampp.html

3. EasyPHP: http://www.easyphp.org

3 Source: http://www.apachefriends.org/en/xampp.html
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9.5. Web Browsers

Preview your documents in the following external web-browsers:

Internet Explorer
Firefox

Netscape
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Opera

9.5.1. Configure the web-browser(s)

Before previewing any documents in any external web-browser, the current web-browser must be installed on your

computer and configure PHP Designer 2007 to work with these web-browsers.

On the Tools menu, point to Preferences (CTRL+E)

Use the left menu and navigate to Preview -> Browsers

Type in the path of the .exe file for the web-browser , or click the Browse button to locate the file
Click Ok
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Hint! PHP Designer 2007 will automatic try to detect your installed browsers, and configure itself to work with these
browsers.

9.5.2. Previewing documents in your favorite web-br ~ owser
Preview documents in your favorite web-browsers by using the submenu on the following tabs on top of the Edit window:
e Preview

« Debug

. Localhost

9.5.3. More information

Internet Explorer: http://www.microsoft.com/windows/ie/default.mspx

Firefox: http://www.mozilla.com/firefox/

Netscape: http://www.netscape.com/
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Opera: http://www.opera.com/
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