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Introduction
and installation

Introducing Visio Professional

Whether you work with information technology or manage a group or busi-
ness, the Visio® Professional drawing application can help you efficiently design
and document your systems and processes. With Visio Professional,
you can

• Design and diagram networks.

• Plan and map intranet and World Wide Web sites.

• Describe and re-engineer business processes.

• Map and create databases.

• Model software systems and design interface elements, and more.
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In addition to solutions, templates, stencils, shapes and wizards, Visio
Professional includes features common to all Visio products that make it the
program of choice for visualizing and communicating ideas. Those features
include

• Easy-to-use drag and drop drawing.

• SmartShapes® technology—shapes programmed to behave the way you expect.

• Compatibility and consistency with Microsoft Windows 95, Office 97, and
Windows NT 4.0.

• A quick and easy process for publishing drawings as Web pages.

• A built-in development tool, Visual Basic for Applications (VBA), that you
can use to customize the Visio interface and create custom solutions.

The Visio user manuals
Visio Professional includes three pieces of printed documentation: Using Visio
Professional (this book), Using Visio Products, and Developing Visio Solutions.
Here’s the type of information you can find in each:

Using Visio Professional (this book)

• Instructions for installing Visio Professional.

• An overview of what’s new in this version and what the product contains.

• Detailed instructions for using features specific to Visio Professional, such
as the Network Diagram Wizard, the Map Database Wizard, or the UML
diagram semantics checker.

• An introduction to ShapeSheet™ spreadsheets and other tools for customiz-
ing Visio shapes and controlling its shapes, pages, menus, and other objects
using a programming language, such as VBA, that supports Automation.

• Where to go for more information about using basic Visio features, working
with a specific shape, or creating a specific type of drawing.

Using Visio Products

• Detailed information about standard Visio functionality.

Developing Visio Solutions

• Everything you need to know about Visio as a development platform,
including sample code, tips, and techniques.

Related topics
Additional sources of Visio Professional information .............................................. 63
Installing Visio Professional ......................................................................................... 3
Visio Professional concepts and content ..................................................................... 9
Visio Professional content .......................................................................................... 12
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Installing Visio Professional

This section includes information about installing Visio Professional and where
to go for help with installation.

System configuration
Required:

• Microsoft Windows 95 or Microsoft Windows NT 4.0

• VGA or better display

• Mouse

• CD-ROM drive for installation

Recommended:

• Pentium, Pentium Pro, or Pentium II PC with 16 MB or more RAM for
Windows 95, and 24 MB or more RAM for Windows NT

• Up to 110 MB of hard disk space required for a full installation; 15 MB for
minimum installation

Optional:

• Windows-compatible printer or plotter

• Modem and Internet access

• Local area network (volume licenses available)

How to prepare for installation
• Close all programs and turn off virus protection software to prevent installa-

tion conflicts.

• If you have another version of Visio installed on your computer and do not
want to overwrite that version, change the default installation folder for
Visio Professional during installation setup.

• To avoid overwriting stencils or templates you’ve customized or created,
place them into a separate folder before you install.

Installing electronic versions of manuals and files
During installation, you have the option of installing .pdf format files for the
following manuals and tools:

• Using Visio Products, Using Visio Professional, Developing Visio Solutions

• Copies of the Unified Modeling Language (UML) notation, semantics, and
other guides developed by Rational Software Corporation. If you create
UML diagrams, these guides are an excellent source of reference information.
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If you work in a corporate environment where most users don’t receive printed
copies of the manuals, you can make these electronic copies available on the
corporate network or intranet.

To open, read, or print the .pdf files, you need to install the Adobe Acrobat
Reader by double-clicking the Setup.exe file located in the Acrobat Reader
folder on the Visio Professional CD.

If you choose not to install the .pdf files during installation, you can still copy
them to your computer. The .pdf files are located in the Docs folder on the
Visio Professional CD.

Installing Visio Professional from the CD
You must be running Microsoft Windows 95 or Microsoft Windows NT 4.0 to
install Visio Professional. Installation starts when you insert the Visio Professional
CD into your CD-ROM drive. If installation does not start, you can install Visio
Professional using the following procedure.

To install Visio Professional on Windows 95 or Windows NT 4.0:

1. Insert the Visio Professional CD into your CD-ROM drive.

2. From the Start menu, choose Run.

3. In the Run dialog box, type d:\setup, where d is the letter assigned to your
CD-ROM drive.

4. Click OK, then follow the instructions on your screen.

The Setup program guides you through the installation process.

Installing Visio Professional on a network
There are two ways to set up Visio Professional on a network server:

• Install a copy on a network server so that multiple workstations can run it
from the server.

• Place the Visio Professional files on a network server so the program can be
copied onto the hard disks of individual workstations.

For information about network administrator installation options, see
Network.txt at the root of your Visio Professional CD.

If you need help with installation
If you encounter problems while installing Visio Professional, call Technical
Support (see Using Visio Products for the correct number for your area). For
help with technical issues, see the Visio Corporation Web site, which you can ac-
cess from within Visio by choosing Help > Visio On The Web > Online Support.
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New and
enhanced features

About Visio Professional 5.0

Visio Professional 5.0 offers new and smarter shapes, an improved drawing en-
vironment, and features that integrate Visio seamlessly with Microsoft Office 97
applications. And, the Visio Professional enhanced wizards, connectors, and
other tools make your work easier and faster.

For details about developer tools new to version 5.0, see Developing Visio
Solutions.

Related topics
New features .................................................................................................................. 5
Visio Professional content .......................................................................................... 12

New features

The following tables describe the new and enhanced features available
in Visio Professional 5.0.

Compatibility

Feature Description

New! Microsoft Office 97 compatibility Send To support  From within Visio, route and send drawings through e-mail to
other recipients.

Binder support  Add headers and footers to Visio drawings included in Microsoft
Binder files and view the drawings in Print Preview mode.

Outlook journaling  Automatically record the time you spend working on Visio
drawings in your Outlook journal.

New! In-place editing Edit objects you embed in Visio drawings without leaving the Visio environment.
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Drawing environment

Feature Description

Updated! Backward compatibility Opening files  Open any Visio file in Visio Professional 5.0, regardless of the
version you created the file in.

Saving files  Save drawings you create in Visio Professional 5.0 so they can be
opened in earlier versions.

New! Drawing page behavior Sizing  To resize the drawing page, simply place the cursor over an edge of the
page, hold down the Ctrl key, and drag.

Rotation  Rotate the contents of the page for any aspect of a drawing that is at an
angle to the rest of the drawing.

Improved! Toolbar Organization  Toolbar buttons are grouped by function so they’re easier to see
and access.

Independent display  Show or hide groups of buttons to make the toolbar more
convenient to use.

Pop-up palettes  Select colors, patterns, and other attributes from pop-up palettes
associated with toolbar buttons, such as Fill Color or Line Weight.

Tools

Feature Description

New! Connector technology Fewer connectors  Fewer, but more powerful connectors make it easier to choose
the one you need.

Dynamic routing  Connectors automatically re-route around shapes when you
drop or move them.

New! Custom patterns, fills, and Create your own custom patterns, fills, and line ends, then easily apply them
line ends to shapes.

New! Full-screen view View drawings in full-screen or presentation mode without toolbars or other
interface elements, and navigate from page to page using the mouse buttons or
arrow keys.

New! ODMA support Handle Visio Professional drawings as part of your Document Management
System (DMS). When Visio detects the presence of Open Document Management
Architecture (ODMA), it passes file management operations to the ODMA
program.

New! Import and annotate Bring .dwg/.dxf AutoCAD files into Visio Professional as images to view, annotate,
AutoCAD files and add Visio shapes to them. Save the imported files as Visio drawings.



N E W  A N D  E N H A N C E D  F E A T U R E S 7

Feature Description

New! Shape Explorer Search for and catalog shapes, stencils, or templates stored on your own computer
or on the Visio Web site.

New! Database Export Export data from selected cells in a shape’s ShapeSheet spreadsheet and store the
data in a database table.

New! Graphics/file support Import  Import Enhanced (32-bit) Metafiles, CorelDRAW 7, and AutoCAD .dwg/
.dxf/.dwf files.

Export  Export Visio drawings as Enhanced (32-bit) Metafiles.

Improved! Web tools Adding hyperlinks  Efficiently add hyperlinks to Visio shapes and drawing pages
so you can jump to other Visio drawing pages or files, documents created in other
applications, or to Web sites (URLs). You can even link to a specific location
within a document or on a Web page.

Saving drawings as HTML files  Improved interface for saving Visio drawings as
HTML files you can publish on the Web. More precise boundaries around shapes
that serve as hot links.

Web Diagram Wizard  Enhanced HTML-code handling, so you can diagram a
broader range of Web sites.

Internet Explorer  Open Visio files in Internet Explorer and edit them there. Use
the browser’s Forward and Back buttons to move between Visio drawings, Web
pages, and other files open in Explorer.

Improved! Database Wizard Efficiency  The Database Wizard in Visio Professional 5.0 runs faster and supports
more ODBC (Open Database Connectivity standard) drivers and new custom
property types. You can also control some ODBC settings from within Visio.

Drawing Monitor  In Visio Professional 5.0, you can control when the drawing
monitor launches. You can add an action to a drawing page so you can launch the
drawing monitor by right-clicking the page.

ODBC settings  From within Visio Professional, modify some of the ODBC
settings that affect how the Database Wizard operates.

Improved! Faster report creation Reports for large drawings  Enhanced performance of the Property Reporting
Wizard enables you to generate inventory and numeric reports quickly even for
very large drawings that include shapes with many custom-property fields.

Faster inventories  To extract data from a drawing, such as an organization chart,
office plan, or network diagram, you can quickly create an inventory report and
write the data to a spreadsheet or text file.
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Content

Feature Description

New! UML support UML diagrams  Visio Professional includes a Unified Modeling Language (UML)
Template with shapes that support static structure UML diagrams.

Microsoft Repository  Export UML diagrams as models that can be stored in
the Microsoft Repository, and import models from the Repository into Visio
Professional as UML diagrams.

New! Network Equipment shapes Visio Professional includes approximately 700 new manufacturer-specific network
equipment shapes (representing 3Com, Cabletron, Cisco, Bay Networks, and HP
equipment).

New! Database and Software Additional templates and stencils support the creation of Bachman and ORM
Diagramming solutions (Object Role Modeling) database design diagrams,  UML (Unified Modeling

Language) software modeling diagrams, and Office 97 user interface diagrams.

New! Marketing shapes Two new Marketing stencils for quickly creating colorful and informative
marketing presentations that include pyramids, bubble charts, spoke diagrams,
and more.

Improved! IDEF0 shapes Improved IDEF0 shape behavior, and several new methodology-specific shapes,
make creating IDEF0 diagrams more efficient.

Improved! Project Timeline Solution Data columns  Add data columns for information such as Start Date, End Date,
and Duration to Gantt charts.

Dynamic updating  Typing in a data column updates the task bars in the Gantt
chart. When you drag a task bar, you update the data in the data columns.

Microsoft Project  Import files in Microsoft Project Exchange (.mpx) format and
display the data in a Visio Professional Gantt chart. You can also export data from
a Visio Gantt chart into .mpx format.

Improved! Organization Chart Wizard Use the Organization Chart Wizard to create organization charts from data stored
in a database table created in an ODBC-compliant database program. Display
some of the database table’s column headings (such as Name and Department)
on position shapes in the chart and add the other column headings to the shapes
as custom-property fields.

Related topics
About Visio Professional 5.0 ........................................................................................ 5
About Visio Professional concepts and content .......................................................... 9
Visio Professional content .......................................................................................... 12
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Visio Professional
concepts and content

About Visio Professional concepts and content

Whether you create drawings as your primary job or only occasionally, you
don’t have to learn a complex design or CAD program. Visio Professional pro-
vides powerful graphics capabilities, an intuitive user interface, and the drag
and drop drawing technique you can use to quickly create and distribute the
drawings you need.
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From idea to Visio Professional drawing

To draw, simply drag shapes to the
drawing page. If you need additional
shapes, you can create them.

When your drawing is complete, you can print it,
include it in other documents, or distribute it on an
intranet or the World Wide Web.

HTTP://W W W

The Visio Professional drawing environment
You start by choosing a solution that matches the type of drawing you want to
create. A solution includes everything you need to turn an idea into a drawing,
such as

• Blank drawing pages set up with an appropriate size, orientation, and scale.

• Shapes that look and behave like real-life objects.

• Tools for editing existing shapes or drawing your own shapes from scratch.

• Pre-set styles for text, lines, and shapes so you don’t need to spend time
formatting.

• Wizards that automate complex or routine tasks.

• Automation tools that help you customize the way the program works.

To open a solution from within Visio Professional, choose File > New, then
choose the drawing type you want. Opening a solution actually opens a template
file, a file that contains shapes, drawing pages, and other tools. Each template
includes one or more stencil files on which shapes are stored. You can open ad-
ditional stencils whenever you need them, no matter what template you’re
working in.
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Stencil:
Directional Map

Shapes.VSS

Drawing page

Template:
Directional Map.VST

Shape: Hospital

When you choose a Visio Professional solution, you actually open a template file, which
includes shapes on stencils, a drawing page, styles, and other tools.

Working with Visio Professional files
Because templates and stencils are types of files, you can find them in the Visio
Professional folder in Windows Explorer organized the same way solutions are
organized under the File > New menu. The Visio folder includes a Solutions
subfolder, where you can find a folder for each drawing type. Within a drawing-
type folder, you can find template and stencil files. You can open a template or
stencil from within Visio Professional or from the Windows Explorer by
double-clicking the file icon.
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Template files, ( ), have a .vst extension. Stencil files, ( ), have a .vss extension. Drawing
files have .vsd extensions.

Related topics
About Visio Professional 5.0 ........................................................................................ 5
Basing new drawings on templates ........................................... Using Visio Products  9
Displaying, moving, and adding stencils .................................. Using Visio Products  8

Visio Professional content

To create a drawing in Visio Professional, you open a solution. Each solution
consists of a template (a file that serves as the container for the shapes), a draw-
ing page, and tools you use to create a drawing. Each template includes one or
more stencils, which are files that contain the shapes you drag onto the drawing
page.

The following table, which is organized by drawing type, lists the Visio
Professional solutions and the templates and stencils they contain. For details
about creating a drawing using a specific template, choose Help > Template
Help, then double-click Visio Templates.



V I S I O  P R O F E S S I O N A L  C O N C E P T S  A N D  C O N T E N T 1 3

Block Diagram Solutions

  Templates   Stencils

Basic Diagram Basic Shapes

Block Diagram Blocks, Blocks Raised

Block Diagram with Perspective Blocks with Perspective

Business Diagram Solutions

  Templates   Stencils

Charts and Graphs Charting Shapes

Form Design Forms Shapes

Office Layout Office Layout

Marketing Charts and Diagrams Charting Shapes, Marketing Clipart, Marketing Diagrams

Organization Chart Organization Chart Shapes

Project Timeline Project Timeline

Database Solutions

  Templates   Stencils

Crow’s Foot ERD Crow’s Foot ERD Shapes

Bachman Bachman

IDEF1X ERD IDEF1X ERD Shapes

Object Role Modeling Object Role Modeling Shapes
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Flowchart Solutions

  Templates  Stencils

Audit Diagram Audit Diagram Shapes, Connectors and Callouts

Data Flow Diagram Data Flow Diagram Shapes

Flowchart - Basic Basic Flowchart Shapes, Basic Flowchart Shapes2

Flowchart - Advanced Audit Diagram Shapes, Connectors and Callouts, Data Flow Diagram Shapes,
Miscellaneous Shapes, SDL Diagram Shapes, TQM Diagram Shapes Work Flow
Diagram Shapes

IDEF0 Diagram IDEF0 Diagram Shapes

Mind Mapping Diagram Mind Mapping Diagram Shapes

SDL Diagram SDL Diagram Shapes, Connectors and Callouts

TQM Diagram TQM Diagram Shapes

Work Flow Diagram Work Flow Diagram Shapes, Connectors and Callouts

Internet Diagram Solutions

  Templates   Stencils

Web Diagram Web Diagram Shapes

Map Solutions

  Templates  Stencils

Directional Map Directional Map Shapes

Geographic Maps Africa, Asia, Europe, Mid-East, North and South America, US and Canada,
Maps of the World
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Network Diagram Solutions

  Templates   Stencils

3Com Equipment 3Com LinkBuilder Shapes, 3Com Other Equipment Shapes, 3Com SuperStack
Shapes, Accessories, Miscellaneous Equipment, Structured Racks

Basic Network Basic Network Shapes, Basic Network Shapes 2

Bay Networks Equipment Bay Networks Access Node, Bay Networks BayStack, Bay Networks Centillion,
Bay Networks Distributed 5000, Bay Networks Other Equipment, Bay Networks
System 3000, Bay Networks System 5000, Accessories, Miscellaneous Equipment,
Structured Racks

Cabletron Equipment Cabletron Micro MMAC, Cabletron MMAC Plus, Cabletron MMAC, Accessories,
Miscellaneous Equipment, Structured Racks

Cisco Equipment Cisco 7000 Family, Cisco Access Products, Cisco Catalyst Switches, Cisco Other
Equipment, Accessories, Miscellaneous Equipment, Structured Racks

Hewlett Packard Equipment Hewlett Packard, Accessories, Miscellaneous Equipment, Structured Racks

Logical Network Diagram Desktop Symbols, General Annotation, IBM Symbols, Miscellaneous Symbols,
Network Connections, Network Icons, Telecom Symbols
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Software Diagram Solutions

  Templates   Stencils

Booch OOD Booch OOD

Chen ERD Chen ERD

COM and OLE COM and OLE

Express-G Express-G

Fusion Booch OOD, Rumbaugh OMT, Jacobson Use Cases, Connectors

Gane-Sarson DFD Gane-Sarson DFD

Jacobson Use Cases Jacobson Use Cases

Martin ERD Martin ERD

Nassi-Schneiderman Nassi-Schneiderman

Program Structure Language Level Shapes, Memory Objects

Rumbaugh OMT Rumbaugh OMT

Shlaer-Mellor OOA Shlaer-Mellor OOA

SSADM SSADM

System Structure System Diagrams

UML - Static Structure Diagram UML - Static Structure Shapes

Windows User Interface Office 97 User Interface, Win95 User Interface

 Yourdon and Coad Yourdon and Coad

Visio Extras

  Templates   Stencils

Borders, Callouts, Clipart, Connectors, General Annotation, Symbols

Related topics
About Visio Professional 5.0 ........................................................................................ 5
New features .................................................................................................................. 5
About Visio Professional concepts and content .......................................................... 9
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Designing and
documenting networks

About network diagrams in Visio Professional

The network diagramming solution in Visio Professional includes the templates
and wizards you need to create and manage physical and logical network
diagrams.

You can represent a network at different levels of detail in a single drawing file,
from a general geographic overview of the locations linked by the network to an
annotated physical diagram of a server room.
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You can store data with network shapes by entering the data into the existing
custom-property fields of the shapes.

When you want to store additional custom data, you can add new custom-
property fields.

The network wizards in Visio Professional make it easy to base network diagrams
on existing data or to generate databases from network diagrams. You can

• Use the Network Diagram Wizard to create a network diagram based on
node and segment information stored in a spreadsheet or database.

• Plan your network first using a diagram, store data in the shapes, and then
use the Network Database Wizard to create a database from the diagram.

• Use the Network Database and Network Diagram Wizards together to revise
and update network diagrams based on changes to the database table.

Related topics
About storing data in shapes ................................................. Using Visio Products  177
Creating network diagrams from ODBC databases ................................................. 21
Creating ODBC databases based on network diagrams ........................................... 23
From overview to detail: Creating “drill-down” network diagrams ........................ 19
Revising and updating network diagrams based on database tables ....................... 24
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From overview to detail: Creating “drill-down” network diagrams

A “drill-down” network diagram can consist of several levels of detail. For ex-
ample, one level can display a network geographically, indicating the location
of your company offices on a map. From each office location, you can drill
down in the network diagram one level to a logical diagram of the servers, desk-
top computers, printers, and other equipment the network includes. From the
logical diagram, you can “drill down” another level to a specific description of
one piece of equipment or to a physical diagram of how a particular server
room is organized.
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Each drawing page in a Visio diagram can have different settings. For example, you can draw
the geographic level of your network diagram on an unscaled, legal-sized (A3) drawing page,
and you can draw a physical diagram of a server closet on a scaled, letter-sized (A4) page.

Because you can add hyperlinks to shapes or pages in Visio drawings, you can
jump directly from an office location at the geographic level to a logical dia-
gram for that location’s network. Or, you can jump from the logical diagram to
a Microsoft Excel spreadsheet that includes inventory data for all the equipment
in the network.

As you create a drill-down network diagram, you can get detailed information
in the following ways:

• For details about how to use a specific shape, right-click the shape, then
choose Shape Help from the shortcut menu.

• For details about drawing a specific type of diagram (for example, a geo-
graphic diagram, or a physical network diagram), choose Help > Template
Help, then double-click Visio Templates.

To create the geographic level in a drill-down network diagram: 

1. In Visio Professional, choose File > New > Drawing.

2. Choose File > Page Setup, then click Page Size.
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3. For Page Size, click Standard or Metric (ISO), then select the page size you
want in the list. For Page Orientation, click Portrait (tall) or Landscape
(wide), then click OK.

4. Choose File > Stencils > Maps, then choose the geographic area you want to
include in your drill-down network diagram. Drop the state, country, or
geographic region you want on the drawing page.

NOTE  Continents and other large geographic areas, such as Europe or the
United States, are located at the bottom of stencils, so you may have to scroll
to see them.

5. Choose File > Stencils > Block Diagram > Basic Shapes to open the Basic
Shapes stencil. Drop a shape (for example, Star 5) in all the locations on the
map where your company has branches. Select the shapes representing the
branches, click the fill color button ( ), and then choose the color you
want to apply.

6. Choose File > Save As to save and name the drill-down network diagram.

TIP  To close stencils you are no longer using, right-click the stencil’s title bar,
then choose Close.

To create the logical or physical level in a drill-down network diagram: 

1. In the same network diagram where you drew the geographical level, choose
Insert > Page, then click Page Properties.

2. Under Name, type a name for the new drawing page (for example, Logical
Network or Server Room), then click OK.

3. Choose File > Stencils > Network Diagram, then choose the network sten-
cils you want.

4. If you’re drawing a physical network diagram, choose File > Page Setup, then
click Drawing Scale to choose a scale (for example,1/16:1) for the drawing
page. Click OK.

5. Drop and connect shapes to create the logical or physical network diagram
you want.

6. Choose File > Save to save the diagram.

To add a hyperlink to a shape or page in a drill-down network diagram: 

1. Select the shape or display the page to which you want to add a hyperlink.

2. Choose Insert > Hyperlink.

3. Type or locate the name of the file or Visio drawing page you want to link to,
then click OK.

To jump to the location you linked to, right-click the shape you added a
hyperlink to, then choose Hyperlink > Open from the shortcut menu.
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TIP  You can customize a shape’s double-click behavior, so that you can double-
click the shape to jump to another page in the same drawing. To customize
double-click behavior, select the shape, then choose Format > Double-click. In
the Double Click dialog box, choose Go To Page, select the page you want to
jump to, then click OK.

Related topics
Adding, modifying, and deleting hyperlinks ....................... Using Visio Products  228
Setting page orientation and scale .......................................... Using Visio Products  17

Creating network diagrams from ODBC databases

If you store data about the physical structure of a network (that is, the
network’s segments and the nodes each segment includes) in a database created
in an ODBC-compliant application, the Network Diagram Wizard can analyze
the data and represent it in a network diagram.

Product
Development

David Nettles

Kenton Smythe

Mick Ivars

Bobby Wagner

P.D. Printer

Phil's Shared Modem

Jack Abbott

The Network Diagram Wizard interprets each record in the database as a single node on the
network. If no field in the database lists segment names, the wizard treats all the nodes as
attached to one segment.

The Network Diagram Wizard works best if the data in your database is easy to
interpret. To assist the Network Diagram Wizard, set up the database as follows:

• Arrange your data in a single database table (the table can be the result of
a query).

• Include a field in the database table that contains node-name information.
The wizard prompts you for the name of this node-name field, then uses the
data in the node-name field to create labels on the nodes in the diagram.
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• Include segment-name and node-type fields to save time, although these
fields are not mandatory.

The segment name determines how the nodes are grouped. If no segment-
name field exists, the wizard treats all the nodes as belonging to one segment
and prompts you for the segment name.

The node type is a physical description of the node hardware. The wizard
uses the node-type field to choose a Visio shape to represent each node in
the network diagram. If a node-type field exists in the database table, the
wizard prompts you to map each unique node type to a Visio master. If no
node-type field exists, the wizard prompts you to map each individual node.

• Include as many additional fields as you want in the database table. You
have the option of adding these fields to shapes in your network diagram as
custom-property fields.

To create a network diagram from a database: 

1. In Visio Professional, choose Tools > Macro > Network Diagram > Network
Diagram Wizard.

2. On the first wizard screen, click Next. On the second screen, choose ODBC
Data Source, then click Next.

3. On the next screen, choose the data source from which you want to create a
network diagram.

If you’re creating a diagram based on a database you created using the Net-
work Database Wizard, choose [Original Table Name] Diagram.

If the database you want to use doesn’t appear, click Create Data Source to
set up the database as an ODBC data source.

4. Follow the remaining wizard screens. For help on a screen, click More Info.

NOTE  You can also create a network diagram by entering node and segment
information manually on Network Diagram Wizard screens.

After you run the Network Diagram Wizard to create a diagram from a data-
base, you may want to revise the diagram. For example, you can add more
nodes to a segment or add a custom-property field, such as Cost, to the network
shapes. After you’ve made your revisions, you can run the Network Database
Wizard to create an updated database that incorporates revisions made to the
diagram.

Related topics
About data-driven shapes and drawings .............................. Using Visio Products  195
Creating ODBC databases based on network diagrams ........................................... 23
Revising and updating network diagrams based on database tables ....................... 24
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Creating ODBC databases based on network diagrams

If shapes in a network diagram have custom-property fields, you can run the
Network Database Wizard to generate a Microsoft Access 7.0 database from the
diagram. You can choose which drawing pages, shapes, and custom-property
fields you want the database to include.

The Network Database Wizard generates two database tables. Network Table contains a
row for each shape in the diagram and a column for each custom-property field associated
with the network shapes. If you have data stored in the custom-property fields, the data
appears in the table cells. Network Table Connections stores information about the
connections between the network shapes.

If you want to pass data between the database and the network diagram, you
can link the drawing to the database. Then, if you revise the database, you can
update the diagram based on the revisions. Or, if you revise the diagram, you
can update the database.

To generate a database based on a network diagram: 

1. In Visio Professional, open the network diagram you want to create a data-
base from.

2. Choose Tools > Macro > Network Diagram > Network Database Wizard.

3. On the first wizard screen, click Next. On the second screen, choose Create
A Database From A Network Drawing, then click Next.

4. Follow the remaining wizard screens. For help with a screen, click More Info.

TIP  You can add right-click actions and events to a linked diagram with which
you can control when information passes between the diagram and database.
To add actions and events, run the Network Database Wizard. On the second
screen, choose Add Database Actions And Events To A Drawing, then click Next.
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Related topics
About data-driven shapes and drawings .............................. Using Visio Products  195
Creating network diagrams from ODBC databases ................................................. 21
Revising and updating network diagrams based on database tables ....................... 24
Synchronizing drawings and databases ................................ Using Visio Products  202

Revising and updating network diagrams based on database tables

The Network Diagram Wizard and the Network Database Wizard are designed
to work together. This collaboration allows you to

• Add records or fields to a database you originally created from a network
diagram and generate a new diagram based on the revisions. Adding
a record (row) adds a piece of equipment to the diagram. Adding a field
(column) adds a new custom-property field to the shapes in the diagram.

• Distribute the database to other Visio users, who can then generate network
diagrams of their own.

When you create a database from a network diagram, the Network Database
Wizard creates two database tables in which it stores the network information.
It also creates a query. You can run this query to merge information from the
two tables into one new table of node and segment information. The new table
is organized so the Network Diagram Wizard can read its data and create a net-
work diagram.

To revise a diagram based on changes to database tables: 

1. In Microsoft Access 7.0, revise the tables the Network Database Wizard cre-
ated when it generated a database from a network diagram.

2. Run the query named Create Diagram Query From [Table Name] to create a
new table named [Original Table Name] Diagram.

3. In Visio Professional, choose Tools > Macro > Network Diagram > Network
Diagram Wizard. On the first wizard screen, click Next. On the second
screen, choose ODBC Data Source, then click Next.

4. On the third screen, choose [Original Table Name] Diagram for the table
you want the wizard to read, then click Next.

5. Follow the remaining wizard screens. For help with a screen, click More Info.

Related topics
Creating network diagrams from ODBC databases ................................................. 21
Creating ODBC databases based on network diagrams ........................................... 23
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Planning and
designing Web sites

About the Visio Web site tools

With the shapes on the Web Diagram stencil, you can diagram the structure of
a Web site before you actually create the HTML pages and put them on the
Web. By first diagramming your Web site, you can visualize and experiment
with the site’s navigation patterns so you can solve problems the site’s visitors
might have in advance.

Using the Web Diagram Wizard, you can create a diagram of an existing
intranet or Web site. The diagram provides a graphical representation of how a
site is organized.

Because shapes in a Web site diagram are linked to the Web locations they rep-
resent, you can save the diagram as an HTML page and include it on your Web
site as a site map.

ht tp: / /www.vis io.com

Vis io  Home Page

ht tp : / /205.185.183.34/html /p .h tml

Lorem Ipsum

ht tp : / /205.185.183.34/html /
m5 .h tm l

Setupex.exe

ht tp : / /205.185.183.34/html /
demo.h tm l

Adip isc ing El i t

h t tp : / /205.185.34/html /m.html

Dolor s i t  amet

ht tp : / /devweb/usr /FEUGAIT/

F E U G A I T  N U L L A
FACILISI

h t tp : / /devweb/usr /FEUGAIT/
consec t . h tm

FNF Consec te tue r

h t tp : / /devweb/usr /FEUGAIT/
l up ta tum.h tm

FNF lup ta tum

m a i l t o : W R W @ F e u g a i t  . c o m

W R W @ F e u g a i t  . c o m

ht tp : / /devweb/

FNF Du is  au tem ve l
e u m

ht tp : / /devweb/usr /FEUGAIT/
do lo re .h tm

FNF Du is  do lo re  to
Feugai t  Nu l la  Fac i l i s i

m a i l t o : W R W @ F e u g a i t  . c o m

W R W @ F e u g a i t  . c o m

ht tp : / /devweb/usr /FEUGAIT/
do lo re .h tm

FNF Du is  do lo re  to
Feugai t  Nu l la  Fac i l i s i

m a i l t o : W R W @ F e u g a i t  . c o m

W R W @ F e u g a i t  . c o m

m a i l t o : W R W @ F e u g a i t  . c o m

W R W @ F e u g a i t  . c o m

ht tp : / /devweb/usr /FEUGAIT/
vel i t .h tm

FNF Vu lpu ta te  Ve l i t

You can use a Web site diagram to visualize the navigation of a large site with which
you’re not familiar or to plan and revise a site for which you’re responsible.

Related topics
Creating diagrams of existing Web sites .................................................................... 28
Planning new Web sites .............................................................................................. 26
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Planning new Web sites

The shapes on the Web Diagram stencil are designed to make planning and re-
vising the structure of a Web site easy and convenient.

The stencil includes URL shapes you can use to represent links in a Web site.
URL shapes have built-in connectors that connect a link to the page on which
the link originated, creating a Web site diagram that resembles an organization
chart.

http: / /205.185.183.34/
html /p.html

Lorem Ipsum

http: / /205.185.183.34/
html /m5.html

Setupex.exe

ht tp: / /205.185.183.34/
html /demo.html

Adip isc ing
Elit

ht tp: / /205.185.34/html/
m.html

Dolor si t
amet

There are several kinds of URL shapes. Choose a shape based on the kind of connection (top,
side, stackable) you want to create. Drag a control handle to connect a link to the Web page
on which the link originated.

You can add a title, a Web address (for example, http://www.visio.com/), and an
icon representing a link type to each URL shape.

http: / /205.185.183.34/html/p.html

Lorem Ipsum

A URL shape representing a page on a Web site. To change a shape’s title, URL, and icon
(link type), right-click the shape, then choose Configure URL.
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You can add differentiating icons to URL shapes when you need to indicate
special types of Web locations, such as graphics, forms, or a home page.

http:/ /www.visio.com

Vis io Home Page

To add a differentiating icon to a URL shape, select the shape, then choose Edit > Open URL.
In the group window, select the current icon and delete it, then drag the differentiating icon
you want from the Web Diagram stencil. Click the close box to close the group window.

After you add a URL to a URL shape, Visio links the URL shape to the site the
address represents. To jump to the Web site, right-click the shape.

http:/ /205.185.183.34/html/p.html

Lorem Ipsum

When you choose the URL for a URL shape from the shortcut menu, Visio opens your Web
browser and locates the site the URL represents.

The URL shapes in your Web site diagram are linked to the Web locations they
represent, so you can save the diagram as an HTML page and include it in the
Web site as a site map.

Most Web sites are fairly large and complex, so that their diagrams are unlikely
to fit on one printed page. You can quickly move a URL shape and its links to a
new drawing page.
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http://205.185.183.34/
html/m5.html

Setupex.exe

http://205.185.183.34/
html/demo.html

Adipiscing
Elit

http://205.185.34/html/
m.html

Dolor sit
amet

To move a portion of a Web site diagram to a new page, right-click the URL shape you want
to move, then choose Make Subpage.

For details about creating a Web site diagram, choose Help > Template Help;
double-click Visio Templates, then double-click Internet Diagram; and finally
double-click Web Diagram.

Related topics
Creating diagrams of existing Web sites .................................................................... 28
Saving drawings as HTML pages .......................................... Using Visio Products  120

Creating diagrams of existing Web sites

You can use the Web Diagram Wizard to create a graphical representation of an
existing Web site. A Web site diagram can help you understand the way a site is
organized and serve as a visual tool for reorganizing or expanding a site. While
you can’t automatically update a Web site using a Visio Web site diagram, the
diagram serves as an excellent structural guide.

When the Web Diagram Wizard explores a Web site, it actually generates two files:

• A Visio drawing file (.vsd) that contains the Web site diagram. The diagram
resembles an organization chart, in which each link in the Web site is repre-
sented by a shape.
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• A text file that describes the relationships among the links in the Web site. If
you want to revise the layout or formatting of a Web site diagram (for ex-
ample, use a vertical instead of a horizontal layout), you can save time by
having the wizard read the information from the text file rather than from
the actual site on the Web.

When you’re diagramming a Web site, it’s a good idea to limit the search in
some way. For example, the home page of the Web site you’re searching might
include a link to the Microsoft Web site so people can download the newest ver-
sion of some software. However, you probably don’t want all the links in the
Microsoft site to appear in your diagram. You can tell the wizard to display only
local links in the diagram, not remote ones.

You can also specify a limit to the total number of links (the default is 1,000)
you want to include, the link depth you want the wizard to search, and the kinds
of links (for example, HTML pages, MailTo links, downloadable files, multime-
dia files, and so on) you want the diagram to include.

The Web site diagram
When the Web Diagram Wizard diagrams the structure of a Web site, it creates
a diagram that looks like an organization chart. The home page is positioned at
the top. The shapes connected to the top shape represent the links (or anchors)
on the home page. The same model holds throughout the chart. The same link
may be represented more than once in a drawing because a link may be located
on more than one page.

http://devweb/usr/FEUGAIT/

FEUGAIT NULLA
FACILISI

http://devweb/usr/FEUGAIT/
consect.htm

FNF Consectetuer

http://devweb/usr/FEUGAIT/
luptatum.htm

FNF luptatum

mai l to :WRW@Feugai t  .com

WRW@Feuga i t  . com

http://devweb/

FNF Duis autem vel
eum

http://devweb/usr/FEUGAIT/
dolore.htm

FNF Duis dolore to
Feugait Nulla Facil isi

mai l to :WRW@Feugai t  .com

WRW@Feuga i t  . com

http://devweb/usr/FEUGAIT/
dolore.htm

FNF Duis dolore to
Feugait Nulla Facil isi

mai l to :WRW@Feugai t  .com

WRW@Feuga i t  . com

mai l to :WRW@Feugai t  .com

WRW@Feuga i t  . com

http://devweb/usr/FEUGAIT/
velit.htm

FNF Vulputate Veli t

When you run the wizard, you can make choices about the layout and format of the drawing.
For example, you can decide whether to make the layout horizontal or vertical. You can also
choose how much of the Web site the wizard searches and what types of links it draws.

The wizard adds information to each shape about the Web location that the
shape represents. It also add hyperlinks to shapes so you can jump directly from
the shape to its site on the Web.
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http: / /devweb/usr/FEUGAIT/
dolore.htm

FNF Duis dolore to
Feugait Nulla Facil isi

mai l to :WRW@Feugai t  .com

WRW@Feuga i t  . com

The wizard labels each shape in the Web site diagram with the URL and title (if appropriate)
of the location the shape represents and adds an icon to the shape that identifies the link
type. Right-click a shape to change the URL, title, link type, and icon.

If the wizard encounters an error when browsing for a link (for example, Site
Not Found), it creates a shape for the link but marks the shape with a red bor-
der. You can turn off the error marking for a single shape or for all shapes in the
diagram.

To create a diagram of an existing Web site: 

1. In Visio Professional, choose Tools > Macro > Internet Diagram > Web Dia-
gram Wizard.

2. On the first wizard screen, click Next. On the second screen, check Read
Data From A Web Site, then click Next.

3. On the third screen, click Browse to open a basic Web browser.

4. Type the URL you want or choose Go > Search The Internet to locate the
site you want, then click Use This URL.

5. Follow instructions on the remaining wizard screens to tell the wizard how
to search and how to lay out and format the diagram. For help with a screen,
click More Info.

To jump to the URL that a shape represents: 

• Right-click the shape, then choose Open [URL address].

To change a shape’s URL, title, link type, or icon: 

1. Right-click the shape, then choose Configure URL.

2. Choose a new link type or icon or type a new title or URL, then click OK.

To turn off error marking for a single shape: 

1. Right-click the shape, then choose Configure URL.

2. Under Hide Error, choose None, then click OK.

TIP  To turn off error marking for all shapes in the diagram, right-click the
drawing page with no shapes selected, then choose Properties. In the Custom
Properties dialog box, under Error, choose True.

Related topics
Planning new Web sites .............................................................................................. 26
Revising diagrams created with the Web Diagram Wizard ...................................... 31
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Revising diagrams created with the Web Diagram Wizard

You can quickly revise a Web site diagram you created using the Web Diagram
Wizard without having the wizard search links on the Web a second time.

When the wizard creates a diagram of an existing Web site, it also creates a tab-
delimited text file that describes relationships among the site’s links. To revise a
Web site diagram, have the wizard read data from the text file instead of from
the actual site on the Web.

'Starting URL: http://devweb/usr/FEUGAIT

'Maximum Depth: 4

'Maximum Documents: 60

'Follow Method: Follow Links Only On Initial Server

'Diagram Links: All Links

'Surf Algorithm: Breadth First

'

'ID Parent_ID Title URL Link_Type

'----------------------------------------------------------------------------------------

1 Feugait Nulla Facilisi http://devweb/usr/FEUGAIT/ HTML document

2 1 WRW@Feugait.com mailto:WRW@Feugait.com MailTo:

3 1 FNF Luptatum http://devweb/usr/FEUGAIT/luptatum.htm HTML document

4 1 FNF Consectetuer http://devweb/usr/FEUGAIT/consect.htm HTML document

5 3 FNF Duis autem vel eum http://devweb/ HTML document

6 1 WRW@Feugait.com mailto:WRW@Feugait.com MailTo:

7 2 FNF Duis dolore to FNF http://devweb/usr/FEUGAIT/dolore.htm HTML document

In this Web Diagram Wizard text, the header information, preceded by a single quotation
mark, describes choices you made to limit the wizard’s search. Each data row represents
a Web site link and the links are listed in order by relative ID number.

By default, the Web Diagram Wizard names the text file after the title of the first
page of the Web site you’ve asked the wizard to diagram. For example, if the title
(that is, the text in the <TITLE > </TITLE > HTML tags) of the page is Visio
Corporation Home Page, the text file name is Visio Corporation Home
Page.txt. The wizard saves the text file in the Internet Diagram subfolder in the
Visio Professional Solutions folder.

If you use the wizard to diagram the same Web site more than once, a text file
with the default name may already exist in the Internet Diagram folder. The
wizard asks you if you want to replace the old file with the new one.

You can also change the layout of a Web site diagram by moving a URL shape
and its links to a new drawing page. After you move the shapes, the URL shape
is located on both the original page and the new page. You can jump to the new
page by right-clicking the URL shape on the original page.
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To revise a Web site diagram by reading the text file: 

1. Choose Tools > Macro > Internet Diagram > Web Diagram Wizard.

2. On the first wizard screen, click Next. On the second screen, check Read
Data From A Text File This Wizard Created, then click Next.

3. Follow instructions on the remaining wizard screens to tell the wizard how
to lay out and format the diagram.

To move a URL shape and its links to a new drawing page: 

1. In a Web site diagram, right-click the URL shape you want to move, then
choose Make Subpage from the shortcut menu.

2. For Page Name, Visio enters the name of the Web site the URL shape repre-
sents. If you want the new drawing page to have a different name, type the
new name.

3. If you want a title bar that includes the page name to appear at the top of the
new page, leave the Add Title Bar To New Page option checked, then click OK.

The URL shape and all the shapes connected to it move to the new drawing
page. A copy of the URL shape remains on the original page.

4. To return to the original drawing page, right-click the new drawing page,
and choose Go To [Original Page Name].

TIP  To jump from the URL shape on the original page to the new page, right-
click the URL shape, then choose Go To [New Page Name].

Related topics
Creating diagrams of existing Web sites .................................................................... 28
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Creating business process
engineering diagrams

About the business process diagramming solutions

Visio Professional flowcharting solutions are designed specifically to help
you plan, modify, and document business processes. For example, using Visio
Professional shapes, you can

• Create flowcharts to describe existing processes.

• Create banded diagrams (Rummler-Brache style) to analyze the structure of
cross-functional processes.

• Create IDEF0 diagrams to model process activities.

• Develop process maps that document procedures for ISO 9000 quality stan-
dards reviews.

• Generate flowcharts, cause and effect diagrams, and force field diagrams as
part of a Total Quality Management (TQM) process.

The flowchart and other business process shapes in Visio Professional are de-
signed to store data about the processes the shapes represent. For example,
shapes in the Flowchart, TQM, and other templates have custom-property
fields in which you can enter data about the cost, resources, and time required
to complete a step in your process.

Decis ion
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You can also add new custom-property fields to business process shapes if you
want to store additional data. For example, you can add an Output custom-
property field if you want to identify the expected output from each process step.

Decis ion

After associating data with the shapes, you can generate numeric reports that
make it easy to compare processes or track progress over time. You can also use
the Flowchart Database Wizard to generate databases from business process
diagrams if you want to display and manipulate the data in relational tables.

After you create business process diagrams, you can easily distribute them for
review by converting them to HTML documents and publishing them on the
company intranet.

Related topics
About converting shapes and drawings to HTML .............. Using Visio Products  119
About storing data in shapes ................................................. Using Visio Products  177
Creating databases from business process diagrams ................................................ 38
Creating reports from custom data ...................................... Using Visio Products  180
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Creating business process diagrams

The Process Flow diagram, IDEF0 diagram, and cross-functional process map
that follow are representative of the types of business process diagrams you can
create using Visio Professional. The following table lists the tools most useful
for creating these diagram types.

Tools for creating business process diagrams

Tool name Visio command Result

Flowchart templates File > New > Flowchart Opens one of the following business process diagram templates:
Audit, Data Flow, Flowchart-Basic, Flowchart-Advanced, IDEF0
Diagram, Mind Mapping Diagram, SDL Diagram, TQM Diagram,
Work Flow Diagram.

Template Help Help > Template Help > Opens a template help topic that discusses the best way to use
double-click Visio Templates > the shapes and page settings in a template to create a specific
double-click Flowchart drawing type.

Shape Help Right-click any shape and Opens a shape help topic that discusses how a specific shape
choose Shape Help. behaves.

Flowchart-TQM Tools > Macro > Flowchart > Starts the wizard, which guides you through the process of drawing
Diagram Wizard Flowchart-TQM Diagram a Cause and Effect (Fishbone), Top Down, or Cross-Functional

Wizard flowchart.

Custom Properties Shape > Custom Properties Opens the dialog box where you can enter data into existing
dialog box custom-property fields.

Custom Properties Tools > Macro > Custom Starts the editor, which you can use to add new custom-property
Editor Properties Editor fields to business process shapes.

Property Reporting Tools > Property Report Starts the wizard you can use to create numeric and inventory
Wizard reports based on the custom-property data associated with

business process shapes.

Flowchart Database Tools > Macro > Flowchart > Starts the wizard you can use to generate Microsoft Access
Wizard Flowchart Database Wizard database tables from the custom-property data associated with

business process shapes.

Related topics
About the business process diagramming solutions ................................................ 33
Basing new drawings on templates ........................................... Using Visio Products  9
Creating connected drawings from text files ....................... Using Visio Products  192
Creating databases from business process diagrams ................................................ 38
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Process flowchart

Adipiscing Elit

Minim

Consecetuer

Nonummy

Vel Illum

Luptatum

Dolore

Consequat

Delenit

Vero Eros Blandit

Et Accunsan

Feugait Nulla
Facilisi

Praesent

Feugait Nulla
Facilisi

Iriure

Duis Autem

Lorem
Ipsum

ZZril

Duis Autem

Tincidunt

Sit Amet

Dolor

Lorem
Ipsum

Suscipit

Feugait Nulla
Facilisi

Sed
Diam

Duis Autem

Augue

V. Daniel Hunt, author of Process Mapping:
How to Re-engineer Your Business Processes,

writes that you can’t understand or improve
a business unless you “peel the onion and

examine the processes through which inputs
are converted into outputs.” The basic and

specialized flowchart shapes that come with
Viso Professional are designed to help

you peel the onion.

Cross-functional
process map

Sed Diam

No

Yes

Yes

No

No Yes

Lorem
Ipsum

Dolor
Sit

Duis
Autem

Vero
Eros

OdioSi t  Am
Et Nibh Erat

Ver iam
Vel  EumMin im et Iusto

C o m m o
do

Quis
Nostrud

Magna
Al iquam

Ul lum
Corper

Tinci-
dunt

Ut
Lacreet Henrer i tVolutpat Feugiat Blandit

Praesent ZZri l Deleni t Nul la

Facil isi

Fn i

A cross-functional process map is a flowchart
that displays the contribution each function or
department makes to a process. You can use
process maps to document existing processes,
plan for process improvement, and reflect
departmental goals. Use the Flowchart-TQM
Wizard (File > New > Flowchart) to quickly lay
out the basic structure of a cross-functional
process map.
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IDEF0 diagram

NODE: TITLE: NO.:Lorem Ipsum Dolar Sit Am Et 4A1

1
Lorem Ipsum

2
Dolor Sit

3
Am Et

4
Sed Diam

5
Nibh

6
Euism

Ipsum

Consecetuer

Si t  Am

Sed Nonummy

Diam Nonummy

Tincidunt ut
Lacreet

Adipiscing

Ad Min im

Ut wis i  enim

Ven iam

Vel  eum

C o m m o d o
Consequat

Duis  Autem

Quis Nostrud

Hendrer i t Vulputate Blandi t

Dolore Magna

IDEF0 is a graphical modeling technique for performing needs analysis, systems design, and other planning processes.
The IDEF0 Template includes all the shapes you need to create detailed hierarchical IDEF0 diagrams.
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Creating databases from business process diagrams

With the Flowchart Database Wizard, you can generate a Microsoft Access 7.0
database that contains data stored in business process shapes. If you want to
pass data between the database and the flowchart, you can link the two files.
Then, if you revise either the database or the diagram, you can pass changes to
the linked file. You can choose which shapes and custom-property fields you
want the database to include.

The Flowchart Database Wizard generates two database tables, Flowchart Table and
Flowchart Table Connections. Flowchart Table contains a row for each shape in the diagram
and a column for each custom-property field associated with the flowchart shapes. If you have
data stored in the custom-property fields, the data appears in the table cells. Flowchart Table
Connections stores information about the connections between the flowchart shapes.

To generate a database based on a business process diagram: 

1. Open the diagram from which you want to create a database.

2. Choose Tools > Macro > Flowchart > Flowchart Database Wizard.

3. On the first wizard screen, click Next. On the second screen, choose Create A
Database From A Flowchart, then click Next.

4. Follow the remaining wizard screens. If you need help with a screen, click
More Info.

TIP  You can add right-click actions and events to a linked diagram that you can
use to pass information between the diagram and database. To add actions and
events, run the Flowchart Database Wizard. On the second screen, choose Add
Database Actions And Events To A Drawing, then click Next.

Related topics
About data-driven shapes and drawings .............................. Using Visio Products  195
About the business process diagramming solutions ................................................ 33
Synchronizing drawings and databases ................................ Using Visio Products  202

Process 1

Report

Storage

Process 2

Decision
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Developing software and
designing user interfaces

About software development and user interface diagrams

The Visio Professional software diagramming solution includes templates that
support the major software modeling languages as well as templates you can
use to mock up Microsoft Windows 95 and Office 97 interfaces. With the soft-
ware diagramming shapes, you can

• Create use-case, class, behavior, and implementation diagrams using Booch,
Rumbaugh, Jacobson Use Cases, or other standard notation.

• Develop structured charts (such as Nassi-Schneiderman charts) that show
the procedural components of programs.

• Assemble prototype dialog boxes, menus, wizard screens, and other interface
elements for review, distribution, and usability testing.

The software diagramming shapes are designed so you can quickly represent
the elements in a system and the relationships between them.

Class name
attributes

operations()
{constraints}

Attribute:

Operation:

Class name

You can right-click some class shapes to change the type of class the shape represents,
and you can easily indicate a class shape’s attributes and operations.
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Who le Part

Superc lass Subclass

You can right-click connectors to add line ends that indicate types of relationships
between classes and other shapes.

Interface shapes are designed so you can customize them to represent the
elements you want.

< B ack

When you drop a Button shape on the drawing page, Visio Professional prompts you for the
text to appear on the button. With the List/Combo Box shape, you can represent either a list
or combo box. Right-click a list/combo box, then choose a command to show or hide the
drop-down list.

Related topics
About UML and the Microsoft Repository ............................................................... 45
Creating software design and user interface diagrams ............................................. 41
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Creating software design and user interface diagrams

The Rumbaugh object model, Booch class diagram, Nassi-Schniederman chart,
and Prototype wizard screen that follow represent the kinds of software dia-
grams you can create with Visio Professional. The following table lists the tools
most useful for creating these diagram types.

Tools for creating software diagrams

Tool name Visio command Result

Software diagramming File > New > Software Diagram Opens one of the following software diagramming templates:
templates Booch OOD, Chen-ERD, COM and OLE, Express-G, Fusion,

Gane-Sarson DFD, Jacobson Use Cases, Martin ERD,
Nassi-Schneiderman, Program Structure, Rumbaugh OMT,
Shlaer-Mellor OOA, SSADM, System Structure, UML - Static
Structure Diagram, Windows User Interface, Yourdon and Coad.

Template Help Help > Template Help > Opens a template help topic that discusses the best way to use
double-click Visio Templates > the shapes and page settings in a template to create a specific
double-click Software Diagram. drawing type.

Shape Help Right-click any shape and Opens a shape help topic that discusses how a specific shape
choose Shape Help. behaves.

Related topics
About UML and the Microsoft Repository ............................................................... 45
Creating software design and user interface diagrams ............................................. 41
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Rumbaugh object model

A
B
C
D

Vel I l lum
At vero
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D
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1
2
3
4
5

Adipiscing

1
2
4
8

Colutpat

D
G

Exerci

Ven iam

4
5

Tation

7

Lobort is

D
E

Ut wisi

Laoreet
Magna a l iquam

3
5
6
7
9

Duis Dolore

C
E

Digniss im

Qui Blandit
Augue Corpor

A Rumbaugh object model represents
the relationships between object types or

classes. The model indicates relationships,
such as aggregation, association, and
generalization, with connector shapes

that have special line ends.

Booch class diagram

Lorem
Ipsum

Dolar sit

Magna a l iquam
Consectetuer

Volutpat

Nibh Eu ism

Ut  Wis i

Ven iam

Quis
Nostrud

Qui Blandit

Exercitat ion Am Corper Commodo
Consequat

has

has has

has

has

uses

uses

is

Uses uses uses uses

isis
is

usesuses uses uses

A Booch class diagram is a logical view of
a system. It illustrates the classes and the
relationships between them.
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Nassi-Schneiderman chart

True False

Dolor sit am et

Consecteuer

Lorem Ipsum

True False

Nonummy

Sed diam

Tincidunt

Ut laoreet

Adipiscing eli

True False
Suscipit

Lobortis

True False

Aliquip

Ex a commodo

Nisl ut aliquip

True False
Vel Eum

Iriure

True False

Vulputate

Velit esse molestie

True False

Consequat

Feugiat nulla facilisis

Nassi-Schneiderman charts stack and
divide process boxes into parts to represent

sequence, selection, and repetition. The
charts offer a structured, hierarchical
view of the logic of programs with one

entry and one exit point.

Prototype Wizard screen

Lorem Ipsum Dolor Sit

Duis autem

Consecte tuer Adip isc ing

O K

Cance l

He lp

Apply

Consectetuer  adipc ing e l i t ,  sed
d iam nonummy n ibh  eu ism.

The Windows 95 and Office 97 user interface shapes
make it easy to prototype wizard screens, dialog
boxes, and other interface elements.
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Working with
UML diagrams

About UML and the Microsoft Repository

Sharing system solutions independent of the process or tools used to create
them can improve software quality and reduce development costs and time to
market. Visio Professional provides two tools for sharing system solutions: the
Unified Modeling Language (UML) and the Microsoft Repository.

Using these tools in Visio Professional, you can

• Create UML static structure diagrams using shapes that look and behave in
ways defined in the UML notation.

• Add attributes and operations to UML class, interface, and type shapes so
that attribute and operations data is stored with the shapes as properties.

• Run a wizard that checks the semantics of a UML static structure diagram
and identifies and diagnoses errors.

• Export UML static structure diagrams (including the attribute and opera-
tions data) into the Microsoft Repository as models that can be accessed and
used by people with tools other than Visio Professional.

• Import models from the Microsoft Repository into Visio Professional as
UML static structure diagrams regardless of the tools and processes with
which the models were originally created.

UML
Rational Software Corporation, where UML was developed, defines UML as a
language for specifying, constructing, visualizing, and documenting the arti-
facts of a software-intensive system. The vocabulary of the language is a
notation—a set of shapes in which each shape has a particular meaning. The
grammar has carefully defined semantics that describe how each shape can be
used. In combination, the notation and semantics make it possible to describe
all kinds of systems, regardless of their scope and complexity. Rational Software
Corporation compares UML to a blueprint for a construction project: it helps a
team visualize a program’s architecture throughout the development cycle.
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UML is a derivative language, formed from parts of three earlier languages:
Booch, OMT (Object Modeling Technique), and OOSE (Object-Oriented Soft-
ware Engineering). Unofficially, UML has become widely accepted as a standard
and the Object Management Group (OMG) is considering a proposal for the
adoption of UML as the official standard modeling language.

Microsoft Repository
UML is a universal language developers can use to describe their systems. It
doesn’t, however, solve the problem of data exchange. That’s where the
Microsoft Repository comes in.

The Microsoft Repository is a storage system developers can use to store models
described using the UML language. These models can be accessed by other de-
velopers regardless of the tools the developers use.

The Repository system consists of the following:

• A relational database.

• A Repository engine that manages the data in the database. You use the en-
gine to store and retrieve objects and their relationships from the database.

• Tool information models, which define the kinds of data specific tools can
handle. The data definitions, called types, are then stored in the repository
database. For example, Visio Professional uses the UML tool information
model, which specifies the UML objects Visio Professional can handle.

• Software development tools, such as Visio Professional, which you use to de-
velop and maintain software applications.

Install the UML components during the Visio Professional installation to auto-
matically install the software you need to store and retrieve models from the
Microsoft Repository.
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Repository Database

Repository Engine

UML Tool
Information Model

Visio Professional

You can store the UML static structure diagrams you create as models in the Repository
and you can retrieve models from the Repository and represent them using UML shapes.
Visio Professional stores and retrieves models in Microsoft Access and Microsoft SQL
Server format.

For details about the Microsoft Repository and tool information models, see
the Microsoft Web site. For details about UML, see the UML notation and se-
mantics guides included as .pdf files on the Visio Professional CD. If you didn’t
install the UML .pdf files when you installed Visio Professional, you can find
the files in the Docs directory on the CD.

You must have the Adobe Acrobat Reader installed on your computer to view,
read, or print the .pdf versions of the UML guides. You can install the Acrobat
Reader by double-clicking Setup.exe in the Acrobat Reader directory on the Visio
Professional CD.

Related topics
Exporting UML diagrams as models to the Microsoft Repository .......................... 49
Importing UML models from the Microsoft Repository ......................................... 48
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Importing UML models from the Microsoft Repository

If you want to examine a component model stored in a Microsoft Repository
database so you can use it in a system you’re creating, you can import the model
into Visio Professional as a UML static structure diagram. The database you
import from must be in Microsoft Access 97 or Microsoft SQL Server 6.5 format.

When you import a model, keep the following in mind:

• Logical View  The first page of a UML static structure diagram, called the
Logical View, is the top-most package (storage container for model ele-
ments) of the model.

• Packages  Visio Professional automatically puts the contents of each package
on a separate drawing page. It also adds right-click actions to each package
shape so you can easily jump from a package to a detailed diagram of its
contents.

• UML property editors  After you import a model, you can right-click shapes
in the diagram and choose UML Properties to access a property editor where
you can add property data. For example, some of the properties associated
with Association shapes include Name and Stereotype. Some of the
properties associated with Class shapes include Name, Type, Stereotype, and
Visibility.

• Shape actions  Right-clicking a shape also gives you access to shape actions.
For example, you can choose Suppress Attributes from a Class shape right-
click menu to hide the attributes portion of the shape.

• Shape display  When Visio Professional places shapes representing model
elements on the drawing page, some connector shapes may not display
properly. You may need to rearrange some shapes to display them appropri-
ately on the drawing page.

To import a model from the repository: 

1. Choose File > New > Software Diagram > UML - Static Structure Diagram
to open the UML template.

2. Choose Tools > UML Import Wizard.

3. On the first wizard screen, click Next.

4. On the second screen, type the name and location of, or browse to locate,
the Repository database that includes the model you want to import, then
click Next.

5. On the third screen, select the model you want in the list, then click Next.

6. On the last screen, verify that the information listed is correct. If it’s incor-
rect, click Back to make different choices in the wizard. If it’s correct, click
Finish.
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TIP  After you have imported a UML diagram, you can use the UML Navigator
to see the entire structure of the diagram or to jump to a specific page. To start
the UML Navigator, choose Tools > UML Navigator or right-click any page in
the diagram.

To jump from a package to a diagram of its contents: 

• Right-click a package shape, then choose Go To Package Overview from the
shortcut menu.

Related topics
About UML and the Microsoft Repository ............................................................... 45
Exporting UML diagrams as models to the Microsoft Repository .......................... 49

Exporting UML diagrams as models to the Microsoft Repository

If you’ve created a system component that you want other developers to access
and re-use, you can represent the component in a UML static structure dia-
gram. Then, you can export the diagram as a model to a Microsoft Repository
database. To export to a Repository you store the model in a Microsoft Access
or SQL Server database with the UML type information model, or framework,
in it.

You can add properties to the shapes in a UML static structure diagram using a
property editor. For example, you can add data to a class shape for properties
such as name, attributes, visibility, stereotype, and cardinality. When you export
the diagram, you also export the property data.

When you choose the UML Export Wizard command to export a UML static
structure diagram, Visio Professional runs the Semantics Checker before start-
ing the wizard. The Semantics Checker identifies errors in your diagram and
suggests ways to resolve them. You can also run the Semantics Checker indepen-
dently any time you want to check a UML diagram for errors.

To add properties to a shape: 

1. Right-click the shape, then choose UML Properties from the shortcut menu.

2. Fill in the values you want, then click OK.

TIP  You can also double-click most UML static structure shapes to open the
property editor.
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To run a semantics check and correct errors: 

1. Choose Tools > UML Semantics Checker.

The UML Semantics Checker analyzes your diagram. If it finds errors,
it highlights the relevant shapes in red.

2. Right-click a red shape, then choose Show Error for a diagnosis of the error
and advice about how to fix it.

3. Correct the errors in the diagram, then run the UML Semantics Checker
again to find any additional errors.

If you want to clear all the errors regardless of whether you’ve fixed them,
choose Tools > UML Clear Errors to turn off the error marking, then save
the diagram.

TIP  You can use the UML Navigator to see the entire structure of a UML dia-
gram or to jump to a particular page. To start the UML Navigator, choose
Tools > UML Navigator or right-click any page in a UML diagram.

To export a UML diagram to the Microsoft Repository: 

1. Choose Tools > UML Export Wizard.

2. On the first wizard screen, click Next.

3. On the second screen, choose the diagram you want to export.

4. On the third screen, type or browse for the name of an existing Microsoft
Access database (*.mdb), or type an ODBC data source name or connection
string.

To create a new Microsoft Access (.mdb) repository file, type the name and
path for the new file.

5. On the fourth screen, type a name for the model you want to create in the
Repository.

6. On the last screen, verify that the information listed is correct. If it’s incor-
rect, click Back to make different choices in the wizard. If it’s correct, click
Finish.

Related topics
About UML and the Microsoft Repository ............................................................... 45
Importing UML models from the Microsoft Repository ......................................... 48
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Mapping and creating
database structures

About mapping and creating database structures

The Visio Professional database solution provides tools you can use to map the
structure of an existing database and to plan and create new database struc-
tures. The tools include

• The IDEF1X ERD Template and the Crow’s Foot ERD Template, which in-
clude shapes you can use to map databases. IDEF1X and Crow’s Foot are
specification languages for describing data structures.

• The Map Database Wizard, which analyzes the structure of an existing
Microsoft Access, Microsoft SQL Server, Oracle SQL Server, or other ODBC-
compliant database and creates an IDEF1X or Crow’s Foot diagram that
reflects the structure.

• The Create Database Wizard, which uses the data in an IDEF1X or Crow’s
Foot diagram to generate a Microsoft Access database structure.
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Order ID (FK)
Product ID (FK)

Uni tPr ice
Quant i ty
Discount

Order  Deta i ls

Product ID

Produc tName (AK)
Suppl ier ID (FK)
Category ID (FK)
Quant i tyPerUni t
Uni tPr ice
Uni ts InStock
Uni tsOnOrder
ReorderLeve l
Discont inued

Products

In this IDEF1X diagram, the entity shapes represent two database tables named Order
Details and Products. The connector between the tables indicates an identifying one-to-
many (optional) relationship. The attributes listed in the top box of the entity shapes indicate
the primary key fields in the database tables. The attributes in the bottom box represent the
rest of the fields. (FK) beside a field indicates a foreign key. (AK) indicates a field that is both
required and indexed.

Related topics
Creating database structures from entity-relationship diagrams ............................ 54
Mapping database structures ..................................................................................... 52

Mapping database structures

If you have data in a Microsoft Access 7.0, Microsoft SQL Server, or Oracle SQL
Server, or other ODBC-compliant database, the Map Database Wizard can ana-
lyze the structure of the database and create an IDEF1X or Crow’s Foot diagram
based on the structure.

You can diagram the entire database or only selected database tables, and you
can control whether or not database fields display as attributes on entity shapes
in the diagram.

IDEF1X and Crow’s Foot are specification languages that use entity and rela-
tionship shapes to describe data structures. The following illustration explains
the relationship between elements in a database and shapes in an entity-
relationship diagram.
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Customer ID

CompanyName (AK)
Contac tName
ContactTi t le
Address
City
Region
Posta lCode
Country
Phone
Fax

Customers
Order ID

CustomerID (FK)
EmployeeID (FK)
OrderDate
Requi redDate
ShipppedDate
ShipVia (FK)
Freight
Sh ipName
ShipAddress
ShipCity
ShipRegion
ShipPosta lCode
ShipCountry

Orders

F

A

B

C

D

E

A Database table, represented by an entity shape in the diagram.
B Database table name.
C Primary key fields of the database table, called entity shape attributes in the diagram.
D Additional fields in the database table or shape attributes in the diagram.
E The relationship between the database tables, represented by a connector in the diagram.

End dots and line type (solid or dashed) indicate direction and cardinality. In your database,
you establish relationships between specific fields. In the drawing, connectors connect
entire tables.

F In the diagram, relationships between specific fields are indicated by the (FK) designator,
for foreign key.

To create an entity-relationship diagram from a database: 

1. In an open IDEF1X or Crow’s Foot diagram, choose Tools > Macro >
Database > Map Database Wizard.

2. On the first wizard screen, click Next.

3. On the second screen, choose the database you want to map, then click Next.

4. Follow the remaining wizard screens. For help on a screen, click More Info.

Related topics
About mapping and creating database structures .................................................... 51
Creating database structures from entity-relationship diagrams ............................ 54
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Creating database structures from entity-relationship diagrams

When you’re creating a database to store and track process information, it can
be difficult to think through all the tables the database will need and how fields
in the tables should be related.

Using the IDEF1X and Crow’s Foot templates in Visio Professional, you can
diagram the database before you actually set it up. When you’re satisfied with
the tables, fields, and the relationships between the fields, you can run the Cre-
ate Database Wizard to generate a Microsoft Access 7.0 database structure from
the diagram.

Order ID
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EmployeeID (FK)
OrderDate
Requ i redDate
Sh ipppedDate
ShipVia (FK)
Freight
Sh ipName
ShipAddress
ShipCi ty
Sh ipReg ion
Sh ipPosta lCode
ShipCount ry

Orders

Order ID (FK)
Product ID (FK)

Uni tPr ice
Quant i ty
Discount

Order  Deta i ls

Emp loyee ID

Las tName (AK)
F i rs tName
Tit le
Ti t leOfCourtesy
Bir thDate
Hi reDate
Address
City
Reg ion
Posta lCode
Count ry
H o m e P h o n e
Extens ion
Photo
Notes
Repor tsTo

Emp loyees
A

B

C

D

E

F

A Entity shapes become database tables.
B Entity shape names become database table names.
C Attributes become fields.
D Primary key attributes become primary key fields.
E Relationship connectors and the fields defined as foreign keys (FK) determine the relation-

ship between fields in database tables
F An index will be added in the database to a field labeled (AK) in the diagram.
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As the first step in creating the database, the wizard analyzes your drawing. If it
detects errors, you must exit the wizard and fix the errors. Errors include rela-
tionships that aren’t properly connected and entities without attributes.

Order ID (FK)
Product ID (FK)

Uni tPr ice
Quant i ty
Discount

Order  Deta i ls

Product ID

Produc tName (AK)
Suppl ier ID (FK)
Category ID (FK)
Quant i tyPerUni t
Uni tPr ice
Uni ts InStock
Uni tsOnOrder
ReorderLeve l
Discont inued

Products

The wizard indicates errors in your drawing by coloring the incorrectly used shapes red. For
help resolving a problem, right-click a red shape.

For details about creating an entity-relationship drawing, in Visio Professional,
choose Help > Template Help, double-click Visio Templates, double-click Data-
bases, and then choose either IDEF1X ERD or Crow’s Foot ERD.

To create a database from an entity-relationship diagram: 

1. Open the IDEF1X or Crow’s Foot diagram from which you want to create
a database structure.

2. Choose Tools >  Macro > Database > Create Database Wizard.

3. Follow the wizard screens.
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To diagnose and correct errors in an entity-relationship diagram: 

1. Locate the shapes in an IDEF1X or Crow’s Foot diagram that the Create
Database Wizard marked in red.

2. Right-click a red shape, then choose ERD Errors to learn more about the
 error associated with the shape, and how to correct it.

3. Make your corrections, turn off the red error marking by right-clicking the
drawing page when no shapes are selected, then choosing Clear ERD Errors.

Related topics
About mapping and creating database structures .................................................... 51
Creating network diagrams from ODBC databases ................................................. 21
Creating ODBC databases based on network diagrams ........................................... 23
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Creating
custom solutions

About creating custom solutions

You can do more with Visio Professional than create business process and infor-
mation systems diagrams. By taking advantage of the Visio SmartShapes
technology and open architecture, you can create specialized shapes, develop
combinations of shapes and programs that model the real world and solve spe-
cific drawing problems, and customize the Visio Professional user interface.

The following tools are available to you in the Visio Professional development
environment:

• The ShapeSheet spreadsheet, which takes you under the surface of shapes to
create formulas for specific shape behavior.

• Microsoft Visual Basic for Applications (VBA), with which you can create
macros and control Visio Professional through Automation.

• The Visio Type Library, which contains Automation descriptions of the ob-
jects, properties, methods, events, and constants that Visio Professional
exposes to Automation controllers.

The book Developing Visio Solutions, which comes with Visio Professional, con-
tains everything you need to know about Visio Professional as a development
platform, including sample code and tips and techniques. In addition, you can
view the online Automation Reference by choosing Automation Reference from
the Help menu in Visio Professional.

You can also visit the Visio Solutions Development section of the Visio
Corporation Web site (http://www.visio.com/devweb), where you can learn
more about Visio Professional as a development platform and find other devel-
oper resources.
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Working with the ShapeSheet spreadsheet
When you want to use specialized shapes that model the behavior and appear-
ance of the real-world objects they represent, you can create them by working
with formulas in the shapes’ ShapeSheet spreadsheets.

Behind each Visio shape or shape you draw using the Visio drawing tools is a
ShapeSheet spreadsheet containing formulas that determine how a shape be-
haves. When you make changes to a shape on the drawing page, you update its
ShapeSheet formulas. You can also make changes directly in the ShapeSheet
spreadsheet, where you have more precise control over a shape’s appearance
and behavior. For example, you can add formulas that create a control handle,
change a shape’s fill color if it reaches a certain size, or make one shape’s behav-
ior dependent upon the behavior of another shape on the drawing page.

The ShapeSheet spreadsheet contains sections, each of which controls part of the shape.
Each section contains cells with formulas that further define the shape’s properties and
attributes. For example, the Connection Points section contains cell formulas that represent
the x- and y-coordinates of each connection point on the shape.

To display a shape’s ShapeSheet:

• Select the shape, then choose Window > Show ShapeSheet.

Once you’ve created specialized shapes, you can make the shapes part of a draw-
ing solution by storing them on new stencils and distributing the shapes and
stencils in a template.

For more information about ShapeSheet spreadsheets, press F1 in Visio
Professional, click Index, then type “shapesheet spreadsheets.”
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Working with Automation
You can take advantage of the Visio open architecture to solve graphics prob-
lems and create custom solutions. Open architecture means that Visio exposes
its objects, such as windows, drawing pages, shapes, layers, menus, and toolbars,
through a well-structured Automation interface. Using a development environ-
ment that supports Automation, you can write programs to control Visio
objects. For example, you can automatically update drawings you create from
data that changes from day to day. Or you can automate routine shape develop-
ment tasks that you perform over and over.

To write the programs, or macros, that control Visio objects, you can use the
fully-licensed version of Microsoft Visual Basic for Applications (VBA) that
comes with Visio Professional, or you can use Visual Basic, C/C++, or any other
Automation controller.

Visio Professional includes a type library—a file that contains Automation de-
scriptions of the objects, properties, methods, events, and constants that Visio
exposes to Automation controllers. Visio object types can help you write code
more effectively because you can view Visio Automation descriptions in and
copy code templates from the Object Browser.

To open the Visual Basic Editor and create, debug, or run VBA
programs:

• Choose Tools  > Macro > Visual Basic Editor.

TIP  You can also press Alt + F11 to open the Visual Basic Editor.

For details about using the Visual Basic Editor, press F1 in Visio Professional,
click Index, then type “Visual Basic Editor.”

Related topics
About creating your own shapes .......................................... Using Visio Products  207
About customizing shape behavior .............................................................. Visio Help
Creating new templates ......................................................... Using Visio Products  142
Sample custom solution: Network Asset Tracking ................................................... 60
Sample custom solution: Sales Automation Tool ..................................................... 61
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Sample custom solution: Network Asset Tracking

The Network Asset Tracking solution was designed to make it easy to track de-
tailed information about each piece of equipment in a corporate network.
Using the tool, an IS professional can

• Open a custom-designed template and create a diagram representing part of
the corporate network.

• Right-click each shape in the diagram to open a specially-designed dialog
box.

• Type data in the dialog box for each piece of equipment that describes its
hardware and software specifications, inventory number, and information
about when it was purchased and how it’s used.

• Automatically add the data to each equipment shape in the diagram and
generate reports based on the data.

• Automatically store the data in a database table.
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Cloud

To develop the Network Asset Tracking solution, add a right-mouse action called Asset
Information to network shapes and store the shapes on a new stencil. Create a new template
including the new stencil and save a VBA project as part of the template. In the VBA project,
design a form which users see as a dialog box where they can enter equipment-related data,
write code behind events in the form so clicking OK adds the data to shapes as custom-
property fields and to a database table, and write a macro that opens the form in response
to the Asset Information right-click action.

Related topics
About creating custom solutions ............................................................................... 57
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Sample custom solution: Sales Automation Tool

The Sales Automation Tool was designed to make selling network equipment
more convenient for sales personnel on the road. Using the tool, a sales em-
ployee can

• Select products from a hierarchical product catalog stored in a Microsoft
Access database using selection criteria properties.

• Drag and drop shapes representing these products to create a Visio Professional
network diagram that reflects a customer’s equipment needs.

• Keep a running total of the cost and list price for the system being assembled.

• Choose a command on the Visio Professional menu to generate a cost esti-
mate that details the cost of each piece of equipment as well as the total cost
in a Microsoft Excel spreadsheet.

• Choose a command on the Visio Professional menu to generate a proposal
in Microsoft Word. The proposal includes an agreement letter, a copy of the
network diagram, and the cost estimate.
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The following drawing illustrates the development required to support this tool.
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To develop the Sales Automation Tool, in Visual Basic 5.0 build an Automation server (A)
which categorizes network equipment records stored in a Microsoft Access database (B).
Visio communicates with the server through Automation (C), allowing sales employees to
select records and drop them on the drawing page as network shapes (D). Using VBA code
(E), add menu commands to the Visio interface, which open Excel and Word and generate
estimates and proposals (F).

Related topics
About creating custom solutions ............................................................................... 57
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Where to
go from here

This book focuses on features and tools unique to Visio Professional. You can
learn more about working with Visio applications from several other sources.

For example, if you’re new to Visio products, you might want to start with Using
Visio Products, which includes chapters on creating and saving drawings, work-
ing with shapes and text, and printing. Or, if you’re a developer and your focus
is Visio as a development platform, Developing Visio Solutions contains the in-
formation you need.

If you prefer to get help from online sources, you can access an electronic ver-
sion of the information in this manual and in Using Visio Products, or access
certain Visio reference tools that are available only in online form. The Visio
Corporation Web site at www.Visio.com also includes information and
downloadable files that can help you get the most out of Visio Professional.

Related topics
Additional sources of Visio Professional information .............................................. 63
Installing Visio Professional ......................................................................................... 3
Introducing Visio Professional ..................................................................................... 1
Visio Professional content .......................................................................................... 12
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Additional sources of Visio Professional information

The following table lists places you can find information about Visio
Professional and describes the type of information you’ll find in each place.

More information on Visio Professional

Information source Type of information

Using Visio Products A good place to start if you’ve never used Visio before.

Covers tasks common to Visio Standard, Visio Professional, and Visio Technical.

Developing Visio Solutions Contains information about Visio as a development platform, including sample
code, tips, and techniques.

Online Automation Reference Describes the Visio objects, properties, and methods that you can access from an
external program.

Choose Help > Automation Reference.

More Info buttons on Opens a window of information about the options on a wizard screen, or about
Visio Professional wizard screens Visio features relevant to the task the wizard helps you complete.

Click More Info on a wizard screen.

Screen tips Toolbar buttons  Float the pointer over a toolbar button for a moment to see a tip
about what the button does.

Control handles  Float the pointer over a control handle ( ) on a
shape for a moment to see a tip about what dragging the handle accomplishes.

Online help An online version of the information in Using Visio Professional and in Using Visio
Products, and an explanation of every Visio command and dialog box option. You
can search the file by keyword.

To use online help, choose Help > Visio Help.

For details about options in a dialog box, click the Help button in the dialog box.

Template help Provides information about how to create specific drawing types, including the
most efficient sequence in which to work, how shapes work together, and tips
and tricks.

Choose Help > Template Help, double-click Visio Templates, and then double-
click a drawing type.
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Information source Type of information

Shape help A window of information that explains how to use a shape.

Right-click any shape, then choose Shape Help.

Technical support Choose Help > Visio On The Web > Online Support.

Visio Corporation Web site Includes information about Visio Corporation and its products, such as:

Case studies that describe how corporations have used Visio products.

White papers that describe in detail certain Visio features or functionality.

Downloadable files for updates and programs that can help you use Visio
more effectively.

Developer tips and tools.

Choose Help > Visio On The Web > Visio Home Page.

Drawing Resources Web page A Web page on the Visio Corporation Web site that contains links to resources
related to drawing types Visio Professional supports.

Choose Help > Visio On The Web > Drawing Resources.

Visio Solutions Library A section of the Visio Corporation Web site where you can learn about and
purchase job-specific shapes, time-saving utilities, and other custom drawing
solutions.

Choose Help > Visio On The Web > Visio Solutions Library.

Related topics
Installing Visio Professional ......................................................................................... 3
Introducing Visio Professional ..................................................................................... 1
Visio Professional content .......................................................................................... 12





Appendix:
Visio wizards

Visio Professional wizards

Wizards in Visio Professional automate routine tasks, perform unique func-
tions, and create special drawing types from scratch. The following list
describes what each wizard helps you accomplish.

TIP  Many wizards include More Info buttons. Click More Info for background
information or help understanding the options on a screen.
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Wizards in Visio Professional

Wizard name What it does How to run it

Build Region Assembles selected geographic shapes into a region. You can Tools > Macro > Maps >
designate an anchor shape to control the position and size of Build Region
the other shapes in the region.

Chart Shape Wizard Creates stackable and extendable shapes you can use to add Tools > Macro > Business
special effects to charts.  Diagram > Chart Shape Wizard

Create Database Wizard Generates a Microsoft Access 7.0 database table from an Tools > Macro > Database >
entity-relationship diagram created using the IDEF1X or Create Database Wizard
Crow’s Foot template.

Custom Properties Editor Edits, adds, or deletes custom-property fields from master Tools > Macro > Custom
shapes that you’ve used in a particular drawing, or from a Properties Editor
standalone stencil that you’ve created.

Database Export Generates a database table that reflects the data in custom- Tools > Macro > Database >
property and other ShapeSheet cells. The program that Database Export
creates the table must be ODBC-compliant.

Database Wizard Links Visio shapes and drawings to databases created in Tools > Macro > Database >
ODBC-compliant database programs. After links are Database Wizard
established, you can pass information between a drawing
and a database, create drawings that are graphical
representations of database tables, and generate new master
shapes that represent data stored in database records.

Flowchart Database Generates a Microsoft Access 7.0 database table from a Tools > Macro > Flowchart >
Wizard flowchart. Links flowchart shapes to records in ODBC- Flowchart Database Wizard

compliant databases.

Flowchart-TQM Guides you through the process of laying out and formatting Tools > Macro > Flowchart >
Diagram Wizard a Cause/Effect, Force Field, Top Down, or Cross Functional Flowchart-TQM Diagram

(Rummler-Brache) diagram. Wizard

Map Database Wizard Generates an entity-relationship diagram, using shapes from Tools > Macro > Database >
the IDEF1X or Crow’s Foot templates, that describes the Map Database Wizard
structure of a database created in an ODBC-compliant program.

Network Database Generates a Microsoft Access 7.0 database table from a Tools > Macro > Network
Wizard network diagram. Links network shapes to records in ODBC- Diagram > Network Database

compliant databases. Wizard

Network Diagram Analyzes data describing the structure of a network and Tools > Macro > Network
Wizard represents it in a network diagram. The data must be stored Diagram > Network Diagram

in a database created in an ODBC-compliant program. Wizard

Office Layout Wizard Guides you through the process of setting the drawing scale, Tools > Macro > Business
choosing the page size and orientation, and creating the basic Diagram > Office Layout
wall structure for an office layout diagram. Wizard
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Wizard name What it does How to run it

Organization Chart Generates an organization chart from a data file in Microsoft Tools > Macro > Business
Wizard Excel (.xls), Org Plus (.txt), or comma- or tab-delimited text Diagram > Organization

(.txt) format, or from a database table created in an ODBC- Chart Wizard
compliant program.

Page Layout Wizard Automates the process of setting up the drawing page size, Tools > Macro > Visio Extras >
orientation, and scale for a drawing. Assists you in adding a  Page Layout Wizard
title block and border to the pages in a new or existing drawing.

Print ShapeSheet Opens the Print ShapeSheet dialog box, where you can choose Tools > Macro > Visio Extras >
which sections of the ShapeSheet to print and whether to print Print ShapeSheet
the ShapeSheet to a printer, the Clipboard, or a file.

Project Timeline Wizard Generates a project timeline from a data file in Microsoft Excel Tools > Macro > Business
(.xls), comma- or tab-delimited text, or Microsoft Project Diagram > Project Timeline
Exchange (.mpx) format. Or, generates a project timeline Wizard
structure into which you can enter data.

Property Reporting Generates inventory reports such as bills of materials or Tools > Property Reporting
Wizard equipment and furniture inventories, and numeric reports Wizard

such as cost totals or averages, from shapes that store data in
their custom-property fields.

Shape Explorer Locates specific shapes and stencils. You can open the stencil Tools > Macro > Shape Explorer
a shape is on or the template a stencil is in from within Shape
Explorer.

SmartShape Wizard Customizes the appearance or behavior of a selected shape’s Tools > Macro > Visio Extras >
text, connectors, notes, or protection settings. SmartShape Wizard

Stencil Report Wizard Generates a Visio drawing of the masters on a selected stencil. Tools > Macro > Visio Extras >
You can choose how many masters appear on a page, whether Stencil Report Wizard
the page includes a header or footer, and whether or not to list
each master’s name and status bar prompt.

UML Export Wizard Exports a diagram created using the UML template as a model Tools > Macro > Software
to be stored in the Microsoft Repository. Diagram > UML Export Wizard

UML Import Wizard Imports a model from the Microsoft Repository into Visio Tools > Macro > Software
as a UML diagram. Diagram > UML Import Wizard

Web Diagram Wizard Generates a diagram of a World Wide Web or intranet site. Tools > Macro > Internet
You can control which links the diagram includes and its Diagram > Web Diagram
layout and format. Wizard
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Web Diagram Wizard 69
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Map Database Wizard 51, 53, 68
Network Database Wizard 18,

23, 24, 68
Network Diagram Wizard 18,

21, 22, 24, 68
Office Layout Wizard 68
Organization Chart Wizard 69
overview 67
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