


WinView Help Index

WinView is a Windows 3.1 hosted graphics file viewer.    It is designed ONLY to display files and is not 
capable of manipulating files in any way (it cannot even print files).    Because it is optimized to be a 
viewer, WinView provides views of multiple files and an easy way to move between files.

For new users I strongly suggest you read the items below marked with a ».    If you have any 
questions please don't hesitate to call our BBS or write us.    If you like WinView, please send in your 
money - that's the only way we earn any money for this effort.

thank you,

Dave Thielen

The following Help Topics are available:

How To...

» What WinView is and isn't 

» The Directory, Sketch, and Picture View 

Sketch View speed and Multi-tasking 

Specify Files to Display 

Select Pictures to View 

Go to a Picture 

Scroll a Picture 

Make a Picture Full Screen 

Commands...
Using the Toolbar 

The File Menu... 

The View Menu... 

» Keyboard Commands 

Shareware...
Written by 

» Registration 

Technical Support & Suggestions 



What WinView is and isn't
WinView is a Windows 3.1 hosted graphics file viewer.    It is designed ONLY to display files and is not 
capable of manipulating files in any way (it cannot even print files).    Because it is optimized to be a 
viewer, WinView provides views of multiple files and an easy way to move between files.

WinView was designed to be used in the following manner;    1) You choose a directory that holds a 
number of files you wish to view.    2) You select those files in the directory you wish to look at.    3) 
You then walk through those files one by one to display them.

If you want a package to convert file formats, print images, and basic image processing (changing the 
number of colors, etc.), I highly reccomend Paint Shop which is another shareware package written 
and sold by JASC, Inc.    I have no affiliation with them - just a happy user.



Directory, Sketch, & Picture View
WinView is always in one of three display or view modes.    These modes are Directory    , Sketch , 
and Picture    View modes.

Directory and Sketch View modes are two different ways to look at all the files in the directory you 
selected.    In DIrectory mode you see a list of file names, much like a DIR command in DOS or when 
you use the File Manager.

In Sketch mode you see a thumbnail sketch of each file.    Because the file is reduced to a very small 
size, the picture you see, especially for highly detailed large bitmaps, will not be real clean.    
However, in most cases you should see enough to identify the bitmap.

In picture mode you see a single picture.    This picture will always be displayed at 100% resolution.    
If you are displaying the picture in the WinView window it will be in the upper left corner of the window 
if the picture is smaller than the window.    If you are displaying the picture full screen, it will be 
centered in the middle of your screen.

There is one important distinction to keep in mind.    Directory and Sketch view will display all the files 
in the directory that match the file specification you made when starting WinView, setting the 
DIrectory, or selecting one of the recent directories.    However, Picture view will only display the files 
you selected in Directory and/or Sketch view.



Sketch View speed & multi-tasking
The first time you click on Sketch View, it needs to draw each bitmap.    This takes time since it not 
only needs to read each file but to then scale the bitmap down to the thumbnail size.    Therefore, the 
initial rendering is time consuming.

To minimize this time delay on subsequent painting, all drawn thumbnail sketches are kept in memory. 
So if you cover the WinView window and then uncover it, the re-paint is fast.    It is only the first paint 
that takes time.

If all the sketches cannot fit in the Window, to minimize time, only the visible pictures are drawn.    
Therefore, the first time you scroll down, the pictures coming into view for the first time will need to be 
read from thei file and scaled.    Once again, this will take a noticeable time.

When you change directories, all these saved sketches are thrown away.    Therefore, if you are 
displaying directory A and switch to directory B, you will have to wait again.    Then if you switch back 
to directory A, you will need to wait again.

And, if you stay in the same directory and switch the file specification, that is still a change and all the 
files will have to be re-rendered.

If you find yourslef switching between 2 directories, run 2 instances of WinView instead of switching 
within one.

Also, the rendered bitmaps are stored in discardable memory.    So if your system runs low on 
memory, WinView will release the memory it is using so that other applications will have enough 
memory to run.    However, in this case when re-painting WinView will again have to re-render the 
sketches.

This was purposefully designed this way because a slower WinView that leaves enough memory for 
other applications is superior to a fast WinView that does not leave enough memory for others.

Finally, because this takes so long, WinView allows you to run other Windows applications while it is 
painting the window is Sketch View mode.    While the cursor is over WinView it is an hourglass.    
However, if it is over another window (press ALT_TAB if WinView is full screen) it is now in control of 
that application (although the system will appear a little jerky).    You can even end WinView at this 
time by pressing CTRL-ESC and then End Task.



Specify Files to Display
The first step to using WinView is to specify the files you wish to display.    This chooses the files you 
will see in the DIrectory and Sketch View modes.    And it is from this list that you will select the files to 
view in Picture View mode.

The files are specified with a directory and wildcard(s).    You may only specify one directory - there is 
no way with WinView to bring up multiple directories at one time.    However, within that directory you 
may specify multiple sets of wildcards, each spereated by a ;.    For example, to bring up all BMP and 
DIB files, you could specify C:\WINDOWS\*.BMP;*.DIB.

You can set the files to display by one of three methods:

1) When you run WinView you can specify the files on the command line.    For example: 
winview c:\windows\*.bmp.

2) The File menu contains the four most recent directories you have displayed (assuming 
that you have displayed at least 4 directories).    Click on one of these to switch to that 
directory.

3) The File, Directory menu command will bring up a dialog box prompting for the 
directory you wish to display.    In there you may choose the directory and the files in the 
directory you wish to display.    Note: because you are selecting multiple files, typing 
wildcards into the file name in the dialog and pressing ENTER will exit the dialog with that 
selection.    This is different from how the dialog acts when you are prompted for a single 
filename in most other programs where pressing ENTER on a wildcard will keep the box 
up and display the files that fit the typed in wildcards.

If you specify a directory that does not exist, then WinView will continue to display the directory it was 
on.    When WinView starts, unless you specify a directory on the command line, no directory is 
specified.

The specified directory will be displayed in the title bar.



Select Pictures to View
In Directory and/or Sketch View you need to select the pictures you wish to display.    In both views 
you can select a file by clicking on it.    You de-select a file by clicking on a selected file.

In Directory view you can also select a range of files by clicking on one, and then hold down the 
SHIFT key and click on a second.    All files between the two will then also be selected.

You can also use the select commands in the View menu, Select All    and Clear All .    This will 
select or clear all the files displayed.

The bottom of the screen will show the number of files selected, as well as the size and date/time of 
the file most recently clicked on.

This is an important step.    In Picture View mode you cannot change which files are selected and 
picture mode will only display selected files.    Therefore, you must select all the files you wish to 
display first.

If in doubt, select them all.



Go to a Picture
There are two ways to display a picture when you are in Directory or Sketch View mode:

1) Double click on a file.    This will select that file and then switch to picture mode with 
that file displayed.

2) Select the files you wish to display and then switch to Picture View mode using either 

the View, Picture View    menu command or the toolbar button .

Once you are in Picture View mode, you can switch between selected files by one of three methods:

1) Press PgDn to go to the next selected picture and PgUp to go to the previous selected 
picture.

2) Use the toolbar button  to go to the next selected picture and 

 to go to the previous selected picture.
3) In the View menu you can use the commands Next Picture    to go to the next selected picture and 
Previous Picture    to go to the previous selected picture.



Scroll a Picture
If a picture is smaller than the window, then there is no need to scroll and scroll bars will not appear 
on the window.    However, if the picture is larger than the window, then the window will have scroll 
bars.    In this case you can scroll two ways:

1) You can click in the scroll bars.    If you click in the scroll region, the picture will shift half 
a window in that direction.    If you click in the scroll button it will shift 1/10th of the window 
in that direction.

2) You can use the cursor keys.    The cursor keys act the same as clicking in the scroll 
bars, shifting the picture half a window in the desired direction.    There is no keyboard 
equivilent to shift less than half a window.



Make Picture Full Screen
If you wish you can make a picture occupy the entire screen.    This is different from maximizing the 
WinView window because none of the window is visible, just the picture.

You can make a picture full screen by one of three methods:

1) Press the ENTER key.

2) Press the  button on the toolbar.
3) In the View menu use the command Full Screen .

You exit full screen mode by pressing the ESC key.

In full screen mode all the keyboard commands work.    In particular, the PgUp, PgDn, and cursor 
keys can be used to move between files and scroll within files.

While you are in full screen mode you can still switch to other Windows applications (using ALT-TAB 
or CTRL-ESC).    There are no special restrictions while in full screen mode and it does not interfere 
with bringing other Windows applications to the top.



Using the Toolbar

The toolbar has the following commands:

 Switch to a different dirrectory.    Only valid in Directory or Sketch mode.    Same 
as the File, Directory menu command.

 Switch to directory of filenames view.    Same as View, Directory View menu 
command.

 Switch to display single picture (file) view.    Same as View, Picture View menu 
command.

 Switch to display sketch of all files view.    Same as View, Sketch View menu 
command.

 Display the next selected picture.    Only valid in picture mode.    Same as View, 
Next Picture menu command or the PgDn key.

 Display the previous selected picture.    Only valid in picture mode.    Same as 
View, Previous Picture menu command or the PgUp key.

 Display the present picture in full screen mode.    To exit full screen mode, press 
the ESC key.    Only valid in picture mode.    Same as View, Full Screen menu command or the ENTER 
key.

Brings up the help system (where you are now).    Same as the Help, Index 
menu command.

 Brings up the about box.    Have you paid for your copy?    Same as the 
Help, Help menu command.



The File Menu...
The following commands are in the File menu:

Directory Used to select the to display.

The Last 4 Directories The last four directories displayed by WinView

Exit Exits WinView



Directory
Brings up the File Open common dialog box for you to specify the files you wish to display.    The 
dialog lists all the graphics file extensions it understands under All Graphics Files as well as each type 
individually.

The files are specified with a directory and wildcard(s).    You may only specify one directory - there is 
no way with WinView to bring up multiple directories at one time.    However, within that directory you 
may specify multiple sets of wildcards, each spereated by a ;.    For example, to bring up all BMP and 
DIB files, you could specify C:\WINDOWS\*.BMP;*.DIB.

If you specify a directory that does not exist, then WinView will continue to display the directory it was 
on.

The specified directory will be displayed in the title bar.

Shortcuts

Toolbar:



Last 4 Directories
The is a list of the last four directories you called up under WinView.    This is the same as specifying 
the displayed directory under File, Directory.



Exit
Use this command to end your WinView session.    You can also use the Close command on the 
application Control menu.

Shortcuts

Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



The View Menu...
The View menu offers the following commands:

Toolbar Shows or hides the toolbar.

Status Bar Shows or hides the status bar.

Next Picture Displays the next selected picture.

Previous Picture Displays the previous selected picture.

Full Screen Displays the picture in full screen mode.

Select All Selects all the files.

Clear All De-selects all the files.

Picture View Switches to Picture View mode.

Directory View Switches to Directory View mode.

Sketch View Switches to Sketch View mode.



Toolbar
Use this command to display and hide the Toolbar, which includes buttons for some of the most 
common commands in WinView, such as Directory.    A check mark appears next to the menu item 
when the Toolbar is displayed.



Status Bar

The status bar provides the following information on the picture displayed:

1) The name of the file.

2) The size of the image in pixels (width x height x depth)

3) The size of the file in bytes.

4) The date stamp of the file.

5) The time stamp of the file

When you are pulling down a menu, help text describing the menu item you are on will be in the 
status bar.

Use this command to display and hide the Status Bar, which describes the action to be executed by 
the selected menu item or depressed toolbar button, and keyboard latch state. A check mark appears 
next to the menu item when the Status Bar is displayed.



Next Picture
Available only in Picture View mode.

Switches the display to the next selected picture.

Shortcuts

Toolbar:
Keys: PgDn



Previous Picture
Available only in Picture View mode.

Switches the display to the previous selected picture.

Shortcuts

Toolbar:
Keys: PgUp



Full Screen
Available only in Picture View mode.

Switches the display to full screen mode.    You need to press ESC to exit full screen mode.

Shortcuts

Toolbar:
Keys: Enter



Select All
Available only in Directory View and Sketch View mode.

Selects all the files.



Clear All
Available only in Directory View and Sketch View mode.

De-selects (clears) all the files.



Picture View
Available only in Directory View and Sketch View mode.

Available only if one or more files are selected.

Switches to Picture View, displaying the first selected picture in the list.

Shortcuts

Toolbar:



Directory View
Available only in Sketch View and Picture View mode.

Switches to Directory View.

Shortcuts

Toolbar:



Sketch View
Available only in Directory View and Picture View mode.

Switches to Sketch View.

Shortcuts

Toolbar:



Keyboard Commands
The keyboard commands were primarily designed for full screen mode.    Because the picture is the 
only thing visible on the screen in full screen mode, keyboard commands are the only way to control 
the program in full screen mode.

In full screen mode you can still switch to other applications using ALT-TAB or CTRL-ESC.    When 
you do this WinView basically becomes a second wallpaper layed down over all the other windows 
and any windows you activate layed on top of it.

The following keyboard commands exist only in Picture View mode:

PgDn Switches the display to the next selected file.

PgDn Switches the display to the previous selected file.

\/ Scroll the picture down a half window/screen

/\ Scroll the picture up a half window/screen

=> Scroll the picture right a half window/screen

<= Scroll the picture left a half window/screen



About
WinView was written by David Thielen.

It is written in Microsoft VC++ 1.0 and uses the ImageMan library to read the bitmap files.

WinView is owned and marketed by WTB Software, Redmond, WA.    This is a shareware product - 
please support it if you use it.

Copyright © 1993 by David Thielen, ALL RIGHTS RESERVED

Please read the Shareware Information    section to read the restrictions on its distribution.



Shareware Information
This product is shareware with some specific restrictions.    Please read these restrictions before you 
pass this product on.

1) This product is supported solely by voluntary donations.    If you use the product please 
mail $4.00 to:
WTB Software
15127 N.E. 24th
Suite 325
Redmond, WA    98052

2) You may use WinView at no charge for one month.    At the end of the month you must 
either remove WinView from your computer permanently or pay the $4.00 charge.    If you 
use WinView for over one month without paying the fee, then the charge for WinView is 
$795.95.    Site licenses are available for very little charge.

3) You may not include WinView on any set of distribution media if any of the media in the 
set includes bitmap images.    In other words, you can include WinView on a disk of 
graphics tools but you may not include it on a set of disks that also have images on them. 
Licenses to include WinView are available for inclusion at a minimal charge (in some 
cases just for a copy of the disk).

4) A CD-ROM version is under development that would handle multiple directories and 
have all the sketches already rendered so that Sketch View would be very fast even the 
first time.



Technical Support & Suggestions
Technical support is available via one means only, our BBS.    Depending on a voluntary charge of 
$4.00 a copy doesn't even cover the cost of the BBS.    Have you paid your $4.00 yet?

Bug Reports and suggestions are welcomed by either BBS or mail.    If you send something by mail 
you probably won't receive a response but I will consider it and I do appreciate your taking the time to 
tell me.

Mail address:
WTB Software
15127 N.E. 24th
Suite 325
Redmond, WA    98052

BBS number: 206-868-2250




