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The Index contains a list of all Help topics available for the Help Example. For information on how to use Help,
press F1 or choose Using Help from the Help menu.



Edit Menu

The Edit menu includes commands that enable you to move text to and from the clipboard, to delete text, and to
undo a previous editing operation.

For more information, select the Edit menu command name.

Clear Deletes text without moving it to the clipboard.
Copy  Copies text to the clipboard.

Cut Deletes text and moves it to the clipboard.

Paste  Moves text from the clipboard to the edit window.
Undo Cancels a previous operation.




File Menu
The File menu includes commands that enable you to open and save files, establish a new workspace, and to print.

For more information, select the File menu command name.




Glossary

clipboard



Copying Text

This topic explains how to copy text to and from the clipboard. (This topic is associated with the keywords "copy"
and "clipboard.")



Deleting Text

This topic explains how to delete text. (This topic is associated with the keywords "delete" and "clipboard.")



Exiting

This topic explains how to exit HelpEx.



Edit Clear Command

This topic explains the Edit menu's Clear command.



Edit Copy Command

This topic explains the Edit menu's Copy command.



Edit Cut Command

This topic explains the Edit menu's Cut command.



Edit Paste Command

This topic explains the Edit menu's Paste command.



Edit Undo Command

This topic explains the Edit menu's Undo command.



File Exit Command

This topic explains the File menu's Exit command.



File New Command

This topic explains the File menu's New command.



File Open Command

This topic explains the File menu's Open command.



File Print Command

This topic explains the File menu's Print command.



File Save Command

This topic explains the File menu's Save command.



File Save As Command

This topic explains the File menu's Save As command.



Context Sensitive Topics

This Help system includes topics that you can call directly from the Helpex sample application. To get context-
sensitive help from Helpex, press Shift+F1 and click on any element of the Helpex application window. You can also
highlight any Helpex menu command using the keyboard and press F1 to get help on the command. Each topic has a
unique context identifier, listed in the [MAP] section of the Help project file:

[MAP]

#define HELPID_EDIT CLEAR 100
#define HELPID_EDIT _COPY 101
#define HELPID_EDIT_CUT 102
#define HELPID_EDIT_PASTE 103
#define HELPID_EDIT_UNDO 104
#define HELPID_FILE_EXIT 200
#define HELPID_FILE NEW 201
#define HELPID_FILE_OPEN 202
#define HELPID_FILE_PRINT 203
#define HELPID_FILE_SAVE 204
#define HELPID_FILE_SAVE_AS 205
#define HELPID_EDIT_WINDOW 300
#define HELPID_MAXIMIZE_ICON 301
#define HELPID_MINIMIZE_ICON 302
#define HELPID_SYSTEM_MENU 305
#define HELPID_TITLE BAR 306
#define HELPID_SIZING_BORDER 307



Edit Window

The edit window in the sample application really doesn't let you edit anything.



Maximize Icon

This topic describes the maximize icon.



Minimize Icon

This topic describes the minimize icon.



Sizing Border

This topic describes the sizing border that surrounds the application window.



System Menu

This topic describes the system menu.



Title Bar

This topic describes the title bar that is used for application and document windows.



Bitmaps by Reference

A bitmap can be placed in a sentence El, just like any character. Click on the maximize button bitmap to open a
pop-up box with more information.

iriwiord
You can also put bitmaps at the left margin of the Help window. Text will automatically wrap along the right edge of
the bitmap.

.

Or the bitmap can be at the right window margin, and text will automatically wrap along its left edge.



The coding for this bitmap is:
text... |PTETMAHCON DD} rox

Note: You cannot code bml or bmr bitmaps
as hotspots in this version of Help.



Visually Placed Bitmap

WIC\o20)8.

The Microsoft logo shown here was pasted from Clipboard into the Help topic file using Word for Windows.

Try clicking on the logo.



The Microsoft logo is a registered trademark of Microsoft Corporation.



Windows System Fonts
This is Courier 10 point.
This is Helv 10 point.

This is Modern 12 point.
This is Roman 12 point.

This is TMS RMN 12 point.



Note:  Although they are available in Windows,
the Script and Symbol fonts do not display
with this version of Help shipped with the 3.0 SDK.

This is Script 12 point.

Tnuo 1o ZYupoi 12 mourvt (Symbol font).



Vowels and Consonants

Find the vowels and consonants in the word below by clicking on them one at a time.

Microsoft



The letter M is a consonant.



Yes, the letter i is a vowel.



No, the letter c is not a vowel.



R is a consonant.



This letter o is one of two in the word Microsoft.



The letter s is between two vowels in this word.



This o is the second one in Microsoft. Did you find the other one?



No, f is not a vowel.



The trailing t in Microsoft is a consonant.



Tutorial Lesson

There are three things to remember about your life vest:



Tutorial Lesson

There are three things to remember about your life vest:

® Where it is.



Tutorial Lesson

There are three things to remember about your life vest:

¢ Where it is.
e How to put it on.



Tutorial Lesson

There are three things to remember about your life vest:

e Where it is.
e How to put it on.
e How to inflate it.



Help can be authored with interactive instructional segments:



Congratulations!
You have found a topic that has no context-string identifier. It is accessible from a browse sequence only.

Can you think of a reason to author such a topic?



Simulation
Help can be used for simple simulations.

Click the check boxes in any order to change the format of the word WinHelp below:

WinHelp
[1  bold
] italic

[] underline



Simulation
Help can be used for simple simulations.
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Simulation
Help can be used for simple simulations.

Click the check boxes in any order to change the format of the word WinHelp below:

WinHelp
[1  bold
(4 italic

underline



Simulation

Help can be used for simple simulations.

Click the check boxes in any order to change the format of the word WinHelp below:
WinHelp
bold
talic

2 underline



Simulation
Help can be used for simple simulations.

Click the check boxes in any order to change the format of the word WinHelp below:

WinHelp

bold
(] italic
(] underline



Simulation

Help can be used for simple simulations.

Click the check boxes in any order to change the format of the word WinHelp below:

WinHelp

B bold
italic

underline



Simulation
Help can be used for simple simulations.

Click the check boxes in any order to change the format of the word WinHelp below:

WinHelp
1 bold
(4 italic
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Simulation

Help can be used for simple simulations.

Click the check boxes in any order to change the format of the word WinHelp below:
WinHelp

B bold
italic

(] underline



Simulation
Help can be used for simple simulations.

Click the check boxes in any order to change the format of the word WinHelp below:

WinHelp

bold
italic
underline



Eureka!

You found a topic that is accessible from a keyword search only. This topic is not linked through hypertext in any
way.

You can use this technique to access topics without having to index them and author jumps. You can also access
topics like this directly from your application through the use of multiple keyword tables.






Windows Keys

The keyboard topics below come from Help for Windows. You can create similar keyboard topics for your
application's Help. Choose from the following list to review the keys used in Windows:

Cursor Movement Keys

Dialog Box Keys
Editing Keys

Help Keys

Menu Keys

System Keys

Text Selection Keys

Window Keys




Cursor Movement Keys

Key(s) Function

DIRECTION key Moves the cursor left, right, up, or down in a field.
End or Ctrl+Right Arrow Moves to the end of a field.

Home or CTRL+Left Arrow Moves to the beginning of a field.

PAGE UP or PAGE DOWN Moves up or down in a field, one screen at a time.



Dialog Box Keys

Key(s) Function

TAB Moves from field to field (left to right and top to bottom).

SHIFT+TAB Moves from field to field in reverse order.

ALT+letter Moves to the option or group whose underlined letter matches the one you type.
DIRECTION key Moves from option to option within a group of options.

ENTER Executes a command button.

Or, chooses the selected item in a list box and executes the command.

ESC Closes a dialog box without completing the command. (Same as Cancel)
ALT+DOWN ARROW Opens a drop-down list box.
ALT+UP or DOWN ARROW  Selects item in a drop-down list box.
SPACEBAR Cancels a selection in a list box.
Selects or clears a check box.
CTRL+SLASH Selects all the items in a list box.
CTRL+BACKSLASH Cancels all selections except the current selection.

SHIFT+ DIRECTION key Extends selection in a text box.
SHIFT+ HOME Extends selection to first character in a text box.

SHIFT+ END Extends selection to last character in a text box



Editing Keys

Key(s) Function

Backspace Deletes the character to the left of the cursor.
Or, deletes selected text.

Delete Deletes the character to the right of the cursor.

Or, deletes selected text.



Help Keys

Key(s) Function

F1 Gets Help and displays the Help Index for the application. If the Help window is
already open, pressing F1 displays the "Using Windows Help" topics.

In some Windows applications, pressing F1 displays a Help topic on the selected
command, dialog box option, or system message.

SHIFT+F1 Changes the pointer to RQ so you can get Help on a specific command, screen
region, or key. You can then choose a command, click the screen region, or press
a key or key combination you want to know more about.
(This feature is not available in all Windows applications.)



Menu Keys

Key(s) Function

Alt Selects the first menu on the menu bar.

Letter key Chooses the menu, or menu item, whose underlined letter matches the one you
type.

Alt+letter key Pulls down the menu whose underlined letter matches the one you type.

LEFT or RIGHT ARROW Moves among menus.

UP or DOWN ARROW Moves among menu items.

Enter Chooses the selected menu item.



System Keys

The following keys can be used from any window, regardless of the application you are using.

Key(s) Function

Ctrl+Esc Switches to the Task List.

Alt+Esc Switches to the next application window or minimized icon, including full-
screen programs.

Alt+TAB Switches to the next application window, restoring applications that are running
as icons.

Alt+PrtSc Copies the entire screen to Clipboard.

Ctrl+F4 Closes the active window.

F1 Gets Help and displays the Help Index for the application. (See Help Keys)



Text Selection Keys

Key(s)

Function

SHIFT+LEFT or RIGHT ARROW
SHIFT+DOWN or UP
SHIFT+END

SHIFT+HOME

SHIFT+PAGE DOWN

SHIFT+PAGE UP

CTRL+SHIFT+LEFT or RIGHT ARROW
CTRL+SHIFT+UP or DOWN ARROW

CTRL+SHIFT+END
CTRL+SHIFT+HOME

Selects text one character at a time to the left or right.
Selects one line of text up or down.

Selects text to the end of the line.

Selects text to the beginning of the line.

Selects text down one window.

Or, cancels the selection if the next window is already
selected.

Selects text up one window.

Or, cancels the selection if the previous window is already
selected.

Selects text to the next or previous word.

Selects text to the beginning (UP ARROW) or end (DOWN
ARROW) of the paragraph.

Selects text to the end of the document.

Selects text to the beginning of the document.



Window Keys

Key(s) Function

ALT+SPACEBAR Opens the Control menu for an application window.

ALT+Hyphen Opens the Control menu for a document window.

Alt+F4 Closes a window.

Alt+Esc Switches to the next application window or minimized icon, including full-
screen programs.

Alt+TAB Switches to the next application window, restoring applications that are running
as icons.

AIt+ENTER Switches a non-Windows application between running in a window and running
full screen.

DIRECTION key Moves a window when you have chosen Move from the Control menu.

Or, changes the size of a window when you have chosen Size from the Control
menu.






Clipboard

This is a topic that describes the Windows term "clipboard". If you click the "clipboard" term within the Copying
Text or Glossary topic, this Help topic will be displayed in a pop-up window.

This topic is also tagged with the keyword "clipboard," for use with the WinHelp Search option.






