
BodyWorks® Help
BodyWorks® is an informational program that lets you explore the world of anatomy.    This on-

line system should help you with any questions you may have about the program's operation.    For 
additional help, please refer to your user's manual.

To learn how to use Help, press F1.
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General Overview
BodyWorks® is an interactive information system designed to let you explore the world of 

anatomy.    These concepts are illustrated in both text and pictures.    The program lets you "navigate" 
from one item to another, from one system to another, in any order.

The screen is divided into four main areas: the buttons at the top, the picture on the left, the item 
list on the right, and the text below that.    All of these work together to present information and control 
your exploring.

The item list shows the various subjects you can get information on at that moment.    If you'd like 
to see the text associated with an item, select it with the mouse.    This will make that item's text entry 
available in the text window.

Some of the subjects in the item list have a dot next to them.    This indicates that they link to 
additional information.    If you select these a second time, you are taken to a new screen.    This new 
screen may also have additional items that can take you to other screens.    This linking method lets 
you move from one topic to another, in any order you'd like.

If at any point you'd like to go back to what you were viewing earlier, you can backtrack using the 
"back" arrow.

The other buttons at the top of the window let you go to the different body systems.    These let 
you go to those systems immediately from any point in the program.    For more help on these please 
see Buttons.

See also Hypertext



Hypertext
When you are reading the text entries for the various items in BodyWorks®, you will notice some 

words are highlighted.    These are hypertext entries.    If you click on these words, you will either be 
given a definition of the word from the glossary, or given a choice of other screens that will give you 
more information on that subject.    The word "hypertext" above is an example.    Hypertext is provided 
throughout the program to define terms and allow an easy way to branch off to other related issues.

See also General Overview and Glossary



Hypertext - This is an example of hypertext.



Printing
If you have a printer installed in Windows, then you can print the text and graphics from 

BodyWorks®.    Please refer to your Windows manual for help on installing printers if necessary.

To print
1. Have the information you'd like to print displayed on the screen.
2. From the File menu, choose the Print option.

You may wish to change some of the options for your printer prior to printing.    These can include 
printer resolution, orientation (portrait or landscape), color usage, etc.    Choose Print Setup from the 
File menu to make these changes.

Printing Options:
Copies Indicates the number of copies to print.
Resolution This lets you control the quality of the print.    Higher resolutions look 

better, but take longer to print.    If you have problems printing to a laser 
printer, be sure the printer has enough memory to print at the resolution 
you've selected.    If there isn't enough memory, you may need to print at 
a lower resolution.

Orientation This refers to how the page is printed.    It can be either Portrait, which 
prints like a standard typed page, or Landscape, which prints the image 
sideways.

See also File Menu and Medical Records



Memory - This is space used by the printer to form the image.    A 300dpi image will generally take a 
minimum of 1M of printer memory. 



Exporting Graphics & Text using the Clipboard
BodyWorks® lets you export the pictures and text of the program for use in your own documents. 

This is done using Window's clipboard.    The clipboard is a temporary area that Windows uses to 
store things that you Cut or Copy from a specific application.    Generally, this data can then be Pasted 
into other parts of the program, or even into different documents.    The destination program must be 
able to receive the appropriate type of data being pasted.

To copy a picture into another program
1. Find the picture you'd like to copy.
2. Choose Copy picture from the Edit menu.
3. Switch to the program you'd like to paste the picture into.    This can be done by selecting a 

window from that program or using Windows Task Manager.    See your Windows manual for 
additional help on these.

4. Using the destination program's tools, paste the picture into your document.    This is usually 
the Paste command from the Edit menu.

To copy text into another program
1. Find the individual text item you'd like to copy.
2. Choose Copy text from the Edit menu.
3. Switch to the program you'd like to paste the text into.
4. Using that program's tools, paste the text into your document.

See also Using Window's Notepad and Edit Menu



Cut - This is a standard Windows function which removes data from a document and copies it to the 
Clipboard.    It can then be Pasted into another document or program.    Cut is usually found under the Edit 
menu.



Copy - This is a standard Windows function which copies data from a document to the Clipboard.    It can 
then be Pasted into another document or program.    Copy is usually found under the Edit menu.



Paste - This is a standard Windows function which lets you place data into a document.    The data must 
have previously been Cut or Copied to the Clipboard.    Paste is usually found under the Edit menu.



Using Window's Notepad

Windows includes a notepad program which allows you to work with small text files.    It also lets 
you Paste in text from other programs.    You can use this function with BodyWorks® to let you assemble 
and edit personal notes as you explore through the program.

To use Notepad
1. Run Notepad.    You may do this before you run BodyWorks®, or after the program's already 

running.    Notepad is generally found in the Windows Accessories group.    See your Windows 
manual if you need help.

2. Switch to BodyWorks®.
3. Find any text you'd like to add to the notepad.
4. Choose Copy text from the Edit menu.
5. Switch to the Notepad.
6. Choose Paste from the Edit menu.    This will paste the text in at the current insertion point.    At 

this point, you can edit the text if you'd like.

If you find the notepad's functions limiting, you can do a similar procedure with any type of word 
processor.    Windows includes a basic word processor in the Write application.    This program is 
usually found in the Accessories group.

See also Exporting Graphics & Text and Edit Menu



Using the Index
BodyWorks® provides an index to the information in the program.    You can call it up from the 

Index option under the Tools menu.    It has a list of all the different topics covered in the program.    
You can scroll down this list and go to any individual entry immediately.    You can also search for a 
topic if you aren't sure how it's listed.    There's even a phonetic option which finds words even if 
you're not sure how they're spelled.

To go to an item
1. Find the entry of interest in the index list using the scroll bar.
2. Select it with the mouse.
3. Press the "Goto" button.

To find a word in the index
1. Press the "Search" button.

2. Type in the word you're interested in at the "Search for:" prompt.
3. If you aren't sure how the word is spelled, you can check the "Phonetic search" box.    This searches for 
words that sound like what you've typed in.
4. Press the "OK" button.

This will search the index and give you list of those entries that match.
5. Select the entry you'd like from the list and press the "Goto" button.
6. If you'd like to have the full list again, press the "Index" button.

See also Tools Menu



File Menu
Medical Records

The Medical Records option works as a database to store important medical information on 
you and up to 50 other people.    It will store things such as name, address, allergies & 
prescriptions and any other medical history items.

Print
The Print option lets you print graphics and text to your current printer.    If you would like to 

change any of the printing parameters, use Print Setup described next.

Print Setup
Print Setup lets you control many of the aspects of your printing environment.    These include 

the resolution of the printer, the orientation, the number of copies to print, and other parameters 
such as color usage, patterning, and paper type.    The types of controls available is specific to 
your individual printer.

The print setup box should also have some facility for specifying the destination for the print. 
This is usually one of the computer's printer ports such as LPT1 or LPT2.    You can generally 
choose to direct this output to a file as well.    This lets you postpone your printing until a later 
date, or lets you create a file which can be printed on another machine.

For a complete description of these options, please refer to your Window's manual and any 
documentation that came with your specific printer.

Exit
This option simply lets you quit the program.

See also Printing and Medical Records



Resolution - This refers to the size of the dots used to form the image on your print out.    The higher the 
resolution, the finer the image will appear, but it may take longer to print.



Orientation - This refers to how the page is printed.    It can be either Portrait, which prints like a standard 
typed page, or Landscape, which prints the image sideways.



Topics Menu 1 of 2
The Topics menu lists the various systems that are covered in BodyWorks®.    You may go to any 

of these using this menu, or press the corresponding button at the top of the window.

Skeletal System
The skeleton is the framework of the human anatomy, supporting the body and protecting its 

internal organs.    Two hundred and six bones compose the skeleton.    This section covers these 
bones and the ways in which they are connected.

Muscular System
The human body contains more than 650 individual muscles anchored to the skeleton, which 

provide pulling power so that you can move around.    These muscles constitute about 40% of your total 
body weight.    The body is moved primarily by muscle groups, and not by individual muscles.    These 
groups of muscles power all actions ranging from the threading of a needle to the lifting of heavy weights.

Nervous System
The nervous system of the human anatomy is responsible for sending, receiving, and processing 

nerve impulses.    All of the body's muscles and organs rely upon these nerve impulses to function.    
Three systems work together to carry out the mission of the nervous system: the central, the peripheral, 
and the autonomic nervous systems.    This section covers these systems and includes items such as the 
brain, the spinal cord and other nerve groups of the body.

Cardiovascular System
In order for the body to stay alive, each of its cells must receive a continuous supply of food and 

oxygen.    At the same time, carbon dioxide and other materials produced by the cells must be picked up 
for removal from the body.    This process is continually maintained by the bodies circulatory system.    The 
primary circulatory system consists of the heart and blood vessels, which together maintain a continuous 
flow of blood through the body.

Respiratory System
The respiratory system is responsible for supplying oxygen to the blood and expelling waste 

gases.    This section covers the lungs, air passages and muscles which make the system work.

Digestive System
The digestive system is responsible for processing food, breaking it down into usable proteins, 

carbohydrates, minerals, fats, and other substances, and introducing these into the bloodstream so that 
they can be used by the body.    It includes the mouth, esophagus, stomach and intestines as well as the 
liver, gall bladder and pancreas.

See also Buttons



Topics Menu 2 of 2
The Topics menu lists the various systems that are covered in BodyWorks®.    You may go to any 

of these using this menu, or press the corresponding button at the top of the window.

Sensory Organs
The sensory system includes the eyes, the ears, the nose, and the mouth.    The integumentary 
system is the name given for the skin, hair, nails, and glands covering the body.    It is included 
here because the skin is the largest sensory organ.

Lymphatic System
The lymphatic system is a specialized part of the circulatory system.    It's job is to carry some 

nutrients to cells, primarily fat, and to aid in the distribution of white-blood cell which are part of the bodies 
immune system.

Endocrine System
All the organs in the endocrine system are glands.    They are unique from other glands, because 

they release chemicals known as hormones into general circulation.    The organs of the endocrine system 
are located in widely separated parts of the body: in the cranial cavity, in the neck, in the thoracic cavity, in 
the abdominal cavity, in the pelvic cavity, and outside the body cavities.    The hormones they release are 
important to body functions.    They regulate basic drives and emotions, such as sexual urges, violence, 
anger, fear, joy, and sorrow.    They also promote growth and sexual identity, control body temperature, 
assist in the repair of broken tissue, and help to generate energy.

Genitourinary System
The genitourinary system includes the urinary and reproductive organs.    Because these organs 

are located in the same area of the body, and share some functions, they often are treated together.

Health & Fitness
Today, more and more people are concerned with their health and fitness.    Participation in sports 

and exercises, concerns about diet and nutrition, and considerations of the household products used to 
maintain health are expanding.    Because all of these are related to the anatomy and its processes in 
some way, it is worthwhile to be familiar with common illnesses, health care products, nutrition, and 
exercise.    This section cover a number of topics within the general category of "Health and Fitness."    
The information contained herein is meant for general information purposes only, and a doctor or 
pharmacist should be consulted before starting on any diet, engaging in an exercise program, or treating 
any illness, as failure to do so could result in adverse side-effects.    A physician will be able to counsel 
you on your specific physiological needs better than the general information given here.

Living
This section covers many of the processes of living including conception, pregnancy, and 

childbirth.    It also give details on birth rates, mortality rates, and population growth.    Other biological 
changes which occur during the course of one's life, such as menstruation and menopause, are also 
included.



See also Buttons



Edit Menu
Copy picture

The Copy picture command is the way BodyWorks® lets you export the graphics of the 
program.    When you choose this option, it makes a copy of the current picture to Window's 
Clipboard.    The clipboard is a standard feature of Windows which acts as a temporary holding 
area for data that is being exchanged between different programs.    Once the picture is on the 
clipboard, you can switch to another program that accepts graphics, and Paste it in.

Copy text
This command is nearly identical to Copy picture described above, but it copies text rather 

than pictures.    The text can easily be pasted into virtually every Windows word processor.

See also Exporting Graphics & Text and    Using Window's Notepad



Buttons
Topics

The Topics are the various systems that are covered in BodyWorks®.    You may go to any of these 
using their buttons, or you may select them from the Topics menu.

The topic buttons are:

Back Arrow

As you are exploring through the program, if at any point you'd like to go back to what you were 
viewing earlier, you can backtrack using the "back" arrow.

See also General Overview, Topics



Lessons
BodyWorks® has several lessons which let you explore the different anatomic systems.    They 

take you through the systems in a step-by-step fashion.    When you enter the Lesson section, you are 
presented with a list of lessons you can take.    When you select one, VCR like controls will appear 
which let you step through the individual entries.

The "Forward" button takes you to the next entry.

The "Reverse" button takes you to the previous entry.

The "Stop" button will end the lesson.

As you step through the lesson, all of the other program's functions are still active.    This lets you 
explore as you take the tour.    When you are ready to go on, the "Forward" button will always take 
you to the next step.

See also Quizzes and Tools Menu



Quizzes
BodyWorks® has several quizzes over the different anatomic systems.    There are ten questions 

for each quiz, selected randomly from the program.    The questions are a combination of multiple 
choice and identification questions.

If you are stuck on a question, you can press the "Surrender" button, and the program will show 
you the answer.    You can leave the quiz at any time by pressing the "End Quiz" button.

Your score is based on the number you got correct and how fast you answered.    The program 
will keep track of the person with the highest score.    If you have done well on the quiz, it will ask you 
to enter your name as the new high score.

See also Lessons and Tools Menu



Tools Menu
Lessons

There are several lessons in BodyWorks® which let you explore the different anatomical 
systems.    They take you through the systems in a step-by-step fashion.

Quizzes
There are quizzes for each section, and ten questions for each quiz.    These are selected 

randomly from the program.

Bookmarks
Bookmarks allows you to place bookmarks throughout the program as you browse.    Just like 

regular bookmarks, they let you quickly go back to a position you've saved earlier.

Index
BodyWorks® provides an index to the information in the program.    You can call it up from the 

Index option under the Tools menu.    It has a list of all the different topics covered in the program. 
You can scroll down this list and go to any individual entry immediately.    You can also search for 
a topic if you aren't sure how it's listed.    There's even a phonetic option which finds words even if 
you're not sure how they're spelled.

Glossary
BodyWorks® includes a glossary of some of the more uncommon terms used in the program. 

This will present you with a list of the terms available for definition.    When you select one, the 
definition will be displayed in the text box below.    When you are done, you can press the "Okay" 
button to close the glossary.

Pictures
The image list is a specialized index to the pictures in BodyWorks®.    Rather than having 

access to all of the information in the program as you do with the standard index, this option lists 
the unique pictures only.    You can select one and then press the "Goto" button.

Movies
BodyWorks® has movies which depict different anatomical functions.    The Movie List option 

calls up a list of the movies included.    To see one, select one and press the "Play" button.

See also Lessons, Quizzes, Bookmarks, Index, Glossary and Movies



Using the Glossary
BodyWorks® provides a glossary of some of the more uncommon terms used in the program.    

You can access the glossary from the Tools menu.    This will present you with a list of the terms 
available for definition.    When you select one, the definition will be displayed in the text box below.    
When you are done, you can press the "Okay" button to put the glossary away.

See also Tools Menu



Medical Records
The Medical Records option works as a database to store important medical information on you 

and up to 50 other people.    It will store things such as name, address, allergies & prescriptions and 
any other medical history items.

When you begin, it will give you a screen which lets you manage the people you have in your 
database.    This lets you add, delete and edit the individual entries.    When you first    begin, the list 
will be empty and you will need to add a new person with the "Add" button.    It will ask you the name 
for the person, then let you begin editing the new record.    Enter your information into the fields and 
press the "Okay" button when you are done.    The fields of information will scroll as you enter your 
data, but all the information is still intact and saved.    If you have more information than will fit in the 
top areas, you can include it in the large "medical history" section at the bottom.    You can come back 
and make changes to this data at a later time using the "Edit" button on the first screen.    You can 
also delete records from the same screen.

See also File Menu



Movies

BodyWorks® includes several movie sequences.    When a movie is available, there will be a 
small projector in the upper right corner of the picture.    To run the movie, simply click on that button.    
You can also select movies from the Movie List option found under the Tools menu.

See also Tools Menu



Speech & Sound
To help with the pronunciations of different words, BodyWorks® has a speech feature.    This will 

speak the name of an item when you press its button.    Any item which has a small speaker on the 
item button will speak.

To hear the voice, the program requires a Windows compatible sound board be installed in your 
system.    Additionally, you will need to have a driver for the card installed in Windows system.    This is 
done through the Drivers option in the Windows Control Panel.    The Control Panel is usually found in 
your Main group.    For help on configuring your sound card, please refer to your Windows manual 
and any documentation that came with your card.



Special Note about Graphics
Though BodyWorks® will work on any system running Windows, you will get the highest quality 

graphic images if you are using a 256 or greater color graphics display.    Many systems are capable 
of this type of graphics, but the video drivers that come with Windows generally only support 16 color 
display.    Your graphics card manufacturer should have drivers for these higher modes if the card can 
support them.    They will also have instructions on how to install them into Windows.



Bookmarks
Bookmarks allows you to place bookmarks throughout the program as you browse.    Just like 

regular bookmarks, they let you quickly go back to a position you've saved earlier.    When you get to 
a place you'd like to come back to later, call up the Bookmark option.    This will call up a screen that 
lets you manage the bookmarks.    It has ten slots for bookmarks.    You can select a slot, and press 
the "Set" button.    If you choose a slot where a bookmark already exists, it will be replaced.    When 
you'd like to return to this place, choose Bookmarks again, select one of the set bookmarks and press 
the "Goto" button.    The bookmarks are saved between sessions so you can always go to your 
favorite places.    If you'd like to remove one of these, select it and press the "Delete" button.

See also Tools Menu




