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Changes To This Version

The current version of MidiBase is 1.06beta

Added: Save Filelist command (See File Menu)
File Drag & Drop support
Uninstall Program 
StatusBar 

Fixed: Minor DDE & path bug

Previous additions and bug fixes :

Version 1.05beta

Added: Locator Bar
Shuffle & Intro play (See Options Menu)
Option to en/disable TreeView topics (See TreeView)
Auto read trackinfo option (See Properties Dialog)
Undo Command
Non-Destructive Delete (See Edit Menu)
Find Duplicates command (See Database Menu)
Sorting by Times Played (See Database Menu)
Program Manager installation option
Dynamic Data Exchange support

Fixed: FileList is now truly multiselect
Del shortcut conflict with entry boxes (See Popup Menu)
Select All now focuses the filelist (See Edit Menu)
PlayList entries are also removed by Del Refs
Now looks ok with different display settings

Version 1.04beta

Added: Find Command
Read Tracks button in Properties Dialog.
Divider between Treeview and filelist turns dark when resized.
Now Catalogs, just like with importing, can be 
          exported in different ways.

Removed the View menu (Refresh moved to Database menu)

Fixed: PlayList/MediaPlayer connection bug
Enter after title when last in list bug
Improved load and save: Trackinfo isnt stored in the database anymore, 
          but is read only when needed (see Properties Dialog).

Version 1.03beta

Added: Playlist

Fixed: Unreg. User Notification bug

Version 1.02beta



Fixed: Move now works properly (sorry)
Double-clicking filelist bug
Catalog pathname in column 1 bug

Version 1.01beta

Added: Move, Copy, Rename
Treeview autosort
Help is now available

Fixed: Improved filelist display



Registering MidiBase

This program meets the specifications of the shareware-concept. If you find this program useful and have 
worked with it a while (30 days at maximum), you are obligated to register it. Use the registration form in 
"register.txt" for that.

Why should I register ?

Registered users profit from the following benefits:

- Get notified periodically about new versions, either by email or mail.
- These updates can be downloaded via the Internet or sent to you, at your cost, by mail.
- Updates can be used with your current registration.
- Discounts on major updates (if released it will be version 2).
- You wont get bothered by the Unregistered Notification Dialog anymore.
- You contribute to the health of the shareware concept.

If you register MidiBase, we will assume that you are doing so having tested the shareware version and 
ascertained that it's suitable for your hardware and requirements. We cannot provide refunds for 
shareware registration if you subsequently change your mind.

Entering the registration code

Once you have received your registration code you can enter it into MidiBase. You do this by choosing 
Register from the Help menu. A dialog window pops up in which you can enter the code. If you choose 
OK MidiBase shows a message whether the registration was successful. If you have registered 
successfully, youll wont be bothered again by the notification message.



Legal Notice

MidiBase and this HelpFile are copyrighted to Dnote Software 1997. All Rights 
Reserved.

Under no circumstances is it allowed to copy, modify or distribute registered versions. It is allowed to 
spread the shareware version, under the condition that no registration codes are included or brought to 

the attention of the recieving party, and that nothing is added to, deleted from or modified in the 
distributable archive.

Dnote Software does not assume responsibility for any damage or loss caused by the use of this 
program, however it comes down. 

All the registered trademarks used herein are registered to whoever it is that owns them. This notification 
is given in lieu of any specific list of trademarks and their owners, which would not be as inclusive and 
would probably take a lot longer to type. 



Overview

MidiBase is software tool that enables you to manage, index and play your midifiles. 

Once midifiles are scanned they are stored in the database, along with all the information belonging to 
them, maker, file and track information.

The main benefit from using a database instead of a file manager is that you can add relevant information 
to the midifiles, and they can be view in different perspectives. MidiBase combines the two in such a way 
that you keep the functionality of both.

Main features

- Look and feel of the Windows® Filemanager
- Stores information in files that can be used by other applications
- Export file catalogs for backup, reference and sharing purposes
- Import your own file catalogs, so that artist and title information are added to the files
- Automatically adds author information to the midifiles (40 authors known at the moment)
- Comes with a catalog describing the artists and titles of over 800 midifiles
- DDE (Dynamic Data Exchange) support
- Too much to list here...

System requirements

- A PC with some kind of music playback device
- Microsoft® Windows 3.1 or better
- Some midifiles

See Also:
Version Info & Changes



Installation / DeInstallation

Installing MidiBase

You probably already copied the MidiBase files on you harddisk. If not you should move the files to a 
permanent place on you harddisk, preferably in a designated directory you have created for MidiBase.

Additionally you can create a program group and/or program icon in the Program Manager / Start Menu of 
Windows and add some extra functionality for Windows 95. This is not done by a separate setup 
program, but from within MidiBase itself.

If you start MidiBase for the first time, or after youve upgraded to a newer version, MidiBase automatically 
displays the installation dialog. If not you can reach this dialog by choosing Install from the Options Menu.

Heres the description on the usage of the Install Dialog:

Program Manager

Here you can choose in which Program Group you want the MidiBase icon to appear in. By default a 
group called MidiBase is selected. If this group doesnt exist, MidiBase will create it automatically. If you 
choose one of the existing groups from the group combobox, MidiBase will only add the MidiBase icon to 
it.

Once youve selected an appropriate group, you can press Create to create the Group/Item.

DDE Commands (See DDE support)

To configure Windows to support DDE for MidiBase, press Register. MidiBase will now adjust the proper 
settings in windows registry.

Uninstalling

To remove the MidiBase program from your computer, just start UNINSTAL.EXE from the directory you 
have installed MidiBase into. If you are going to remove the complete directory wherein the MidiBase 
program is located (the uninstall program will ask you if it has to do this), you have to be sure no other 
files are there which you need in the future. There is no way to get the files back once the uninstaller has 
completed. If youre not sure, just choose NO when the uninstaller asks you to remove the entire directory. 
The temp-directory where MidiBase temporarily stores deleted files is also deleted when the MidiBase 
directory is removed, so be warned.

Note : Due to some strange behaviour of the Windows 95 Start Menu, it may be possible that MidiBase 
icons still appear in a Program Folder after uninstalling. This is no big problem, the shortcuts are in fact 
removed, the next time you start Windows the Start Menu is updated and the icons will no longer appear.



How To Get Started Using MidiBase

The first thing you do after you have started MidiBase for the first time, is installing it. After this is done 
you have to scan in some midifiles. This is done by selecting the menu Database|Scan Dir, dragging & 
dropping or by the Windows 95 file menus. MidiBase works for a while, then all the files are displayed in 
the MidiBase window. 

To benefit from the possibilities of MidiBase at this stage you should crossmatch the reference catalog or 
one that you can provide (see below). Alternatively you can type in artist and title info by hand using 
appropriate boxes located just below the menus (the maker cant be changed here, because MidiBase 
recognizes most of that automagically).

With the tree-view at left-hand you can select which subset of the database you want to look into. In the 
filelist located right in the window you can do various things with the files using the right-mouse-button, 
the Edit menu or the MediaPlayer Buttons. Double clicking a file starts playing it.

See Also:
Usage
Crossmatching the provided catalog
Crossmatching your own catalogs



Usage

Getting started

Adding Artist and Title info to midifile

Menus

Main Window

Shortcut Keys

Catalog files



The Main Window

This section describes the components of the main window of MidiBase. Here you can do all those things 
promised in the Overview part of this help file.

Located at top are the menus

Directly below the menus are three boxes stating Artist Title and By. The first two are used to type in 
artist and title information by hand , the third reflects the maker or author of the selected midifile. This 
information is derived from the midifile at scan-time.

The two boxes that take up most of the windows space are the treeview and filelist.

Just below the TreeView and FileList is the StatusBar. Here you can see information about how many files 
are visible in the FileList (left-side) and about the file(s) youve selected (right-side).

The bottom panel is for midifile playback purposes. The MediaPlayer buttons are used to play and browse 
the playlist. Next to is the PlayList Combobox. In the right of the panel is the Locator Bar.



Shortcut Keys

Many function in MidiBase are accessible by just using the keyboard. This section describes some useful 
tricks to speed up the usage of the program.

Adding Artist and Title information :
By pressing F2 in the filelist the cursor jumps to the Artist text-entry box from where you can enter Artist 
information. If you press Enter from this box, the cursor jumps to the Title entry-box so you can enter the 
Title of the song. If you press Enter again then the selection in the FileList goes to the next file in the list 
and the cursor jumps back to the Artist entry-box. This feature is very handy when entering information for 
a large amount of midifiles. (See Also Adding Artist and Title information by hand).

Playing Midifile(s) :
If you press enter from the FileList the current selection is sent to the PlayList and the first midifile in this 
list is played.

Playing, Stopping and Resuming Playback :
These commands are implemented in the MediaPlayer buttonbar. With the spacebar you can command 
MidiBase to Play (if stopped) , Resume (if paused) or Stop (if playing) the current song.

Deleting References :
To delete references to midifiles, make a selection in the FileList and press the Delete button on the 
keyboard. (See Also : Delete Refs. from the Edit Menu).

Help :
On-line help appears after pressing F1. If you want information about a control in any window just make it 
the active one (you can see this by the dotted border which appear around the control or selection) and 
press F1. To get help about a menu item, just move your pointer above it and press F1.

Find :
You can search for files by pressing F3 from the main window. (See Also : Find)

Notes about basic Windows® shortcuts :
Microsoft Windows offers many shortcut features which, of course, are also available in MidiBase. For 
example if you press Tab or Shift-Tab you move to the resp. next and previous control in the window. 

Menus can be accessed by pressing the Alt key before typing the underlined letter of the menu in the 
menubar. Some menu items have a faster shortcut which can be looked up in that particular menu item, 
next to the command text. For example, the menu-item from the File menu which exits MidiBase displays 
Exit          Alt+F4, in this case you can press Alt+F4 to quit MidiBase. 

Any controls which have a underlined character in them can be reached by pressing that underlined letter 
while holding down the Alt key.



Scanning Midifiles

To make MidiBase usable you first have to scan in a few midifiles. Every subsequent use of this 
command adds files to the database, ignoring duplicates that may already be in the database.

To scan a directory for midifiles use the command Database>Scan Dir in the menu of the main window. A 
dialog appears with the following components:

Select Directory to Scan :
Here you type in which directory to scan. Alternatively you can use the Drive and Directory lists for that.

Include Subdirectories :
If you want MidiBase to search through all the subdirectories of the provided directory name, then check 
this option (defaults to checked).

Drive :
Select on which drive the directory is located.

Directories :
This box shows the directory tree on the selected drive. Double click to open or close a directory and click 
to select the directory to scan.

Click OK to start scanning (a dialog appears with a status bar and other information about the scan in 
progress).

Note : You can also scan in midifiles by dragging and dropping files from the FileManager / Explorer or 
the context sensitive file menus of Windows 95 (see Using DDE).



Drag & Drop Midifiles

In addition to scanning midifiles by Scan Directory and from the Windows 95 file menus (DDE support), 
you can also use the FileManager (Win3.11) or Explorer (Win95) to add midifiles to the MidiBase 
database. 

All you have to do is make a selection of one or more files in the FileManager/Explorer and drag the 
mouse-pointer over the MidiBase window and release the mouse-button. MidiBase will then retrieve the 
necessary information on the file, and add it to the database. If one ore more files dropped already resite 
in MidiBase, you will be prompted to continue or abort the drop action.



DDE Support

The Windows DDE (Dynamic Data Exchange) mechanism enables users to control certain applications 
from within other applications. MidiBase also supports this feature.

The most common usage of DDE for MidiBase is from the filemenus in the Windows 95 Explorer, File 
windows and Open/Save dialogs. Every time the user click the right-button on a file here a context 
sensitive menu pops up to present the user with some common and file-specific commands. 

MidiBase currently supports two additional commands for Midifiles which are Play In MidiBase and Scan 
In MidiBase.

The Play In MidiBase command scans in the selected file, adds it to the playlist and starts playing it.
The Scan In MidiBase command only scans in the selected file.

Note :You will be notified in case you try to add midifiles which are already scanned into MidiBase.

To enable DDE for MidiBase you first must have windows configured to support it. You do this by 
selecting the menu Options|Install (you probably already did this when you first started MdiBse).



File Menu Description

Save FileList
After prompting for a destination filename, creates a tab-delimited textfile containing information about the 
midifiles which are currently visible in the FileList. If you want to create a listing about all the files in the 
database you choose ALL from the TreeView pane before using the Save FileList command.

Quit w/o Saving
Quits MidiBase but doesnt save the database. All changes to the will be lost, so use it with care ! Quitting 
MidiBase without saving the database can be useful in situations where you entered data or scanned 
directories you didnt meant to.

Exit (Shortcut Alt+F4)
Saves the database and exits MidiBase.



Edit Menu Description
See Also : FileList Popup Menu

Undo    (Shortcut Ctrl+Z)
Most commands can be undone ONCE, see the Undo topic for more info.

Select All    (Shortcut Ctrl+A)
Selects all the files currently visible in the filelist.

Find (Shortcut F3)
Opens a window which you can use to find specific midifiles

Properties (Shortcut Ctrl+R)
Opens a window in which all information about a specific midifile is displayed. (See Properties Dialog).

Rescan (Shortcut Ctrl+S)
Rescans the selected files and stores new information about them (artist and title info are kept intact 
though).

Delete Refs (Shortcut Del)
Deletes the selected information about the midifile.

Delete
Deletes the selected midifile(s) and their reference(s). 
Delete actually moves the files to the Temp directory in your MidiBase directory (Windows 95 users may 
recognize the Recycle Bin concept in it). These files will be really deleted when you start MidiBase the 
next time. This enables you to restore deleted midifiles that you cant anymore with the Undo command.

Move
Moves the midifile(s) to another drive/directory and modifies the(ir) reference(s).

Copy
Copies the midifile and optionally modifies the log in the target directory.

Rename
Renames the midifile (only possible one at a time)



Database Menu Description

Scan Dir
Scans a directory and adds the found files in the database. (see also Scanning a Directory)

Crossmatch Catalog
Crossmatches a given catalog with the contents of the database (see also Catalogs and CrossMatching)

Export Catalog
Exports the information in your database to a catalog which can be used for backup, reference and 
exchanging purposes (see also Exporting a Catalog)

Find Duplicates
Searches the database for duplicate midifiles based on their size and filename. The results are displayed 
two by two under the Find Result topic of the TreeView. If desired, you can delete duplicates in the 
FileList.

Refresh Tree (Shortcut F5)
Recalculates the treeview so that the latest entered information is reflected in it. After that it collapses all 
the branches in the tree and refreshes the FileList.

Sort by Filename
Sorts the entire database by filename.

Sort by Artist
Sorts the entire database by artist.

Sort by Scan Date
Sorts the entire database by when the files where added to the database.

Sort by Times Played
Sorts the database by the times that each midifile was played from within MidiBase. After you have used 
this command youll find your favourites files in the top of the list.



Options Menu Description

Log with Copy
Keeps your copies tracked in a log-file.

Shuffle Play
With this option checked, your selection gets inserted into the PlayList at random every time you use 
PlayList This and Add To PlayList.

Intro Scan
Plays only the first few seconds of the midifiles in the playlist.

Install...
Opens the install dialog from which you can configure additional Windows features.



Help Menu Description

Contents
Shows the contents section of this helpfile

Register
Brings up a window in which you can register MidiBase

About
Displays the about box of MidiBase. Until you are registered you will see it once in a while.



The Treeview

In this section you can choose which midifiles are visible in the filelist section of the main window. If you 
select All all the midifiles in the database are visible. To display a subset of the database open a folder in 
the treeview and select the appropriate item there, for instance an artist or maker.

A special item in the TreeView called Find Result hold the files you found with the previous Find 
command or Find Duplicates (Database menu) command.

Using the right-mouse-button you can popup the TreeView popup-menu. From here you can select which 
folders you want to appear in the TreeView (some functions will work faster with less folders visible, like 
Update TreeView). 

When you make changes to the midifiles in the FileList, they are not immediatly reflected in the TreeView. 
Use the command Update TreeView (F5) from the Database Menu to recalculate the TreeView to include 
your changes.



The FileList Section

In this section you can see the midifiles which apply to the selection in the treeview. The titlebar of the 
mainwindow reflects how many files in the database are visible herein. 

In the filelist you can select one or more midifiles with which you then can perform actions like copy, move 
and delete, using the popup menu or the Edit menu. If you hold down the Shift key while clicking in the 
list, you can select multiple adjacent rows at once. While pressing the Ctrl key, you can add individual 
rows to your selection.

Using the column header bar in top of the FileList you can resize each column to your desires. If you dont 
wish to see a particular column, then just make it as narrow as possible (this requires very precise mouse 
handling though).

To play midifile(s) use the Play Button on the MediaPlayer strip , the PlayList This option from the popup 
menu, double-clicking it/them or the Enter key. If you only want to add the selection to the playlist without 
actually starting to play them use Add To Playlist.



FileList Popup Menu

<<Help Menu

This popup menu is displayed whenever the right-button is clicked in the filelist. You can execute several 
commands from it:

PlayList This (Shortcut Enter or Double-Click)
Replaces the PlayList with the current selection and starts playing the first file.

Add To PlayList
Adds the current selection to the playlist.

Properties (Shortcut Ctrl+P)
Opens the Properties Dialog in which all the information about the midifile is displayed.

Rescan (Shortcut Ctrl+R)
Rescans the selected files and stores the newly found information (See Also scanning) 

Delete Reference (Shortcut Del)
Deletes the selected information about the midifile.

Delete File
Deletes the selected midifile(s) and their reference(s).
Actually moves the files to the Temp directory in your MidiBase directory (Windows 95 users may 
recognize the Recycle Bin concept in it). These files will be really deleted when you start MidiBase the 
next time. This enables you to restore deleted midifiles that you cant anymore with the Undo command.

Move File
Moves the midifile(s) to another drive/directory and modifies the(ir) reference(s).

Copy File
Copies the midifile and optionally modifies the log in the target directory.

Rename File
Renames the midifile (only possible one at a time)



Finding Midifiles

To search for specific midifiles use the option Find from the Edit Menu (shortcut key F3) or    the Find 
button in the top-right corner of the mainwindow. An edit box then pops up in which you can specify the 
text to look for. If you press Enter from this box, MidiBase starts to look for case-insensitive (sub)matches 
of your text in the fields Artist, Title, Maker and Filename. Pressing ESC from this box abandons the Find 
command. 

All the found files (if any) are displayed in the filelist and the topic Search Results in the TreeView is 
selected. Until you restart MidiBase or start a new search this information is available by pressing Search 
Results from the treeview.



The Undo Command

Undo restores the effect(s) of the last command MidiBase has executed.

The commands can be undone:
- Artist and Title change
- Delete Refs
- Delete, Move and Rename File

These commands cannot be undone and clear the Undo history:
- Any of the Sort commands
- Scan Dir and Rescan
- Crossmatch Catalog

All other commands have no effect on the Undo history, so youre safe most of the time.

Undo is not available when its option in the Edit Menu is disabled and states Cant Undo. In other cases it 
will state the command to be undone. The shortcut key to Undo is Ctrl+Z.



Properties Dialog

This dialog shows all the information that is in the database about the midifile. It can be reached by the 
Edit menu, the FileList Popup menu or by pressing Ctrl+R. This command is only available when 1 
midifile is selected.

Pressing the Read Tracks button shows information on the tracks of the midifile (the midifile has to be 
available for loading). If you check the Read On Open option, then the tracks will be automatically red 
every time you open the properties dialog.



The MediaPlayer Buttonbar

Located at bottom-right are a set of buttons which control the playback of the midifile. Usage of these 
buttons are analog to a VCR or CD-player. Using the previous and next buttons you can choose resp. the 
previous and next song in the PlayList.

See Also : Locator Bar



The Locator Bar

With this control you can scroll between the begin and end of the midifile. Its also displays the position in 
the current song.



The PlayList

This list represents the midifiles that are in queue to be played and is displayed in the combobox next to 
the MediaPlayer buttons.

The file which is visible in the combobox is the one currently playing, or which will start to play after you 
hit the play button. By dropping down the list of the combobox you can start or choose another song in 
the PlayList. Alternatively you can use the previous and next buttons on the MediaPlayer to do this.

You add files to the PlayList by selecting them in the filelist and choosing Add To PlayList from the 
popup menu. Double-clicking a selection, pressing Enter or choosing PlayList This from the popup 
menu replaces the entire PlayList and starts the first midifile in queue that youve selected.

See Also: Options Menu for the Shuffle Play and Intro Scan topics.



Adding artist and title by hand

By using the two boxes just below the main menu you can provide artist and title information about the 
selected midifile in the filelist. If you have a large amount of files to modify this information of, then use the 
enter key instead of tabbing or clicking. MidiBase selects the next file in filelist everytime you hit enter 
after providing artist and title information.

To automate the process of typing in artist and title information take a look at these topics:
Crossmatching the provided catalog
Crossmatching your own catalogs



Log with Copy option

This option can be toggled from the Options Menu. If it is checked then MidiBase logs each copy you 
make in a file called midilog.txt in the directory youve copied your file(s) to. This comes in handy when 
you copy your files for a friend, and want to specify in detail which files you have given him. The 
information stored in this log is : filename, artist, title and maker.



Catalog files

Purpose

The purpose of the catalog files (both your own and the provided one) is to add artist and title information 
to the files that are scanned into MidiBase. In opposite to doing this by hand This saves much time to 
work you possibly already have done.

How does MidiBase uses these catalogs ?

MidiBase uses a process which we have called crossmatching. For every file that is scanned in the 
database, the program searches through the catalog for similar filename and, if necessary, filepath and 
uses the found information to fill in the artist and title of the midifile.

See Also
Crossmatching the provided catalog
Crossmatching your own catalogs
Exporting catalogs



Crossmatching the provided Catalog

The provide reference file (called ref_vxxx.cat) is used to assign artist and title information to your 
scanned-in midifiles. All you have to do is select the menu Database>Crossmatch catalog, and selecting 
the file ref_vxxx.cat from the path where MidiBase resides. (Do not check the "use path" option at this 
time, the ref. file doesnt contain path information). Now your files are automatically provided with artist 
and song information. 

The catalog provided with this version contains over 800 titles !

The latest reference files can be downloaded from the internet using the address stated in the about 
Dnote section.

If you think you can help us in expanding the reference file, then scan in all your files and send your own 
exported catalog file ! (your information is handled discretely)

!!! NOTE !!!
If you are a person who renames his files a lot: shame on you. MidiBase isn't able to recognize renamed 
files. In these cases I hope you have maintained a listing about your midifiles, so that you can use that as 
reference, (see Crossmatching your own Catalogs). 



Crossmatching your own Catalogs

If you already have a large collection of midifiles and have kept them tracked one way or another, it is 
possible to import this information into MidiBase. You can also crossmatch catalogs which you have 
previously exported (e.g. in case of data-loss or when working on another system than you own).

What you have to do before MidiBase can read you catalog

This is only applicable to situations where you have to read in a filelisting of your own. Catalogs exported 
with MidiBase itself are always rereadable.

The catalog specification

Catalogs are no more than specially formatted textfiles. They can be generated with any texteditor and 
most spreadsheet utilities like: Notepad, Word and Excel. 

Catalogs have to be very strict in the way they hold information. You cannot just read in your filelist 
without first having modified it to meet the desires of MidiBase. There are three ways in which catalog 
files can be made up, in all cases though every midifile has to be described on a separate line, between 
the filename, artist and title there has to be one, and only one, tab (even between empty fields); no tab 
characters may appear in the data itself .

1 - No path information
Use this when you dont care where midifiles are located. In this case its advisable to make sure that no 
duplicate filenames are used. The order of the data is: filename, artist, title. Here is an example of such a 
file:

mrmister.mid    [TAB]    Mr Mister    [TAB]    Broken Wings

2 - Path together with filename in column 1
In this case the filename and pathname are together in one column. E.G.:

d:\midifile\mrmister.mid    [TAB]    Mr Mister    [TAB]    Broken Wings

3 - Path separate in column 4
In this case you add an extra column in which the filepath is separately stored. E.G.:

mrmister.mid    [TAB]    Mr Mister    [TAB]    Broken Wings    [TAB]    d:\midifile

When you have stored your listing in Excel :

Save your listing from Excel in the tab delimited text format. Make sure you have ordered your columns 
properly and removed those columns you dont need (anymore).

When you have stored your listing in a Word table:

- Delete the columns you dont need. 
- Order the the columns of the table like described above.
- Select the entire table
- Click the command Convert Table To Text and click the option Tabs when youre prompted with: separate 
text with.
- Delete any redundant information and table headers and save the file as a .CAT file.
- Use Crossmatch Catalog in MidiBase to select this new file and youre done.

When you have stored your listing in a database:



Because there are many databases around there, its impossible to describe the procedure for each 
different one. What can be said though is that most of them somewhere have a function called something 
like export or convert database/table. Use this command after youve made sure the data is ordered o.k., 
or if this isnt possible do it afterwards with word or excel.

When you have stored your listing in a plain text file:

This is the most difficult thing to do. If you have separated your information in some kind of way though, 
youre save, just replace these separators and order the columns like described above. In other cases you 
have to do this by hand.

See also : Crossmatching



Crossmatching

Look at these topics for background information on crossmatching in MidiBase:
Crossmatching the provided catalog
Crossmatching your own catalogs

The crossmatch dialog is reached by selecting the menu Database>Crossmatch Catalog from the main 
window. In this dialog you can select which file to crossmatch and information about which way data is 
stored in the catalog youre about to scan.

NOTE: Catalogs exported by MidiBase itself can appear in three different formats, if you havent 
remember the way you exported it, then check the catalog to find out.

Get Data : Press this button and browse and select the catalog you want to crossmatch. After this the 
catalog filename is displayed below this button.

Use pathnames : If you want MidiBase to check the pathnames of you midifiles too, so that a more 
restrictive crossmatch is done, you should check this option.

Location of path : Make a choice here when youve decided to include pathname checking. When With 
filename in column 1 is selected, MidiBase expects that both the path and filename are in the first 
column of the catalog (e.g. d:\midifile\hello.mid). If Separate in column 4 is checked then MidiBase 
expects the filepath is located separately in the 4th column. The filename in this case is also located 
separately in column 1.

Press OK to start crossmatching or choose Cancel to cancel the operation.



Exporting your own Catalogs

Why ?

There are a couple of reasons that make you want to export the information about your midifiles to a 
catalog, these are the main ones:

- For backup purposes. If you save your catalogs once in a while you are always secured that in case of 
data-loss or a computer malfunction your hard work isnt to waste. After such a disaster you can always 
rescan your midifiles and reread the information from the backed up catalog.( See : Crossmatching your 
own catalogs)

- For reference and sharing purposes. Imagine that you copied a few megabytes of midifiles for a friend. 
To prevent this friend from typing in all the titles that arent provided in the Reference Catalog, all he has to 
do is to crossmatch the catalog you have exported for him. Ofcourse this friend has to use MidiBase too !

How ?

To export a catalog from your midifiles select the menu-option Database>Export Catalog. The Export 
Dialog pops up to ask you about where and how to store the new catalog.



Export Dialog

This dialog appears after choosing Export Catalog from the Database Menu.

Set File
Press this button and specify where and under which filename to save the Catalog.

Use pathnames
Check this if you want to store the path of the midifiles in the catalog. Its advisable to use this option, 
because when you crossmatch this catalog again, you then have the option to ignore or include them.

Location of Path
If youve checked Use Pathnames you can specify here where to put the path. By selecting the option 
With filename in column 1 the pathname is stored together with the filename (e.g. c:
\midifiles\mrmister.mid). If you select Separate in column 4 the paths of the midifiles are stored in a 
separate column.



Software

You can send your registrations, bug reports and ideas to Dnote software by:

Mail : Dnote Software
Seringenstraat 3
5644 PK Eindhoven

 Holland

Email : dnote@pi.net

The latest version of MidiBase and the Reference Catalog can always be found at:

WWW : http://www.pi.net/~dnote/software




