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Introduction
Overview
Audition for Windows 95/NT is a small freeware utility that will allow you to play sound files located in a disk 
directory. A play list is created of all sound files found in the selected folder.

Playing Sound Files
Sound files can be played individually, or the entire play list can be played one after another. Double-click your 
mouse on a sound file listed in the play list to hear individual sounds.

Editing Sound Files
Commands are included to launch your favorite WAV file editor and speaker volume control applications. These 
can be specified using the Audition Options dialog box.

Audition for Windows 95/NT provides a simple means of playing and editing all of those sound files you’ve been 
collecting.



Installing Audition
Installation
To install Audition for Windows 95/NT on your computer simply create a new, empty folder and place the files; 
AUDITION.EXE and AUDITION.HLP there.

AUDITION.EXE - The Audition Application
AUDITION.HLP - The Windows 95 Help File

Note: If you have an earlier version of Audition for Windows 95/NT installed on your computer, simply replace the 
AUDITION.EXE and AUDITION.HLP files with the newer versions. Audition stores configuration information in the 
MS Windows 95/NT System Registry.

Note: The AUDITION.INI file is no longer used and can be deleted. The various application settings specified in 
the Audition Options dialog box as well as the main window’s size and location on the desktop are now stored in 
the MS Windows 95/NT System Registry.

Warning: If you rename the AUDITION.EXE file you must also rename the HLP file using the same basename. 
For example if you change the Audition application file name to NewName.exe, rename the help file to 
NewName.hlp. The HLP file must reside in the same folder as the application file itself.



Configuring Audition
Audition Options
Select the File | Options menu item to display the Audition Options dialog box. This window will allow you 
change various Audition program settings.

Show Tool Ribbon Tips
Check this item to display small popup tip windows when the mouse pointer is moved over toolbar ribbon 
pushbuttons. A short description of the button currently beneath the mouse will be shown when this item is 
checked.

Place Icon in Taskbar Tray
Check this item to display a small Audition icon in the Taskbar Icon Notification Tray. If this item is selected and 
the Audition window is minimized a button will not be added to the Taskbar, to restore the Audition window on 
the desktop press the small icon in the taskbar tray instead. This item is available to keep the taskbar free for 
other running windows.

Confirm Play List Deletions
Check this box to confirm play list deletions. If this item is checked you will be prompted before removing sound 
files from the play list. Deleting a sound file from the play list does not delete the file on disk, but rather just 
removes it from the play list.

Reload Play List from Last Folder Used
Check this box to reopen the last folder that was used, and load the sound files into the play list whenever 
Audition is launched.

Dark Play List Window Background
Check this item to display the WAV file names in the play list window with a dark background instead of the 
paper white background MS Windows normally uses to display text.

Play Sounds Asynchronously
Check this box to play sound files asynchronously. Checking this item will allow sound files to be played in the 
background. This mode is automatically overridden while the Play All command is in effect.

Sound Editing Application
Specify the name of the sound editing program you would like to use for editing WAV files. Enter the full path 
and file name of the application you wish to use, or press the browse [...] button to the right of this entry field to 
select a file using the standard MS Explorer file browser.

Volume Control Application
Specify the name of the volume control program you would like to use when playing WAV files. Enter the full 
path and file name of the application you wish to use, or press the browse [...] button to the right of this entry 
field to select a file using the standard MS Explorer file browser.

Sounds with Warning Dialog Boxes
Check this box to play a short beep sound when Audition displays a warning dialog box or an error occurs.

OK
Press this button when you have completed your selection of Audition program options. When you press this 
button the Audition Options dialog box will be closed and your settings will be saved.

Cancel
Press this button to close the Audition Options dialog box without making any changes. If you have made any 
changes to the option settings, and then press this button your changes will not be used, and the previous 
settings will remain in use.

Default
Press this button to use the default Audition program options for this dialog box. These will be the same 
settings that were used when Audition was run for the first time.

Note: The options you have selected will be saved when you press the OK button. The desktop location of the 



Audition Options dialog box itself will also be saved. Your settings will be saved in the MS Windows 95/NT 
System Registry.



Selecting Sound Files
Selecting Sound Files
Select the File | Open menu item to display the Sound Folder Browser. Use this dialog box to select a folder 
containing the sound files you would like to audition. Click your mouse on the folders listed in the left hand 
window to display a list of sound files suitable for loading and playing.

Sound File Formats
Audition for Windows 95/NT will play WAV files, the most common form of sound files found on MS Windows 
95/NT systems. WAV files are used by most programs and games that play sounds using your computer system’s 
multimedia equipment.

Note: The desktop location of the Sound Folder Browser will be saved and used the next time you open it.



Audition Menus
Menu Commands
The top of the Audition window displays a row of menus used to select various Audition operations. All of 
Audition’s operations are carried out using the items listed on these menus. To display the items available click 
your mouse on the desired menu title. A drop down list will be displayed, allowing you to select the command you 
wish to carry out.

 The File Menu
 The Edit Menu
 The View Menu
 The Sound Menu
 The Help Menu

Tip: Most commonly used menu commands can also be invoked using shortcut keys or buttons on the toolbar 
ribbon.



File Menu
File Menu Commands
The File menu provides commands used to work with the sound files used by Audition. A short description of each 
item follows:

Open
Opens the Sound Folder Browser window and allows you to select a folder containing sounds files. The 
Ctrl+O shortcut can also be used for this command.

Properties
Displays a small window showing file properties for the currently selected sound file. This window will display 
the sound file’s name, folder location, size, last modification date and file access permissions. The Alt+Enter 
shortcut can also be used for this command.

Options
Opens the Audition Options dialog box and allows you to change Audition program settings.

Exit
Closes the Audition program and returns control to the Explorer desktop. The Ctrl+Q shortcut can also be 
used for this command.

Tip: Commonly used File menu commands can also be invoked using shortcut keys or buttons on the toolbar 
ribbon.



Edit Menu
Edit Menu Commands
The Edit menu provides commands used to edit the contents of Audition play lists. A short description of each 
item follows:

Delete
Deletes the currently selected sound file from the play list, this command does not delete the sound file from 
the disk, but rather just removes it from the play list. The Del shortcut can also be used for this command.

Edit
Opens the sound editor program and loads the currently selected sound file from the play list for editing. The 
Ctrl+E shortcut can also be used for this command.

Tip: Commonly used Edit menu commands can also be invoked using shortcut keys or buttons on the toolbar 
ribbon.



View Menu
View Menu Commands
The View menu provides commands used to change Audition display options. These items provide a means of 
changing the Audition window appearance. A short description of each item follows:

Toolbar
Use this command to turn the toolbar ribbon on and off. If this item is checked the Audition toolbar ribbon will 
be displayed below the menu bar. To hide the toolbar ribbon uncheck this item. Most commonly used 
Audition menu commands have a toolbar button. If the toolbar ribbon is turned off you will have to use the 
normal Audition menus.

Status Region
Use this command to turn the status region on and off. If this item is checked the Audition status region will 
be displayed at the bottom of the Audition window. To hide the status region uncheck this item. The status 
region displays current program status and will also display a brief description of each menu command as 
the mouse is moved.

Refresh
Refreshes the Audition play list to reflect the sound files currently located in the selected folder. The F5 
shortcut can also be used for this command. This command is useful if you’ve used the MS Explorer to move 
or delete sound files from the currently selected sound folder that Audition is using.

Minimize
Minimizes the Audition window to a button or icon on the taskbar. The Ctrl+Y shortcut can also be used for 
this command. To restore the window to the desktop press the Audition button on the taskbar, or the program 
icon in the taskbar notification tray.

Always on Top
Use this command to keep the Audition window top most on the desktop. When this item is checked the 
Audition window will float above all other non-topmost windows on the desktop. This item is useful if you 
normally run Audition with a small window that would be easily obscured by other applications.

Tip: Commonly used View menu commands can also be invoked using shortcut keys or buttons on the toolbar 
ribbon.



Sound Menu
Sound Menu Commands
The Sound menu provides commands used to play the sound files listed in Audition’s play list. A short description 
of each item follows:

Play
Plays the currently selected sound in the play list. The Ctrl+P shortcut can also be used for this command. 
Double-clicking the mouse on a sound in the play list or pressing the Enter key will play individual sound files 
as well.

Play All
Use this item to play all of the sounds currently in the play list. The Ctrl+A shortcut can also be used for this 
command.

Stop
Stops playing the sounds in the play list when the Play All command was previously issued. The Esc 
shortcut can also be used for this command.

Volume
Opens the volume control program and allows you to change your system’s speaker volume level. The 
volume control program used will be the application you specified in the Audition Options dialog box.

Tip: Commonly used Help menu commands can also be invoked using shortcut keys or buttons on the toolbar 
ribbon.



Help Menu
Help Menu Commands
The Help menu provides commands used to get help for Audition operations. A short description of each item 
follows:

Contents
Opens the Audition Help window and displays the Table of Contents. The F1 shortcut can also be used for 
this command.

Search
Opens Audition Help and displays the Search window. You can use this window to search for specific 
Audition help topics.

How to Use Help
Opens a Help window that explains how to use MS Windows 95 Help files.

About Audition
Displays the Audition splash box. This window contains the current version number of Audition and a 
program copyright notice. Click the mouse anywhere in this window to close it

Tip: Commonly used Help menu commands can also be invoked using shortcut keys or buttons on the toolbar 
ribbon.



Toolbar Buttons
Tool Ribbon Buttons
Most commonly used Audition menu commands can also be quickly invoked by pressing a button on the toolbar 
ribbon displayed at the top of the main window. These buttons work exactly the same way as the corresponding 
menu items that they duplicate.

Open - Open the Sound Folder Browser

Refresh - Refresh the play list

Properties - Show document properties

Delete - Delete the current selection

Edit - Edit the current selection

Volume - Open the Speaker Volume program

Play  - Play the current selection

Play All - Play all files in the list

Stop - Stop playing sound files

Options - Open the Audition Options dialog box

Help - Open this Help file

About - Show Audition splash box

Tip: If the Show Tool Ribbon Tips option was selected a small popup tip window will appear when the mouse 
pointer is placed over a button. A short description of what each button does can be viewed using this method.



Shortcut Keys
Shortcuts
Shortcut keys allow you to quickly invoke a menu item command without displaying the menu and then selecting 
an item. The most commonly used menu commands can be invoked using the following shortcut keys.

Ctrl+A Play All files in the play list
Ctrl+E Edit the selected sound file
Ctrl+O Open the Sound Folder Browser
Ctrl+P Play the current selection
Ctrl+Q Exit Audition , and return to the desktop
Ctrl+Y Minimize Audition to an icon

Esc Stop playing sound files
Del Delete the selection

Enter Play the current selection
Alt+Enter Show properties for the selected sound file

F1 Display this Help file
F5 Refresh the play list



Comments and Upgrades
Comments and Suggestions
If you have comments, questions or find any bugs in Audition for Windows 95/NT please feel free to contact me 
on CompuServe or America Online.

Upgrade Notification
If you would like to be notified when this application is upgraded send me an email message with your online 
address. Please include the version number you are using and the location that you downloaded my software 
from. I will email you when a new version of Audition for Windows 95 is uploaded to my web site on the Internet, 
CompuServe, America Online, ExecPC, ZD Net, and MSN.

Gregory Braun
CompuServe: 71613,2175
AOL: GreggBraun
Email: 71613.2175@compuserve.com
Web Site: http://www.execpc.com/~sbd
Phone: 1.414.444.8497

Contributions
While Audition is offered as Freeware, if you would like to pay for it you are welcome to send any amount you 
wish to:

Gregory Braun
5609 West Hadley Street
Milwaukee, WI 53210-1554    USA

Your contributions are always welcome, and encourage me to continue developing new applications.

Web Site
Visit my web site on the Internet to download the latest versions of all of my freeware offerings.

Software by Design Web Site

(http://www.execpc.com/~sbd)



Release History
Audition for Windows 95/NT Release History

v2.0 Original in-house development and testing of MS Windows 95/NT conversion using Win32 SDK.

v2.1 Added 95/NT splash box for release.

v2.2 Added MS Windows 95/NT Help file. 

v2.3 Fixed several minor bugs. 

v2.4 Replaced INI file with MS Windows 95/NT System Registry entries.

Last Update: April 11th, 1997

Web Site
Visit my web site on the Internet to download the latest versions of all of my freeware offerings.

Software by Design Web Site

(http://www.execpc.com/~sbd)



System Registry
Audition for Windows 95/NT System Registry Key
Audition for Windows 95/NT stores configuration settings in the MS Windows 95/NT System Registry. These 
settings are updated automatically while Audition is running. There is no need to edit these settings manually.

If you insist upon editing these settings, you do so at your own risk. Audition automatically updates registry entries 
when it exits. If you wish to edit these settings make sure Audition is not running while you edit them. If Audition is 
currently running your changes will be overwritten when Audition exits.

Audition for Windows 95/NT stores configuration settings in the following system registry key:

HKEY_CURRENT_USER
Software
Software by Design
Audition for Windows 95/NT
Section
Label = Value

Warning: There is no need to edit these settings manually. Audition will automatically maintain these settings for 
you. If you do edit these, you do so at your own risk.



Software by Design Web Site
Software by Design
You can download the latest versions of all of my freeware from my web site on the Internet. I post the latest 
releases of my software programs there first. Click your mouse on the link listed below to visit the Software by 
Design web site.

Software by Design Web Site

(http://www.execpc.com/~sbd)

Freeware Titles
The following software titles are available at my web site and can also be found on CompuServe, America Online, 
ExecPC, MSN and ZD Net.

NoteBook for Windows (NBOOK.ZIP)
NoteBook for Windows 95/NT (NBOOK32.ZIP)
Reminders for Windows (REMIND.ZIP)
Reminders for Windows 95/NT (REMIND32.ZIP)
ToolBar for Windows (TBAR.ZIP)
ToolBar for Windows 95/NT (TBAR32.ZIP)
Screen Loupe for Windows (LOUPE.ZIP)
Screen Loupe for Windows 95/NT (LOUPE32.ZIP)
Screen Loupe for Macintosh (LOUPE.SEA)
Password Keeper for Windows 95/NT (PASSKEEP.ZIP)
CardBase for Windows 95/NT (CARDBASE.ZIP)
Quiz Wizard for Windows 95/NT (QUIZWIZ.ZIP)
File Editor for Windows (FXEDIT.ZIP)
File Editor for Windows 95/NT (FXEDIT32.ZIP)
Crypto for Windows 95/NT (CRYPTO.ZIP)
Icon Extractor for Windows (ICONX.ZIP)
Icon Extractor for Windows 95/NT (ICONX32.ZIP)
Audition for Windows 95/NT (AUDITION.ZIP)
TxEdit for Windows 95/NT (TXEDIT.ZIP)
DLL Show for Windows 95 (DLLSHOW.ZIP)
RGB Editor for Windows (RGB.ZIP)
RGB Editor for Windows 95/NT (RGB32.ZIP)
FontShow for Windows 95/NT (FONTSHOW.ZIP)
Programmer's IDE (PMAN.ZIP)
Programmer's IDE 95/NT (PMAN32.ZIP)
Touch for Windows (WTOUCH.ZIP)
Disk CleanUp for Windows 95/NT (CLEANUP.ZIP)
BattleStar for Windows (BSTAR.ZIP)
BattleStar for Windows 95/NT (BSTAR32.ZIP)
World Radio for Macintosh (WRADIO.SEA)

Note: The latest versions of my software programs are always posted on my web site first. Versions found on the 
other online services may be earlier releases.



BBS and Internet Operators
Webmasters
Please upload the original ZIP file intact and title the submission:

"Audition for Windows 95/NT v2.4"
--Author Gregory Braun

Web Site
Visit my web site on the Internet to download the latest versions of all of my freeware offerings.

Software by Design Web Site

(http://www.execpc.com/~sbd)

Note: This site also supports anonymous FTP transfers.




