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HOW TO USE TANGAROOS

TANGAROOsÔ    is an educational tool that can help develop skills in pattern 
recognition and spatial orientation by using the concept of tangram shapes (see 
History).    It also is a tool to promote creativity.    Usually, tangram shapes are made 
from any number of materials that may or may not be convienient to use.    With the 
proliferation of computers, people are finding that TANGAROOsÔ    is a fun and easy 
way to carry on the tradition of teaching with tangrams. 

In keeping with these ideas, TANGAROOsÔ    can be used in essentially two modes:    
duplicate and create.    Duplicate assumes that you already have a picture that you are 
going to build.    This picture can be either in electronic form (picture file) or just on a 
piece of paper.    From there, your job is to use the seven shapes to duplicate the 
picture.    TANGAROOsÔ    has many options to help you perform this task.    Not only 
is there a wide variety of ways the shapes can be manipulated (see Quick Reference 
Guide), but there are also three different skill levels (see Options menu).    
TANGAROOsÔ    is packaged with a picture file, and you can find many books in your 
local library that contain more tangram pictures.

A lot of adults feel that they have out-grown the idea of tangrams.    That's why 
TANGAROOsÔ    was developed with a create mode.    Kids and adults both will find it 
very rewarding and enjoyable to develop new tangram pictures.    TANGAROOsÔ    will 
even let you save your creation to your very own picture file (see File menu).

That's really all there is to know to get started.    HAVE FUN!



HISTORY OF TANGRAMS

No one is really sure where tangrams originated.    Some sources believe it began as an 
ancient Chinese puzzle that was created when an old Chinese man dropped a square 
tile that shattered into the seven tangram shapes.    He found that the shapes could be 
rearranged together to form an endless number of larger shapes.

Tangrams have been used throughout history in Europe and have been made especially 
famous in the United States by Sam Loyd.    It seems that the popularity of tangrams 
comes and goes, but even now it is still being used as a teaching tool in many schools. 
You can read more about tangrams in your local library.



MENUS

      File

      Picture

      Options

      Flip Parallelogram

      Mouse Help

      Help



USING THE MOUSE

      Selecting Shapes

      Dragging Shapes

      Rotating Shapes

      Erasing Shapes

      Color Shapes Black



HELPFUL HINTS

Use the Mouse Help menu feature if you need a brief reminder about how to use the 
mouse to manipulate the shapes.    Just click on the Mouse Help menu and a quick 
reference is displayed.

There is also a Quick Reference Guide to using the mouse and menus that you can 
access under the Help menu.    It is helpful to print this guide and keep it handy when 
using TANGAROOsÔ.

In using TANGAROOsÔ, I have found that creativity can strike at any time.    Therefore, 
you need the ability to save your creation.    There is a Save Mode that allows you to do 
this.    If you are creating a picture with the Save Mode off (not checked) and then you 
turn the Save Mode on, your picture will reappear on the screen    (even if all seven 
shapes have not been used yet).    At this point you should finish your picture and then 
choose Save from the File menu.

NOTE: If your creativity strikes in the Beginner or Novice skill level, your shapes will 
remain on the screen but will be placed within the left half of the screen and not 
in their current positions.    Their orientation will be the same; you will just have 
to place them in their correct position for your picture.

Each picture file can hold up to 50 pictures.    One way to build a picture file is to open a 
new or existing file with less than 50 pictures, activate the Save Mode option, create 
your new picture, and then choose Save from the File menu.    However, you may want 
to transfer a picture from one file to another.    This can be done using the following 
steps:

1. Open the file which holds the picture you want to transfer (by selecting 
Open... from the File menu).

2. Select the picture to be placed on the screen (right side).

3. Re-create the picture with the shapes (left side of screen).

4. Activate the Save Mode option from the Options Menu.

5. Choose New... from the File menu.

6. Choose Save from the File menu.

7. Select an existing file name where you want to store the picture.    The 
picture will be appended to this file.

Remember, you can not have more than 50 pictures in a single file.



COPYRIGHT/LICENSE AGREEMENT/WARRANTY

TANGAROOsÔ 1.0 Copyright Ó 1993 Stephen A. Deskevich

ALL RIGHTS RESERVED

License Agreement and Warranty Disclaimer

You should carefully read the following terms and conditions before using this 
software.    Use of this software indicates your acceptance of these terms and 
conditions.    If you do not agree with them, do not use the software.

Shareware Version

You are hereby licensed to:    use this Shareware software for a 30-day evaluation 
period; make as many copies of this Shareware software and documentation as you 
wish; give exact copies of the original to anyone; and distribute this Shareware 
software and documentation in its unmodified form via electronic means.    There is no 
charge for any of the above.

You are specifically prohibited from charging, or requesting donations, for any such 
copies, however made; and from distributing the software and/or documentation with 
other products (commercial or otherwise) without prior written permission with one 
exception:    Disk Vendors approved by the Association of Shareware Professionals are 
permitted to redistribute TANGAROOsÔ , subject to the conditions in this license, 
withoutspecific written permission.

Unregistered use of TANGAROOsÔ after the 30-day evaluation period is in violation 
of federal copyright laws.

Evaluation and Registration

This is not free software.    This license allows you to use this software for evaluation 
purposes without charge for a period of 30 days.    If you use this software after the 30-
day evaluation period, a registration fee of $20 is required.    Payments must be in US 
dollars drawn on a U.S. bank, and should be sent to TANgible Software, 721 
Freeman Dr., Concord, NC 28025.

Site licenses are available for school systems and businesses.

When payment is received, you will be sent a registered copy of the latest version of 
TANGAROOsÔ.

One registered copy of TANGAROOsÔ may be dedicated to a single person who 
uses the software on one or more computers or to a single workstation used by 
multiple people.

You may access the registered version of TANGAROOsÔ through a network, 



provided that you have obtained individual licenses for the software covering all 
workstations that will access the software through the network.

Governing Law

This agreement shall be governed by the laws of the State of North Carolina.

Disclaimer of Warranty

THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD "AS IS" AND 
WITHOUT WARRANTIES    OF ANY KIND AS TO PERFORMANCE OF 
MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED 
OR IMPLIED.    THE ENTIRE RISK AS TO THE RESULTS AND PERFORMANCE 
OF THE SOFTWARE IS ASSUMED BY YOU.    BECAUSE OF THE VARIOUS 
HARDWARE AND SOFTWARE ENVIRONMENTS INTO WHICH TANGAROOsÔ 
MAY BE PUT, NO WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS 
OFFERED.

GOOD DATA PROCESSING PROCEDURE DICTATES THAT ANY PROGRAM BE 
THOROUGHLY TESTED WITH NON-CRITICAL DATA BEFORE RELYING ON IT.    
THE USER MUST ASSUME THE ENTIRE RISK OF USING THE PROGRAM. 

TANgible SOFTWARE AND STEPHEN A. DESKEVICH WILL NOT BE LIABLE FOR 
ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, INDIRECT OR SIMILAR DAMAGES 
DUE TO THE LOSS OF DATA, LOSS OF BUSINESS PROFITS, BUSINESS 
INTERRUPTION OR ANY OTHER REASON, EVEN IF TANgible SOFTWARE AND 
STEPHEN A. DESKEVICH HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGES.    IN NO EVENT SHALL TANgible SOFTWARE'S AND/OR STEPHEN A 
DESKEVICH'S LIABILITY FOR ANY DAMAGES EVER EXCEED THE PRICE PAID 
FOR THE LICENSE TO USE THE SOFTWARE, REGUARDLESS OF THE FORM OF 
THE CLAIM.



ORDERING INFORMATION

TANGAROOsÔ 1.0 Registration Form/Invoice

To order, send check or money order with this order form to TANgible Software, 721 
Freeman Dr., Concord, NC 28025. Payments must be in U.S. dollars drawn on a U.S. 
bank.

Any questions about registration options, product details, technical support,    dealer 
pricing, site licenses, etc, should be directed to the address above or by CIS Email to 
Steve Deskevich at 71021,625 or Internet 71021.625@compuserve.com.

Please check one:                             5.25" Disk                             3.5" Disk 

Payment:     Quantity      ____      x        $20.00 ea. = __________

            North Carolina residents add 6% sales tax + __________

TOTAL PAYMENT      __________

MAILING ADDRESS: 

Name:____________________________________________________

Address:_________________________________________________

City/State/Zip Code: ____________________________________

Country/Postal Code: ____________________________________

Telephone: ______________________________________________

Electronic Mail address: ________________________________

Comments: 



FILE MENU COMMANDS

New

This menu command opens a new file in which to store pictures that you create.    A 
dialog box will ask you for the new name.    A default extension of .TAN will be 
assumed if none is given.    Although you can choose any valid DOS name, it is 
recommended that you use the default extension in order to later identify a 
TANGAROOsÔ picture file.

Open...

This menu command opens an existing picture file.    A dialog box will show both a 
file and directory listing which you can use to find the appropriate file.    The file 
listings will assume an extension of .TAN by default.    You can also type the file 
name in the box above the file listing and press the OK button.

NOTE: This menu command only opens the picture file.    To place a picture
on the screen, pull down the Picture menu and click on Select...

Save...

This menu command saves the picture that is currently on the screen to a file.    
There are three restrictions for saving a picture:    1) Save Mode must be turned on, 
2) The picture must be made from all seven shapes, and 3) The file you are saving 
to cannot contain more than 50 pictures.

Close

This menu command closes the current picture file.

Exit

This menu command will exit TANGAROOsÔ.



PICTURE MENU

Select...

This menu command allows you to select a picture from the opened picture file.    A 
dialog box will display the pictures, allowing you to step through the file using the "+" 
and "-" buttons.    Along with the picture, its index number within the file is shown.    
When you find the picture that you want, press the OK button.

NOTE: Before a picture can be selected, you must open a valid picture file
by pulling down the  File menu and clicking on Open... . .

The Delete button is used to delete a picture from the file.    This button is only active 
if TANGAROOsÔ is started with a      /a command line argument (for example, 
TANGAROO.EXE /a). 

NOTE: Once the picture is deleted, it cannot be recalled.

Clear Screen

This menu command clearS the screen by erasing the selected picture and replacing 
all the shapes back onto the shapebar.

NOTE: To erase only the shapes and not the selected picture, see mouse
command erase.



OPTIONS MENU

Skill

This menu command will bring up another menu with three skill levels (expert level is 
the default):

Beginner
1) Shapes can be placed anywhere on the white screen.
2) Shapes can be "dropped" on the selected picture.
3) The selected picture is always in the "show answer" mode (see

below).

Novice
1) Shapes can be placed anywhere on the white screen.
2) Shapes can be "dropped" on the selected picture.
3) The selected picture is shown in black.

Expert
1) Shapes can only be placed on the left side of the screen they

cannot be "dropped" on the selected picture).
2) The selected picture is shown in black on the right of the screen.

NOTE: The skill level can be changed at any point in the game.    However, 
changing the skill level will replace all the shapes back on the
shapebar.

Show Answer

This menu command allows you to see how the selected picture is put together.    
This option is turned off (not checked) by default.

Snap To Shape

This menu command allows you to turn shape-snapping on and off.    This option is 
on (checked) by default.    When snapping is turned on, two shapes will "snap" 
together if they are close enough to each other.    However, only the corners of the 
shapes will snap together.

Sound

This menu option toggles the sound capabilities of TANGAROOsÔ on and off.    You 
must have a sound driver loaded for this option to work.



Save Mode

This menu command is used to activate the save picture capabilities. A newly 
created picture cannot be saved to a file unless this option is turned on (checked).    
When TANGAROOsÔ is in this mode, you cannot select a picture.    Turning this 
option off (not checked) will clear the screen of all shapes and pictures and return 
you to the expert skill level.

NOTE: See Helpful Hints for more information.



FLIP PARALLELOGRAM

This command does not have a menu associated with it.    This command allows you 
to "flip" (i.e., mirror image) the parallellogram shape once it is on the screen.



MOUSE HELP MENU

This menu contains a quick reference to help you use the mouse to manipulate the 
shapes.    This is a reference feature only; there are no selections available within 
this menu.



HELP MENU

Index

This menu option will start the help program and displays a list of topics to view.

Quick Reference

This menu option will start the help program and displays a quick reference guide 
to using the mouse and the menus.

About TANGAROOsÔ 

This menu option will bring up information about the TANGAROOsÔ program 
including the version number and the copyright information.



SELECTING SHAPES

Use the shape-bar        to access the shapes that are used to build 
pictures.    Select a shape by placing the mouse cursor over one of the shape buttons 
and clicking the left mouse button.    This will place the shape on the screen where 
you can drag, rotate, erase, or color the shapes black.

Once a shape has been selected        the shape's button will indicate 
that it cannot be used again.    Therefore, all pictures are made from exactly seven 
shapes.

NOTE: Each shape can only be used once.    You must use all seven shapes to 
create a picture.



DRAGGING SHAPES

Once a shape has been selected and is on the screen, you move it into position by 
dragging.    To drag a shape, do the following:

1) Place the cursor over the shape on the screen.
2) Click and hold the left mouse button.
3) Move the mouse until the shape is where you want it.
4) Release the left mouse button and the shape will be "dropped"

onto the screen.

After the shape has been "dropped", you can drag, rotate, erase, or color the shapes 
black.

If the snap to shape option is checked on the menu, the shape that you are dragging 
and dropping will "snap" to another shape on the screen if they are close enough.



ROTATING SHAPES

To build pictures, it is sometimes necessary to rotate the shapes to get them in the 
correct position.    You can rotate shapes in both clockwise and counter-clockwise 
directions as follows:

Clockwise

1) Place the cursor over the shape on the screen.
2) Click the right mouse button.

Counter-Clockwise

1) Place the cursor over the shape on the screen.
2) Click the left mouse button.

Counter-clockwise rotation may be tricky at first.    It is important to keep the mouse still 
when clicking the left mouse button.

NOTE: In addition to rotating a parallelogram, you may have to flip the shape to 
get it in the right position.



ERASING SHAPES

Sometimes it will be necessary to erase a shape from the screen.    You can erase a 
single shape or all of them at the same time as follows:

Erase Single Shape

1) Place the cursor over the shape on the screen.
2) Hold down the Shift key and click the right mouse button.

Erase All Shapes at Once

1) Hold down the Ctrl key and click the right mouse button.

In both cases, the shape will be erased from the screen and its shape button will be 
active again.    The shape will then have to be selected again before it can be used.



COLORING SHAPES BLACK

When building a picture, it helps to color all the shapes on the screen black to compare 
them to the picture you selected.    This is done by holding down the Shift key and 
clicking the left mouse button.    Shapes can be returned to their original colors by the 
same method.

NOTE: You cannot move the shapes on the screen until you return them to their 
original color).



QUICK REFERENCE GUIDE

Using The Mouse

Select Shape    --    Single click left mouse button with cursor on shape bar

Drag Shape    -- Click and hold left mouse button with cursor on shape 
then move mouse

Rotate Right    --    Single click right mouse button with cursor on shape

Rotate Left    --    Single click left mouse button with cursor on shape

Erase A Shape    --    Hold down shift key then single click right mouse button
with cursor on the shape

Erase All Shapes -- Hold down Ctrl key then single click right mouse button

Color Shapes Black -- Hold down shift key then single click left mouse button
(same action will return shapes to original colors)

Using The Menus

File New    --    Creates a new file to hold pictures that are created    (Alt+F+N)

File Open --    Opens an existing picture file    (Alt+F+O)

File Save --    Saves a picture file    (Alt+F+S)

File Close --    Closes the currently opened picture file    (Alt+F+C)

File Exit --    Exits TANGAROOsÔ     (Alt+F+X)

Picture Select    -- Allows you to select a picture from the currently opened
file    (Alt+P+S)

Picture Clear Screen -- Replaces all shapes to the shape bar and erases the
selected picture from the screen    (Alt+P+C)

Options Skill    -- Allows you to choose skill level    (Alt+O+K)



Options Show Answer    -- Toggles solution viewing on and off    (Alt+O+S)

Options Snap To Shape -- Toggles shape snapping on and off    (Alt+O+N)

Options Sound    -- Toggles sound capabilities on and off    (Alt+O+O)

Options Save Mode    -- When checked, allows you to save a picture to a file
(Alt+O+A)

Flip Parallelogram -- Flips parallelogram shape after it has been selected 
(Alt+L)

Help Index -- Starts help program showing the index of topics    (F1)

Help Quick Reference -- Starts help program showing the quick reference 
(Alt+H+Q)

Help About -- Shows information about    TANGAROOsÔ  (Alt+H+A)




