
License Key Administrator main screen

The License Key Administrator's main screen displays a list of currently installed Rational software licenses and each license's 
status. Click on any column heading (Product, Type, Expiration, and Qty) to sort the licenses according to that column's 
properties.

The buttons at the top of the screen perform the following actions when selected.    Their menu command equivalents follow the 
button information.

Clicking 
the Icon

Does the following Equivalent menu command

 
Invokes the License Administrator Wizard License > License Wizard

 
Invokes the License Key Administrator and displays the License Key 
Certificate Wizard dialog box, enabling you to enter license key 
certificate information

License > Enter a License…

 
Displays the Import License Key(s) dialog box, enabling you to import a 
license key

License > Import License 
Key(s)…

 
Displays the Request Permanent License Key dialog box, enabling you 
to request a permanent license key

License > Request 
Permanent License Key(s)…

 
Displays the Change License Key Count dialog box, enabling you to 
change the license key count for a particular license

License > Change License 
Key Count…

 
Electronically sends a pending, permanent license key request for a 
node-locked or floating license

License > Send Pending 
Request(s)…

 
Displays the standard Windows Print dialog box, enabling you to print a 
license key request. You can fax the printed request to Rational 
Software, or phone Rational Software and provide the information 
contained in the printed request.

License > Print Pending 
Request(s)…

 
Displays the Delete License Key Requests dialog box, enabling you to 
delete all or selected license key requests

License > Delete 
Request(s)…

 
Displays the Company Account Information dialog box, enabling you to 
enter or modify company name and account number information from 
the Rational License Key Certificate

Edit > Account Information

 
Displays the Modify User Contact Information dialog box, enabling you 
to enter or modify contact information for the person who will receive 
the license keys

Edit > User Contact 
Information

N/A Displays the Modify Renewal Contact Information dialog box, enabling 
you to enter or modify contact information for the person Rational 
Software should contact with renewal and maintenance information

Edit > Renewal Contact 
Information

 
Displays the Service Configuration dialog box, enabling you to locate 
the license key files and specify the license key source you want to use

Settings > Service 
Configuration

 
Displays the Proxy Settings dialog box, enabling you to specify whether 
a proxy is in use and the relevant host information

Settings > Proxy 
Configuration

 
Displays the version information for Rational's License Key 
Administrator

Help > About Rational License 
Key Administrator

 
Displays the License Key Administrator Help for the main screen. Click 
the button, then click on the main screen.

N/A

N/A Displays the License Key Administrator online help. Help > Contents and Index

N/A Opens the Rational Web site (if you are online) Help > Rational on the Web

N/A Changes the material displayed in the License Key Administrator's main 
window, allowing you to see licenses according to the following criteria:

Show only valid licenses
Show floating licenses
Show node-locked licenses
Show server licenses

View > Show > Invalid and 
Expired Licenses
View > Show > Floating 
Licenses
View > Show > Node Locked 
Licenses
View > Show > Served 
Licenses

N/A Specifies whether you want to receive warnings about license key 
expirations. 

Checkout > Display Expiration 
Warnings 

N/A Specifies that an application request a product license key first rather 
than a Rational Suite license.

Checkout > License Order 
(Suite Map)





Obtain a License with the License Key Administrator Wizard

The License Key Administrator Wizard takes you through the steps necessary to obtain a license for your machine. The first 
dialog box in the Wizard, What action do you want to take?, provides the following choices:

· Point to a FLEXlm License Server to get my licenses 

· Enter the data from a Rational Software License Certificate to install that license on this machine 

· Request a license from Rational Software via Internet Connection, E-mail, or FAX 

· Import a Rational License File 

You can keep the Wizard from appearing every time you start the License Administrator by selecting the Don't show this wizard 
on startup again. I'll use the toolbar to activate it. checkbox near the bottom of the dialog box.

Select Finish at the end of each succession of dialog boxes in the Wizard to complete your task.

Access this dialog box by selecting either License > License Wizard or the Wizard button on the License Key Administrator 
button bar.



Enter License Information

Use the series of License Key Certificate Wizard dialog boxes to enter license key certificate information. 

1. In the first dialog box, choose either a Temporary License Key, a Term License Agreement (TLA) Key, or a 
Permanent License Key, depending on what is written on your license certificate.

2. In the second dialog box, choose the type of license you are installing, a Node-Locked License Key or a Floating 
License Key.

3. In the third dialog box, choose the Product and Version you are licensing and enter:

· The License Key

· The Issued Date (if you are installing either a TLA or permanent key)

· The Expiration Date (if you are installing a Temporary or TLA license key)

· The number of key Units you want (if you are installing a floating license)

4. Click Finish to complete your task.

Access this dialog box by selecting either License > Enter a License or the Enter button on the License Key Administrator 
button bar.



Import License Key(s) dialog box

Use this dialog box to import a license key update file.

In the Import License Key(s) dialog box, select the .upd file and then click Open. 

Access this dialog box by selecting either License > Import License Key(s) or the Import button on the License Key 
Administrator button bar.



Request Permanent License Key dialog box

Use this dialog box to request either node-locked or floating permanent license keys. The Rational License Key Administrator 
updates the License Administrator's main screen to indicate pending requests for permanent license keys and creates a license 
request file, rational_request.dat and rational_request.dat.txt, located by default in \Program Files\Rational\Common.

Select this option To request

Permanent version of 
ALL Temporary License 
Keys

Permanent license keys for all entries listed.

Permanent version of 
SELECTED Temporary 
License Keys

Permanent license keys for entries currently 
selected.

Select from list A permanent license key for a Rational 
product. Use this option if you have not 
previously installed temporary license keys.

Choosing the Select from list option activates the Node-locked and Floating options and the product drop-down list box.    
Select either Node-locked or Floating and specify the product.

If you are requesting permanent license keys for all or selected temporary license keys, the Rational License Administrator 
activates the User Count text box. Enter the permanent license key count.

To send your license key request to Rational electronically, select Send all requests to Rational immediately and then click 
OK. The Rational License Key Administrator sends all pending requests.

To fax or phone your license key request to Rational, deselect Send all requests to Rational immediately and then click OK. 
Select License > Print Pending Request(s) and then either fax the printed request to Rational Software, or phone Rational 
Software and provide the information contained in the printed request. For information about contacting Rational Software, see 
the printed request or click here.

Notes:

· You can request license keys only for products that you have purchased.

· To delete pending requests, right-click one or more pending requests and select License > Delete Request(s). Then select 
the appropriate option in the Delete License Key Requests dialog box. You cannot delete requests that you have already 
sent to Rational Software.

· You can also change the number of users that use a floating license. For more information, click here.

Access this dialog box by selecting either License > Request Permanent License Key(s) or the Request button on the 
License Key Administrator button bar.



Change License Key Count dialog box

Use this dialog box to change the number of floating licenses available from a license server system. You can increase or 
decrease the floating license key count to balance your licensing loads among different server systems. By reducing your floating 
license key count to zero, you can then uninstall your license server software and install the software on a new system.

If you are moving your license server software to another system, remove the license keys from your first system before 
removing your licensed software or installing software on your new system.

Select Yes to remove the selected license key from the machine.    Select the check box to immediately send your request that 
Rational remove the license key.

Access this dialog box by selecting either License > Change License Key Count or the Change button on the License Key 
Administrator button bar.



Delete License Key Requests dialog box

Use this dialog box to delete all or selected license key requests. To delete pending requests, right-click one or more pending 
requests and select Delete requests from the shortcut menu. Then select the appropriate option in the Delete License Key 
Requests dialog box and click OK. 

You cannot delete requests that you have already sent to Rational Software.

Access this dialog box by selecting either License > Delete Request(s) or the Delete button on the License Key Administrator 
button bar.



Company Account Information dialog box

Use the Company Account Information dialog box to enter the account information for your license key.

· Enter your company's name in the Company Name box (required).

· Enter your primary account number in the Rational Account Number (Primary) box. This number appears on the License 
Key Certificate for the Rational Software product you purchased (required).

· Leave the Rational Account Number (Secondary) box blank unless Licensing Support instructs you otherwise.

Access this dialog box by selecting either Edit > Account Information or the Edit Account Information button on the License 
Key Administrator button bar.



Modify User Contact Information dialog box

Use the Modify User Contact Information dialog box to supply information about the person who should receive permanent 
license keys or TLA license keys from Rational Software (user data); do this when you request a license key.

Provide the requested information when entering or editing user contact data (required information appears here in bold): First 
Name, Last Name, Title, Company Name, Country, Phone, EMail Address or Fax, Postal Address, City, State/Province, 
ZIP/Postal Code.

Notes:

· You must enter an email address if you want Rational Software to email license keys.

· State/Province and ZIP/Postal Code are not required outside of the USA.

Access this dialog box by selecting either Edit > User Contact Information or the Edit Contact Information button on the 
License Key Administrator button bar.



Modify Renewal Contact Information dialog box

Use the Modify Renewal Contact Information dialog box to supply information about the person Rational Software should 
contact with renewal and maintenance information (renewal data).

Provide the requested information in the following fields as you wish: First Name, Last Name, Title, Company Name, Country, 
Phone, EMail Address, Fax, Postal Address, City, State/Province, ZIP/Postal Code.

Notes:

· You must enter an email address if you want Rational Software to email license keys.

· State/Province and ZIP/Postal Code are not required outside of the USA.

· There are no required fields when entering renewal data.

Access this dialog box by selecting Edit > Renewal Contact Information.



Service Configuration dialog box

Use the Service Configuration dialog box to specify the locations of license key files, the license key source, and, for users of a 
floating license, the license server system where the license key is installed, and specific port numbers for the license manager 
and vendor daemons.

Access this dialog box by selecting either Settings > Service Configuration or the Service Configuration button on the 
License Key Administrator button bar.

These are the controls in the dialog box:

License Key File 

Select New File 

License Key File Location 

Use Node-Locked Key 

Use single server 

Port 

Show Licenses 

Use redundant servers 

Set Up Servers 

A word about Advanced License Server Options

Normally, port numbers are not pre-assigned so that the system may assign them dynamically to make best use of resources. 
However, in specialized server situations, such as communicating through a firewall, you will need to specify the port numbers so 
that the same ones are always used. In such a case, a license request would be routed to the license manager daemon port 
(specified in lmgrd Port), which passes the request to the application using the Rational vendor daemon port (specified in 
Rational Vendor Port). 

For an overview of the license manager and vendor daemons, see the section "The License Manager Daemon and the Vendor 
Daemon" in the FLEXlm Features and Configuration chapter of Administering Licenses for Rational Software.

The following text boxes are used together. The Rational_redirect.dat file, located by default in \Program 
Files\Rational\Common, stores the port information along with the name of the license server system.

lmgrd Port 

Rational Vendor Port 



Proxy Settings dialog box

Use the Proxy Settings dialog box to specify either a normal server or a proxy server for the location of the license files, as well 
as the local and target host information, if applicable.

These are the controls in the dialog box:

Normal and Proxy buttons 

Redundant Servers and Redundant Servers Proxy buttons 

Local Host Name, Local Host ID 

Target Host Name, Target Host ID 

Access this dialog box by selecting either Settings > Proxy Configuration or the Proxy button on the License Key 
Administrator button bar.



Use the License Key File box to choose the kind of license key file you want to work with:

· Floating - Permanent

· Floating - Temporary

· Node Locked - Permanent

· Node Locked - Temporary



Use the Select New File button to choose a different license file than the one displayed in License Key Files Location. When you 
select this button, the standard Windows file selection dialog box will appear.



The License Key File Location text box displays the system location of the license key file.



Use the Use Node-Locked Key (on local machine) option to select a node-locked key as your license source. If your system is 
configured as a server, using a node-locked key is your only option. However, you can mix node-locked and floating licenses on 
a non-server machine.



Select the Use single server option to use a floating license on a single server as your license source, then enter the name of 
the license server in the text box. 

You can also indicate a port number if you wish in the Port box. To see the list of floating licenses, click Show Licenses.

You can use the single server option only if your system is NOT configured as a server. However, you CAN mix node-locked and 
floating licenses on a non-server machine.



Use the Port text box to enter a port number if you wish.



If you have selected Use single server and specified a license server name, you can review the available license keys on the 
license server by selecting the Show Licenses button. This displays the Server Licenses dialog box, which contains 
information about the single server licenses currently available. You cannot modify information in this dialog box.



Select the Use redundant servers option to use three servers (primary, secondary, and backup) for your license source. To set 
up the servers, click Set Up Servers to access the Set up Redundant Servers dialog box.



Selecting the Set Up Servers button displays the Set up Redundant Servers dialog box. To set up the servers:

1. Enter the names of the Primary, Secondary, and Backup servers.

2. Enter a port number if you wish.

See the licenses associated with each server by clicking Show Primary Licenses, Show Secondary Licenses, and Show 
Backup Licenses to display the Server Licenses dialog box.



The Display Expiration Warnings menu selection specifies whether you want to receive warnings about license key 
expirations. Toggle the menu item to enable or disable expiration warnings. 

Note:
· It is not recommended that you routinely disable expiration warnings.    This should only be done when batch processes 

might not run properly with license expiration messages popping up.



Modify Suite Map dialog box

If you have license keys installed for both a Rational product and a Rational Suite edition, the licensing software, by default, 
requests the Rational Suite key first. You can specify that an application request a product license key first by selecting the 
Modify Suite Map menu selection. Doing so displays the Modify Suite Map dialog box.

In the Modify Suite Map dialog box, select the product(s) that will try to acquire a product-level license before trying to acquire a 
suite-level license upon startup. 

To revert to the default settings for a product, clear the check boxes for all selections.



Select Normal to specify that a normal server setup will be used (the default) or select Proxy to specify that a proxy server setup 
will be used. (Proxy means that, if this system is connected to the Internet, you can request license keys for a system that is not 
connected to the Internet.) These options can be used when your system is configured either as a client or a server.



Select Redundant Servers to specify that a normal redundant server setup will be used or select Redundant Servers¾Proxy 
to specify that a proxy redundant server setup will be used. (Proxy means that, if this system is connected to the Internet, you 
can request license keys for a system that is not connected to the Internet.)    These options can be used only when your system 
is configured as a server.



Use Local Host Name and Local Host ID to enter the host name and ID of the local system on which the license key is 
installed. These fields are active only when you are running in proxy mode.



Use Target Host Name and Target Host ID to enter the host name and ID of the remote system on which the license key is 
installed. These fields are active only when you are using redundant servers.



Glossary

ANY-HOST 

Evaluation Key 

Floating License 

GLOBEtrotter FLEXlm Server 

License 

License Key 

License Key Administrator 

License Key Code 

License Type 

Node-Locked License 

Permanent License Key 

Temporary Key Code 

Temporary License Key 

Temporary License Key Certificate 

Term License Agreements (TLAs) 



A license key issued for ANY HOST will run on any system, and is not tied to the customer's system ID.



A temporary key that lets a customer use and evaluate Rational software for a fixed period of time. The product Business Unit 
determines the duration of the Evaluation Key. Evaluation Keys can be node-locked or floating. Evaluation Keys are coordinated 
through the Rational Sales team and will run on any host.



A license type that requires a license server. The license server manages a pool of floating license keys. Rational client 
applications contact the license server when the software is executed. Multiple clients can share the pool of floating licenses; one 
license is granted per client per product. 



Software license manager for Windows, NT, UNIX, Java, and VMS. Detailed information on GLOBEtrotter and FLEXlm can be 
found at http://www.globetrotter.com 



A legal right to use a product. A customer receives a license when they purchase the product. However, they need a license key 
to use a Rational product.



Generic term used in this document to describe keys that enable licenses on a customer system. The types of License Keys are 
floating and node-locked.



A program written by Rational Software, which provides a customer interface to Rational's Licensing system. Starting with the 
release of Rational Suite 1.0 and associated point products, the License Key Administrator is installed whenever a Rational 
software product is installed on a Windows system. For hosting floating licenses, the License Key Administrator is installed when 
the FLEXlm server is installed on a License Server system.



An encrypted code used to enforce a license agreement.



The valid types of licenses are temporary, permanent, evaluation, and Term License Agreement (TLA) licenses.



A type of license key that is specific to a particular system. A node-locked license key allows the software to be used only on the 
host for which it is licensed.



A license issued to a customer for running Rational products. Permanent licenses are specific to a product and system. 
Permanent keys no not expiration dates and allows the customer to use the software indefinitely. Permanent keys can be node-
locked or floating. 



A short-term license key that enables a customer run Rational software products without registering a host. Temporary License 
Keys can be node-locked or floating and can be used on any system for 60 days. Node-locked temporary keys are installed on a 
client system. Floating temporary keys are installed on a license server. 



The FLEXlm encrypted code that temporarily lets a customer run a particular Rational product using a temporary key. 



A piece of paper or electronic file that contains information a customer needs to install a temporary key. The temporary key 
allows the customer to begin using Rational software. The Temporary License Key Certificate is shipped to the customer with the 
software installation media.



Variations of a Permanent Key. TLAs are issued to a site to let their employees use Rational software for a negotiated period of 
time. TLAs are issued by Rational Sales and have an expiration date.



About Rational Software Licensing

Related Topics 

Rational Software offers two types of licenses: node-locked and floating. The product you purchased includes a node-locked or a 
floating license.

Typically, you install a temporary license key to start using the purchased product. You then request and install a permanent 
license key or, if you purchased a Term License Agreement (TLA), a TLA license key, to ensure continued use of the product. 
The temporary license key and other licensing information are available from the Temporary License Key Certificate included in 
the product packaging.

Rational Software makes it easy to work with licenses by providing the Rational License Key Administrator for installing and 
requesting license keys and, for system administrators who manage floating licenses, GLOBEtrotter FLEXlm License Manager 
for configuring license servers. 

To get started:

· For node-locked licenses, click  for the steps you follow to install your temporary license key. To learn more about node-
locked licenses, click 

· For floating licenses, if you’re a system administrator click  for the steps you follow to install your temporary license key. 
If you are a user of a floating license, click 

 for the steps you follow to specify the license server system where your system administrator installed the temporary license 
key. To learn more about floating licenses, click 

Important:
· The Rational Solutions for Windows install disk includes many Rational Software products. However, you can use the 

temporary license key available from the Temporary License Key Certificate to run only the product you purchased. If you 
want to install and evaluate other Rational Software products that are available on the install disk but that you have not 
purchased, please contact Rational Software. For more information, click here.



 How floating licenses work

 Related Topics

A floating license lets a specific number of users concurrently run a Rational Software product on their systems. Typically, a 
system administrator installs a floating license on a license server system. The system administrator uses the Rational License 
Key Administrator to install a license key and to specify the number of users, and GLOBEtrotter FLEXlm License Manager to 
configure and start the license server. 

The users of a floating license use the Rational License Key Administrator to specify the name of the license server system 
where the system administrator installed the floating license. This lets them run the purchased Rational Software product on their 
systems.

To work with a floating license if you are a system administrator:

1. Install the GLOBEtrotter FLEXlm License Manager (available on the Rational Solutions for Windows install disk) on the 
license server system. The Rational License Key Administrator is installed automatically.

2. Install the temporary license key to enable users to run the product. The license key and other information are available 
from the Temporary License Key Certificate. Remember to tell your users the hostname (displayed in the Proxy Settings 
dialog box of the Rational License Key Administrator) of the license server system. For more information about installing the 

temporary license key, click 

3. Configure and start the license server. For more information, click 

4. Request a permanent license key. For more information, click 

5. Install a permanent license key or a TLA license key. For more information, click 

To work with a floating license if you are a user:

1. Install the purchased Rational Software product on your system. The Rational License Key Administrator is installed 
automatically.

2. Use the Rational License Key Administrator to specify the hostname of the license server system where your system 

administrator installed the floating license. For more information, click 

3. Run the product.

Notes:
· System administrators can request a permanent license key without first installing a temporary key. However, users cannot 

use the product until a license key is installed. To use the product immediately, install the temporary license key and then 
request the permanent license key.

· The FLEXlm License Manager compares the current time on the license server system with the current system time of each 
floating license user. If the two times differ by more than 24 hours, the license key will not work and the user will be unable 
to run the purchased Rational Software product.

· For more information about FLEXlm licensing, click http://www.globetrotter.com. 

· The GLOBEtrotter licensing tool, Lmtools, is installed at the same time as the FLEXlm License Manager. Lmtools provides 
diagnostic and other information for managing floating licenses. For detailed information about using Lmtools, click 
http://www.globetrotter.com/manual.htm and read section 6.13.



 Installing a temporary floating license key

 Related Topics

Typically, a system administrator installs the temporary license key for a floating license on a license server system, using the 
Rational License Key Administrator. 

You must have your Temporary License Key Certificate before you install your temporary license keys.

To install a temporary floating license key:

1. Select Globetrotter FLEXlm License Server > License Key Administrator from the Start > Programs menu.

2. Select either the Enter button or License > Enter a License. 

3. On the License Key Certificate Wizard dialog box, select Temporary License Key. 

4. In the second wizard screen, select Floating License Key. 

5. In the next wizard screen, provide the requested information (the product, expiration date, license key, and quantity are 
available from the Temporary License Key Certificate) and then click Finish. The Rational License Key Administrator 
displays the temporary license key and creates the license file Rational_server_temp.dat, located by default in \Program 
Files\Rational\Common.

After you install the temporary license key, you must configure and start the license server using the GLOBEtrotter FLEXlm 

License Manager on the license server system. For more information, click .

Before your users can run the purchased product, they must use the Rational License Key Administrator to specify the hostname 
of the license server system where you installed the temporary license key. For more information about what users must do, click 

. You can copy the text from that topic and email it to your users with the name of the license server system, so they will know 
what they need to do before they can use the product.

Notes:
· To ensure uninterrupted use of the product, request a permanent license key as soon as you have installed the temporary 

license key. For more information, click 

· The FLEXlm License Manager compares the current time on the license server system with the current system time of each 
floating license user. If the two times differ by more than 24 hours, the license key will not work and the user will be unable 
to run the purchased Rational Software product.



 Specifying the license server

 Related Topics

1. If you are one of multiple users of a floating license, you must use the Rational License Key Administrator to specify the 
hostname of the license server system where your system administrator installed the floating license key. You must do this 
before you can run the product on your system. 

2. Contact your system administrator for the hostname of the license server system.

3. Select Rational Productname > Rational License Key Administrator from the Start > Programs menu.

4. Select either the Server button or Settings > Service Configuration.

5. On the Service Configuration dialog box, select Use Single Server and then specify the hostname of the license server 
system.

6. Click OK. The Rational License Key Administrator creates the file Rational_redirect.dat, located by default in \Program 
Files\Rational\Common, that contains the name of the license server system.

Note:

· The FLEXlm License Manager compares the current time on the license server system with the current system time of 
each floating license user. If the two times differ by more than 24 hours, the license key will not work and the user will be 
unable to run the purchased Rational Software product.



 Requesting a permanent floating license key

 Related Topics

1. Select Globetrotter FLEXlm License Server > License Key Administrator from the Start > Programs menu.

2. Select either the Edit Account Information  button or Edit > Account Information  to display the Company Account 
Information dialog box and enter information in the Company Name and Rational Account Number (Primary) fields. The 
primary account number is available from the Temporary License Key Certificate. 

3. Select either the Edit Contact Information  button or Edit > User Contact Information     to display the Modify User 
Contact Information dialog box and enter information in the following fields:    First Name, Last Name, Title, Company 
Name, Country, Phone, EMail Address or Fax, Postal Address, City, State/Province, and ZIP/Postal Code. 
(State/Province and ZIP/Postal Code are not required outside of the USA.) 

If you want to electronically request a permanent license key, you must provide an email address.

4. Select either the Request button or License > Request Permanent License Key(s). 

5. In the Request Permanent License Keys dialog box, select an option.

Select this option To request

Permanent version of ALL 
Temporary License Keys

Permanent license keys for all entries listed.

Permanent version of 
SELECTED Temporary License 
Keys

Permanent license keys for entries currently 
selected.

Select from list A permanent license key for a Rational 
product. Use this option if you have not 
previously installed temporary license keys.

· Choosing the Select from list option activates the Node-locked and Floating options and the product drop-down list 
box.    Select Floating and specify the product.

· If you are requesting floating license keys, the Rational License Administrator activates the User Count text box. Enter 
the license key count.

6. To send your license key request to Rational electronically, select Send all requests to Rational immediately. The 
Rational License Key Administrator sends all pending requests.

To fax or phone your license key request to Rational, deselect Send all requests to Rational immediately. Select License 
> Print Pending Request(s) and then either fax the printed request to Rational Software, or phone Rational Software and 
provide the information contained in the printed request. 

7. Click OK. The Rational License Key Administrator updates the main screen to indicate pending requests for permanent 
license keys and creates a license request file, rational_request.dat and rational_request.dat.txt, located by default in 
\Program Files\Rational\Common.

Notes:
· You can request license keys only for products that you have purchased.

· To delete pending requests, either select the Delete button, select License > Delete Request(s), or right-click one or more 
pending requests and select Delete requests from the shortcut menu. Then select the appropriate option in the Delete 
License Key Requests dialog box. You cannot delete requests that you have already sent to Rational Software.

· You can also change the number of users that use a floating license. For more information, click 



 Installing a permanent or TLA floating license key

 Related Topics

Typically, a system administrator installs a permanent license key or a TLA license key for a floating license on a license server 
system, using the Rational License Key Administrator. 

If you received a license key update file (.upd) from Rational Software, you can import the file to automatically install the 
permanent or TLA license key. Otherwise, you can manually enter the license key using information provided by Rational 
Software.

To import a license key update file:

1. Select Globetrotter FLEXlm License Server > License Key Administrator from the Start > Programs menu.

2. Select either the Import button or License > Import License Key(s).

3. On the Import License Keys dialog box, find the .upd file and select Open. The Rational License Key Administrator then 
updates the license key information and copies the .upd file to the license file Rational_server_perm.dat, located by default 
in \Program Files\Rational\Common.

4. Click OK.

To enter the license key:

1. Select Globetrotter FLEXlm License Server > License Key Administrator from the Start > Programs menu.

2. Select either the Enter button or License > Enter a License. 

3. On the License Key Certificate Wizard dialog box, select Permanent License Key or Term License Agreement (TLA) 
Key.

4. On the second wizard screen, select Floating License Key.

5. On the next wizard screen, provide the requested information (the product, issued date, license key, quantity, and expiration 
date for a TLA license key are available from the information you received from Rational Software) and then click Finish. 
The Rational License Key Administrator then updates the license key information and creates the license file 
Rational_server_perm.dat, located by default in \Program Files\Rational\Common.

Important:

After you install the permanent or TLA license key, you must use the GLOBEtrotter FLEXlm License Manager on the license 

server system to configure the license server to use the license file Rational_server_perm.dat. For more information, click 
Notes:

· If your email program supports launching programs from file attachments, you can also import a license key update file by 
double-clicking the .upd attachment in the email notification you received from Rational Software. Otherwise, save the file 
attachment to any folder and then double-click the saved .upd file. In the Import License Key(s) dialog box, select the .upd 
file and then click Open.

· The license key update file contains the new license key, as well as information for existing licenses already installed on the 
license server system. When you import the license key update file, Rational License Key Administrator automatically 
replaces the existing license file with the update file.

· The GLOBEtrotter FLEXlm License Manager compares the current time on the license server system with the current 
system time of each floating license user. If the two times differ by more than 24 hours, the license key will not work and the 
user will be unable to run the purchased Rational Software product.



 Configuring and starting the license server

 Related Topics

After you install a floating license key, you must configure and start the license server using the GLOBEtrotter FLEXlm License 
Manager. 

1. Double-click the FLEXlm License Manager icon in the Windows Control Panel.

2. In the Setup tab, specify the location of the following files (located by default in \Program Files\Rational\Common):

· The license server file, Lmgrd.exe

· The license file (Rational_server_temp.dat for temporary license keys, or Rational_server_perm.dat for permanent 
license keys or TLA license keys)

· The license debug log file, Debug.log

3. To start the license server as a Windows NT system service, select Use NT Services. You can also click Start Server at 
Power-Up to automatically start the license server. Otherwise, you must start the server manually (click Start in the Control 
tab and wait 15 to 30 seconds for the server to start) whenever you restart the license server system.

4. Click OK.



 Requesting to change a floating license key count

Related Topics 

Note the following regarding changing the number of floating licenses available from a license server system: 

· You can increase or decrease the floating license key count to balance your licensing loads among different server 
systems. 

· By reducing your floating license key count to zero, you can then uninstall your license server software and install the 
software on a new system.

If you are moving your license server software to another system, remove the license keys from your first system before 
removing your licensed software or installing software on your new system.

Select Globetrotter FLEXlm License Server > License Key Administrator from the Start > Programs menu.

1. On the License Key Administrator's main screen, select the permanent license key or TLA license key for which you want to 
change the number of users.

2. Select either the Change button or License > Change License Key Count.

3. In the dialog box, select an option:

Select this option To

Add Additional License Keys Display the Add Additional License Key(s) 
dialog box to increase the number of users 
that can use a floating license

Remove License Keys Display the Remove License Key(s) dialog 
box to decrease the number of users that can 
use a floating license

4. Specify the number of users (key count) you are adding or removing. The Rational License Key Administrator automatically 
recalculates the total.

5. Click OK. The Rational License Key Administrator updates the main screen's display to indicate the pending request.

6. Contact Rational Software with your request:

· To send your request electronically, select either the Select button or License > Send Pending Request(s) and then 
click OK. The Rational License Key Administrator sends all pending requests.

· To fax or phone your request, select either the Print button or License > Print Pending Request(s) and then either 
fax the printed request to Rational Software, or phone Rational Software and provide the information contained in the 

printed request. Information about contacting Rational Software is included in the printed request, or click 

When you receive the license key update file (.upd) from Rational Software, you must import the file to complete changing the 

number of users. For more information, click 
Notes:

· If you decrease the key count, the difference is credited to your account and you can use the keys again at a later date so 
other users can run the purchased product. 

· To delete pending requests, right-click one or more pending requests and select Delete requests from the shortcut menu, 
and then select the appropriate option in the Delete License Key Requests dialog box. You cannot delete requests that you 
have already sent to Rational Software.



 How node-locked licenses work

 Related Topics

A node-locked license lets a single user run a Rational Software product on a single system. The user installs a license key on 
the system, using the Rational License Key Administrator. A node-locked license cannot be installed on a license server system.

To work with a node-locked license:

1. Key Administrator is installed automatically.

2. Install a temporary license key. The license key and other information are available from the Temporary License Key 

Certificate. For more information, click 

3. Request a permanent license key. For more information, click 

4. Install a permanent license key or a TLA license key. For more information, click 

5. Run the product.

Note:

· You are not required to install a temporary license key; instead, you can directly request a permanent license key. However, 
you cannot use the product until a license key is installed. To use the product immediately, install the temporary license key 
and then request the permanent license key.



 Installing a temporary node-locked license key

 Related Topics

1. Select Rational Productname > License Key Administrator from the Start >Programs menu.

2. Select either the Enter button or License > Enter a License. 

3. On the License Key Certificate Wizard dialog box, select Temporary License Key. 

4. On the second wizard screen, select Node-Locked License Key. 

5. On the next wizard screen, provide the requested information (the product, expiration date, and license key are available 
from the Temporary License Key Certificate) and then click Finish. The Rational License Key Administrator displays the 
temporary license key and creates the license file Rational_server_temp.dat, located by default in \Program 
Files\Rational\Common.

Note:
· To ensure uninterrupted use of the product, request a permanent license key as soon as you install the temporary license 

key. For more information, click 



 Requesting a permanent node-locked license key

 Related Topics

1. Select Rational Productname > License Key Administrator from the Start menu.

2. Select either the Edit Account Information  button or Edit > Account Information  to display the Company Account 
Information dialog box and enter information in the Company Name and Rational Account Number (Primary) fields. The 
primary account number is available from the Temporary License Key Certificate. 

3. Select either the Edit Account Information  button or Edit > User Contact Information     to display the Modify User 
Contact Information dialog box and enter information in the following fields:    First Name, Last Name, Title, Company 
Name, Country, Phone, EMail Address or Fax, Postal Address, City, State/Province, and ZIP/Postal Code. 
(State/Province and ZIP/Postal Code are not required outside of the USA.) 

4. If you want to electronically request a permanent license key, you must provide an email address.

5. Select either the Request button or License > Request Permanent License Key(s). 

6. In the Request Permanent License Keys dialog box, select an option.

Select this option To request

Permanent version of ALL 
Temporary License Keys

Permanent license keys for all entries listed.

Permanent version of 
SELECTED Temporary License 
Keys

Permanent license keys for entries currently 
selected.

Select from list A permanent license key for a Rational 
product. Use this option if you have not 
previously installed temporary license keys.

7. Choosing the Select from list option activates the Node-locked and Floating options and the product drop-down list box. 
Select Node-locked and specify the product.

· To send your license key request to Rational electronically, select Send all requests to Rational immediately. The 
Rational License Key Administrator sends all pending requests.

· To fax or phone your license key request to Rational, deselect Send all requests to Rational immediately. Select 
License > Print Pending Request(s) and then either fax the printed request to Rational Software, or phone Rational 
Software and provide the information contained in the printed request. 

8. Click OK. The Rational License Key Administrator updates the main screen to indicate pending requests for permanent 
license keys and creates a license request file, rational_request.dat and rational_request.dat.txt, located by default in 
\Program Files\Rational\Common.

Notes:
· You can request license keys only for products that you have purchased.

· To delete pending requests, either select the Delete button, select License > Delete Request(s), or right-click one or more 
pending requests and select Delete requests from the shortcut menu. Then select the appropriate option in the Delete 
License Key Requests dialog box. You cannot delete requests that you have already sent to Rational Software.

· You can also remove a node-locked license key. For more information, click 



 Installing a permanent or TLA node-locked license key

 Related Topics

If you received a license key update file (.upd) from Rational Software, you can import the file to automatically install the 
permanent license key or TLA license key. Otherwise, you can manually install the license key.

To import a license key update file:

1. Select Globetrotter FLEXlm License Server > License Key Administrator from the Start > Programs menu.

2. Select either the Import button or License > Import License Key(s).

3. On the Import License Keys dialog box, find the .upd file and select Open. The Rational License Key Administrator then 
updates the license key information and copies the .upd file to the license file Rational_server_perm.dat, located by 
default in \Program Files\Rational\Common.

4. Click OK.

To enter the license key:

1. Select Globetrotter FLEXlm License Server > License Key Administrator from the Start > Programs menu.

2. Select either the Enter button or License > Enter a License. 

3. On the License Key Certificate Wizard dialog box, select Permanent License Key or Term License Agreement (TLA) 
Key.

4. On the second wizard screen, select Node-Locked License Key.

5. On the next wizard screen, provide the requested information (the product, issue date, license key, and expiration date for a 
TLA license key are available from the information you received from Rational Software) and then click Finish. The Rational 
License Key Administrator then updates the license key information and creates the license file Rational_server_perm.dat, 
located by default in \Program Files\Rational\Common.

Notes:

· If your email program supports launching programs from file attachments, you can also import a license key update file by 
double-clicking the .upd attachment in the email notification you received from Rational Software. Otherwise, save the file 
attachment to any folder and then double-click the saved .upd file. In the Import License Key(s) dialog box, select the .upd 
file and then click Open.

· The license key update file contains the new license key, as well as information for existing licenses you have already 
installed. When you import the license key update file, Rational License Key Administrator automatically replaces the 
existing license file with the update file.



 Requesting to remove a permanent or TLA node-locked license key

 Related Topics

1. Select Rational Productname > Rational License Key Administrator from the Start > Programs menu.

2. On the License Key Administrator's main screen, select the permanent license key or TLA license key, which you want to 
remove.

3. Select either the Change button or License > Change License Key Count.

4. In the Change License Key Count dialog box, select Yes . The Rational License Key Administrator updates the main 
screen's display to indicate the pending request.

5. Contact Rational Software with your request:

· To send your request electronically, select either the Select button or License > Send Pending Request(s) and then 
click OK. The Rational License Key Administrator sends all pending requests.

· To fax or phone your request, select either the Print button or License > Print Pending Request(s) and then either 
fax the printed request to Rational Software, or phone Rational Software and provide the information contained in the 

printed request. Information about contacting Rational Software is included in the printed request, or click 

When you receive the license key update file (.upd) from Rational Software, you must import the file to complete changing the 

number of users. For more information, click 
Notes:

· If you decrease the key count, the difference is credited to your account and you can use the keys again at a later date so 
other users can run the purchased product. 

· To delete pending requests, right-click one or more pending requests and select Delete requests from the shortcut menu, 
and then select the appropriate option in the Delete License Key Requests dialog box. You cannot delete requests that you 
have already sent to Rational Software.



 Importing a license key update file (.upd)

 Related Topics

1. Select Globetrotter FLEXlm License Server > License Key Administrator from the Start > Programs menu.

2. Select either the Import button or License > Import License Key(s).

3. On the Import License Keys dialog box, find the .upd file and select Open. The Rational License Key Administrator then 
updates the license key information and copies the .upd file to the license file Rational_server_perm.dat, located by 
default in \Program Files\Rational\Common.

4. Click OK.

Note:
· You can also import a license key update file by selecting License > Import License Key(s) in the Rational License Key 

Administrator. In the Import License Key(s) dialog box, select the .upd file and then click Open. 



 Contacting Rational Software Licensing Support

If you have questions regarding the licensing of your Rational Software products, please contact the appropriate Licensing 
Support office.

North America and
Latin America

phone: (800) 728-1212
fax: (781) 676-2460
email: lic_americas@rational.com 

Europe
(includes Israel 
and Africa)

phone: +31 20 4546 200
fax: +31 20 4546 202
email: lic_europe@rational.com 

Japan phone: +612 9419 0111
fax: +612 9419 0123
email: lic_apac@rational.com 

For more information:

· Check the Rational Software Web site for new licensing information and capabilities. Click http://www.rational.com/.

· For more information about Rational Solutions for Windows, click http://www.rational.com/rs.

· For general technical support information, click http://www.rational.com/support.

· For information about Rational Software and other Rational Software products, click http://www.rational.com/.



 Contacting Rational Software Technical Publications

 Related Topics

If you have comments or suggestions about the Rational Software Licensing online Help, please email your feedback to 
techpubs@rational.com. Thank you.

For licensing questions or problems, please contact Licensing Support. For more information, click 



 How do I work with an evaluation license key?

 Related Topics

If you received an evaluation copy of a Rational Software product, you also received an evaluation license key. This license key 
lets you run the product for a limited time for evaluation purposes. 

To work with an evaluation license key, follow the instructions for working with a temporary license key for a node-locked license.



 How do I work with an emergency license key?

 Related Topics

If a license key becomes corrupt or cannot be used, you can contact Rational Software to request an emergency license key. 
This license key lets you continue using the product until the license key problem is resolved. For more information about 

contacting Rational Software, click 

To work with an emergency license key, follow the instructions for working with a temporary license key for a node-locked or 
floating license, depending on the type of license you purchased.



 How do I move a license from one system to another?

 Related Topics

To move a node-locked license:

1. Use the Rational License Key Administrator on the current system to remove the permanent license key or TLA license key. 

For more information, click . Keep in mind that once you remove the license key, you can no longer use the purchased 
Rational Software product on that system.

2. Install the product on the new system. 
3. Use the Rational License Key Administrator on the new system to request a new license key from Rational Software. For 

more information, click 

4. When you receive a license key update file (.upd) from Rational Software in response to your request, import the file on the 

new system to begin using the product. For more information, click 

To move a floating license if you are a system administrator:

1. Use the Rational License Key Administrator on the license server system to change the number of users (key count) to zero 

(0). For more information, click . Keep in mind that, once you change the number of users to zero, your users can no 
longer use the purchased Rational Software product.

2. Install the GLOBEtrotter FLEXlm License Manager on the new license server system.
3. Use the Rational License Key Administrator on the new license server system to request a new license key from Rational 

Software. For more information, click 

4. When you receive a license key update file (.upd) from Rational Software in response to your request, import the file on the 

new license server system. For more information, click 
5. Use the GLOBEtrotter FLEXlm License Manager to configure the license server and tell your users the name of the new 
license server system where the floating license is installed.

To move a floating license if you are a user:

After your system administrator installs the new license key and configures the new license server, use the Rational License Key 
Administrator on your system to specify the new license server system.

Note:

· To move a license from one site to another, please contact Rational Software. For more information, click 



 How do I request a license key for a system that is not email-enabled?

Related Topics 

Use these steps to request a license for a system that does not have an HTTP connection.    See Notes for more information.

1. Start the Rational License Key Administrator on the system that does not have email.

2. Ensure that all required information is provided in the Company Account Information and Modify User Contact Information 
dialog boxes. If you want to receive the license key on a machine that is email-enabled, provide that email address on the 
Contact dialog box.

3. Select either the Request button or License > Request Permanent License Key(s) and request a permanent license key. 
The Rational License Key Administrator creates a license request file rational_request.dat.txt, located by default in 
\Program Files\Rational\Common. 

4. Contact Rational Software:

· To email your request, copy Rational_request.dat to a system that is email-enabled and email the file to auto-
licensing@rational.com.

· To fax or phone your request, print the request and then either fax the printed request to Rational Software, or phone 
Rational Software and provide the information contained in the printed request. For information about contacting 

Rational Software, see the printed request or click 

5. Install the permanent license key:

· If you received a license key update file (.upd) from Rational Software, copy the file to the system that is not email-
enabled and use the Rational License Key Administrator to import the file. For more information about importing 

license keys, click 
· Otherwise, use the Rational License Key Administrator on the system that is not email-enabled to manually enter the 

permanent license key. For more information about entering license keys, click .

Notes:
· The Rational License Key Administrator uses the HTTP protocol to send license key requests. As a result, if your system is 

connected to the Internet and supports HTTP connections (if you can use a Web browser to view external Internet sites), 
you can submit license key requests. License keys will be returned to the email address you specified on the Contact 
dialog box. 



 How do I remove a license key?

You can remove permanent license keys and TLA license keys using the Rational License Key Administrator. 

Use these steps to remove a license key from one system before moving your licensed software to another system.

· For node-locked licenses, you simply remove the license key. For more information, click 
· For floating licenses, the system administrator changes the number of users using the license key (key count) to zero (0). 

For more information, click 

When you remove a node-locked license key or decrease the key count of a floating license key, the change is credited to your 
account so that you can use the license key or the key count in the future.



 Why doesn’t the Rational Software product I installed work?

 Related Topics

The Rational Solutions for Windows install disk includes many Rational Software products. However, you can use the temporary 
license key you received to run only the product you purchased. Ensure that you installed the product you purchased and that 
you have installed the license key for that product.

If you want to install and evaluate other Rational Software products that are available on the Rational Solutions for Windows 

install disk but that you have not purchased, please contact Rational Software. For more information, click 



 Contacting Rational Software Support

Contact Rational Customer Support if you have questions regarding the installation, use, or maintenance of this Rational 
Software product.

Review the Technical Notes available on the Rational Technical Support Web site for information about diagnosing and 
correcting common problems: http://www.rational.com/sitewide/support/technotes/suites.jtmp.

The following table provides Rational License Support contact information. If you have questions about acquiring license keys for 
your Rational Software products, contact Rational License Support. See the online help in the Rational License Key 
Administrator for additional licensing support information.

Rational Support 
Resource

Contact Information Notes

U.S. and Canada 800-433-5444

781-676-2450

support@rational.com 

Specify “Rational Suite” in the subject 
line of the e-mail message. 

For existing issues, put the case ID of the issue 
in the subject line as well.

Europe +31 (0)20 4546 200 support@europe.rational.com 

Asia Pacific +61 2 9419 0111

+61 2 9419 0123 (Fax)

support@apac.rational.com (English only)

support@japan.rational.com(Japanese)

World Wide Web http//:www.rational.com Use the Feedback link to go to the feedback 
page.

.



 How do I move licensed software to another system?
Related Topics 

Use the following steps to move your licensed Rational software product from one system to another:

To move software and licenses from one client system to another

1. Remove the software license keys for the software you are moving. For example, if you are moving Rational Suite 

AnalystStudio, remove the license keys for this product.    For more information about removing license keys, click here.  
2. Use Add/Remove Programs on the Windows Control Panel to remove your Rational software product.
3. Install your Rational software product on your new system. 
4. Request and install your new permanent node-locked licenses on your client system.

To move software and licenses from one server system to another 

If you are moving your FLEXlm License server software to another server system:

1. Reduce the license key count to zero. For more information about removing license keys, click here.  
2. Use Add/Remove Programs on the Windows Control Panel to remove your FLEXlm License Server software.
3. Install the FLEXlm License Server software on your new system.
4. Request and install your new permanent floating licenses on your server system.



'Invalid Host' Message when I start a program

 Related Topics 

You received the following message when you started a licensed program:

Failed to check out a <product-name> key:

Invalid host 

The hostid of this system does not match the hostid specified in the license file

1. You may have copied or moved your Rational software from one system to another without removing your licenses from the 
first system. 

2. You may have copied your license key file to an incorrect system.

3. Confirm that you have the proper license key for your system. If the host name specified in the rational_perm.dat file differs 
from the name of the system where you are running your Rational software, your license key file may not be set up properly. 

Click here to review the steps for moving license keys.



Using redundant license servers (hosts)

Click here to read more about redundant server set up.

You can configure your licensing environment to use multiple license servers to ensure that license keys are more reliably 
available to your users. A redundant license server environment is typically configured with three license server systems. Your 
license server systems should be on the same subnet.

Servers should be configured with the following facts in mind:

· The Primary, or master, server is where clients obtain their licensing keys.

· The Secondary server becomes the master server if the Primary server goes down.

· The Backup server is never the master server.    It is there strictly to establish the quorum, which states that two of three 
redundant server systems must be running for licenses to be served.

The servers always appear in this same order in the license file.    For example:

SERVER server1 host_id [port #]

SERVER server2 host_id [port #]

SERVER server3 host_id [port #]

On the Proxy Settings dialog box:

· The Local Host Name and ID in row A always indicate the Primary license server.

· The Target Host Name and ID in row B always indicate the Secondary license server.

· The Target Host Name and ID in row C always indicate the Backup license server.

A Primary server is never in Proxy mode; it is the machine from which the license keys are served. 

A Proxy mode system must be configured identically to the system for which it is seeking license keys.



 Configuring redundant license servers

Read me first to find out more about using redundant license servers.

Read me next to read more about redundant server set up.

The following steps describe how to set up a redundant license server environment. Before you can configure redundant license 
servers, you must install the GLOBEtrotter FLEXlm License Manager software on three systems. 

In order to complete the following steps, you need the host name and host ID for each of your license server systems.

1. Start the License Key Administrator on one of your license server systems.

2. Select either the Proxy button or Settings > Proxy Configuration.

3. On the Proxy Settings dialog box, select the Redundant Servers button.

4. In the B row, specify the name and ID for the Secondary server (host) in the Target Host Name and Target Host ID fields.

5. In the C row, specify the name and ID for the Backup server (host) in the Target Host Name and Target Host ID fields.

6. Click OK to save your settings.



 Requesting license keys via proxy

You can request permanent floating license keys from Rational for systems that do not have an Internet connection. You use a 
proxy system that has an Internet connection to make license key requests on behalf of other license server systems. You can 
request either normal or redundant license keys via proxy.

To use a proxy system to request your license keys, you must complete the following steps:

1. Install the GLOBEtrotter FLEXlm License Manager software on a system that is connected to the Internet. 

2. Install the GLOBEtrotter FLEXlm License Manager software on the systems for which you requesting license keys. 

3. Obtain the host name and host ID information for the license server system for which you are requesting license keys. Click 
here learn how to do this.

4. Use the proxy system to request license keys for a single system or for multiple systems.



 Obtaining the host name and host ID for a license server system

Use these steps to obtain the host name and host ID information for your license server system:

1. Install the GLOBEtrotter FLEXlm License Manager software on your license server system.

2. Start the License Tools program by selecting Start > Globetrotter FLEXlm License Server > License Tools.

3. Click on the Hostid button in the Lmtools window.    The program displays six lines of information. 

· The first line HOSTNAME=[hostname] contains the host name of your system. When entering it into the License Key 
Administrator on the proxy system, enter only the name following the equal sign. 

· The host ID is the last line of data, which contains the string DISK_SERIAL_NUM. When entering the host ID into the 
License Key Administrator on the proxy system, enter the hexadecimal number after the words DISK_SERIAL_NUM=.



 Requesting license keys for a single license server via proxy

The following steps describe how to request license server for a system that is not connected to the Internet. 

In order to complete the following steps, you must install the GLOBEtrotter FLEXlm License Manager software on two systems – 
the system connected to the Internet, from which you will request license keys, and the system for which you are requesting 
license keys. In addition, you need the host name and host ID for the license server system for which you are requesting license 
keys. 

1. Start the License Key Administrator on your proxy system.

· In Client mode you would request a node-locked license.

· In Server mode you would request a floating license for another machine.

2. Select either the Proxy button or Settings > Proxy Configuration.

3. On the Proxy Settings dialog box, select the Proxy button. 

4. Specify the host name and host ID for the license server system for which you are requesting license keys in the Local 
Host Name and Local Host ID fields.

5. Prepare and send your license key requests. Click here for more information about requesting permanent floating license 
keys.



 Requesting license keys for redundant license servers via proxy

Read me first to find out more about using redundant license servers.

Read me next to read more about redundant server set up.

The following steps describe how to request a redundant license key for systems that are not connected to the Internet. 

In order to complete the following steps, you need to install the GLOBEtrotter FLEXlm License Manager software on four 
systems – the system connected to the Internet and from which you will make your license key requests and the other three 
systems for which you are requesting keys.

In addition, you need the host name and host ID for three license server systems – the information for the systems that are not 
connected to the Internet.

1. Start the License Key Administrator on your license server system.

2. Select either the Proxy button or Settings > Proxy Configuration.

3. In the upper left column of the pane, click the Redundant Servers-Proxy button.

4. In the A row, specify the name and ID for the Primary server (host) in the Local Host Name and Local Host ID fields.

5. In the B row, specify the name and ID for the Secondary server (host) in the Target Host Name and Target Host ID fields.

6. In the C row, specify the name and ID for the Backup server (host) in the Target Host Name and Target Host ID fields.

7. Prepare and send your license key requests. Click here for more information about requesting permanent floating license 
keys.



 Setting up redundant servers

You must use three different servers.    Each server must have a license file containing three SERVER lines in the same order, 
that is, Primary, Secondary, and Backup.    The servers always appear in this same order in the license file in the format:

SERVER server1 host_id [port #] (Primary)

SERVER server2 host_id [port #] (Secondary)

SERVER server3 host_id [port #] (Backup)

While the port number is marked as optional, it is strongly recommended that you specify it as follows:

· All three servers must operate on the same TCP/IP port.

· Other processes cannot share this port.    If there are any other processes running on the particular network port, the three 
redundant servers will not be able to communicate with each other.

You specify the port numbers on the servers by editing the license file (usually named Rational_server_temp.dat or 
Rational_server_perm.dat, depending on whether you are using a temporary or permanent license).

1. Open the license file in Notepad.    The names and locations of your license files, both temporary and permanent, are found 
on the Service Configuration dialog box.

2. Find the lines that begin with SERVER.    For example:

SERVER snelson_nt DISK_SERIAL_NUM=54938590 

SERVER wsmith_nt DISK_SERIAL_NUM=54938546 

SERVER rjones_nt DISK_SERIAL_NUM=54938228 

3. At the end of each line, insert a space, then enter a port number that is not used by any other process, but make sure that 
the port number is the same for all three servers.    You can use any unused port number between 0 and 64000.    The 
added port numbers are bolded in the following example:

SERVER snelson_nt DISK_SERIAL_NUM=54938590 27005

SERVER wsmith_nt DISK_SERIAL_NUM=54938546 27005

SERVER rjones_nt DISK_SERIAL_NUM=54938228 27005

4. Save the file and close it.

On the Client side, you must now enter the port number in the Rational License Key Administrator. 

5. On the Service Configuration dialog box, select Use redundant servers, then click Set Up Servers.    Enter the port 
number in the Port (Optional) field on the Set up Redundant Servers dialog box and click OK.

This Client information is stored in the Rational_redirect.dat file listing the three machines in the exact order in which they 
are listed in the license file.    This file must exist for the Client to access a license from the redundant servers.



Point to a FLEXlm License Server to get my licenses

Selecting this option on the License Key Administrator Wizard's first dialog box displays the Server Type dialog box.

· Choosing the option The licenses are stored on a single server license displays the Server Name(s) and Port dialog box 
with the Server Name and Port ID fields activated. Enter the server name and the port number, if desired.

· Choosing the option The licenses are stored on a redundant server displays the Server Name(s) and Port dialog box 
with the Server Name, Port, Secondary Server Name, and Backup Server Name fields activated. Enter the primary 
server name, secondary server name, backup server name, and the port number, if desired.

Selecting Finish at the end of the succession of dialog boxes in the Wizard completes your task. You will be pointed to a server to 
get your licenses.



Enter the data from a Rational Software License Certificate to install that license on this machine

1. Selecting this option on the License Key Administrator Wizard's first dialog box displays the Please select the license key 
you are entering dialog box. 

2. Selecting any of the three options on this dialog box (Temporary, Permanent, or Term License Agreement) displays the 
Please select the license key type you are installing dialog box.

3. Selecting either the Node-Locked or Floating option on this dialog box displays the License Key Information dialog box.

4. In the License Key Information dialog box, choose the Product and Version you are licensing and enter:

· The License Key

· The Issued Date (if you are installing either a Term License Agreement or Permanent key)

· The Expiration Date (if you are installing a Temporary or Term License Agreement license key)

· The number of key Units you want (if you are installing a floating license)

5. Selecting Finish at the end of the succession of dialog boxes in the Wizard completes your task. 



Request a license from Rational Software via Internet Connection, E-mail, or FAX

Selecting this option on the License Key Administrator Wizard's first dialog box displays the Company Account Information 
dialog box. 

1. Enter the Company Name and primary Rational Account Number, and the secondary Rational Account Number if you 
have been instructed to do so. Click Next.

2. Enter user data in the User Contact Information dialog box if it has not already been filled in: First Name, Last Name, Title 
(optional), Company Name, Country, Phone, EMail Address or Fax, Postal Address, City, State/Province, and 
ZIP/Postal Code. Click Next.

3. Enter data as required in the Request Permanent Keys dialog box:

Select this option To request

Permanent version of 
ALL Temporary License 
Keys

Permanent license keys for all entries listed.

Permanent version of 
SELECTED Temporary 
License Keys

Permanent license keys for entries currently 
selected.

Select from list A permanent license key for a Rational 
product. Use this option if you have not 
previously installed temporary license keys.

· Choosing the Select from list option activates the Node-locked and Floating options and the product drop-down list 
box.    Select either Node-locked or Floating and specify the product.

· If you are requesting permanent license keys for all or selected temporary license keys, the Rational License 
Administrator activates the User Count text box. Enter the permanent license key count.

4. Selecting Finish at the end of the succession of dialog boxes in the Wizard completes your task. 

Notes:

· You can request license keys only for products that you have purchased.

· To delete pending requests, right-click one or more pending requests and select License > Delete Request(s). Then select 
the appropriate option in the Delete License Key Requests dialog box. You cannot delete requests that you have already 
sent to Rational Software.



Import a Rational License File

Selecting this option on the License Key Administrator Wizard's first dialog box displays the Import a License Type dialog box.

1. Either enter a *.upd or *.txt file name or browse to the file location you want.

2. Selecting Import at the end of the succession of dialog boxes in the Wizard completes your task. 



The port number that lmgrd.exe uses when communicating with rational.exe. 



The port number that rational.exe uses when communicating with lmgrd.exe.




