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Introducing EndNote Plus

Welcome to EndNote Plus, an Enhanced Reference Database and Bibliography Maker. As the subtitle suggests, EndNote Plus is a 
program with a dual purpose. 

First, EndNote Plus is a database manager—specialized in storing, managing, and searching for bibliographic references in your 
private reference library. 

Second, EndNote Plus is a bibliography maker—it builds lists of cited works automatically, and can format references to paste into 
footnotes as well. EndNote scans your word processor paper for in-text citations. It then compiles a bibliography using the information 
in your database. Finally, it will produce a copy of your paper, reformatting the in-text citations and placing the bibliography at the 
end. You select the style to use and EndNote does the rest! EndNote can reformat documents created by Microsoft Word 3, 4, and 5, 
WordPerfect 1.0 - 2.1, MacWrite 5.0, MacWrite II and WriteNow 1.0-2.2. It can also reformat documents in RTF (Rich Text Format), 
and plain text documents.

EndLink is the online database import facility for EndNote. It is an add-on module to EndNote which enables you to import journal 
references from online databases into your EndNote libraries. EndLink is not a program itself, rather it is a resource file which, when 
present in the same folder as the EndNote program, endows EndNote with a new import capability.

To use EndLink, you log on to your database service, and capture the results of your search as they are listed to the screen. Then you 
start EndNote, Import the resulting text file using EndLink, and the references are imported directly into an EndNote library. Further 
instructions on begin on page 28.
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What You Have

This guided tour is a brief introduction to EndNote Plus and EndLink. It will show you the major 
features of EndNote Plus and EndLink:

• How to use EndNote Plus as a desk accessory.

• How EndNote Plus creates bibliographies automatically, placing them directly into your word 
processor document.

• How to import database capture files using EndLink.

When you've finished with the Guided Tour, we suggest that you explore on your own. EndNote Plus 
has many features not covered in the tour. In particular, you may want to create a new library and 
add several references to it, to see how EndNote's Edit Window works.

The EndNote Plus/EndLink demonstration package consists of this Guided Tour, and the 
demonstration diskette. The demonstration diskette contains:

• EndNote Plus demonstration program
• EndNote Plus desk accessory demo
• EndLink demonstration resource file
• Styles folder
• Claris folder
• Font/DA Mover
• Examples folder
• Examples Download file

The EndNote Plus program is used for formatting references in word processor documents, 
accessing reference libraries, changing formatting styles, and importing and exporting files. This 
demo allows you to add only 10 new references.

The EndNote Plus Desk Accessory can be used as a companion to your word processor to access 
your reference libraries while you are writing. You can perform searches, add references, and sort 
your libraries with the desk accessory.

The Styles folder contains the bibliographic styles EndNote Plus uses to create bibliographies. 
Styles contain the details required to properly format bibliographic references and in-text citations, 
and can be modified with the EndNote program.

The Claris Folder is for use with MacWrite II only. You may ignore the Claris folder if you are 
using a different word processor.

Font/DA Mover is the program you’ll use to install the EndNote Plus Desk Accessory into your 
System file. 

The Examples folder contains the sample files you’ll use in this guided tour.

The Example Download file is an example of a capture file from an online database, which you can 
Import using EndLink.

Limitations of the Demonstration Package

The demonstration version of EndNote and EndLink are intended for evaluation purposes only and 
as a result they have several limitations.

• New references cannot be added to a library that already has over ten references in it.
• A paper cannot be formatted that has over ten citations in it.
• EndLink will only import four references.

System Compatibility

EndNote Plus requires Macintosh System 4.2 or higher. The way to determine which system you are 
using is to choose About the Finder from the Apple menu. You will see a small window with the 
number of the System in the upper left corner. If you are using a System with a lower number, 
contact your Apple dealer or User Group for a set of new System disks. Then be sure to run the 
Installer program to install the new System.
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EndNote Plus is compatible with A/UX version 2.0.

EndNote Plus is compatible with System 7.0. However, EndNote Plus does not take advantage of any of System 7’s 
new features. Installing the EndNote Plus Demonstration program

To use this demonstration program you'll need to install the program and desk accessory in a way 
that will make them available while working in your word processor.

Installing the EndNote Plus Demonstration program is easy. If you are using a hard disk, turn on 
your computer, make a folder called “EndNote,” insert the EndNote Plus Demonstration disk, and 
drag the EndNote Plus icon, the Styles folder icon, the Examples folder icon, and the EndLink icon 
to your hard disk. There’s no need to copy the EndNote Plus Desk Accessory or Font/DA Mover 
icons at this time. 

If you are using MacWrite II, you will also need to use the Claris folder. If you don’t currently have 
a Claris folder in your System Folder, put the Claris folder that came with this demo into your 
System Folder. If you do already have a Claris folder, do not replace it. Instead, open both the Claris 
folder that came with this demo, and the one in your System Folder. Compare the dates of the Claris 
XTND System and the MacWrite II translators in the two folders. If the files in the EndNote Claris 
folder are newer than the ones in your System Folder, then copy those files to your Claris folder in 
your System Folder.

The first time you start the program, EndNote Plus may ask you for the location of your Styles 
folder. We recommend that you keep the styles folder in your EndNote folder.

Select the folder and click on Select Folder.
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Installing the EndNote Plus Desk Accessory

The EndNote Plus Desk Accessory must be installed in the System file using the Font/DA Mover 
utility available on the EndNote Plus Demonstration disk. Start by double-clicking on the EndNote 
Plus desk accessory icon.
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If you are running System 7, the suitcase will open just like a folder, and you will see the EndNote 
Plus Demo DA file. Drag that file to your closed System Folder. You will then be asked if it is alright 
to place it in the Apple Menu Items folder.  Click OK.

If you are using System 6 (or earlier), clicking on the EndNote Plus DA will start the Font/DA 
Mover program  automatically and you will see the following window:

In the left list you’ll see EndNote Plus. The right list will be empty. Click on the Open button 
underneath the right-hand window. 

You’ll see the familiar Open File window. Next you’ll need to find your System file. Normally the 
System file will reside in a folder called System folder. Double-click on System folder, and then find 
System in the list displayed. Finally, select the System file and choose Open. 
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Now the right-hand window should be showing a list of desk accessories already installed in your 
system.

Click on EndNote Plus in the left window. The >>Copy>> button between the windows will 
activate. Click on the >>Copy>> button to copy the EndNote Plus Desk Accessory into your 
System file. When the copy operation is done, click the Quit button to return to the Finder desktop. 

Check that you’ve installed the EndNote Plus Desk Accessory by pulling down the Apple menu. 
EndNote Plus should be available now. If not, repeat these instructions carefully.
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Start the Guided tour to EndNote Plus

This section will introduce you to the way you’ll use EndNote Plus together with your word 
processor to create in-text citations and bibliographies.

We have provided an Examples folder on your EndNote Plus Demonstration disk. This folder 
contains a sample EndNote reference library called Paleo Library, and four versions of a paper that 
could have been written by someone researching dinosaurs. Each version is in the format of a word 
processor that EndNote supports: Microsoft Word, WordPerfect, WriteNow and MacWrite. Use the 
one appropriate to your word processor.

The procedures for creating a bibliography are described under the assumption that you are not using 
MultiFinder. However, it is important to note that anything done from the EndNote Plus DA can be 
done from the EndNote Plus application under MultiFinder.
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1. Open the Sample Paper in Your Word Processor
Start by opening the paper in your word processor. If you’re using Microsoft Word, you’ll see a 
screen like the following (of course, if you don’t use Word, the screen will be different).

Now pretend, if you will, that you are writing this paper, and you’ve just typed in the sentence at the 
end of the first paragraph. You would like to cite the work responsible for this idea, so, with your 
mouse, position the cursor at the end of the sentence, just before the period.

Add an extra space before the period so that your citation will be separated from your text. To 
retrieve the proper citation, call up the Paleo Library.
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2. Open an EndNote Library

Pull down the Apple menu in the upper left corner of your Macintosh screen, and choose EndNote 
Plus. If you don’t see it there, you’ll need to follow the instructions in at the beginning of this guide 
for installing the EndNote Plus Desk Accessory. When you have selected EndNote Plus, it will ask 
you to open a library. Find the Paleo Library inside the Examples folder and open it. 

An EndNote Plus menu will be added to the right side of the menu bar at the top of your screen. This 
menu will appear whenever the EndNote Plus Desk Accessory is active. You’ll use it to access the 
many features of the DA.

You should see an EndNote library window:

Now that the library is open, you’ll want to find a specific reference to cite. 
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3. Find a Reference to Cite
Pull down the EndNote Plus menu, and choose the Find… option. 

In the first search item, enter the word that will identify the reference you want to cite. In this 
example, you’ll be searching for the word “Triceratops.” Click Find and EndNote will instantly 
perform a search for any references in the Paleo Library containing the word “Triceratops.” The 
three matching references will appear in the library window. Notice the label “Showing 3 references 
out of 200” at the top of the library window:

The reference you want to cite is by Whitney. To look at the details of this entry, double-click on that 
line in the library. You will see the following window:

This is the edit window, which you will use to add and change references in your EndNote library. 
Notice how the authors are entered: one author per line. Click on the close box in the upper left of 
this window to return to the library window.

4. Copy a Citation from EndNote and Paste it into the Example Paper
Notice that the Whitney reference is highlighted in the library window. You are going to Copy the 
temporary citation for the Whitney reference to the paper by way of the Clipboard. Either choose 
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Copy from the Edit menu, or else press -C. Next, return to your word processor by clicking back ⌘
on the Paleo Paper window. Choose Paste from the Edit menu or press -V. You’ll see a temporary ⌘
citation in the paper appearing like this:

...origin of this larger reptile is quite uncertain at this time, it is thought to be 
from central or eastern Asia [Whitney, 1987 #19].

This pasted citation is only a temporary marker. Later, when you’re finished with your paper, you’ll 
use EndNote Plus to format the temporary citations and to build a bibliography automatically. 
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5. Open the Library in EndNote Plus 
Now pretend that you are done typing your paper and that all the temporary citations have been 
placed. Save your paper in your word processor.

Quit from the EndNote Plus Desk Accessory by closing the open reference library window. Quit 
your word processor. Then find your EndNote folder, and double-click on the EndNote Plus icon. 
Choose Open from the File menu. EndNote will ask you to locate your library. Find the Paleo 
Library you were just working with and click on the Open button. You’ll see the library window.

6. Open the Paper in EndNote

The next step is to open your Paleo Paper in EndNote Plus for formatting. Choose Open Paper... 
from the Paper menu. EndNote will ask you to locate your paper. Find and open the Paleo Paper you 
just worked on, the one appropriate to your word processor
EndNote will show you the paper window, listing the citations it found in the paper. 

To produce this information, EndNote scanned your paper for temporary citations, compiled a list of 
them, and looked each one up in the reference library. The numbers in the left-hand column show 
how many matches EndNote found for each citation. A “1” indicates that all the citations matched 
exactly one reference in the library, and there were no ambiguities.

7. Choose a Style

Before formatting, choose the bibliographic style you want to use in your paper. Pull down the Styles 
menu and notice the different styles available. Choose the Numbered style. The Numbered style will 
tell EndNote to replace in-text citations with numbers and also to number the bibliography that 
appears at the end of the paper
Now you’re ready to format the paper. This means that EndNote is going to make a copy of the 
paper with properly formatted in-text citations, and with a bibliography at the end.

8. Format the Paper in EndNote
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After selecting the Numbered style, choose Format from the Paper menu. EndNote will ask you to 
name the file that will contain the formatted copy of the paper, with the default being the name of the 
original paper plus the name of your bibliographic style, as shown below. Your original paper won’t 
be replaced; the new name insures that EndNote only makes a copy.
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9. Open the Formatted Paper in the Word Processor 
When the formatting is done, you’re ready to look at the formatted paper. Quit EndNote by choosing 
Quit from the File menu. Then open the formatted copy of the paper in your word processor. You’ll 
see that EndNote Plus has performed its magic!

So, you see, using EndNote Plus is really quite simple. You use the EndNote Plus 
DA (or the application if you’re using MultiFinder) to look up and Copy/Paste 
citations into your paper. When you’re finished writing, you add the final 
bibliographic touches to your paper with the EndNote Plus application. You’ll 
have to choose the formatting style, and EndNote Plus does the rest—instantly! 

Enhanced Features of EndNote Plus

Sorting
Sorting a reference library can help you organize information for printing, copying or just browsing. 
You can sort any library window, whether it shows a complete library or a partial listing of 
references resulting from a successful search.

Choosing Sort Library… from the References menu brings up the sort order window.

Each of the five boxes can contain one field name, but you don’t have to use all five boxes to sort a 
library. Enter field names by clicking on Insert Field and releasing the mouse button on the name 
you want. 
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You can also enter field names by typing the name directly, using the mouse or the Tab key to move 
from field to field. The button at the right of each box indicates ascending or descending order.

The following sort instructions will sort the library by year, in decreasing order, and then by author, 
in increasing order.

With the field names entered, click on Sort. EndNote will sort the reference library according to your 
instructions. 

Here are the results of the descending year and ascending author sort on Paleo Library:

Before the Sort Library command is used, your EndNote library will be sorted by author and year, 
both in ascending order. New and edited references are automatically sorted according to this 
system. After the Sort Library command is used, this automatic sorting process is disabled. New 
references will simply be added to the end of your sorted library. Editing a reference will have no 
effect on its position.

Choosing Show All ( -H) from the ⌘ References menu restores the original author/year order and the 
automatic filing process. 

You can also sort your final bibliography in the same or different manner by specifying this in the 
bibliographic style.
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Searching
To start a search, choose Find… ( -F) from the ⌘ References menu (EndNote Plus menu in the DA). 
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You will be presented with a window, containing three empty fields, called search items, where you 
will enter your search specifications. 

The fields menu allows you to specify the reference field to search in. You can limit your search to 
Author, Year, Title, Keywords, or any other field. 

Once you have entered the search instructions, click on the Find button. If EndNote can’t find any 
references using your instructions, you’ll hear a beep to indicate that there are no matches. If 
references that match your instructions exist, the library window will show only the matching 
references. 

Additional Search Features
The Boolean And, Or, and Not radio buttons between the search terms indicate how they are to be 
combined. Combining with And means that EndNote will only find references with both term, 
whereas combining with Or will return references which have either the first term or the second 
term. Combining the terms with a Not will only show references which have the first term but not 
the second term.

The Match Case allows you to specify that the references must contain terms in the same 
combination of upper and lower case as the search term.  For example: Searching for Hall or Robin 
will not find hall or robin if the Match Case is selected.

Match Words specifies that only whole-word matches will be found, not partial word matches. For 
example: Searching for fossil will not find fossils or fossilize if the Match Words option is chosen.

QuickFind is a special high-speed search feature that works in conjunction with EndNote’s special 
indexes. It will only be enabled if you have already indexed your library by selecting QuickFind 
Index from the Edit menu. Creating a QuickFind index will increase the size of your database but 
will make searching on it much faster. QuickFind indexes are intended for databases of over one 
thousand records. Performance will not be greatly improved for smaller databases.
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Extra search items can be added or deleted using the New Item, Insert Item, and Delete Item 
buttons on the lower right-hand side of the window. New adds a new search item to the bottom of the 
list, Insert adds a search item above the current item, and Delete removes the current search item. 

Every EndNote search looks through the entire reference library. If you do not choose Show All after 
a successful search, but instead begin another search, EndNote will still bypass the current search 
results and look through the entire reference library.

Example. Find the references pertaining to both ozone and antarctic that were not written in 
1989, plus any references that use the word “greenhouse” in the title. Enter ozone and antarctic 
as the first two search items and connect them using the And option. Leave the field menu for these 
first two items at Any Field. Enter 1989 as the third search item and change the field menu to Year. 
Combine 1989 with the previous grouping by using the Not option. 

Now that the first three slots are taken up, you will need to press the New Item button to add a new 
search item. Enter greenhouse as the fourth item and change the field menu option to Title. Connect 
this fourth item to the previous grouping by checking the Or option. 

Click Find, and EndNote will locate the references matching these instructions. 

Items in complex Boolean searches are connected from top to bottom, EndNote interprets the search 
like this: 

(((ozone and antarctic) not 1989) or greenhouse) 

Keep this grouping in mind when setting up your searches.

Find Duplicates
EndNote Plus also offers a feature to find duplicate references in your database.  This is helpful to 
people who download a lot of information from online services and usually end up duplicating some 
of the references. Find Duplicates will find all entries with identical author, year and title fields. It 
will also allow you to inspect them before deleting anything.

Printing
EndNote now offers Printing directly from within the program. To print you choose Print... from the 
File Menu. EndNote will print all of the references currently showing in the library window (This 
may be either the entire library or 
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the results of a search). The references will be printed in the style that is currently selected. 

20



21

Journals
EndNote Plus can create a journals table which is used to store information regarding journal 
abbreviations. The journal table can be used to store a Full Journal name and up to three 
abbreviations. To create a journal table choose Journal Abbreviations... from the Edit menu.  If an 
EndNote Journals file does not already exist EndNote will ask you to create a new one.  Click New... 
in the dialogue box. You will then see an empty journals table.  You can begin entering your journal 
names. Use the tab key to move horizontally across the table to type your various abbreviations.  
After entering a number of journal names your journal table may look something like this:

The journal names listed above are not included with this demonstration but you can create your 
own. 

You will also be able to use the journal table during data entry as you will be able to automatically 
insert a journal name or abbreviation into a reference without having to retype it by selecting 
Journal Names... from the References menu and selecting the journal name that you wish to insert. 
You will also be able to specify which abbreviation you would like to be placed in your bibliography 
by specifying the abbreviation format when editing or creating a new bibliographic style.
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Starting the Guided tour to EndLink

EndLink is a resource file, which must be in the same folder as EndNote. You can check that the 
installation was successful by running EndNote, opening a library, and then selecting Import... from 
the File menu. If EndLink™ appears as an option in the window at the bottom of the import window, 
then EndLink has been installed.

The EndLink option may not appear if the EndLink™ file is not in the same folder as the EndNote 
application program. Make sure that you copied the EndLink file into the same folder containing 
EndNote.

22



23

Using the Example Download
To get you started using EndLink, we will provide you with an example of its use. We will use our 
Example Download file located in the Examples folder, which is assumed to be captured from an 
online database.

The two-letter codes you see above are required for EndLink to identify the fields. When using 
DIALOG, you should display in format 4 to show these tags.
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Run EndNote and Create a New Library
When importing references you must first create a new empty database. The demonstration program 
only allows you to import four references at a time to a database with less than ten references.

Select New... from EndNote's File menu, and create a new library, called "Download Import".

An empty library window appears:
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Import References from a Capture File
Next, choose Import... from EndNote's File menu, check that the EndLink™ option is selected, click 
on the capture file, and then click on Open:

While the importing progresses, a counter shows how many references have been imported. THIS 
DEMO VERSION WILL ONLY IMPORT FOUR REFERENCES.

And here is the result:

That's really all there is to it. Four mouse clicks to import from a capture file. 

Seven Steps From Online to EndNote
Transferring references from your online service into EndNote requires the following steps:

• Log on to your online database service,
• Search the online database for the desired  references,
• Log on to an online database service, using a  terminal emulation program,
• Search for your topics,
• Turn on the terminal program’s “capture”, and  list the search results, with tags,
• Log off and quit from your terminal program,
• Run EndNote and create a new library to receive  the imported references, 
• Import the references from the capture file.
• Copy your references from the new library to  your old library

EndLink Imports Journal Articles from Many Databases:
EndLink has successfully imported journal articles from the following databases:
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Medline, CAS (Chemical Abstracts), BIOSIS, PaperChase, Inspec, PsycInfo, SciSearch

EndLink also imports from many other databases on BRS Colleague and Dialog, including Dialog 
OnDisk (CD-ROM).
NOTE: EndLink only imports journal articles. 

Patents, books, reports and other kinds of references will be partially brought in: the author, title, 
year, keywords and abstract will be imported into EndNote, but other fields may not import 
correctly. 

Final Note
Although we have tried to provide you with a thorough demonstration, you may still have some 
questions. If so, please feel free to call us at (510) 649-8176.

26


