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Welcome to The Wild West on-line Help window. We've provided this Help file in case you don't have the 
Owner's Manual handy.

The following Help Topics are available for finding out more about The Wild West program.

If you get stuck when using the program, or need help using a certain function, the following Help Topics 
will provide you with more information about The Wild West. Click on any topic in green underline with 
the mouse to learn more about that topic.

Using the MAIN Screen

Using the EPISODE Screen

All About OPTIONS
          SCRIPT Screen
          BOOKS Screen
          MAPS Screen
          TIMELINES Screen
          HANGMAN Screen
          MUSIC Screen
          LYRICS Screen

How to Use The Wild West HELP 
Clicking on How to Use The Wild West HELP above brings up a separate Help window that provides 
extensive information on how to get the most out of this Help window. Info about using Menu bar and 
Button bar commands is also covered.

To return to this window from any Help screen, click on the Contents button above.

To get out of this Help window and get back to the program, select Exit from the File menu.



Using the MAIN Screen
The Main screen is displayed after the Welcome screens. Think of the Main screen as your "home base" 
where the ten episodes of the program are selected.

Click on any function below - outlined in green - to learn more about that function.

For more Help with The Wild West, click on the Contents button above. This will take
you to the Contents window which lits additional topics you can select for more information.

To get out of this Help window and get back to the program, select Exit from the File menu.



Using the EPISODE Screen
The EPISODE Screen is used to view the episode you selected in the MAIN screen. The functions on this screen 
allow you to control the video's playback and volume as well as provide instant access to key topics and sub-sections 
related to the selected episode. 

Click on any function below - outlined in green - to learn more about that function.

For more Help with The Wild West, click on the Contents button above. This will take
you to the Contents window which lits additional topics you can select for more information.

To get out of this Help window and get back to the program, select Exit from the File menu.



SCRIPT Screen
This sub-section supplements the episode with a written transcript of the episode's narration and dialogs.

Click on any function below - outlined in green - to learn more about that function.

For more Help with The Wild West, click on the Contents button above. This will take
you to the Contents window which lits additional topics you can select for more information.

To get out of this Help window and get back to the program, select Exit from the File menu.



MAPS Screen
To aid in understanding the geograpic setting of the selected episode, this screen provides one or more 
maps to help illustrate the information from that episode.

Click on any function below - outlined in green - to learn more about that function.

For more Help with The Wild West, click on the Contents button above. This will take
you to the Contents window which lits additional topics you can select for more information.

To get out of this Help window and get back to the program, select Exit from the File menu.



TIMELINES Screen
To aid in understanding the chronology of the selected episode, this screen provides a historical timeline 
to illustrate the sequence of events in the episode.

Click on any function below - outlined in green - to learn more about that function.

For more Help with The Wild West, click on the Contents button above. This will take
you to the Contents window which lits additional topics you can select for more information.

To get out of this Help window and get back to the program, select Exit from the File menu.



HANGMAN Screen
Want to test your understanding of the current episode? Hangman is the scene for a final exam where 
youre rewarded for your knowledge or penalized for your mistakes. 

Click on any function below - outlined in green - to learn more about that function.

For more Help with The Wild West, click on the Contents button above. This will take
you to the Contents window which lits additional topics you can select for more information.

To get out of this Help window and get back to the program, select Exit from the File menu.



How to Use The Wild West HELP

Clicking the Help button on any screen opens this Help window. The Help window is context sensitive. 
This means that if you click the Help button from the "MAIN" screen, help for the MAIN Screen will be 
displayed; if you click the Help button from the "EPISODE Screen", help for that screen will be displayed, 
etc.

Once the Help window is open, you can select other topic windows and view all the Help information for 
The Wild West. The Help window will provide you with general and specific Help on using The Wild West.

By pointing to any function outlined in green and clicking once with the mouse, a pop-up window will 
appear that will give you information about that function. To get out of the pop-up window, click again with 
the mouse or press a key on your computer's keyboard.

A comprehensive help screen that describes how to use this Help window can be called up by clicking on the 
Help menu above and selecting the How to Use Help item. "How to Use Help" lists numerous topics that you 
can select that will teach you specific Help window techniques including Help Basics.

Below the Menu bar is a Button bar that will assist you in getting around The Wild West Help quickly. To learn how 
these buttons work, click on the Help menu above and select the How to Use Help item. At the very bottom of the 
window is a topic called Help Buttons that tells you how to use The Wild West HELP command buttons.



COPY Button
If you would like a copy of the displayed text - or just a portion of 
it - click the COPY button. The COPY dialog box will be displayed 
allowing you to save a copy of the entire text (click the "Copy 
ALL" button) or a range of pages (enter the first page of the 
desired page range in the first box and the last inclusive page in 
the second box). Click OK to continue or CANCEL to exit this 
function.

If you click OK, the "Save As" dialog box appears. A default file 
name appears in the File Name box; enter a new name if you 
want. You are also able to select a new directory and drive path* 
if desired. Click OK to save the transcript. It will be saved to the 
indicated path as a standard ASCII ".txt" Text File. Click CANCEL 
to exit without saving. Once the .txt file has been saved to disk, 
you can open it in most word processors. This enables you to 
edit the text, apply any formatting you like and print it if desired.

*    If you selected the Educator's Install when The Wild West
        was installed on your computer's hard drive, the default
        path is drive A:\ (floppy disk drive) and cannot be changed.

Click with the mouse or press a key to continue...



BOOKS Button
Clicking the BOOKS button displays a bibliography of the 
selected episode's related works for further study.

Click with the mouse or press a key to continue...



BACK Button
Clicking this button reverts back to the section of the program 
that was previously running.

For example, clicking BACK while in a TIMELINE screen, playing 
HANGMAN, viewing MAPS or reading a SCRIPT reverts to the 
EPISODE Screen; clicking BACK while the program is displaying 
BOOKS reverts to SCRIPT.

The BACK button avoids having to return to the MAIN Screen 
when you are finished using a sub-section.

Click with the mouse or press a key to continue...



MAIN Button
Clicking MAIN takes the program back to the MAIN Screen where 
you can select another episode to view.

Click with the mouse or press a key to continue...



HELP Button
Clicking the HELP button calls up the Windows on-line help 
screen that will assist you in using The Wild West in the event 
you need instructions and this manual isn't handy. Help is 
"context-sensitive": this means that clicking HELP from any 
screen will display the help information for that screen.

Click with the mouse or press a key to continue...



QUIT Button
Clicking the QUIT button exits the program.

Click with the mouse or press a key to continue...



FX Button
Normally, the program will play a sound effect when any of the 
function buttons are clicked with the mouse. If you would like to 
defeat this feature, clicking this button will turn off sound effects 
playback when a button is clicked. Clicking it again turns FX back 
on.

Click with the mouse or press a key to continue...



Episode Title
The MAIN Screen depicts a map of the western region of the 
United States. The titles of the ten episodes are placed on the 
map over the geographic region where the episodes take place. 
Click on any title with the mouse to view that episode.

Episodes that play from Disk 1 are displayed in yellow;
Episodes that play from Disk 2 are displayed in blue.

Click with the mouse or press a key to continue...



Video Window
When the EPISODE Screen is displayed after selecting a title in 
the MAIN Screen, the selected episode will begin to play 
immediately in this area of the screen.

Click with the mouse or press a key to continue...



PLAY/STOP Button
This button allows you to play and stop the video. This function 
switches between playback and stop when clicked with the 
mouse. You can switch between play and stop anytime.

Click with the mouse or press a key to continue...



VOLUME Button
To adjust the volume of the videos soundtrack, click this button 
with the mouse and a pop-up volume slider will appear. To 
change the volume level, click the slide knob and drag it upwards 
to increase the volume; drag it downwards to decrease the 
volume.

Click with the mouse or press a key to continue...



Scrub Bar
During playback, the scrub button will advance from left to right 
along the horizontal bar as the video plays. At any time during 
play, or even when the video is stopped, you can click the scrub 
button with the mouse and drag it to the left or right. This is the 
equivalent to rewind (dragging to the left) and fast forward 
(dragging to the right).

Click with the mouse or press a key to continue...



Index Window
The index window provides a powerful search function for quickly 
viewing key topics - people, places and things - that appear 
within each episode. When an episode is selected, the index 
window will display a complete list of all the topics covered in 
that episode. To go to the point in the episode where a topic is 
featured in the video, click on its name in the index window. The 
episode will immediately go to that spot in the video and play.

Click with the mouse or press a key to continue...



< Previous Button
If you go to a "next" appearance of a topic, this arrow button 
beneath the index window becomes active. Clicking the Previous 
button allows you to revert back to the last portion of the video 
where the selected topic appears. If there is another previous 
part of the episode that covers that topic, the < remains active. If 
not, the button goes inactive and becomes dimmed.

If a selected topic has only one occurrence in the episode, this 
button will be inactive and dimmed.

Click with the mouse or press a key to continue...



Next > Button
If the selected topic is mentioned more than once in the episode, 
this arrow button beneath the Index Window becomes active. 
Clicking the Next button takes the episode to the next spot in the 
video where that topic appears. If there is another part of the 
episode that covers that topic, the > remains active and can be 
clicked again to advance to the next occurrence. If not, the 
button goes inactive and becomes dimmed.

If a selected topic has only one occurrence in the episode, this 
button will be inactive and dimmed.

Click with the mouse or press a key to continue...



OPTIONS Button
Clicking the OPTIONS button on the EPISODE Screen displays a 
dialog box that allows you to select one of five options that are 
associated with the selected episode.

Click with the mouse or press a key to continue...



Letters
Solve the question by clicking on the letters you think make up 
the answer. You can also enter letters by typing them on your 
keyboard.

Click with the mouse or press a key to continue...



Question Box
A question related to the current episode is selected at random 
and appears here. Your goal is to answer six questions by typing 
or clicking on the displayed letters that make up the answer 
before six wrong letters are picked.

Click with the mouse or press a key to continue...



Answer Box
As you solve the question, correct letters picked from the screen 
or typed on the keyboard appear here.

A set of empty letter spaces comprising the words of the answer 
appears in the Answer box as a hint as to what the correct 
answer might be.

Click with the mouse or press a key to continue...



Wrong Letters Box
As you solve the question, incorrect letters picked from the 
screen or typed on the keyboard appear here. If you pick six 
wrong letters before six questions are answered correctly, you 
lose and the game ends.

Click with the mouse or press a key to continue...



Hangman
Every wrong letter entered as you attempt to solve the question 
causes one body part of the hangman to appear.

Click with the mouse or press a key to continue...



Topic Title
The topic title - a person, place or thing that is significant in this 
episode - appears here.

Click with the mouse or press a key to continue...



Picture
Each topic is illustrated with a picture and the year, or range of 
years, when it occurred.

For a description of the topic, click on its picture. A brief 
description will pop-up on the screen for you to read. When you 
are finished, click the OK button to close the text box.

Click with the mouse or press a key to continue...



Map Window
The map or maps that pertain to the current episode are 
displayed here.

Click with the mouse or press a key to continue...



Description Window
A brief description of the map that appears in the Map Window is 
displayed here.

Click with the mouse or press a key to continue...



< Previous Map Button
If you go to a "next" map, the < Previous arrow button beneath 
the map window becomes active. Clicking the < button allows 
you to revert back to the previous map in the list. If there is 
another previous map, the < remains active. When the first map 
for that episode is displayed, the < button goes inactive and 
becomes dimmed.

If the current episode has only one map, this button will be 
inactive and dimmed.

Click with the mouse or press a key to continue...



Next > Map Button
If the selected episode contains more than one map, the Next > 
arrow button beneath the map window becomes active. Clicking 
the > button displays the next map. If there is a third map, the > 
remains active and can be clicked again to advance to the next 
map. When the last map for that episode is displayed, the > 
button goes inactive and becomes dimmed.

If the current episode has only one map, this button will be 
inactive and dimmed.

Click with the mouse or press a key to continue...



< Previous Button
If you go to a "next" appearance of a topic, the < Previous arrow 
button beneath the index window becomes active. Clicking the < 
button allows you to revert back to the previous page in the script 
where the selected topic appears. If there is another previous 
part of the episode that covers that topic, the < remains active. If 
not, the button goes inactive and becomes dimmed.

If a selected topic has only one occurrence in the episode, this 
button will be inactive and dimmed.

Click with the mouse or press a key to continue...



Next > Button
If the selected topic is mentioned more than once in the episode, 
the Next > arrow button beneath the index window becomes 
active. Clicking the > button takes the episode to the next spot in 
the script where that topic appears. If there is another part of the 
episode that covers that topic, the > remains active and can be 
clicked again to advance to the next occurrence. If not, the 
button goes inactive and becomes dimmed.

If a selected topic has only one occurrence in the episode, this 
button will be inactive and dimmed.

Click with the mouse or press a key to continue...



Text Area
The written transcript of the current episode appears here.

Click with the mouse or press a key to continue...



Script Index
When the SCRIPT sub-section is selected, the index window will 
display the same list of the topics covered in the EPISODE 
Screen. To go to the point in the episode where a topic is 
featured in the script, click on its name in the index window. The 
episode will immediately go to the page in the script where the 
topic discussion begins.

Click with the mouse or press a key to continue...



Turn 1 Page Back
You can read the text at your own speed and can turn pages 
forward or back. To turn one page back, click once with the 
mouse here on the page curl.

Click with the mouse or press a key to continue...



Turn 1 Page Ahead
You can read the text at your own speed and can turn pages 
forward or back. To turn one page ahead, click once with the 
mouse here on the page underneath the page you're reading.

Click with the mouse or press a key to continue...



MUSIC Screen
This section of the program gives you the opportunity to hear the recordings of over 30 songs from The 
Wild West era.

Click on any function below - outlined in green - to learn more about that function.

For more Help with The Wild West, click on the Contents button above. This will take
you to the Contents window which lits additional topics you can select for more information.

To get out of this Help window and get back to the program, select Exit from the File menu.



LYRICS Screen
This screen plays the song you selected and displays the lyrics for you to read or sing along while the 
music plays.

Click on any function below - outlined in green - to learn more about that function.

For more Help with The Wild West, click on the Contents button above. This will take
you to the Contents window which lits additional topics you can select for more information.

To get out of this Help window and get back to the program, select Exit from the File menu.



BOOKS Screen
The BOOKS Screen displays a bibliography of the selected episodes related works for further study.

Click on any function below - outlined in green - to learn more about that function.

For more Help with The Wild West, click on the Contents button above. This will take
you to the Contents window which lits additional topics you can select for more information.

To get out of this Help window and get back to the program, select Exit from the File menu.



Piano Player's Comments
As the piano player waits for you to select a song, he has a few 
things to say. His remarks appear here.

Click with the mouse or press a key to continue...



Song List
The titles of the songs that are related to the current episode 
appear here. To select a song to play, click on its title once with 
the mouse.

Click with the mouse or press a key to continue...



 PLAY/STOP Button
This button allows you to play and stop the music. This function 
switches between playback and stop when clicked with the 
mouse. You can switch between play and stop anytime.

Click with the mouse or press a key to continue...



 VOLUME Button
To adjust the volume of the music, click this button with the 
mouse and a pop-up volume slider will appear. To change the 
volume level, click the slide knob and drag it upwards to increase 
the volume; drag it downwards to decrease the volume.

Click with the mouse or press a key to continue...



Lyrics
The written words of the song appear here.

Please note that some songs are instrumental only and no lyrics 
will appear when selected.

Click with the mouse or press a key to continue...



Bibliography
The list of book references related to the current episode appear 
here.

Click with the mouse or press a key to continue...

 




