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Chapter 1

MWM

1.1 MWM.guide/Contenuti

+—— - - - - =t - - - - ——+
| ! Benvenuto nel primo generatore di file HTML facile-da-usare! |
f—— - - - -t - - - - -+

MW M

——>x Magic WWW (World-Wide Web) files Maker x<-—-—

Versione 3.11

| |
| from an idea of Maurizio Fabiani |
| developed by Massimo Baglione |
| |

Di cosa si tratta ?

La finestra principale -—> Tasti speciali
La finestra per la singola linea

La finestra di aiuto

La finestra '’ What is 2 77/

Il menu

Cosa puo’ fare MWM ? Informazioni generali Ringraziamenti Novita’ di MWM

Addendum

1.2 MWM.guide/Di cosa si tratta?

DI COSA SI TRATTA ?
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Un giorno 11 mio amico Maurizio mi chiese: "Hey Max, pensi sia possibile

scrivere un programma per la creazione di file in formato HTML che dia la
possibilita’ all’ utente di caricare normali file ASCII e trasformarli in

HTML selezionando parti di testo utilizzando il mouse 2"
Gli feci capire che non ero in grado di operare miracoli, ma lui insistette.
Bene, ora ci sono quasi riuscito.

MWM infatti consente di caricare un normale file di testo e tramite il mouse
si puo’ applicare alle righe o alle singole parole selezionate le immagini, i
testi e tutto quello che consente il formato HTML.

L’ interfaccia grafica e’ composta essenzialmente da

— Finestra principale, che mostrera’ il normale file di testo caricato.
Se al testo e’ stata applicata qualche particolare azione, allora verra’
evidenziato con un colore diverso dal resto del testo.
Come molti programmi grafici e word processor, questa finestra contiene
delle piccole immagini associate a delle azioni.

- Finestra per editare una singola linea di testo ed inserire piu’ di un
oggetto nella stessa riga.

— Finestra delle etichette, che mostrera’ le etichette contenute in un
file HTML da linkare. (vedere in seguito)

— Finestra di aiuto, che informa 1’ utente su tutto cio’ che sta’
facendo o succedendo.
MWM mette a disposizione tre livelli di informazioni:

— None, ovvero nulla se non l1l’essenziale.
— Medium, descrizione sommaria dell’ oggetto selezionato.

- High, informazione dettagliata.

— Finestra "What is?", che associa ad ogni riga del testo una piccola
stringa per poter riconoscere "al volo" ogni oggetto.

1.3 MWM.guide/La finestra principale

LA FINESTRA PRINCIPALE.

Una volta caricato il file di testo, lo si potra’ vedere chiaramente in una
delle finestre: la finestra principale.

Con il tasto sinistro del mouse si seleziona una porzione di testo e con
uno dei gadget degli strumenti gli si puo’ assegnare un’ azione che puo’
essere una immagine, un riferimento ad altro testo, una lista e tutte
quelle belle cosette che consente il formato HTML.

Se avete la necessita’ di applicare azioni a singole parole all’ interno di
una riga e’ sufficiente selezionare tale riga con un doppio click.

Una piccola finestra si aprira’ con 1l’intera riga del testo messa a vostra
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disposizione: la finestra per la singola linea.

Il motivo per il quale non ho implementato tale possibilita’ direttamente nella
finestra principale e’ dovuto al fatto che ho voluto semplificare al massimo
1’ uso del programma e che comunque il tipo di gestione del testo di MWM
renderebbe troppo lenta la visualizzazione in caso di scroll.

Applicando diverse azioni al testo si creano degli oggetti che saranno
visualizzati con colori diversi per poterli distinguere con facilita’.

L’ oggetto viene numerato in base all’ ordine di creazione e selezionandolo
si avra’ la possibilita’ di controllarne i dati essenziali nella finestra di
aiuto.

Partendo dal primo gadget a sinistra troviamo:

TEXT IMAGE LIST FORM MORE HEAD CENTER VIEW PREFS

1.4 MWM.guide/Primo gadget TEXT

TEXT gadget

Si intende definire per 1le 1linee selezionate un particolare tipo di
testo.

MWM aprira’ una finestra con diversi gadget:
- "Type" gadget:
— Plain; il testo selezionato rimarra’ tale nel file HTML finale..

- Link into this document;
E’ un link ad una etichetta gia’ creata all’ interno del
documento corrente.

- Link to another document;
In questo caso programmi tipo Mosaic evidenzieranno questa
parte di testo e, se 1’ utente selezionera’ col mouse gquesta
porzione, allora verra’ chiamato il nuovo testo definito da
questa azione.

- Link to a site.
E’ un link ad un sito in cui si desidera entrare.

- Preformatted;
Programmi tipo Mosaic sono "obbligati" a formattare il testo
che devono visualizzare seguendo gli standard in vigore.
Con tale azione si intende specificare che tutto il testo
selezionato non dovra’ assolutamente essere influenzato da
tale formattazione.
E’ molto utile per quei testi che perderebbero di significato
se venisse modificata 1’ impaginazione originale, ad esempio i
listati dei programmi.
Il testo selezionato sara’ racchiuso tra <PRE> e </PRE> e verra’
visualizzato con un font fixed width (typewriter) dal browser.
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- Address.

Con questa azione MWM inserira’ le linee selezionate nell’ area
dedicata alle informazioni dell’ autore del documento, ovvero fara’
parte del <ADDRESS> del documento HTML.

Programmi tipo Mosaic evidenzieranno questo testo.

Paragraph.

Il testo selezionato sara’ racchiuso tra <P> e </P>, ovvero faranno
parte di un paragrafo.

Il tipo di allineamento possibile e’:

DEFAULT, LEFT, CENTER, RIGHT, JUSTIFY.

"Link" gadget:

Attivo per "link to another document", permette di scegliere il file
che dovra’ essere linkato.

"Label" gadget:

Attivo per "link into this document” e "link to another document",
permette di scegliere la label (etichetta) nel file selezionato che
dovra’ essere linkata.

"URI" gadget:

Attivo per "link to a site";
MWM vi dara’ i1 seguenti tipi di URI:

file://localhost/
http://

ftp://

mailto:

news:

gopher:

telnet:

"Site" gadget:

Attivo per "link to a site";
MWM aprira’ un requester per sapere dove dovra’ prendere il nome del
sito. Si puo’ decidere tra:

- Selected line
Il nome del sito e’ rappresentato dalla prima linea selezionata.
Se le linee selezionate sono piu’ di una, allora MWM le ridurra’
automaticamente a una e prendera’ da essa il nome del sito.

— Keyboard
Il nome del sito dovra’ essere inserito manualmente.

- PATH:file
I1 nome del sito e’ definito in un file apposito.
E’ necessario definire una lista di siti prima di usare MWM.
La lista DEVE essere simile a questa:
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www.vol.it
agnus.livewire.com
WWw.lycos.com
www.yahoo.com

Se non diversamente specificato,

"Sites list".

"Markup" gadget:

Aggiunge un Markup al testo corrente.

Si puo’ scegliere fra:

"Font"

Con questa funzione e’

MWM cerchera’ la lista dei
siti nel file "PROGDIR:MWM.sites".
E’ possibile specificare una diversa locazione del suddetto
file usando la funzione del gadget "PREFS"

Citation (Typically in italic). (CITE)
Emphasis (EM)
Strong emphasis (STRONG)
Code (CODE)
Looks like preformatted text,

for example: 1 + 1 = 2.

Author (AU)

For an author of a book, etc.

Person (PERSON)
For a generic person name.

Sequence of chars. (SAMP)
Keyboarded text. (KBD)
Variable name. (VAR)
Definition. (DFN)
Short quote. (Q)
Acronyms. (ACRONYM)
Abbreviations. (ABBREV)
Inserted text. (INS)
Deleted text. (DEL)
Bold text. (B)
Ttalic text. (1)
Typewriter text. (TT)
Underscored text. (U)
"Lined" text. (S)

Big text. (BIG)
Small text. (SMALL)
Subscripted (SUB)
Superscripted (SUP)
Nothing (to clear current markup)
gadget:

il testo attualmente selezionato.

Le possibilita’ sono:

- <H1> Font larghissimo,

- <H2> Font largo, in neretto.
- <H3> Font largo, in corsivo.

in neretto.

alla voce

possibile cambiare le dimensioni del font per
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- <H4> Font normale, in neretto.
- <H5> Font normale, in corsivo.
- <H6> Font piccolo.

C'e’ da dire che queste definizioni sono solo un’ indicazione, dipende
da come 1l browser e i1l suo sistema e’ settato, percui il testo puo’

apparire diverso in ciascun sistema.

Per default, MWM imposta a 5 (H5) tale wvalore che puo’ essere

modificato selezionando il gadget "PREFS" alla voce "HTML defaults".
- "Align" gadget:
Questo gadget e’ usato per specificare 1l’allineamento per 1’heading.
- Left;
- Center;
- Right;
- Justify;
— "OK" gadget:
Conferma 1’azione e inserisce 1’oggetto nel buffer.
— "Cancel" gadget:
Chiude la finestra senza modifiche..
— "Delete" gadget:
Permette di cancellare 1’oggetto che si sta editando..
Se si rende necessario ritoccare un oggetto di tipo TESTO, e’ sufficiente

clickare sul gadget "TEXT" quando il suddetto oggetto e’ selezionato
(oppure un doppio click con il tasto sinistro del mouse su di esso).

1.5 MWM.guide/Secondo gadget IMAGE

IMAGE gadget

Con questa azione si intende _SOSTITUIRE_ il testo selezionato con una
immagine.

MWM aprira’ una finestra con i seguenti gadget:
— "Choose" gadget:
Un requester vi permettera’ di selezionare 1’immagine desiderata.
- "Alt" gadget:

Qui e’ possibile definire il testo alternativo (ALT) per la
immagine selezionata.

- "Type" gadget:
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Con questo gadget si definisce il tipo di immagine:

- Simple; semplice.
- Map; di tipo mappa.

- Link to current;
- Link to another;
- Link to a site;

- "Align" gadget:

(vedere TEXT Gadget, dietro)
(vedere TEXT Gadget, dietro)
(vedere TEXT Gadget, dietro)

Qui si puo’ definire 1l’allineamneto dell’immagine con 1l’eventuale

testo:

- TOP
— MIDDLE
— BOTTOM

- "Link" gadget:

— "Label" gadget:
— "URI" gadget:

- "Site" gadget:

- "OK" gadget:

- "Cancel" gadget:
— "Delete" gadget:

(vedere
(vedere
(vedere
(vedere
(vedere
(vedere
(vedere

TEXT
TEXT
TEXT
TEXT
TEXT
TEXT
TEXT

Gadget, dietro)
Gadget, dietro)
Gadget, dietro)
Gadget, dietro)
Gadget, dietro)
Gadget, dietro)
Gadget, dietro)

Se si rende necessario ritoccare un oggetto di tipo IMMAGINE, e’

sufficiente clickare

sul

gadget

"IMAGE" quando 11 suddetto oggetto e’

selezionato (oppure un doppio click con il tasto sinistro del mouse

su di esso).

1.6 MWM.guide/Terzo gadget LIST

LIST gadget

Questa azione vi permette di trasformare il testo selezionato in una lista.

MWM aprira’ una finestra con i seguenti gadget:

- "Type" gadget:

- Semplice (unnumbered), del

* fa caldo
* fa freddo
* piove

tipo:

Per la lista non numerata e’ possibile anche definire il tipo di

bullet come disc,

— Numerata (numbered),

del ti

circle oppure square.

po:

1- Non bere se devi guidare
2- Non guidare se hai bevuto
3- Il cappuccino e’

piu’

buono della birra
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4—- I1 latte e’ finito, datemi una birra!

Per la lista numerata e’ possibile definire il tipo di numerazione
che puo’ essere del tipo roman, alphanumeric oppure arabic.

- Definita (definition), del tipo:
Colori
rosso
verde
blu
Planetario
Mercurio
Marte
Terra
Giove
- "Add image" e "Add text" gadgets:
Questa azione permette di applicare un oggetto di tipo "TESTO"
o di tipo "IMMAGINE" all’ elemento della lista visualizzato nel gadget
in basso.

— "Compact" gadget:

Se attivo, permette di stabilire che il browser deve visualizzare
la lista in modo compatto <UL COMPACT>.

- "Plain" gadget:

Se attivo, permette di stabilire che il browser deve visualizzare
la lista ’unnumbered’ senza i classici pallini <UL PLAIN>.

— "Continue" gadget:

Stabilisce che la lista numerata deve continuare con la numerazione a
partire dalla fine della precedente <OL CONTINUE>.

- "Starting from (START)" gadget:
Imposta i1l numero con il quale la lista numerata deve cominciare la
numerazione <OL START=n>.
Usabile solo se il gadget "Continue" non e’ selezionato.
- "<LH> Header" gadget:
Usato per definire il titolo della lista.

— "Bullet/Number"" gadget:

Per la lista non numerata e’ possibile definire il tipo di bullet come
disc, circle oppure square.
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Per la lista numerata e’ possibile definire il tipo di numerazione che
puo’ essere del tipo roman, alphanumeric oppure arabic.

Questo e’ un esempio di una lista numerata con una numerazione del
tipo "roman":

<OL TYPE="I">

<LI> First...

<LI> Second...

<LI> Third...

<LI> Some other things...
</0OL>

questa verra’ visualizzata dal browser piu’ o meno nel modo seguente:
I First...
IT Second...
IITI Third...
IV Some other things...

- "Prev" e "Next" gadgets:

Questi due gadget permettono di muoversi linea per line all’interno
della lista per potervi applicare un testo o una immagine.

— "OK" gadget: (vedere TEXT Gadget, dietro)
— "Cancel" gadget: (vedere TEXT Gadget, dietro)

— "Delete" gadget:
Permette di cancellare la lista attualmente editata.
Se la 1lista contiene oggetti di tipo testo o immagine un requester
chiedera’ se si desidera cancellare solo la lista lasciando inalterati
i suddetti oggetti, o cancellare tutto.
Se si rende necessario ritoccare un oggetto di tipo LISTA, e’ sufficiente

clickare sul gadget "LIST" quando il suddetto oggetto e’ selezionato
(oppure un doppio click con il tasto sinistro del mouse su di esso).

1.7 MWM.guide/Quarto gadget FORM

FORM gadget
Questa azione e’ composta da due passi:

nel primo si dovra’ definire la parte di testo che fara’ parte del form.
MWM aprira’ una finestra con i seguenti gadget:

— "Method" gadget:

- GET
- POST

— "Action" gadget:
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Dopo
poss

Con questo gadget si puo’ specificare 1’ azione (ACTION) del form, che
e’ una specifica URL. L’ azione sara’ del tipo: "http://x/y/sample".

questo primo passo noterete che il testo cambia colore ma e’ ancora
ibile (a differenza di tutti gli altri tipi di oggetti) selezionare una

o piu’ linee all’ interno del blocco del form.

Nel

secondo passo sara’ possibile definire i vari componenti del form.

La stessa azione fara’ aprire a MWM una finestra con i seguenti gadget:

"Type" gadget:

— Plain text; e’ un semplice testo
Il testo selezionato sara’ interpretato come un semplice testo,
utile per inserire descrizioni agli oggetti piu’ importanti.

- INPUT;

- List of INPUTs; e’ una lista di INPUT:
Non funzionante se si sta lavorando con la finestra per la
singola linea.
Tutti gli INPUT da definire saranno inclusi in una lista.

"Input" gadget:
Questo gadget contiene i seguenti tipi di INPUT:

Text, Password, Checkbox, Radio, Range, Scribble,
File, Hidden, Submit, Image, Reset e Textarea.

Scegliendo il numero 4 (RADIO), MWM controllera’ se il gadget
"Same RADIO group" e’ selezionato o meno.

Se lo e’, allora il gruppo di INPUT del tipo RADIO che

si stanno creando avranno lo stesso campo e gquindi, una volta creato

il file HTML, Mosaic (o chi per lui) costruira’ i gadget di tipo
RADIO accertandosi che uno e solo uno possa essere selezionato dallo
user.

"Name" gadget:
Con questo si puo’ specificare il campo NAME di un INPUT.
"Value" gadget:

COn questo si specifica il valore di default, o quello iniziale, del
campo VALUE di un INPUT.

"Width" e "Max" gadgets:
Con questi gadget si definiscono la dimensione in caratteri e il
massimo numero di caratteri permessi per gli input di tipo TEXT e
PASSWORD.

"From", "To", "Value" gadgets:

Se si sta creando un input di tipo RANGE, tutti questi tre gadget
saranno abilitati per definire i rispettivi campi dell’ input.
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- "Rows" e "Cols" gadgets:

Con questi gadget le dimensioni in caratteri per 1’elemento TEXTAREA
— "Accept" gadget:

Usato per definire il campo ACCEPT dell’ input di tipo FILE.
— "Source" gadget:

Usato per definire il campo SRC per tutti gli input che lo richiedano.
- "Next" e "prev" gadgets:

Disattivati se il gadget "Same Radio group" non e’ selezionato.

Altrimenti wutili per definire i campi VALUE e SELECTED per ogni
elemento del gruppo di gadget del tipo RADIO.

— "OK" gadget: (vedere TEXT Gadget, dietro)
— "Cancel" gadget: (vedere TEXT Gadget, dietro)
— "Delete" gadget: (vedere TEXT Gadget, dietro)

Ogni elemento del form (esclusi quelli inseriti in una lista) sara’ salvato
nel file HTML prefissato con la stringa <P> che serve a separare il testo
riga per riga.

Per 1inserire due o piu’ elementi del form nella stessa linea e’ possibile
fare un doppio <click su wuna linea ed editarla con la finestra per la

singola linea.

Se si rende necessario ritoccare un oggetto di tipo FORM, e’ sufficiente
clickare sul gadget "FORM" quando il suddetto oggetto e’ selezionato.

1.8 MWM.guide/Quinto gadget MORE

MORE gadget

MWM considerera’ la prima linea selezionata chiedendo cosa
dovra’ farci. Le possibilita’ sono:

— Insert label here <ID>) for hyperlinks;

(
— Insert comment here (<l== ==>);
— Insert empty line. (<P>)
— Insert horizontal graphic line (<HR>) .

1.9 MWM.guide/Sesto gadget HEAD

HEAD gadget

Con questa azione si intende specificare che la parte di testo selezionata
e’ 1’ HEAD (la testa) del file HTML.
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MWM aprira’ una finestra con i seguenti gadget:
- "Title" gadget:
Usato per definire il titolo <TITLE> del documento.
— "Description" gadget:
Permette a MWM di inserire, ad esempio, la seguente linea:
<META NAME="description" CONTENT="We are the world!">
— "Choose" gadget:
Usato per definire un banner fisso:
<LINK REL=BANNER HREF="/Work:Docs/a.html">
Se questo gadget viene selezionato e nessun testo e’ attualmente caricato
nella finestra principale, allora MWM chiedera’ se <cio’ non abbia

importanza e, se cosi’ e’, creera’ automaticamente una linea di testo (la
prima) dove potra’ memorizzare le informazioni del HEAD.

Se si rende necessario ritoccare un oggetto di tipo HEAD, e’ sufficiente

clickare sul gadget "HEAD" guando il suddetto oggetto e’ selezionato.

1.10 MWM.guide/Settimo gadget CENTER

CENTER gadget

Questa azione permette di centrare tutto il testo selezionato <CENTER>.

1.11 "

FONT gadget

Con questa azione si ha a disposizione un modo alternativo per modificare
le dimensioni e il colore del testo, per esempio

<FONT SIZE="+1" COLOR="#00FFFF" Hello world! </FONT>

112 "

CUT gadget

La stessa azione dello item "Cut" del menu "Edit".
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1.13 "

SEARCH gadget

La stessa azione dello item "Search" del menu "Edit".

1.14 "

EDIT gadget

La stessa azione dello item "Adjust selected lines" del menu "Edit".

1.15 MWM.qguide/Ottavo gadget VIEW

VIEW gadget
Questa azione vi permette di chiamare un programma tipo Mosaic per vedere
in gqualunque momento il lavoro finale.
Il programma da chiamare e’ definito usando il gadget

"PREFS" alla voce "Browser"

E’ possibile aprire MWM ed il vostro browser preferito usando lo stesso
schermo pubblico.

1.16 MWM.guide/Nono gadget PREFS

PREFS gadget
Questa azione mostrera’ la seqguente lista di possibilita’:
GUI:
— Screen
Si puo’ scegliere se aprire lo schermo pubblico di MWM nei modi:
Default | Named | Owner

Se si sceglie il modo "Default", MWM aprira’ tutte le sue
finestre sullo schermo pubblico di default (Workbench).

Se si sceglie il modo "Named", MWM vi chiedera’ con un
requester i1l nome dello schermo pubblico su cui aprire le
finestre.

Se si sceglie il modo "Owner", MWM vi chiedera’ con un
requester il tipo di risoluzione del suo schermo personale,
che sara’ ugualmente pubblico ma con 1’appropriata palette di
colori.
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- Font
Cambia il font nella finestra principale.
Default paths:

- ASCII texts
Per definire un path comune a tutti i testi.

- Images
Per definire un path comune a tutte le immagini.

- Work dir
Per definire la directory di lavoro (ex: RAM:T).

Log window:

- Log Window
Permette di personalizzare la finestra di aiuto.

- Log Level
MWM mette a disposizione tre livelli di informazioni:

- None, ovvero nulla se non l’essenziale.
— Medium, descrizione sommaria dell’ oggetto selezionato.
— High, informazione dettagliata.

Utils:

— Browser
Per scegliere i1l programma che dovra’ effettuare il preview.

- Sites 1list
Per scegliere i1 file contenente la lista dei siti.

HTML defaults:

— Headings size;
Quando viene caricato un normale file di testo ASCII, MWM
assegna ad ogni linea un valore pari a zero (default)
percui, se <c’e’ Dbisogno di cambiare il valore di default
per gli headings, MWM salvera’ il valore selezionato al
posto di zero.

Per cambiare questo valore standard e’ necessario
scegliere uno fra "H1 H2 H3 H4 HS5 H6" nella listview.

- BR as EOL
Se attivo, MWM inserira’ la parola chiave <BR> alla fine di ogni linea
cosi’ il testo verra’ salvato rispettando il piu’ possibile
1’ impaginazione mostrata nella finestra principale.

— FONT versus Heading

I1 suo scopo e’ quello di prevenire un possibile conflitto tra
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FONT e Heading.
Si puo’ scegliere tra queste opzioni:

— Only FONT ; 1’ heading verra’ ignorato
— Only heading ; FONT verra’ ignorato
- Mixed (default) ; entrambi verranno scritti

Other

- OK + autosave
Se attivo, MWM salvera’ automaticamente il lavoro nel formato HTML
ogni volta che il gadget "OK" nelle finestre Text, Image, List e Form
verra’ clickato.
Se si sta lavorando con il preview, allora sara’ sufficiente dire al

browser di operare un reload del file automaticamente agiornato da MWM.

1.17 MWNM.guide/La finestra per la singola linea

LA FINESTRA PER LA SINGOLA LINEA.

Selezionando con un doppio click una qualsiasi linea del testo nella finestra
principale, si aprira’ la finestra per la singola linea che permettera’
all’” utente di MWM di editare piu’ in dettaglio il testo.

Qui e’ possibile inserire testi, immagini e input.

Se la 1linea editata non fa parte di un form, allora solo i1 gadget TEXT e
IMAGE saranno disponobili all’uso, altrimenti solo il gadget FORM.

Sono disponibili anche in questa finestra i tasti speciali F1l, F2 e F4 per
queste tre funzioni.

MWM permette qui di usare entrambi i tasti del mouse (sinistro e destro):
* Tasto sinistro:
- clickando e trascinando il puntatore si seleziona parte della
riga da editare;
- con un doppio click su un oggetto gia’ creato, MWM aprira’ la
finestra corrispondente di quell’oggetto;
* Tasto destro:
- se si clicka in un oggetto gia’ esistente, 1l’effetto e’ identico
al doppio click del tasto sinistro altrimenti verra’ selezionata
1’ intera parola al di sotto del puntatore;

— se si clicka fuori della finestra, la finestra per la singola
linea verra’ automaticamente chiusa (anche con il tasto ESC).

1.18 MWM.guide/La finestra di aiuto

LA FINESTRA DI AIUTO.
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Selezionando un oggetto nella finestra principale si notano dei dati che
vengono visualizzati in un’ altra finestra: la finestra di aiuto.

Questa finestra vi dara’ tutte le informazioni contenute negli oggetti:
il numero, il tipo, il path di immagini e testi, le label a cui punta

ed altro ancora.

I1 livello di tali informazioni si puo’ definire selezionando il gadget
"PREFS", scegliendo la voce "Log level".

1.19 MWM.guide/La finestra ” What is? ~

LA FINESTRA "What Is ?".

Questa finestra e’ un supplemento alla finestra di aiuto e si trova alla
immediata
sinistra della finestra principale.

La funzione di questa finestra e’ essenzialmente quella di dare un immediato

commento

H

a tutti gli oggetti creati collaborando con la differenziazione dei colori del

testo per ognuno di essi.

Esempio:
fom e +
| What is? || MWM Edit Window
Fom—m e +
| e e | Uninitialized text
txt Hn X Initialized Text
txt->in Text linked to current document
txt->out Text linked to another document

Text linked to a site

Simple image

Image linked to current document
Image linked to another document
Image linked to a site

txt->site
img simple
img->in
img->out
img->site

| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| Text of the <FORM> block

| |
| |
| |
| |
| |
| |
| |
| |
| |
| |
| |

| |

| |

| |

| |

| |

| |

| |

| |

| img map || Map image

| head | Text of the <HEAD> block

| Form type |

| preformat | Preformatted text <PRE>

| address || Text of the <ADDRESS> block

| paragraph || Paragraph text <P>

| Multi obj || Text including more objects

| Label || There is a label <ID>

| Comment | There is a comment <!—— ... ——>
| Lab & Com || There is both label and comment
| break || There is a break <BR>

| line | There is an horizontal rule <HR>
| font n || There is a FONT

| centered | There is a centered text <CENTER>
fom e e +

Descrizione:
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Con il tasto del e’ possibile aprire o chiudere questa finestra.

1.20

Hn = Heading da <H1> a <H6>, <HD> per il valore di default.

X = Allineamento: L LEFT, C = CENTER, R = RIGHT, J =
type = Form method GET o POST
n = Size of font

MWM.guide/ll menu

IL MENU

Nella finestra principale e’ possibile usare un menu con le

JUSTIFY

seguenti voci:

Project Edit Special Action

Load plain Text Cut Insert label Text
HTML save Copy Go to label Image
HTML save as... Paste Mark location 1 List
Load project Search new Mark location 2 Form
Save project Search again Mark location 3 More
Delete all Adjust sel lines Jump to mark 1 Head
Help keys Jump to mark 2 Center

About Jump to mark 3 Preview

Quit Jump to next TEXT Prefs

1.21

1.22

Jump to next IMAGE
Jump to next LIST
Jump to next FORM

MWM.guide/Project->Load text

Delete all

Cancella tutto il lavoro o solo tutti gli oggetti.
(Usare con cautelal)

MWM.guide/Project->Load plain text

Load plain text
Permette di caricare un normale file di testo ASCII.

Se un testo e’ gia’ stato caricato, MWM vi chiedera’
precedente o accodare il nuovo al wvecchio.

- Replace

— Insert to the beginning;

— Insert to the end;

Insert after the first selected line.

se cancellare il
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1.23 MWM.guide/Project->keys

Tasti speciali

Se 11 testo e’ piu’ lungo o piu’ largo della capacita’ della finestra, lo si

puo’ scrollare sia con i gadget della finestra, sia con i tasti frecce.

I tasti frecce, da soli, scrollano di wuna linea o di una colonna.

sciftati, scrollano wuna pagina su / giu’ / destra / sinistra. Premendo il
tasto alt con i tasti frecce il testo si posizionera’ a inizio / fine oppure
tutto a sinistra / destra. Con 11 tasto control, invece, le frecce

serviranno per dimensionare la finestra principale.

I1 tasto help apre o chiude la finestra di Log.

Il tasto del apre o chiude la finestra "What is?".

Il tasto enter permette di editare la prima linea selezionata.

I1 tasto return inserisce una linea vuota nel testo.

1.24 MWM.qguide/Project->HTML save

HTML save
Salva automaticamente il lavoro nello stesso file HTML oppure, se
non precedentemente definito, dquesta azione aprira’ la finestra
Save come descritto di seguito.
Se il modo "OK + autosave" delle preferenze e’ attivo, questa
funzione verra’ anche eseguita automaticamente ogni volta che il

gadget "OK" viene selezionato nelle finestre Text, Image, List e
Form.

1.25 MWM.guide/Project->HTML save as...

HTML save as...
Permette di salvare il lavoro creando il file HTML.
Questa azione aprira’ la finestra Save con questi gadget:
"Background" gadget:

Puo’ essere usato per specificare 1’immagine che dovra’
riempire il backround del file HTML.

"BGColor" gadget:
Definisce il colore del background.

"Text" gadget:
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Definisce il colore del testo del documento.
"Link" gadget:

Specifies the color used to stroke the text for unvisited
hypertextlinks at the moment the user clicks on the link.

"VLink" gadget:

Specifies the color used to stroke the text for visited
hypertext links.

"ALink" gadget:

Specifies the highlight color wused to stroke the text for
hypertext links at the moment the user clicks on the link.

"Save ALL text" gadget:

Tutto 11 testo presente nella finestra principale deve essere
salvato nel file HTML.

"Save only INITIALIZED text" gadget:

Solo gli oggetti «creati nella finestra principale dovranno
essere salvati, tutto il resto verra’ ignorato.

"Cancel" gadget:

Ritorna senza nulla di fatto alla finestra principale.

1.26 MWM.qguide/Project->Load project

Load project

Carica un lavoro precedentemente salvato.

1.27 MWM.guide/Project->Save project

Save project
Salva 1’ intero lavoro in un file in modo da poterlo richiamare e <

continuare
a lavorare dal punto in cui lo si era lasciato.

1.28 MWM.guide/Project->About

About

Informazioni riguardanti 1’ ideatore ed il creatore di MWM.
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1.29 MWM.guide/Project->Quit
Quit
Fine del lavoro.

MWM salvera’ le preferences e la posizione/dimensione della
finestra principale nel file "MWM.prefs" in ENV: ed in ENVARC:.

1.30 MWM.guide/Edit->Cut

Cut
Questa azione permette di eliminare completamente le linee selezionate
oppure solamente le informazioni create per esse.

Se le si eliminano completamente, allora il testo cancellato verra’
copiato in clipboard.

1.31 MWM.guide/Edit->Copy

Copy

Questa azione copia le linee selezionate in clipboard.

1.32 MWM.qguide/Edit->Paste

Paste

per 1inserire 1l testo contenuto nella clipboard a partire dalla
prima linea selezionata.

Se state usando (per esempio) KCON: per la finestra di log,
potete scrivere «cio’ che volete in questa finestra, selezionare
tutto 11 testo con 1l mouse e premere "Amiga+C" per copiare il
tutto in clipboard.

RICORDATE: premete return dopo 1’ ultima riga altrimenti la
console rimarra’ occupata e MWM non potra’ mandare
messaggi.

Dopo, selezionate la finestra principale di MWM e premete

"Amiga+V".

Questo funzionera’ anche con le commodities ConClip e ConPaste.

1.33 MWM.qguide/Edit->Search new

Search new

Cerca una nuova stringa nel testo.
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1.34 MWM.qguide/Edit->Search again

Search again

Cerca la stessa stringa nel testo.

1.35 MWM.guide/Edit->Adjust selected lines

Edit selected lines
Questa azione permette di editare tutte le linee selezionate.
Se la linea selezionata non e’ un multi object, non verranno modificati
in alcun modo gli oggetti creati precedentemente.

Altrimenti, se c’e’ realmente il bisogno di modificarla, tutti gli
oggetti in essa contenuti dovranno essere cancellati.

1.36 MWM.guide/Cosa puo’ fare MWM ?

COSA PUO’ FARE MWM ?
MWM e’ in grado di gestire le seguenti cose:

— HEAD LINK REL=Banner
META NAME="generator/description/author" CONTENT="..."

- TITLE

— BODY BACKGROUND="..." BGCOLOR="#color" TEXT="#color"
LINK="#color" VLINK="#color" ALINK="#color"

— ADDRESS

— CENTER

— FONT SIZE="n" COLOR="#color"

— A HREF="...#..."

- A ID="..."

- IMG ISMAP ALIGN=TOP|MIDDLE|BOTTOM SRC="..." ALT="..."

- UL TYPE="disc|circle|square" COMPACT PLAIN LH LI
- OL TYPE="Ala|I|i]1l" COMPACT CONTINUE SEQNUM=n LH LI
- DL COMPACT LH DT DD

- <!-— comment -->

- BR

- HR

— P ALIGN=LEFT|CENTER|RIGHT|JUSTIFY

- CITE

— CODE

- EM

- STRONG

— AUTHOR

— PERSON

- SAMP

- KBD

- VAR

— DFN

- Q

— ACRONYM
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— ABBREV

— INS

- DEL

- B

- I

- TT

- U

- S

- BIG

- SMALL

- SUB

- SUP

- &1lt; &gt; &amp; &quot;
&Racute; &Agrave; &Acirc; &Atilde; &Aring; &Auml; &AElig; &Ccedil;
&Eacute; &Egrave; &Ecirc; &Euml; &Iacute; &Igrave; &Icirc; &Iuml;
&ETH; &Ntilde; &Oacute; &Ograve; &Ocirc; &0Otilde; &Ouml; &Oslash;
&Uacute; &Ugrave; &Ucirc; &Uuml; &Yacute; &THORN;
&szlig; &aacute; &agrave; &acirc; &atilde; &atilde; &auml; &aelig;
&ccedil; &eacute; &egrave; &ecirc; &euml; &iacute; &igrave; &icirc;
&iuml; &eth; &ntilde; &oacute; &ograve; &ocirc; &otilde; &ouml;
&oslash; &uacute; &ugrave; &ucirc; &uuml; &yacute; &yuml; &thorn;

- URL for the links

- FORM METHOD=GET |POST

— INPUT TYPE=TEXT|PASSWORD | CHECKBOX|RADIO |RANGE | SCRIBBLE |FILE|HIDDEN |

SUBMIT | IMAGE | RESET
TEXTAREA
NAME, VALUE, SIZE, MAXLENGTH, CHECKED, MIN, MAX, SRC, ACCEPT
- List of INPUTs
- Headings: <H1|H2|H3|H4|H5|H6 ALIGN=LEFT|CENTER|RIGHT|JUSTIFY>

1.37 MWM.guide/Informazioni generali

INFORMAZIONI GENERALT

Questo programma e’ stato studiato seguendo il piu’ possibile le
specifiche della documentazione di Wilbur HTML 3.2.

MWM richiede un sistema operativo dal 3.0 in poi.
MWM lavora con le librerie gadtools e regtools.
Questa versione e’ assolutamente Copyright ©1996-97 Massimo Baglione.

Se ti piace gquesto programma e hai bisogno di tutte le funzioni
disabilitate, puoi spedirmi 40.000 lire italiane al seguente indirizzo:

Massimo Baglione

Via Della Chiesa 1

67019 Civitatomassa
Scoppito L’ AQUILA (Italy)

specificando dove posso mandare il programma completamente funzionante.

Per qualunque consiglio, critica o idea riguardo MWM, contattate subito:
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Massimo Baglione Maurizio Fabiani
(MAUI for Amiga BBS)

39:102/1.5 AmigaNet 39:102/1

39:102/2.5 39:102/2
2:335/602.5 FidoNet 2:335/602
2:335/607.5 2:335/607

InterNet
(Maurizio Fabiani) maui@mbox.vol.it

1.38 MWM.guide/Ringraziamenti

RINGRAZIAMENTI

Devo ringraziare tutti 1 miei betatester per il loro ottimo bug report

riguardo MWM. In particolare, voglio citare:

Troy Bouchard, Mel Greer, Alessandro Di Michele, Kirk Strauser,
Girish V Nath, Paul Stevens.

e, per tutto cio’ che riguarda il resto dello sviluppo di MWM:

Jeff Lavin per il suo grande aiuto riguardo il doc inglese!
David Putzier per il suo fantastico MWMlogo.iff ...check it Out!
Pierluigi Sferrella per il manuale italiano in formato amigaguide.
Mike Handley per il manuale inglese in formato amigaguide.
Wolfgang G. Wettach per il manuale in tedesco.

Poi, un grande bacio (!) lo mando al mio Boss (Maurizio Fabiani) per la

sua infinita pazienza!

L’ ultimo ringraziamento e’ riservato ad Amiga:
(tutti insieme) ...GRAZIE AMIGA!

_____ +_____
-=> % \X/ Amiga! \X/ MAUI BBS! \X/ Love and Beer! x <=-
_The revenge of the italian products_

...enjoy this program!!!

1.39 MWM.guide/Storia di MWM

Novita’ implementate in questa ultima versione di MWM:

-MWM v. 3.11 Mar 12 1997
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—-MWM

-MWM

1.40
ci

1>

2>

Adjusted a little conflict between FONT and Headings.

Added "FONT versus Heading" gadget in Prefs window.

This gadget lets you choose if you need to write only FONT, only Headings
or both (default).

Some internal optimizations.

v. 3.10 Feb 24 1997
Little adjustements.
v. 3.00 Feb 19 1997

Updated to Wilbur - HTML 3.2.
MWM 3.00 will only load the old projects done by MWM 2.12;
previous versions may cause problems!
To update your projects (starting with "WORK_MWM _NEW_4") Jjust load and
resave with MwM 3.00.
Added "Jump to next TEXT/IMAGE/LIST/FORM" items to "Special" menu.
These actions will start a search for the specific object starting from
the next line after the last selected line. (Useful, I think !).
Added "author" for META.
Added "Bullet/Number" gadget in List window.
This action allows you to specify the bullet type (disc, circle, square)
for UL or the numbering method (arabic, alphanumeric, roman) for OL.
Updated OL’s attribute SEQNUM to START.
Changed "Choose" gadget type into "IMAGE window" from text to string.
Changed "Font" text on "TEXT window" to "Heading".
Added FONT tool gadget into "Main window".
With this feature you have an alternative way to modify the text size
and the respective color, for example:

<FONT SIZE="+1" COLOR="#00FFFF" Hello world! </FONT>
If possible, the "What is?" window will show a little information
where the FONT was inserted.
Added CUT, SEARCH and EDIT tool gadgets into "Main window".
Added "Insert label" item to "Special" menu.
Improved gui for "Load text" if another text was loaded.

MWM.guide/Addendum

ao!

Un appunto per il manuale in tedesco tradotto da Wolfgang G. Wettach:

probabilmente il suo lavoro non verra’ agiornato dal sottoscritto
ogni volta che uscira’ una nuova versione di MWM, quindi il
manuale in tedesco e’ valido solo per la versione 2.00.

Provate a caricare 11 file "MWM_eng_HTML.project" incluso in questo
archivio!

E’ il progetto della versione HTML del manuale in inglese.
L"ho incluso per i nuovi utenti di MWM che non hanno le idee chiare
sul funzionamento del programma.
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Grazie di usare MWM!
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