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The Voxel Analyst Window
To tour the Voxel Analyst window, click each area of the window.    When you are finished, click 
again to return to the window.

Manipulating the Window
You can move the Voxel Analyst window, or any of the views, dialog boxes, and toolbars by 
placing the pointer over the title bar and dragging it to a new location.    The Voxel Analyst 
window and views can be manipulated the same as other Windows windows.    To resize the 
window, or a view, drag the border in any direction until the window or view is the size you 
want.

You can also use the commands on the Window Control pull-down menu to control the views.



EXAMPLE

NOTE Double-clicking the Window-Control box on the Voxel Analyst window, or selecting 
Close from it, closes the window and exits Voxel Analyst.

SEE ALSO

S  ELECTING   C  OMMANDS   
U  SING   D  IALOG   B  OXES   



Selecting Commands
Voxel Analyst provides several ways to select commands.    Selecting a command results in some 
action, such as opening a dialog box, turning a mode on (or off), or changing a setting. 

Using Menu Bar Items
Until you become familiar with the Voxel Analyst toolbars, the easiest way to select a command 
is to select a series of items from the menu bar using the left mouse button. 

A menu item followed by a right arrow means that a submenu containing more items follows that 
menu.

EXAMPLE

NOTE    In this guide and in Voxel Analyst Help, a series of menu items is indicated by one or 
more greater than symbols.    For example, File > Open > Dataset means to select Open from the 
File menu, and then select Dataset from the Open menu.

NOTE    If your mouse has been reconfigured so that the button functions are reversed, the left 
mouse button is the right button, and vice versa.

A check mark beside a menu item means that a mode is on or a command has been set.



EXAMPLE

A command name followed by an ellipsis (...) opens a dialog box that requires input from you to 
make the command work.

EXAMPLE

A command that appears dimmed cannot be selected.



EXAMPLE

Using Shortcut Keys
Shortcut keys let you select commands by pressing letter keys on the keyboard.    In each menu 
item, the shortcut key letters are underscored.    To use shortcut keys, press the ALT key followed 
by the letter keys.

EXAMPLE

ALT+f,o,d is the same as File > Open > Dataset.

Using Toolbar Icons
The most frequently used commands appear as icons on toolbars.    To see the corresponding 
command name, move the pointer over the icon; the command name appears.

EXAMPLE

You can toggle the display of a toolbar by clicking the corresonding icon from the Tools toolbar, 
or by selecting the name of the toolbar from the Tools menu.

EXAMPLE

is the same as Tools >View Control Bar (or ALT+t,v).

SEE ALSO

T  HE   V  OXEL   A  NALYST   W  INDOW   
U  SING   D  IALOG   B  OXES   



Using Dialog Boxes
Dialog boxes let you interact with the software.    You may need to use any number of dialog box 
controls, such as text boxes, options, lists, and buttons, to supply the necessary information.

To type information, click the text box where you want to start and begin typing.      If the text 
box contains highlighted text, just begin typing; by default, the characters you type replace the 
highlighted text.

To select an item from a list, click the drop-down arrow to display the list, or use the scroll bar to 
find the item you want.    For more information, see the Microsoft Windows documentation.

SEE ALSO

T  HE   V  OXEL   A  NALYST   W  INDOW   
S  ELECTING   C  OMMANDS   



 



What is a Session?
A session is a convenient way to store the work you have done in Voxel Analyst.    Included in a 
saved session are any datasets you have opened and any color tables and graphic displays you 
have created.

You can recall a saved session for use later on, and you can create multiple sessions.    This is 
particularly useful when working with multiple projects (one project per session). 

IMPORTANT        When you save a session, the datasets, color tables, and graphic displays are 
saved; view setup information is not saved in the session file.

SEE ALSO

C  REATING     A   N  EW   S  ESSION   
O  PENING     A   S  AVED   S  ESSION   
S  AVING     A   S  ESSION   



Creating a New Session
You can create a new session at any time while working in Voxel Analyst.    When you create a 
new session, the current session is replaced by a new session, and any graphic displays you have 
created are replaced by a new empty view.

To create a new session:

Click  on the Toolbar (or select File > New).

SEE ALSO

W  HAT     IS     A   S  ESSION  ? 
O  PENING     A   S  AVED   S  ESSION   
S  AVING     A   S  ESSION   



Opening a Saved Session
Each time you start Voxel Analyst, a new empty session (default.gva) is automatically opened.    
But you can open any previously saved session, and return to working in that session.

TIP        Session files have a .gva extension.    They can reside in any directory or on any drive.

To open a session file in the current directory:

1. Click  on the Toolbar (or select File > Open > Session). 

2. In the File Name text box, type the name of the session file you want to open or select a 
session file name from the list below the File Name text box.

3. Click OK.

In a different directory:
In the Directories list, double click the directory name, and then double click the session file 
name you want to open.

On a different drive:
Select the drive letter from the Drives drop-down list, double click the directory name, and then 
double click the session file name you want to open.

On a networked drive:
Click Network to open the Connect to Network dialog box and connect as you normally would. 
Then double click the directory name and the session file name you want to open.

SEE ALSO

W  HAT     IS     A   S  ESSION  ? 
C  REATING     A   N  EW   S  ESSION   
S  AVING     A   S  ESSION   



Saving a Session
You can save a session to a file anytime while working in Voxel Analyst.    Session files can be 
saved to any directory or drive on your workstation or to any drive/directory on a network 
workstation.

TIP        If you make changes to the current session and exit Voxel Analyst without first saving the 
session, the Save GVA File automatically appears.

To save a session to a file:

1. Click  on the Toolbar (or select File > Save As > Session). 

2. Do you want to create a new file?
· If yes, in the File Name text box, type a new file name (without the extension).
· If no, type the name of an existing file or select a file from the list below the File Name text 

box.
3. Click OK.

SEE ALSO

W  HAT     IS     A   S  ESSION  ? 
C  REATING     A   N  EW   S  ESSION   
O  PENING     A   S  AVED   S  ESSION   

 



Title Bar
Displays the name of the current session.    Each time you start Voxel Analyst (or open a new 
session), the session name is default.gva.



File Menu

Open dataset, color, and session files;
save datasets, color tables, and sessions
to files; set up printing and print files;
import and export data; and exit Voxel
Analyst.



Edit Menu

Copy the entire screen
(or the contents of a fenced
area of the screen) to another
application, such as Clipboard.



Dataset Menu

Review dataset information, delete datasets,
extract datasets from other datasets, resample
datasets, define dataset grids, and edit dataset
attributes and geometries.



Color Table Menu

Create color tables; adjust
data ranges; copy, delete,
and edit color tables; edit
material properties and shading;
and set up and display legends.



Graphics Menu

Create graphics for displaying, manipulating,
and analyzing datasets (3-D volumes);
place graphic displays on different levels;
set the active display; and edit and delete
graphic displays.



View Control Menu

Toggle perspective and
orthogonal views; fit one
or all datasets to a view;
turn dynamics on/off; set
vantage point, target point,
view lighting, and z scale;
turn design elements on/off.



Analyze Menu

Calculate surface areas,
volumes, intersecting volumes,
and statistics; create histograms
and crossplot diagrams; and probe
datasets for values.



Utilities Menu

Define dataset working units; set preferences;
convert sparsely sampled data; convert ASCII-
formatted data to 3-D volumes (and vice versa);
set up and take snapshots; set up and view graphic
displays in stereo.



Tools Menu

Toggle the display
of Voxel Analyst toolbars.



Window Menu

Select standard Windows
commands.



Help Menu

Select standard Windows Help
commands.



Toolbar
Provides icons for frequently used commands, such as Open Session, Save As
Session, and Print.    By default, this bar also includes the Tools icons, which
let you toggle the display of other Voxel Analyst toolbars.

The menu and shortcut key equivalents for the Toolbar are:

File > New (ALT+f,n)

File > Open > Session (ALT+f,o,s)

File > Save As > Session (ALT+f,a,s)

Edit > Copy (ALT+e,c)

Edit > Fence Area (ALT+e,f) 

File > Print (ALT+f,p) 



Tools > View Control Bar (ALT+t,v)

Tools > Graphics Bar (ALT+t,g) 

Tools > Toolbar (ALT+t,t) 

Tools > Coordinate Bar > (ALT+t,c) 

Help > About Voxel Analyst (ALT+h,a)

To turn off the Toolbar, select Tools > Toolbar.



Utility Bar
Provides icons for the most frequently used Utilities commands.
The menu and shortcut key equivalents are:

Utilities > Snapshot > Active View (ALT+u,t)

Utilities > Preferences (ALT+u,p)

To turn off the Utility bar, select Tools > Utility Bar.



Graphics Bar
Provides icons for the most frequently used Graphics commands.
The menu and shortcut key equivalents are:

Graphics > Source Points (ALT+g,u)

Graphics > Outline (ALT+g,o)

Graphics > Boundary Grid (ALT+g,b)

Graphics > Solid (ALT+g,s)

Graphics > Chair (ALT+g,c)

Graphics > Iso-Solid (ALT+g,i)

Graphics > Iso-Surface (ALT+g,f)

Graphics > Envelope (ALT+g,v)

Graphics > Iso-Parametric (ALT+g,p)

Graphics > Cap (ALT+g,a)

Graphics > Cutting Plane (ALT+g,l)

To turn off the Graphics bar, select Tools > Graphics Bar.



View Control Bar
Provides icons for the most frequently used View Control commands.
The menu and shortcut key equivalents are:

View Control > Perspective (ALT+v,p)

View Control > Front (ALT+v,f)

View Control > Back (ALT+v,b)

View Control > Top (ALT+v,t)

View Control > Bottom (ALT+v,o)

View Control > Left (ALT+v,l)

View Control > Right (ALT+v,r)

View Control > Iso+ (ALT+v,i)

View Control > Iso- (ALT+v,s)

View Control > Fit Dataset (ALT+v,d)

View Control > Fit All (ALT+v,a)

View Control > Dynamics (ALT+v,y)

View Control > Levels (ALT+v,v)

View Control > Vantage Point (ALT+v,n)

View Control > Target (ALT+v,g)

View Control > Lighting (ALT+v,h)

View Control > Z Scale (ALT+v,z)

View Control > Design Elements (ALT+v,e)



To turn off the View Control bar, select Tools > View Control Bar.



Main View
The main Voxel Analyst view.    You can open additional views.    Views are used to create, 
manipulate, and analyze graphic displays of 3-D volume datasets.    Views can also be 
manipulated (moved, resized, minimized, and so on) the same as windows.

NOTE    When you exit Voxel Analyst, only the graphic displays and the related datasets and 
color tables are saved; view setup information is not saved. 



Coordinate Bar
Displays the XYZ coordinates of the active dataset.

To turn off the Coordinate bar, select Tools > Coordinate Bar.



Status Bar
Displays Voxel Analyst messages and processing information.

To turn off the Status bar, select Tools > Status Bar.
 



What is a Dataset?
Voxel Analyst can accept any dataset that contains X,Y,Z geometry and multiple data values.    A 
dataset can be a 3-D volume in the air, water, or ground.    The relationship of the data within the 
volume to the geography of a data site provides geographic referencing of the volume.

Volumes, Grids, and Voxels
A 3-D volume or dataset consists of geometry and data attributes.    The geometry specifies the 
site of each data point.    A data attribute is a collection of data values and has one value for each 
data point in the dataset.    A data value can be scalar, vector, or symbolic.

3-D grids are used to locate and reference the data points in 3-D volumes.    Each grid 
intersection is called a grid node.    Every grid node is uniquely identified by a triple of the 
integers or parameters (I,J,K), and has the 3-D coordinates X,Y,Z associated with it.

TIP        The coordinate of every grid node is X[I,J,K], Y[I,J,K], and Z[I,J,K].

Voxel Analyst supports uniform , regular , irregular , structured , and Semi-Structured grids.

A voxel is a 3-D sub-volume delineated by eight neighboing grid nodes.    Voxel means volume 
element in 3-D, as opposed to pixel, which means picture element in 2-D.    Voxels are the 
smallest elements in a 3-D volume.    A 3-D volume is composed of numerous voxels.

Data Types and Sources
Voxel Analyst can accept the following:

· ASCII data formatted as X, Y, Z, A1...A15.
· Any 2-D grids from another modeling package.
· Voxel Analyst-specific ASCII-formatted data (.adf) files that contain X, Y, Z geometry and 

data values.

IMPORTANT        Voxel Analyst ASCII-formatted data must be converted into Voxel Analysts 
Hierarchical Data File (HDF) format before loading into Voxel Analyst.    Horizon data can 
be loaded from either grid files or symbolic data files.    3-D volume dataset geometries and 
data fields can be derived from grid files or from Voxel Analyst ASCII-formatted data files.

· Any gridded data (.grd) file.
· Gridded HDF (.hdf) files.
· Voxel Analyst-specific ASCII-formatted data (.adf) 2-D grid files (including converted HDF 

files)
· Source point or sparsely sampled data (.smp) files.

IMPORTANT        Sparsely sampled data, such as well sample points, must be converted to 3-D 
volume datasets before loading into Voxel Analyst.    Algorithms are used to interpolate data 
in sparse datasets to create 3-D volume output.



· Design elements (AutoCad or MicroStation).

Data Input
The following diagram shows the possible paths for data input to Voxel Analyst:

Data Output
The output from Voxel Analyst includes the following:

· Snapshots ( and formats).
· Gridded HDF (.hdf) files.
· Voxel Analyst-compatible ASCII Data Format (ADF) 2-D grid files (converted from HDF 

files).
· Design elements

SEE ALSO

Importing Data 
Creating a New Dataset 
Opening a Saved Dataset 



Saving a Dataset
Deleting a Dataset 
Copying/Moving a Dataset File 
Exporting Data 



Importing Data
Voxel Analyst lets you import many types of data for creating 3-D volumes and datasets.

SEE ALSO

Importing Source Points 
What is a Dataset? 
Creating a New Dataset 
Opening a Saved Dataset 
Deleting a Dataset 
Copying/Moving a Dataset File 
Exporting Data 



Importing Source Points
You can import uninterpolated sparsely-distributed data from an ASCII sample points (.smp) file 
into Voxel Analyst, creating a new sample point dataset.    Then you can create a graphic display 
by using Graphics > Source Points.    This is useful for viewing sparsely sampled data in its 
original location within a data volume.

NOTE        The source points graphic display is the only graphic display you can create of a 
sample point dataset.

To import source points:
1. Select File > Import > Source Points.

2. Do you want to change the default dataset name?    If yes, type a new name.
3. Click Add File, select a source point file, and click OK.    (TIP        Source point files have an 

.smp extension, and they can reside in any directory, on any drve, or on any network 
drive/directory.)    The number of columns in the file, the number of points in each column, 
and the attribute names appear on the dialog box.

4. Do you want to import data from more than one file?    If yes, repeat Step 3 until you have 
added the files you need.

5. Do you want to import only specific data attributes?    If yes, select the attribute(s) to remove 
and click Remove Attr.

6. Do you want to remove a file from the input list?    If yes, select one of the attributes in the 
file and click Remove File.

7. Click OK to import the points.

SEE ALSO



Importing ASCII Data 
Importing Design Elements 
Importing Grid Geometry 
Importing Grid Attributes 
Importing Grid Layers (Horizons) 



Importing ASCII Data
You can import the geometry, data attributes, or horizons from a Voxel Analyst-compatible 

ASCII Data Format (ADF) file into Voxel Analyst, creating a new dataset.    This is useful for 
importing 2-D grid files output from other software. 

IMPORTANT        The ADF file must contain the following keywords to ensure proper orientation 
of the data:

· ATTRIBUTE MGVA_INDEX <0,1,[2]>    ---    Indicates the parametric index along which 
the data is listed:    0 = I, 1 = J, 2 = K.

· ATTRIBUTE MGVA_MAJOR <row[column]>    ---    Indicates the organization of the data 
within each layer.    By row, the data is interpreted row by row.    By column, the data in 
interpreted column by column.

· ATTRIBUTE MGVA_TYPE <[GRID]>    ---    Indicates the type of data (gridded only) to be 
imported.

· ATTRIBUTE <data field> [units]    ---    Lists the data fields and default units.
· POINT FORMAT STATEMENT    ---    Indicates the order of the information.    If no 

geographic location is given, the default origin is (0,0,0).    For every subsequent line of data, 
the origin is incremented by 1.

See MGVA_ASCII File Format for more information on the Voxel Analyst ADF format.

To import ASCII data:
1. Select File > Import > ASCII Data.



Type the input ASCII file name or, click Browse, select an ASCII input file from the 
dialog box, and click OK.    (TIP        ADF files have a .adf extension, and they can reside in any 
directory, on any drve, or on any network drive/directory.)

The load parameters appear on the dialog box.

NOTE        The load parameters are set when you export a dataset to an ADF file using File 
> Export > ASCII Data, and they cannot be changed at import time.    However, you can place an 
insert point and copy and paste the values into another file if you need to.

2. Do you want to change the default dataset name?    If yes, type a new name.
3. Do you want to change the default description?    If yes, type a new description.
4. Click OK to import the data.

SEE ALSO

Importing Source Points 
Importing Design Elements 
Importing Grid Geometry 
Importing Grid Attributes 
Importing Grid Layers (Horizons) 



Importing Design Elements
You can import any or all design elements from any or all levels in an AutoCad file or in a 
MicroStation design file into Voxel Analyst.    By default, the imported elements overwrite any 
existing elements, but you can choose to overlay the imported elements without destroying 
existing elements.    You can also import solids and surfaces to appear in wireframe mode rather 
than in shaded mode.

To import design elements:
1. Select File > Import > Design Elements.

2. Type the input file name or, click Browse, select an input file, and click OK.
3. Do you want to select the element types to be imported?    If yes, select the Select option 

button and clear the checkboxes (in the Types area) that correspond to the elements you do 
not.want.

NOTE        By default, all element types are selected.    Unless you select the Select option 
button and clear the elements you do not want, all the elements will be imported.

4. Do you want to overlay the elements and save any existing elements?    If yes, select the 
Overlay option button.

NOTE        By default, importing elements overwrites any existing elements.    Unless you 
select the Overlay option button, any existing elements will be destroyed.

5. Do you want the imported elements to appear in wireframe mode?    If yes, clear the Shading 
checkbox.

6. Do you want to import elements only from certain levels?    If yes, type the level(s) you want 
or, click the levels icon, select one or more levels from the Multi-Level Selection dialog box, 



and click OK.

7. Click OK to import the elements.

SEE ALSO

Importing Source Points 
Importing ASCII Data 
Importing Grid Geometry 
Importing Grid Attributes 
Importing Grid Layers (Horizons) 



Importing Grid Geometry
You can build a 3-D volume dataset that contains X, Y, and Z values only (no data attributes) by 
importing one or more grids from an input grid file.    This is useful for building geometries for 
data fields that are represented by a set of grid files, such as MGE Terrain Modeler (MGM) grid 
files.

The X and Y values of the first layer of the new dataset are based on the XY geometry of the first 
grid in the input file.    By default, the X and Y values of the next layer are based on the next grid 
you select from the input file, but you can choose to base the X and Y values of the next layer on 
the XY geometry of the previous layer.

Similarly, the Z value of the first layer is based on the Z value of the first grid in the input file.    
By default, the Z value of the next layer is based on the next grid you select, but you can choose 
to base the Z value on the Z value of the previous layer.    You can also choose to let the Z value 
be interpreted as the difference (delta) between the Z value of the current layer and the Z value of 
the previous layer.

To import grid geometry:
1. Select File > Import > Geometry from Grid(s).

2. Do you want to change the default dataset name?    If yes, type a new name.
3. Type the input file name or, click Browse, select an input grid file, and click OK.    (TIP  
Grid files have a .grd extension and they can reside in any directory, on any drive, or on any 



network drive/directory.)
4. Do you want to change the layer number?    If yes, type a new number.
5. Do you want to change the default void value?    If yes, type a new void value.
6. Do you want to define the Z value?    If yes, select the User Key In option button and in 
the Value text box, type a Z value.
7. Do you want the Z value to be interpreted as the difference between the current layer and the 

previous layer?    If yes, select the Z as Delta option button and in the Delta from Layer text 
box, type a delta value.

8. Click Enter to post the layer to the volume specification.

The layer number increments by one (1).    (Unless you change it, this is the number of the 
next layer.)

9. Do you want to list the layers in ascending order?    If yes, select the Ascending Order option 
button.

10. Repeat Steps 3 - 7 until you have added all the grid layers you want.
11. Do you want to edit a layer?    If yes, select the layer, click Edit Entry, edit the layer 
specification as necessary, and click Enter.
12. Do you want to delete a layer?    If yes, select the layer and click Delete Entry.
13. Click OK to import the geometry.

TIP        Once the geometry is built, you can populate it with attributes by using Import Attributes 
from Grid(s) or Import Horizons from Grid(s) (for geologic data).    For source points, save the 
geometry as an HDF file and input the data to it by using Convert Sparse Data to Volume Data.    
(See Converting Data .)

SEE ALSO

Importing Source Points 
Importing ASCII Data 
Importing Design Elements 
Importing Grid Attributes 
Importing Grid Layers (Horizons) 



Importing Grid Attributes
You can build a 3-D volume dataset that contains X, Y, and Z values and data attributes by 
importing attributes from one or more grids in an input grid file.    You can also edit the 
attribution for an existing 3-D volume dataset.    In both cases, the input grid can be resampled 
along rows or along columns, letting you control the density of the data.    The resampled data 
can be thinned or densified depending on the resampling option you select

To import grid attributes: 

1. Select File > Import > Attributes from Grid(s).

2. Do you want to create a new dataset

SEE ALSO

Importing Source Points 
Importing ASCII Data 
Importing Design Elements 
Importing Grid Geometry 
Importing Grid Layers (Horizons) 



Importing Grid Layers (Horizons)

To import grid horizons:

1. Select File > Import > Horizons from Grid(s).

2.

SEE ALSO

Importing Source Points 
Importing ASCII Data 
Importing Design Elements 
Importing Grid Geometry 
Importing Grid Attributes 



Creating a New Dataset

SEE ALSO

What is a Dataset? 
Importing Data 
Opening a Saved Dataset 
Saving a Dataset
Deleting a Dataset 
Copying/Moving a Dataset File 
Exporting Data 



Opening a Saved Dataset
You can open any previously saved dataset any time while working in Voxel Analyst.    
Remember that you cannot mix gridded data and source point data.    When a source point dataset 
is open, you can only create graphic displays for source points (Graphics > Source Points), and 
when a gridded dataset is open, you cannot create source point graphic displays.

TIP        By default, the active dataset is the last opened dataset, but you can switch to another 
open dataset by selecting a dataset from the Active Dataset box on the Toolbar.    You can also set 
the active dataset by using Graphics > Set Active.    (See Setting the Active Graphic .)

TIP        Dataset (HDF) files have an .hdf extension.    They can reside in any directory or on any 
drive.

To open a dataset file in the current directory:
1. Select File > Open > Dataset. 

2. Type the input file name or select an input file name from the list below the File Name text 
box.

3. Click OK.

In a different directory:
In the Directories list, double click the directory name, and then double click the input file name.

On a different drive:
Select the drive letter from the Drives drop-down list, double click the directory name, and then 
double click the input file name.

On a networked drive:
Click Network to open the Connect to Network dialog box and connect as you normally do.    
Then double click the directory name and the input file name.



SEE ALSO

What is a Dataset? 
Importing Data 
Creating a New Dataset 
Saving a Dataset
Deleting a Dataset 
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Saving a Dataset
You can save a dataset to a file anytime while working in Voxel Analyst.    Dataset (HDF) files 
can be saved to any directory or drive on your workstation or to any drive/directory on a network 
workstation.

To save a dataset to a file:
1. Select File > Save As > Dataset.





2. Do you want to create a new file?
· If yes, type a new file name (without the extension).
· If no, type the name of an existing file or select a file from the list below the File Name text 

box.
3. Click OK.

SEE ALSO
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Deleting a Dataset
You can delete any open dataset including the active dataset.

IMPORTANT Deleting a dataset deletes it from memory not from disk.    Any graphic displays 
associated with the dataset are also deleted.

To delete the active dataset, select Dataset > Delete.    When the Warning dialog box appears, 
click OK.

To delete a dataset other than the active one, enter a dataset name in the Active Dataset box on 
the toolbar or use Graphics > Set Active to change the active dataset to a different dataset.    Then 
select Dataset > Delete and click OK when the Warning dialog box appears.

SEE ALSO
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Copying/Moving a Dataset File
You can copy or move an HDF file to another directory or drive on the same workstation or to a 
different workstation. 

IMPORTANT        You must also copy or move the related CTR (color table file) along with the 
HDF file. 

SEE ALSO
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Exporting Data
Voxel Analyst gives you two export options:    ADF output and design elements.

SEE ALSO
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Exporting ASCII Data
Any 3-D volume dataset can be exported to a 2-D Voxel Analyst-compatible ASCII-formatted 
(ADF) output file.    This file can be converted to an HDF file and input back to Voxel Analyst (or 
to another modeling package).

You can extract data from within a specific data range along a specific parametric axis and in a 
specific order (row by row or column by column).    In row by row order, the resulting data 
organization is:

x1, y1, z1, a1
x1, y1, z2, a1
x1, y1, z3, a1

In column by column order, the resulting data organization is:

x1, y1, z1, a1
x1, y2, z1, a1
x1, y3, z1, a1

You can also control the way the data is ordered in the output file:    by the geometry (the order of 
the XYZ coordinates) and/or by the order of the data attribute(s).    The coordinate or attribute 
whose order number is one (1) is exported first, and so on.

TIP        You can prevent a specific coordinate or a attribute from being exported by selecting its 
Report Status (Yes).    This changes the Report Status to No and the coordinate or attribute will 
not be exported.

To export data to an ASCII output file:
1. Click File > Export > ASCII Data.



2. Do you want to export data from a different dataset?    If yes, select the dataset.
3. Type the output file name or click Browse, select an output file, and click OK.
4. Do you want to extract data along a different parametric axis?    If yes, select an axis.
5. Review the data range for the selected axis.    Do you want to edit the range?    If yes, type 
a new minimum value in the left-hand box and/or type a new maximum value in the right-hand 
box.
6. Do you want to extract the data column by column?    If yes, select the Column Major 
option button.
7. Do you want to order the extracted data by geometry only?    If yes, select the No option 
button (for Data Field Order).
8. Do you want to edit the default order of the coordinates?    If yes, select the coordinate 
that you want to reorder and click either the up arrow or the down arrow.    (For example, to 
reorder the coordinates from XYZ to YXZ, select the X coordinate and click the down arrow or 
select the Y coordinate and click the up arrow.)
9. Do you want to order the extracted data by attribute only?    If yes, select the No option 
button (for Geometry Order).



10. Do you want to edit the default order of the attributes?    If yes, repeat Step 8 for data 
fields instead of coordinates.
11. Click OK to extract and to export the data.

SEE ALSO
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Exporting Design Elements
Graphic displays of both gridded datasets and source point datasets can be exported to an output 
file as design elements.    You can select the graphics to be exported by the view in which they 
occur or by the level on which they reside.    The graphics can be exported as solids or as 
wireframes. 

To export dataset graphics to design elements:
1. Select File > Export > Design Elements.

2. Type the output file name or click Browse, select an output file, and click OK.
3. Do you want to select graphics by view?    If yes, select the By View checkbox and enter 
the view.
4. Do you want to select graphics by level?    If yes, select the By Level checkbox and enter 
the level number(s).
5. Enter the design file level on which to place the output elements.
6. Do you want to apply a Z scale to the output elements?    (This will exaggerate the 
elements along their Z axes.)    If yes, select the Apply Z Scale checkbox.
7. Clear the checkboxes that correspond to the graphics that you do not want to export as 
wireframes.

NOTE        By default, all of the available graphics will appear as wireframes.    If you do not 
want any of the graphics to appear as wireframes, click N in the Wire column.



8. Clear the checkboxes that correspond to the graphics that you do not want to export as solids.

NOTE        If you want all of the available graphics to appear as solids, click A in the Solid 
column.    If you do not want any of the graphics to appear as solids, click N in the Solid 
column.

9. Click OK to export the graphics.

SEE ALSO

Exporting Data 
Exporting ASCII Data 



Uniform Grid
A 3-D grid in which spacing along all orthogonal axes is constant and identical; all edges are the 
same length, creating cubic voxels.    (X0, Y0, Z0) is located at the lower-left corner.



Regular Grid
A 3-D grid in which spacing is constant along the X, Y, and Z axes, but not equal for each axis; 
edge lengths of a voxel are constant along each axis.    In a regular grid, (X,Y,Z) = (X0, Y0, Z0) + 
(dX*I, dY*J, dZ*K), where (X0, Y0, Z0) is the origin of the grid and dX, dY, and dZ are the 
edge lengths of each voxel.    Defined by a regular 3-D grid, voxels are identical rectangular 
bricks aligned with the axes.

TIP        When dX=dY=dZ, a regular grid becomes a uniform grid.



Irregular Grid
A 3-D grid in which spacing can be irregular along the X, Y, and Z axes and edge lengths of 
different voxels differ along each axis.    In an irregular grid, (X,Y,Z) = (X[I],Y[J],Z[K]).    Voxels 
may have different sizes in an irregular grid.    They are still rectangular bricks and axis aligned.

TIP        Irregular grids are also referred to as rectilinear grids.    Regular grids are special cases of 
irregular grids.



Structured Grid
A 3-D grid in which the X,Y,Z coordinates for each grid node are completely arbitrary.    In a 
structured grid, (X,Y,Z) = (X]I],J,K], Y[I,J,K], Z[I,J,K]).    The twelve edges of a voxel can have 
different lengths, and they may not align with axes.    Voxels are warped bricks.    Different voxels 
can have different edge lengths.

TIP        A structured grid can be modeled to conform to physical or geological formations and 
shapes.



Semi-Structured Grid
A 3-D grid only structured along one or two axes while regular or irregular (rectilinear) along the 
other axes.    The most commonly used semi-structured grids are structured along the Z axis and 
regular along the X and Y axes.

In such semi-structured grids, (X,Y,Z) = (X0 + dX * I, Y0 + dY * J, Z(I,J,K)).    The edges of a 
voxel are aligned with the X and Y axes but not the Z axis.    Edge lengths of different voxels are 
the same along the X and Y axes, but different along the Z axis.    This type of 3-D grid can be 
created by stacking regular 2-D digital elevation grids.
 



What is a Color Table?
Color tables are used in Voxel Analyst to enhance graphic displays.    You create a color table for 
each data attribute in the active dataset or for each attribute that you want to visualize.

A color table consists of one or more data subranges in which colors are assigned to data values. 
You determine an interval and an increment for each subrange and define a beginning color and 
an ending color.    The interval determines the division of data values within the data value range. 
The increment is the number by which the data is automatically incremented in each subrange.    
Voxel Analyst determines the color/data value assignments based on the interval, the attributes 
beginning and ending data values, and the beginning and ending colors that you defined.

EXAMPLE

SEE ALSO
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Creating a New Color Table
You can create a new color table any time while using Voxel Analyst, although usually this is 
done before creating any graphic displays.

Defaults are provided for the new color table name, the below and above range colors, the 
number of intervals and the increment, and the beginning and ending colors for the first 
subrange.    By default, the beginning and ending data values of the first subrange are the 
minimum and maximum data values of the first attribute listed.

Once you have created a set of color tables, create graphic displays to visualize the variation of 
data values in the dataset.    You will probably want to edit the current tables and/or load different 
tables throughout your Voxel Analyst session.    (See Editing a Color Table .)

NOTE        If you exit Voxel Analyst without first saving the newly created color table to a file or 
without saving the current session to a file, the color table is not saved.    See Saving a Color 
Table 

To create a new color table:
1. Select Color Table > Create.    By default, the range of each attribute in the active dataset 

appears on the dialog box.    In the following example, colors0 is a color table for the data 
values (-0.060396 to 0.244152) in the data attribute acetone.



2. Do you want to change the name of the new color table?    If yes, clear the Color Table box 
and type a new name.

3. Do you want to change the below range color?    If yes, click the Below Range Color box.

In the Red, Green, and Blue boxes, type a color number (0.00 to 1.00). (Or use the sliders.)    
The resulting color interactively appears next to the default color.    When you are finished, 
click OK to return to the Create Color Table dialog box.

4. Do you want to change the above range color?    If yes, click the Above Range Color box and 
repeat Step 4.

5. Do you want to see the attributes in a different dataset?    If yes, select the dataset.
6. View the minimum/maximum data values using the scroll bars, if necessary.
7. Select the attribute you want to use for the data range of the color table.
8. Do you want to change the number of intervals?    If yes, type an integer.
9. Do you want to change the increment number?    If yes, type a floating-point value.
10. Do you want to change the beginning data value?    If yes, type a floating-point number.
11. Do you want to change the ending data value?    If yes, type a floating-point number.
12. Do you want to change the beginning color?    If yes, click the Beginning Colors box and 

repeat Step 4.
13. Do you want to change the ending color?    If yes, click the Ending Colors box and repeat 

Step 4.
14. To define the next subrange, Click Next
15. Repeat Steps 9 - 13 until you have defined as many subranges as you require. 

TIP        If you make a mistake, you can delete the current subrange by clicking Delete.    If 
you need to go back to a previously created subrange, click Previous.

16. When you are finished, click OK to create the new color table.

SEE ALSO

What is a Color Table? 
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Creating a Legend 



Opening a Saved Color Table
You can open any previously saved color table file anytime while working in Voxel Analyst.

TIP        Color table files have a .ctr extension.    They can reside in any directory or on any drive.

To open a color table file in the current directory:
1. Select File > Open > Color File. 

2. Type the input file name or select an input file name from the list below the File Name text 
box.

3. Click OK.

In a different directory:
In the Directories list, double click the directory name, and then double click the input file name. 

On a different drive:
Select the drive letter from the Drives drop-down list, double click the directory name, and then 
double click the input file name.

On a networked drive:
Click Network to open the Connect to Network dialog box and connect as you normally do.    
Then double click the directory name and the input file name.

SEE ALSO
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Saving a Color Table
You can save a color table to a file anytime while working in Voxel Analyst.    Color table files 
(CTR files) can be saved to any directory or drive on your workstation or to any drive/directory 
on a network workstation.

A CTR file is a palette of one or more color tables that contains surface-material properties, 
shading, and colors.    (See Editing the Material Properties    and Setting the Shading Method )

To save a color table to a file:
1. Select File > Save As > Color File. 

2. Do you want to create a new file?
· Type a new file name (without the extension).
· If no, type the name of an existing file or select a file from the list below the File Name text 

box.
3. Click OK.

SEE ALSO
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Editing a Color Table
There are numerous ways you can edit a color table.    You can adjust the data value range, 
change the color/data value assignments and add labels, change the material properties (such as 
shading, highlighting, and relection), and change the shading method.

SEE ALSO
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Adjusting the Value Range
You can adjust the minimum/maximum data values for any dataset attribute.    The values can be 
scaled or clipped.    The adjustments impact the related color table(s).    Scaling the values 
redistributes the data value assignments.    Clipping the values cuts off the data values below and 
above the new minimum and maximum values that you define.

NOTE        Scaling the range does not effect the original number of colors (intervals).    Also, if 
you added labels to a table, you have the option to discard or to maintain the current labels.

To adjust the value range:
1. Select Color Table > Adjust Range.

2. Do you want to edit a different table?    If yes, select a table.
3. Do you want a different dataset?    If yes, select the dataset.
4. Select the attribute that contains the values you want to adjust.
5. Type a new minimum value and a new maximum value.
6. Do you want to scale the values?
· If yes, click Adjust.
· If no, select the Clip Value Range option button.
7. Do you want to discard the current labels?    If yes, clear the Maintain Current Lavel Settings 

checkbox.



8. Click OK.

SEE ALSO
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Editing the Color Value Assignments
You can edit and delete the data value/color assignments in any color table.    You can also define 
labels for any data value/color pair or edit existing labels.

To edit data value/color assignments:
1. Select Color Table > Edit.

2. Do you want to edit a different table?    If yes, select a table.
3. Do you want the object color to be constant?

· If yes, select the Constant Color option button and click the Constant Color box.    Type 
values or use the sliders to define a constant color or select the No Color option button.    
When you are finished, click OK to return to the Edit Color Table dialog box.    Click OK to 
save the changes. 



· If no, select the data value/color pair that you want to edit.    To edit the data value, type a 
new value in the Value box.    To edit an existing label or to add a label, type a label in the 
Label box.    To edit the color, click the Color box.    Type values or use the sliders to define a 
new color or select the No Color option.    When you are finished, click OK to return to the 
Edit Color Table dialog box.

4. Do you want to change the increment?    If yes, type a new value.
5. Click Enter to enter the changes.
6. Do you want to delete a data value/color pair (and label)?    If yes, select the data you 
want to delete and click Delete.
7. Click OK.

SEE ALSO
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Editing the Material Properties
An objects surface appearance is determined by the shading, highlighting, reflection, and other 

material properties, which are stored in color tables.    You can control the surface appearance 
of graphic displays (of datasets) by editing the material properties stored in one or more of 
the related color tables.

The reflection coefficients and gloss are defined as percentages (0 - 100).    The reflection 
coefficients are:

· Ambient    ---    causes the object to appear as if the light source surrounds it.
· Diffuse    ---    causes the object to appear as if the light source originates from a single point, 

producing shading and a three-dimensional appearance.
· Specular    ---    causes the object to appear as if the light source originates from your eye and 

bounces off at an angle, producing a bright spot on the object.

TIP        Create a graphic display and experiment with changing material properties.

To edit the material properties:
1. Select Color Table > Material Properties.

2. Do you want to edit a different table?    If yes, select a table.
3. Do you want to edit any of the reflection coefficients?    If yes, type values or use the sliders.
4. Do you want to edit the gloss?    If yes, type a value or use the slider.    (TIP        0 = dull gloss, 

100 = high gloss.)
5. Do you want to change the color of the specular reflection?    If yes, click the Color box.    

Type values or use the sliders to edit the color.    When you are finished, click OK to return to 
the Edit Material Properties dialog box.

6. Do you want the surface of the object to appear smooth?    If yes, select the Smoothing 



checkbox.    (NOTE        You can turn off smoothing by clearing this checkbox.)
7. Click OK

SEE ALSO
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Setting the Shading Method
The shading method defined in a color table also effects the appearance of graphic displays 

created using that color table.    The shading methods are:

· Edges    ---    creates colored lines at interval edges.
· Filled    ---    creates filled colors in which each interval has a constant color.
· Smooth    ---    creates smooth blending from one interval color to the next.
· Blended    ---    blends a selected color to a constant blend color, which can be blended to or 

from the interval color.

TIP        Create a graphic display and experiment with selecting different shading methods.

To set the shading method:
1. Select Color Table > Shading Method.

2. Do you want to edit a different table?    If yes, select a table.
3. Select one of the Shading Method option buttons.
4. If you selected Blended, select either the Blend to Value Color option button or the Blend 

from Value Color option button.    Then click the Blend Color box.    Type values or use the 
sliders to edit the blend color.    When you are finished, click OK to return to the Edit Shading 
Method dialog box.

5. Click OK.

SEE ALSO
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Copying a Color Table
You can create a new color table or rename a color table by copying a color table to a new table 

name.

To copy a table:
1. Using File > Open > Color File, open the CTR file that contains the color table that you want 

to copy.
2. Select Color Table > Manipulate.

3. Select the table you want to copy.
4. Type a new name.
5. Do you want to make a copy?    If yes, click Copy.
6. Click OK.

SEE ALSO

Deleting a Color Table 



Deleting a Color Table
You can delete any color table from the active CTR file.

To delete a table:
1. Using File > Open > Color File, open the CTR file that contains the color table that you want 

to delete.
2. Select Color Table > Manipulate.

3. Select the table you want to delete.
4. Click Delete.
5. Click OK.

SEE ALSO

Copying a Color Table 



Creating a Legend
You can create a legend for any color table in the open CTR file.    A legend enhances a graphic 
display by providing a key to the data value/color assignments in the color table that was used to 
create the display.    (See Creating a Graphic Display .)

To create a legend:
1. Select Color Table > Legend Setup

2. Do you want a different color table?    If yes, select a table.
3. Type a title for the legend.
4. Do you want to the legend to have a subtitle?    If yes, type a subtitle, such as the units. 
5. Type the number of significant digits for the data values.
6. Do you want the legend to display horizontally?    If yes, select the Horizontal option 
button.
7. Do you want labels (if any were created) to appear in the legend?    If yes, select the Label 
checkbox.
8. Do you want labels only to appear?    If yes, clear the Value checkbox.
9. Click OK.

SEE ALSO
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Displaying a Legend
A legend can be manipulated like a regular window.    You can also edit any of the colors on a 
legend dialog box by clicking the box that corresponds to the color you want to edit.

To display a legend:
1. Using Color Table > Legend Setup, define the legend display parameters.
2. Select Color Table > Legend Display.
3. Do you want to place the legend in the active view?    If yes, while the pointer is on the 

legend dialog box, press the mouse Reset button.    Then, using the menu that opens, locate 
the legend origin by clicking in the active view.

Note        Once it is placed, the legend cannot be edited or moved, and it disappears when the 
active view is updated.

SEE ALSO

Creating a Legend 
 



What is a Graphic Display?
Graphic displays let you visualize, manipulate, and analyze 3-D datasets.    You can create a 
graphic display for any open dataset.    Graphic displays can be placed on any level in any Voxel 
Analyst view.    (By default, they are placed in the active view.)    View levels can be turned on or 
off to emphasize specific displays.    (See Setting Levels .)    The displays can be moved, rotated, 
scaled and rearranged to suit your workflow.    (See Moving a Dataset .)

SEE ALSO
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Creating a Graphic Display
You can create any combination and number of graphic displays.    Multiple displays of the same 
data type or of different data types can be created.    But you cannot mix displays of gridded data 
with displays of sample point data.    For example, you cannot create an iso-solid of a sample 
point dataset.

TIP        If you are going to work with sample points, you first must import the points    by using 
File > Import > Source Points.    (See Importing Data .)

You first must open (or create) at least one color table based on the dataset you want to 
visualize/analyze    The coloring, interval shading, and material properties are determined by a 
data attribute and a color table that you select.    (See Setting the Shading Method and Editing the 
Material Properties .)    You can also change display characteristics by editing the related color 
table(s) and varying the standard views.    (See Editing a Color Table    and Setting Viewing Mode 
and Position .)

Experiment to see what each display looks like using your datasets and color tables.    You can 
interactively see the effects of varying the parameter settings before placing each display.    Once 
the display is placed, you can edit it by selecting Graphics > Edit.    (See Editing a Graphic 
Display 

Editing the Related Color Table(s)
You can edit any color table you want to use by clicking Edit on the Create [graphic display type] 
dialog box.    This opens the Edit Color Table dialog box, which lets you edit the data value/color 
assignments (and labels) in the selected color table.    (See Editing the Color Value Assignments 

Defining the Parametric Range
Many graphic displays require that you adjust the IJK parametric range values. The parametric 
range defines the dimensions of the display in three directions.    Another way to look at it is that 
you define how much of the dataset you want to see.

To define the parametric range:
1. Click the Range icon.



2. Type the I, J, and K values or use the sliders.
3. Click OK to save the changes.

Selecting a Level
You can place different displays on different levels in the same view or you can open additional 
views and create a different graphic display in each one.    Unless you specify a different level, all 
graphic displays are placed on level one by default.

To select a level:
1. Type a level number or, click the Level icon.



2. Select a level and click OK.

Selecting a Style
You can control the style in which a graphic display appears.    The style consists of the display 
mode (shaded, wireframe, or sketch) and the amount of transparency defined as a percent, with 0 
= opaque (no transparency) and 100 = invisible.

IMPORTANT        To see transparency correctly, set lighting to Two-Sided by using Utilities > 
Preferences.

To select a style:
1. Click the Style icon.

2. Select a display mode option button.
3. Type a transparency value or use the slider to define transparency.
4. Click OK.

SEE ALSO

Source Points 
What is a Graphic Display? 
Editing a Graphic Display 
Setting Display Mode 
Setting the Active Graphic 
Deleting a Graphic Display 



Source Points
You can view sparsely or irregularly sampled source points as a graphic display.    The display 
looks like cubes because Voxel Analyst performs a linear interpolation of the points to their cubic 
weights.    The interpolation is based on the data range (low and high values) and the data size 
range (low and high values) that you define.

To create a source points display:

1. Click  on the Graphics bar or select Graphics > Source 
Points.

2. Do you want to use a different dataset?    If yes, select a dataset.
3. Select a shading data attribute.



4. Select a color table.
5. Select a level.
6. Select the style parameters.
7. Type values or use the sliders to define the data range.
8. Type values or use the sliders to define the data size range.
9. Click OK to place the points.

SEE ALSO
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Outline
This display is an outline of a selected dataset that you can create for reference. 

To create an outline:

1. Click  on the Graphics bar or select Graphics Outline.

2. Do you want to use a different dataset?    If yes, select a dataset.
3. Do you want to edit the color of the outline?    If yes, click the Color box and edit the 
color using the Adjust Color dialog box.    When you are finished, click OK.
4. Select a level.
5. Select the style parameters.
6. Click OK to place the outline.

SEE ALSO

Source Points 
Boundary Grid 
Solid 
Chair 
Iso-Solid 
Iso-Surface 
Envelope 
Iso-Parametric 
Cap 
Cutting Plane 



Boundary Grid
This display is an outline of the boundary grid of a selected dataset.    This display is also useful 
for reference.

To create a boundary grid:

1. Click  on the Graphics bar or select Graphics > Boundary 
Grid.

2. Do you want to use a different dataset?    If yes, select a dataset.
3. Select a shading data attribute.
4. Select a color table.
5. Define the parametric range.
6. Select a level.
7. Select the style parameters.
8. Click OK to place the grid.

SEE ALSO

Source Points 
Outline 
Solid 
Chair 
Iso-Solid 
Iso-Surface 
Envelope 



Iso-Parametric 
Cap 
Cutting Plane 



Solid
This display is a solid block of a selected dataset (or a portion of a dataset). 

To create a solid:

1. Click  on the Graphics bar or select Graphics > Solid.

2. Do you want to use a different dataset?    If yes, select a dataset.
3. Select a shading data attribute.
4. Select a color table.
5. Define the parametric range.
6. Select a level.
7. Select the style parameters.
8. Click OK to place the solid.

SEE ALSO

Source Points 
Outline 
Boundary Grid 
Chair 
Iso-Solid 
Iso-Surface 
Envelope 
Iso-Parametric 
Cap 



Cutting Plane 



Chair
This display is a solid block of a selected dataset with a notch cut into one corner, revealing the 
interior of the dataset.    An example of a chair graphic display is shown on the dialog box.    
There are eight possible notch origins.    You can type a notch origin value, select it from a list, or 
select the number on the diagram.

To create a chair:

1. Click  on the Graphics bar or select Graphics > Chair.



2. Do you want to use a different dataset?    If yes, select a dataset.
3. Select a shading data attribute.
4. Select a color table.
5. Define the parametric range.
6. Select a level.
7. Select the style parameters.
8. Enter the notch origin.
9. Type values or use the sliders to define the notch range (similar to defining the parametric 

range).
10. Click OK to place the chair.

SEE ALSO

Source Points 
Outline 
Boundary Grid 
Solid 
Iso-Solid 
Iso-Surface 
Envelope 
Iso-Parametric 
Cap 
Cutting Plane 



Iso-Solid
This display is a 3-D solid of all data points having a constant range for a selected iso-solid data 
attribute.    You define the data range (low and high values) of the iso-solid to suit the dataset.

To create a solid:

1. Click  on the Graphics bar or select Graphics > Solid.

2. Do you want to use a different dataset?    If yes, select a dataset.
3. Select a shading data attribute.
4. Select a color table.
5. Define the parametric range.
6. Select a level.
7. Select the style parameters.
8. Select the iso-solid data attribute.
9. Type values or use the sliders to define the iso-solid data range.



10. Click OK to place the iso-solid.

SEE ALSO

Source Points 
Outline 
Boundary Grid 
Solid 
Chair 
Iso-Surface 
Envelope 
Iso-Parametric 
Cap 
Cutting Plane 



Iso-Surface
This display is an open-ended 3-D surface that fits through all data points having a constant 
value for a selected iso-surface data attribute.    You adjust the iso-surface data value to suit the 
dataset.

To create an iso-surface:

1. Click  on the Graphics bar or select Graphics > Iso-Surface.

2. Do you want to use a different dataset?    If yes, select a dataset.
3. Select a shading data attribute.
4. Select a color table.
5. Define the parametric range.
6. Select a level.
7. Select the style parameters.
8. Select an iso-surface data attribute.



9. Type a value or use the slider to define the iso-surface data value.
10. Click OK to place the iso-surface.

SEE ALSO

Source Points 
Outline 
Boundary Grid 
Solid 
Chair 
Iso-Solid 
Envelope 
Iso-Parametric 
Cap 
Cutting Plane 



Envelope
This display surrounds or envelopes all data points having a constant value plus or minus a user-
defined tolerance.    You adjust the envelope and tolerance values to suit the dataset.    The 
envelope surface consists of boxes generated around values that occur within the region defined 
by the tolerance value.

NOTE      In Bubble mode, the surface looks bubbled because the boxes are diagonal to the grid 
lines of the dataset.    In Box mode, the surface looks jagged because the boxes are parallel to the 
grid lines.

To create an envelope:

1. Click  on the Graphics bar or select Graphics > Envelope.

2. Do you want to use a different dataset?    If yes, select a dataset.



3. Select a shading data attribute.
4. Select a color table.
5. Define the parametric range.
6. Select a level.
7. Select the style parameters.
8. Select an envelope data attribute.
9. Type a tolerance value.
10. Type a value or use the slider to define the envelope value.
11. Do you want the surface to appear jagged?    If yes, select the Box option button.
12. Click OK to place the envelope.

SEE ALSO

Source Points 
Outline 
Boundary Grid 
Solid 
Chair 
Iso-Solid 
Iso-Surface 
Iso-Parametric 
Cap 
Cutting Plane 



Iso-Parametric
This display is an IJK parametric surface through a selected dataset.    You select a data attribute 
that you want to see, a parametric axis, and the parametric data value.    The surface shows any 
data in the selected attribute that are intercepted by it.

TIP    This display is similar to a cutting plane, but an iso-parametric follows the IJK parametric 
axes rather than cutting through grid layers.

To create an iso-parametric:

1. Click  on the Graphics bar or select Graphics > Iso-
Parametric.

2. Do you want to use a different dataset?    If yes, select a dataset.
3. Select a shading attribute.
4. Select a color table.
5. Define the parametric range.
6. Select a level. 
7. Select the style parameters. 



8. Select a parametric axis option button.
9. Type a value or use the slider to define the parametric axis data value.
10. Click OK to place the iso-parametric.

SEE ALSO

Source Points 
Outline 
Boundary Grid 
Solid 
Chair 
Iso-Solid 
Iso-Surface 
Envelope 
Cap 
Cutting Plane 



Cap
This display is a bounded iso-parametric cross section of an iso-solid.    The section shows areas 
of constant data value bounded by two selected data attributes.

To create a cap:

1. Click  on the Graphics bar or select Graphics > Cap.

2. Do you want to use a different dataset?    If yes, select a dataset.
3. Select a shading data attribute.
4. Select a color table.



5. Define the parametric range.
6. Select a level.
7. Select a style.
8. Select a parametric axis option button.
9. Type a value or use the slider to define the parametric axis data value.
10. Select the cap data attribute.
11. Type values or use the sliders to define the cap data range.
12. Click OK to place the cap.

SEE ALSO

Source Points 
Outline 
Boundary Grid 
Solid 
Chair 
Iso-Solid 
Iso-Surface 
Envelope 
Iso-Parametric 
Cutting Plane 



Cutting Plane
This display is a surface that cuts through the grid layers of a selected dataset.    You select a data 
attribute that you want to see.    The plane shows any data in the selected attribute that are 
intercepted by its surface.    You also control the distance that the plane appears from the center 
of the dataset and the amount of pitch (the angular position relative to the vertical axis) and yaw 
(the angle of rotation about the vertical axis relative to a fixed horizontal reference direction).

To create a cutting plane:

1. Click  on the Graphics bar or select Graphics > Cutting 
Plane.



2. Do you want to use a different dataset?    If yes, select a dataset.
3. Select a shading data attribute.
4. Select a color table.
5. Define the parametric range.
6. Select a level.
7. Select a style.
8. Type values or use the sliders to define the distance, pitch, and yaw.
9. Click OK to place the cutting plane.

SEE ALSO

Source Points 
Outline 
Boundary Grid 
Solid 
Chair 
Iso-Solid 
Iso-Surface 
Envelope 
Iso-Parametric 
Cap 



Editing a Graphic Display
If you have not changed the active graphic using Set Active, you can edit the last created graphic 
display by selecting Graphics > Edit.    This opens the dialog box that you used to create the 
graphic.    If you have changed the active graphic, selecting Graphics > Edit opens the dialog box 
that was used to create that graphic.    In either case, you can edit the dataset, attributes, color 
table, parametric range, level, style, and other parameters that apply to the graphic display.

SEE ALSO

What is a Graphic Display? 
Creating a Graphic Display 
Setting Display Mode 
Setting the Active Graphic 
Deleting a Graphic Display 



Setting Display Mode
Three display modes are available:    shaded, wireframe, and sketch.    When you first start Voxel 
Analyst, the default display mode is shaded, but you can switch to one of the other modes if you 
want.

IMPORTANT        Changes in display mode override the original display mode and effect all 
graphic displays

To change to wireframe mode:
Select Graphics > Change Mode > Wireframe.

Example        

To change to sketch mode:
Select Graphics > Change Mode > Sketch.

Example        

SEE ALSO

What is a Graphic Display? 
Creating a Graphic Display 



Editing a Graphic Display 
Setting the Active Graphic 
Deleting a Graphic Display 



Setting the Active Graphic
The active dataset is the dataset that you last opened, but you can change the active dataset to 
another open dataset.    Likewise, the active graphic display is the display that you last created, 
but you can change it to a different display.    You can also delete a dataset, edit a graphic display, 
or delete a graphic display.

TIP        You can also change the active dataset by using the Active Dataset box in the Voxel 
Analyst toolbar:

To use Set Active:
1. Select Graphics > Set Active.

2. Do you want to change the active dataset?    If yes, select a dataset and click Close.
3. Do you want to delete a dataset?    If yes, select the dataset, click Delete, and click Close.
4. Do you want to change the active graphic?    If yes, select the graphic, and click Close.
5. Do you want to edit a graphic?    If yes, select the graphic, and click Edit.    Use the dialog 
box that appears to edit the graphic displays parameters.    When you are finished, click OK to 
return to the Set Active dialog box.    Then click Close.
6. Do you want to delete a graphic?    If yes, select the graphic, click Delete, and click 
Close.

SEE ALSO

What is a Graphic Display? 
Creating a Graphic Display 



Editing a Graphic Display 
Setting Display Mode 
Deleting a Graphic Display 



Deleting a Graphic Display
You can delete the last created graphic display (or the active graphic display) by selecting 
Graphics > Delete. 

SEE ALSO

What is a Graphic Display? 
Creating a Graphic Display 
Editing a Graphic Display 
Setting Display Mode 
Setting the Active Graphic 
 



Setting Up a View
View Control provides options for configuring Voxel Analyst views.    The way you set up each 
view determines the way the dataset(s) look in that view.    You can configure a view any time 
during your session, but most configuration takes place as after you open datasets and create 
graphic displays.

SEE ALSO

Setting Viewing Mode and Position 
Opening a New View 
Displaying Design Elements 
Fitting the Display to a View 
Using Dynamics 
Closing a View 



Setting Viewing Mode and Position

View Modes
The viewing modes are:    orthogonal view, in which the object length and distance are preserved, 
and perspective view, in which objects appear to shrink into the distance.    The default is 
orthogonal iso -.

EXAMPLE

Perspective toggles the active view between orthogonal view and perspective view.

To change to perspective view:

Click  on the View Control bar (or select View Control > 
Perspective).

EXAMPLE



View Positions
Eight standard view positions (front, back, top, bottom, and so on) are provided.    You can 
change the view position by selecting any of these commands.

EXAMPLE To change the view position to Top view, click  
on the View Control Bar (or select View Control > Top).



SEE ALSO

Setting Levels 
Setting Z Scale 
Setting Lighting 
Setting Target Point 
Setting Vantage Point 



Setting Levels
You can turn any level (1 - 63) on or off in any Voxel Analyst view.    By default, all levels are 
turned on the first time you use Voxel Analyst.

Turning off a level turns off all the graphic displays (and design elements, if any) on that level.    
This is useful for expanding the number of graphic displays or for isolating certain displays 
without deleting the rest of the displays.    For example, in an analysis workflow, you can create 
different displays on multiple levels and then turn off specific levels to compare the displays.

To turn selected levels on/off:

1. Click  on the View Control bar (or select View Control > 
Levels).

2. Click the levels you want, or press (and hold) the mouse Data button, drag the pointer over 
several levels, and release the button.

3. Click Apply and repeat Step 2, or click OK.

To turn all levels off:
On the Multi-Level Selection dialog box, click All Off and click OK.

To turn all levels on:



On the Multi-Level Selection dialog box, click All Off and click OK.

SEE ALSO

Setting Viewing Mode and Position 
Setting Z Scale 
Setting Lighting 
Setting Target Point 
Setting Vantage Point 



Setting Z Scale
Z scale is the amount of vertical exaggeration that graphic displays can have in any given view.    
The height of an object increases as the Z scale value increases.

To adjust Z scale:

1. Click  on the View Control bar (or select View Control > Z 
Scale).

2. In the Current Z Scale box, type a new value.
3. Click Apply and repeat Step 2, or click OK.

SEE ALSO

Setting Viewing Mode and Position 
Setting Levels 
Setting Lighting 
Setting Target Point 
Setting Vantage Point 



Setting Lighting
Lighting lets you control the direction from which graphic displays are illuminated in each view. 

This setting affects only the graphic displays/design elements in the view you select.

To set lighting:

1. Click  on the View Control bar (or select View Control > 
Lighting).

2. Click a view to locate the lighting direction.    (You can adjust the direction as many times 
as you want.)

3. When you are finished, click  again.

SEE ALSO

Setting Viewing Mode and Position 
Setting Levels 
Setting Z Scale 
Setting Target Point 
Setting Vantage Point 



Setting Target Point
You can adjust the angle between you and objects in any view according to a target point that 

you select.

To adjust the angle of view:

1. Click  on the View Control bar (or select View Control > 
Target).

2. Click a view to locate the target point.    (You can adjust the target point as many times as 
you want.)

3. When you are finished, click  again.

SEE ALSO

Setting Viewing Mode and Position 
Setting Levels 
Setting Z Scale 
Setting Lighting 
Setting Vantage Point 



Setting Vantage Point
You can adjust the viewing position (not to be confused with standard view positions) of the 
graphic displays in any view.    The viewing position consists of the azimuth (0 to 359 degrees), 
the declination (-180    to +180 degrees), the distance between you and the object (0.1 to 10.0 
times the object size), and the field of view (1 to 179 degrees).    You can interactively see the 
changes as you adjust any or all of these settings.

To adjust viewing position:

1. Click  on the View Control bar (or select View Control > 
Vantage Point).

2. Do you want to change the azimuth?    If yes, in the Azimuth box, type a new value.    (Or, 
press and hold the mouse Data button on the Azimuth dial, drag the pointer to the value you 
want, and release the button.)

3. Do you want to change the declination?    If yes, in the Declination box, type a new value.    
(Or use the slider.)

4. Do you want to change the distance?    If yes, in the Distance box, type a new value.    (Or use 
the slider.)

5. Do you want to change the field of view?    If yes, in the Field of View box, type a new value. 
(Or use the slider.)

6. Click Close.

SEE ALSO

Setting Viewing Mode and Position 
Setting Levels 



Setting Z Scale 
Setting Lighting 
Setting Target Point 



Opening a New View
Voxel Analyst lets you open as many views as your project requires, but only one (1) view can be 
active at a time.    Voxel Analyst views are the same as windows in that you can cascade, tile, and 
iconify them.    The names of the open views (VA 1, and so on), the standard view, and the view 
mode (perspective or orthogonal) are listed on the Window menu.

To open a new view:
Select Window > New Window (or press ALT+w,n).    The new view becomes the active view.

SEE ALSO

Setting Up a View 
Displaying Design Elements 
Fitting the Display to a View 
Using Dynamics 
Closing a View 



Displaying Design Elements
If you have imported design elements from an AutoCad file, for example, you can turn them on 
or off in any view.    Design Elements toggles the display of design elements off and on in the 
active view.    (The default is on.)

To turn off design elements:

Click  on the View Control bar (or select View Control > Design 
Elements).

SEE ALSO

Setting Up a View 
Opening a New View 
Fitting the Display to a View 
Using Dynamics 
Closing a View 



Fitting the Display to a View
Fitting the display means to adjust its size to fit the bounds of the view.    You can fit the active 
dataset (graphic displays only) to the active view, or you can fit all datasets (and design elements, 
if any) to the active view.

To fit the active dataset only:

Click  on the View Control bar (or select View Control > Fit 
Dataset).

To fit all datasets/design elements:

Click  on the View Control Bar (or select View Control > Fit 
All).

SEE ALSO

Setting Up a View 
Opening a New View 
Displaying Design Elements 
Using Dynamics 
Closing a View 



Using Dynamics
View dynamics lets you apply dynamic spin (horizontal and vertical rotation) and zoom to 
graphic displays.    Rotation is the speed at which an object rotates about its horizontal or vertical 
axis.    Zoom is the speed at which an object zooms in and out.    Both rotation and zoom are 
defined as a percent of 100, with zero (0) percent being no movement.    If you make adjustments 
to these parameters while dynamics is on, you can interactively see the effects.

NOTE Dynamics remains on until you turn it off.    The current settings are saved when you turn 
dynamics off.

To turn on and adjust dynamics:

1. Click  on the View Control bar (or select View Control > 
Dynamics).

2. Click Dynamics.
3. Do you want to change the horizontal rotation speed?    If yes, in the Horizontal Rotation box, 

type a new value.    (Or use the slider.)
4. Do you want to change the vertical rotation speed?    If yes, in the Vertical Rotation box, type 

a new value.    (Or use the slider.)
5. Do you want to change the zoom in/out speed?    If yes, in the Zoom Speed box, type a new 

value.    (Or use the slider.)
6. Click Close.

SEE ALSO

Setting Up a View 



Opening a New View 
Displaying Design Elements 
Fitting the Display to a View 
Closing a View 



Closing a View
To close a view:
Select Close from the Control box in the upper left corner of the view.

SEE ALSO

Setting Up a View 
Opening a New View 
Displaying Design Elements 
Fitting the Display to a View 
Using Dynamics 



Azimuth
The horizontal direction expressed as the angular distance between the direction of a fixed point 
and the direction of the object.



Declination
The angular distance north or south from horizontal (0 degrees) measured along a circle passing 
through -180 degrees and +180 degrees.

 



Viewing Dataset Information
You can view information, such as the geometry type, the bounding volume, the grid size, the 
attribute sizes, and the data range, about any open dataset.    This is useful for initially 
acquainting yourself with the data and for finding specific information during the workflow.    
You can also rename datasets and attributes, edit dataset file names, modify attribute units, void 
values, and multiplier values, and change symbolic attributes to non-symbolic ones.

To view dataset information:
1. Select Dataset > Information.

2. View the information about the current dataset.    Notice the bounding volume, the grid size, 
and the attribute information.

3. Do you want to see a different dataset?    If yes, select the dataset from the Dataset drop-down 
list.



4. Do you want to rename the current dataset?    If yes, in the Rename text box, type a new 
name.

5. Do you want to change the dataset description?    If yes, in the Description text box, type a 
new description.

6. Do you want to rename the current dataset file?    If yes, in the File Name text box, type a 
new name.

7. Do you want to see a different attribute?    If yes, select the attribute from the Attribute drop-
down list.

8. Do you want to rename the current attribute?    If yes, in the Rename text box, type a new 
name.

9. Do you want to change the attribute description?    If yes, in the Description text box, type a 
new description.

10. Do you want to change the attribute units?    If yes, in the Units text box, type new units.
11. Do you want to see the data range for the current attribute?    If yes, click Scan.
12. Do you want to change the void value for the current attribute?    If yes, click Void Value and 

type a new value in the text box.
13. Do you want to change the multiplier value for the current attribute?    If yes, click Multiplier 

and type a new value in the text box.
14. Do you want to change the attribute to a non-symbolic attribute?    If yes, click Symbolic.

SEE ALSO

Resampling the Data 
Extracting Data 
Defining a Grid 
Editing Data Attributes 
Editing Dataset Geometry 



Resampling Data
You can resample any dataset to create a new dataset.    This is useful when working with a 
dataset that contains too many or too few data values.    The resampled data can be thinned or 
densified depending on the resampling option you select.    The resampled dataset becomes the 
active dataset.

To resample a dataset:
1. Select Dataset > Resample.





2. Do you want to resample a dataset other than the current dataset?    If yes, select the dataset 
from the Dataset drop-down list.

3. Review the current IJK index values.
4. Do you want to change the default name of the resampled dataset?    If yes, in the 
Resampled Dataset text box, type a new name.
5. Select a resample method.
6. In the I, J, or K text boxes, type new values; click the I, J, or K option for the value(s) you 
do not want to change.
7. Click OK.

NOTE A resampled dataset is loaded in memory only.    To save it to a file, select File > Save As 
> Dataset.

SEE ALSO

Viewing Dataset Information 
Extracting Data 
Defining a Grid 
Editing Data Attributes 
Editing Dataset Geometry 



Extracting Data
You can create a new dataset by extracting a subset of data from another dataset.    This is useful 
when working with a large dataset or a dataset that contains void values.    (You can check the 
dataset for void values and extract a new dataset that does not contain void values.)

To extract data from a dataset:
1. Select Dataset > Extract.





2. Do you want to extract data from a dataset other than the current dataset?    If yes, select the 
dataset form the Dataset drop-down list.

3. Do you want to change the default name of the extracted dataset?    If yes, in the Name 
text box, type a new name.
4. Do you want to change the default description?    If yes, in the Description text box, type 
a new description.
5. Click the Parametric Range icon.
6. Move the sliders or type values to adjust the IJK parametric range of the new dataset.
7. Click OK.
8. Click OK on the Extract Dataset dialog box.

SEE ALSO

Viewing Dataset Information 
Resampling the Data 
Defining a Grid 
Editing Data Attributes 
Editing Dataset Geometry 



Defining a Grid
You can create a new 3-D volume (uniform, regular, or irregular grid) for any dataset using 
interactive graphics to add grid slices to the datasets IJK parametric axes.    (You can also create a 
new unattributed 3-D volume by copying an existing grid geometry and modifying it.    The 
resulting dataset is empty and you must import data to it.)

To define a new grid:
1. Select Dataset > Define Grid.





2. Do you want to modify the default name of the new grid?    If yes, in the Dataset text box, 
type a new name.

3. Click Add Single to start building the new grid.    Move the pointer to position the new 
slice along the I axis.    You can change the axis by clicking one of the axis options.
4. To add multiple slices, click Add Multiple and in the Number of Slices text box, type the 
number of slices.    Then position the slices along the axis.
5. Click OK.

To modify an existing grid:
1. Select the dataset from the Dataset drop-down list.
2. Review the grid size and type any changes in the IJK text boxes.
3. In Slice Operations, click the axis you want to modify.
4. To add a slice or slices, follow the instructions for defining a new grid.
5. To delete a slice or slices, click Delete Single or Delete Multiple and click the slice or 
slices you want to delete.
6. Click OK.

SEE ALSO

Viewing Dataset Information 
Resampling the Data 
Extracting Data 
Editing Data Attributes 
Editing Dataset Geometry 



Editing Data Attributes
You can edit the data values for any attribute in a 3-D gridded dataset.    This is useful for 
eliminating anomalous or unwanted data.    It is also useful for visualizing the connections 
between homogeneous bodies, such as contaminant plumes, in an analysis workflow.    To do 
this, you construct a local geometry or area of influence centered around the data, and apply an 
interpolation algorithm (Constant , Metric Method , Multiquadric Method , Thin-Plate Spline 
Method , or Volume Spline Method ) to it.    This lets you interpret new data between the bodies 
(adding new data to the dataset).

The interpolation is applied to the attribute values on all grid nodes within the local geometry.    
You adjust the local geometry or influence range to suit the data.    The center grid node and the 
grid nodes within the influence range are input points for the interpolation.

TIP When the influence range is I=0, J=0, K=0, only the center node is affected.

When the Fast option is on, only the data at the grid nodes immediately next to the edges of the 
influence range are interpolated resulting in faster processing.    However, the interpolated values 
deviate more from the input values than when Fast is off.

To edit data attributes:
1. Select Dataset > Edit Attributes.





2. Do you want to work with a dataset other than the active dataset?    If yes, select the dataset 
from the Dataset drop-down list.

SEE ALSO

Viewing Dataset Information 
Resampling the Data 
Extracting Data 
Defining a Grid 
Editing Dataset Geometry 



Editing Dataset Geometry
There are several ways you can edit a datasets geometry.    You can change the origin, reorganize 
the IJK parametric axes, and change the matrix.    You can also move a dataset to another location 
and rotate and scale it.

SEE ALSO

Editing Dataset Origin 
Viewing Dataset Information 
Resampling the Data 
Extracting Data 
Defining a Grid 
Editing Data Attributes 



Editing Dataset Origin
The dataset origin point consists of an X-coordinate value, a Y-coordinate value, and a Z-
coordinate value.    You can edit the origin point by changing any or all of these values.

To edit a datasets origin:
1. Select Dataset > Edit Geometry > Origin.





SEE ALSO

Moving a Dataset 
Rotating a Dataset 
Scaling a Dataset 
Reorganizing a Dataset 
Returning a Dataset to Its Identity Matrix 
Returning a Dataset to Its Primary Matrix 



Moving a Dataset

To move a dataset:
1. Select Dataset > Edit Geometry > Move.





SEE ALSO

Editing Dataset Origin
Rotating a Dataset 
Scaling a Dataset 
Reorganizing a Dataset 
Returning a Dataset to Its Identity Matrix 
Returning a Dataset to Its Primary Matrix 



Rotating a Dataset

To rotate a dataset:
1. Select Dataset > Edit Geometry > Rotate.





SEE ALSO

Editing Dataset Origin 
Moving a Dataset 
Scaling a Dataset 
Reorganizing a Dataset 
Returning a Dataset to Its Identity Matrix 
Returning a Dataset to Its Primary Matrix 



Scaling a Dataset

To scale a dataset:
1. Select Dataset > Edit Geometry > Scale.





SEE ALSO

Editing Dataset Origin 
Moving a Dataset 
Rotating a Dataset 
Reorganizing a Dataset 
Returning a Dataset to Its Identity Matrix 
Returning a Dataset to Its Primary Matrix 



Reorganizing a Dataset

To reorganize a dataset:
1. Select Dataset > Edit Geometry > Organize.





SEE ALSO

Editing Dataset Origin 
Moving a Dataset 
Rotating a Dataset 
Scaling a Dataset 
Returning a Dataset to Its Identity Matrix 
Returning a Dataset to Its Primary Matrix 



Returning a Dataset to Its Identity Matrix

To return a dataset to its identity matrix:
Select Dataset > Edit Geometry > Identity.

SEE ALSO

Editing Dataset Origin 
Moving a Dataset 
Rotating a Dataset 
Scaling a Dataset 
Reorganizing a Dataset 
Returning a Dataset to Its Primary Matrix 



Returning a Dataset to Its Primary Matrix

To return a dataset to its primary matrix:
Select Dataset > Edit Geometry > Primary.

SEE ALSO

Editing Dataset Origin 
Moving a Dataset 
Rotating a Dataset 
Scaling a Dataset 
Reorganizing a Dataset 
Returning a Dataset to Its Identity Matrix 



Resampling Options
· Keep every nth entry    ---    resamples every nth value along each grid column/row.    (The 

resampled volume dimension is equal to the largest integer value greater than or equal to (the 
original grid dimension)/n.)

· Replace every n with average    ---    resamples the average of every nth value along each grid 
column/row.    (The resampled volume dimension is equal to (the original grid dimension)/n.)

· Add n entries between indices    ---    adds n values between each IJK par(type popup 
definition text here)

· Interpolate into n indices    ---    linearly interpolates along each grid row/column into n and 
uses the results to define the corresponding volume entry.    The resulting volume row/column 
dimension is equal to n.

Where n equals:

Row -- resamples along a row.
Column -- resamples along a column.

NOTE        Interpolate into n indices is only available when importing data attributes from 
grid(s).



Constant Interpolation
This method applies the center node value to all grid nodes in the influence range.
 



Probing a Dataset
Under construction.

SEE ALSO

Viewing Dataset Statistics 
Creating a Crossplot 
Calculating Surface Area 
Calculating Volume 
Calculating Irregular Volumes 



Viewing Dataset Statistics
Under construction.

SEE ALSO

Probing a Dataset 
Creating a Crossplot 
Calculating Surface Area 
Calculating Volume 
Calculating Irregular Volumes 



Creating a Crossplot
Under construction.

SEE ALSO

Probing a Dataset 
Viewing Dataset Statistics 
Calculating Surface Area 
Calculating Volume 
Calculating Irregular Volumes 



Calculating Surface Area
Under construction.

SEE ALSO

Probing a Dataset 
Viewing Dataset Statistics 
Creating a Crossplot 
Calculating Volume 
Calculating Irregular Volumes 



Calculating Volume
Under construction.

SEE ALSO

Probing a Dataset 
Viewing Dataset Statistics 
Creating a Crossplot 
Calculating Surface Area 
Calculating Irregular Volumes 



Calculating Irregular Volumes
Under construction.

SEE ALSO

Probing a Dataset 
Viewing Dataset Statistics 
Creating a Crossplot 
Calculating Surface Area 
Calculating Volume 

 



Defining Working Units
Under construction.

SEE ALSO

Setting Preferences 
Converting Data 
Taking Snapshots 
Creating Stereo Displays 
Creating Reports 



Setting Preferences
Under construction.

SEE ALSO

Defining Working Units 
Converting Data 
Taking Snapshots 
Creating Stereo Displays 
Creating Reports 



Converting Data
Under construction.

SEE ALSO

Defining Working Units 
Setting Preferences 
Taking Snapshots 
Creating Stereo Displays 
Creating Reports 



Taking Snapshots
Under construction.

SEE ALSO

Defining Working Units 
Setting Preferences 
Converting Data 
Creating Stereo Displays 
Creating Reports 



Creating Stereo Displays
Under construction.

SEE ALSO

Defining Working Units 
Setting Preferences 
Converting Data 
Taking Snapshots 
Creating Reports 



Creating Reports
Under construction.

SEE ALSO

Defining Working Units 
Setting Preferences 
Converting Data 
Taking Snapshots 
Creating Stereo Displays 

 



To open a saved dataset:
Select File > Open > Dataset.



To save a dataset to a file:
Select File > Save As > Dataset.



To turn levels on/off:

Click  in the View Control bar (or select View Control > 
Levels).

1. Click the level numbers you want, or press and hold the mouse Data button and drag the 
pointer over several level numbers.

2. Click OK.



To adjust Z scale:

Click  in the View Control bar (or select View Control > Z 
Scale).

1. In the Current Z Scale text box, type a new Z scale value.
2. Click Apply and view the result, or click OK.



To adjust viewing position:

Click  on the View Control bar (or select View Control > 
Vantage Point).

1. In the Azimuth text box, type the azimuth value.
2. In the Declination text box, type the declination value.
3. In the Distance text box, type the distance between you and the object.
4. In the Field of View text box, type the field of view value.
5. Click Close.



To turn on and adjust dynamics:

Click  on the View Control bar (or select View Control > 
Dynamics).

1. Click Dynamics to turn dynamics on.
2. In the Horizontal and Vertical Rotation text boxes, type the horizontal and vertical rotation 

speeds, respectively.
3. In the Zoom Speed text box, type the zoom speed.
4. Click Close.



To view dataset information:
Select Dataset > Information.

1. View the information about the current dataset.    Notice the bounding volume, the grid size, 
and the attribute information.

2. Do you want to see a different dataset?    If yes, select the dataset from the Dataset drop-down 
list.

3. Do you want to rename the current dataset?    If yes, in the Rename text box, type a new 
name.

4. Do you want to rename the current dataset file?    If yes, in the File Name text box, type a 
new name.

5. Do you want to see a different attribute?    If yes, select the attribute from the Attribute drop-
down list.

6. Do you want to rename the current attribute?    If yes, in the Rename text box, type a new 
name.

7. Do you want to change the attribute units?    If yes, in the Units text box, type new units.
8. Do you want to see the data range for the current attribute?    If yes, click Scan.
9. Do you want to change the void value for the current attribute?    If yes, click Void Value and 

type a new value in the text box.
10. Do you want to change the multiplier value for the current attribute?    If yes, click Multiplier 

and type a new value in the text box.
11. Do you want to change the attribute to a non-symbolic attribute?    If yes, click Symbolic.



To resample a dataset:
Select Dataset > Resample.

1. Do you want to resample a dataset other than the current dataset?    If yes, select the dataset 
from the Dataset drop-down list.

2. Review the current IJK index values.
3. Do you want to change the default name of the resampled dataset?    If yes, in the Resampled 

Dataset text box, type a new name.
4. Select a resample method.
5. In the I, J, or K text boxes, type new values; click the I, J, or K option for the value(s) you do 

not want to change.
6. Click OK.



To extract data from a dataset:
Select Dataset > Extract.

1. Do you want to extract data from a dataset other than the current dataset?    If yes, select the 
dataset form the Dataset drop-down list.

2. Do you want to change the default name of the extracted dataset?    If yes, in the Name text 
box, type a new name.

3. Do you want to change the default description?    If yes, in the Description text box, type a 
new description.

4. Click the Parametric Range icon.

5. Move the sliders or type values to adjust the IJK parametric range of the new dataset.
6. Click OK.
7. Click OK on the Extract Dataset dialog box.



To define a grid:
Select Dataset > Define Grid.

To define a new grid:
1. Do you want to modify the default name of the new grid?    If yes, in the Dataset text box, 

type a new name.
2. Click Add Single to start building the new grid.    Move the pointer to position the new slice 

along the I axis.    You can change the axis by clicking one of the axis options.
3. To add multiple slices, click Add Multiple and in the Number of Slices text box, type the 

number of slices.    Then position the slices along the axis.
4. Click OK.

To modify an existing dataset grid:
1. Select the dataset from the Dataset drop-down list.
2. Review the grid size and type any changes in the IJK text boxes.
3. In Slice Operations, click the axis you want to modify.
4. To add a slice or slices, follow the instructions for defining a new grid.
5. To delete a slice or slices, click Delete Single or Delete Multiple and click the slice or slices 

you want to delete.
6. Click OK.



To edit data attributes:
Select Dataset > Edit Attributes.

Do you want to work with a dataset other than the active dataset?    If yes, select the dataset from 
the Dataset drop-down list.



To edit a dataset's origin:
Select Dataset > Edit Geometry > Origin.



To move a dataset to a new location:
Select Dataset > Edit Geometry > Move.



To rotate a dataset:
Select Dataset > Edit Geometry > Rotate.



To scale a dataset:
Select Dataset > Edit Geometry > Scale.



To reorganize a dataset:
Select Dataset > Edit Geometry > Organize.

 



MGVA_ASCII File Format
This appendix describes requirements for creating an MGVA_ASCII format data file.    
Descriptions of the commands that you use to create this file and examples of MGVA_ASCII 
files are also provided.

NOTE        Two commands in Voxel Analyst use the MGVA_ASCII file format:    Convert ASCII 
to Volume and Convert Volume to ASCII.      These commands and Import ASCII Data provide a 
convenient way to input and output ASCII data.

Command Requirements 

1. The first command must be MGVA_ASCII. 

2. The second command must be version <ver. no.>. 

3. The rest of the commands are organized into groups.    These groups must appear in the 
following order: 

Dataset 
XYZ_Points 
Attribute (This group of commands can be repeated.) 

4. Commands within each group can be in any order. 

5. MGVA_ASCII commands are not case-sensitive; keywords are case-sensitive.    (A 
keyword is a predefined mnemonic that represents a parameter value.) 
6. All MGVA_ASCII commands except MGVA_ASCII have one or more parameters 
shown within angle brackets (< >).    Multiple parameters are delimited by white spaces (space, 
tab, or line feed). 
7. Most MGVA_ASCII commands have default parameter values that take effect if the 
command is omitted.    Default parameter values are listed within square brackets ([    ]) in the 
appropriate command descriptions. 
8. Parentheses can be used in MGVA_ASCII commands to improve their readability.    

Parentheses do not change the meaning of the command. 

9. A number sign (#) must be placed in front of each comment line. Comments are optional. 

Command Descriptions 

1. MGVA_ASCII    ---    This command must be the first command in an MGVA_ASCII file.    
This command defines the file format. 

2. version <ver. no.>    ---    This command must be the second command in an MGVA_ASCII 
file.    ver. no is a character string that represents the version of the MGVA_ASCII format 
specification. 

EXAMPLE:    version 5.1



3. Dataset Command Group 

· dataset <name> <descr> <kind>    ---    This command starts the Dataset command group. 

name is the name of the dataset.    If name contains white spaces, it must be quoted. 

descr      is the description of the dataset. 

kind specifies the kind of dataset.    Valid values are 0, 1, and 2.    The corresponding 
keywords are:

Value      Keyword 

      0              VOLUME 
      1              SURFACE 
      2              LINEAR

EXAMPLE 1:    dataset mining sample 0 

In this example, a value is used for the kind parameter. 

EXAMPLE 2:    dataset "mining set" sample 0 

In this example, the dataset name is quoted because it contains a white space. 

EXAMPLE 3:    dataset "mining set" sample VOLUME 

In this example, the VOLUME keyword has been substituted for the kind parameter value in 
Example 2. 

· dimensions <i> [10] <j> [10] <k> [10]    ---    This command specifies dimensions in the i, j, 
and k parametric directions.    Valid values for the i, j, and k parameters must be integers. 

EXAMPLE:    dimensions 15 15 15 

· index_method <x> [DELTA] <y> [DELTA] <z> [DELTA]    ---    This command specifies 
the index method for x, y, and z.    Valid values for the x, y, and z parameters are integers in 
the range zero to 15.    The corresponding keywords are: 

Value      Keyword 

0                    DELTA 
1                    I 
2                  J 
3                  K 
4                  IJ 
5                  JI 
6                  IK 
7                  KI 
8                  JK 
9                  KJ 
10              IJK 
11              IKJ 
12              JIK 
13              JKI 
14              KIJ 
15              KJI 



EXAMPLE 1:    index_method 10 12 14 

EXAMPLE 2:    index_method IJK JIK KIJ 

In this example, keywords have been substituted for the parameter values in Example 1. 

· bounding_vol <minx> [0] <maxx> [1] <miny> [0] <maxy> [1] <minz> [0] <maxz> [1]    
---    This command specifies the minimum bounding volume of the dataset.    Valid values for 
the minx, maxx, miny, maxy, minz, and maxz parameters are floating point numbers. 

EXAMPLE:    bounding_vol 1 2 1 2 1 2 

NOTE        If the points_x, points_y, and points_z commands are used, the minimum bounding 
volume is calculated from the grid coordinates given by these commands. 

· transform <a00> <a01> .. <a33>    ---    This command specifies a 4X4 transformation 
matrix.    The parameter values are floating point numbers.    The default values are the values 
used in the identity matrix (I). 

4.    XYZ_Points Command Group 

· num_dpoints <x> [0] <y> [0] <z> [0]    ---    This command specifies the number of x, y, and 
z points in the grid.    Valid values for the x, y, and z parameters are integer numbers or zeros. 

EXAMPLE:    num_dpoints 1 1 1 

NOTE        If the bounding_vol command has been omitted, and if the points_x, points_y, and 
points_z commands specify coordinates, the minimum and maximum values of these 
coordinates replace the default values of the bounding volume. 

· points_x <x0> <x1> ...<xn>    ---    Valid values for the xn parameters are grid points in x.    
The number of parameters must be equal to the x parameter of the num_dpoints command. 

EXAMPLE:    points_x 1 

· points_y <y0> <y1> ...<yn>    ---    Valid values for the yn parameters are grid points in y.    
The number of parameters must be equal to the y parameter of the num_dpoints command. 

EXAMPLE:    points_y 1 

· points_z <z0> <z1> ...<zn>    ---    Valid values for the zn parameters are grid points in z.    
The number of parameters must be equal to the z parameter of the num_dpoints command. 

EXAMPLE:    points_z 1 

5.    Attribute Command Group 

· attribute <name> <descr>    ---    This command starts the Attribute command group. 

name is the name of the attribute.    If name contains white spaces, it must be quoted. 

descr is the description of the attribute data. 

EXAMPLE 1:    attribute gold ore 

EXAMPLE 2:    attribute "concentration of alcohol" contaminants 

In this example, the attribute name is quoted because it contains white spaces. 

· order <d> [1]    ---    This command specifies the number of attribute data elements per cell in 
the grid. Valid values for the d parameter are integers. 



EXAMPLE:    order 3 

· data_type <type> [FLOAT]    ---    This command specifies the data type of the attribute.    
Valid values for the type parameter are integers in the range zero to seven.    The 
corresponding keywords are the following: 

Value      Keyword 

0                    BYTE 
1                    U_BYTE 
2                    SHORT 
3                    U_SHORT 
4                    INT 
5                    U_INT 
6                    FLOAT 
7                    DOUBLE 

EXAMPLE 1:    data_type 0 

EXAMPLE 2:    data_type BYTE 

In this example, the BYTE keyword has been substituted for the type parameter value in 
Example 1. 

· field_flags <flags> [0]    ---    This command specifies the type of attribute field.    Valid 
values for the flags parameter are the integers 0, 4, 8, and 16, or any combination thereof.    
The corresponding keywords are the following: 

Value      Keyword              Description 

0                    None                        No attribute field type is specified. 
4                    SYMBOL            Declares the attribute data as symbolic values. 
8                    VOID                        Turns on the data void value. 
16                MULT                      Turns on the data multiplier. 

EXAMPLE 1:    field_flags 4 

EXAMPLE 2:    field_flags SYMBOL 

In this example, the SYMBOL keyword has been substituted for the flags parameter value in 
Example 1. 

EXAMPLE 3:    field_flags 8+16+4 

Example 4:    field_flags VOID+MULT+SYMBOL 

In this example, keywords have been substituted for the parameter values in Example 3. 

· multiplier <mult> [1.0]    ---    This command specifies the field multiplier. mult is a double-
precision, floating point number. 

Example:    multiplier 2.0 

· void_value <void> [0.0]    ---    This command specifies the field void value. void is a 
double-precision, floating-point number. 

Example:    void_value 1.0 

· units <units> [""]    ---    This command specifies the attribute data units.    units is a 
character string that describes the units. 

Example:    units ppm 



· data <data0> <data1> ...<datan>    ---    The parameters [data0] to [datan] comprise the 
attribute data.    The number of data values must be the following: 

dimensions.k * dimensions.j * dimensions.i * order. 

The data type of the parameters must correspond to the type specified by the data_type 
command. 

MGVA_ASCII File Format -- Examples 

EXAMPLE 1:        The following is a generic example of the MGVA_ASCII file format.    Default 
parameter values are shown in square brackets ([ ]).    Comments are preceded with a number 
sign (#).    Comments provide descriptions of the commands. 

MGVA_ASCII                                                                                      # This command must be first. 

version <ver_no>                                                                            # This command must be second. 

dataset <name> <descr> <kind>                            # Begins the Dataset group.

dimensions <i> [10] <j> [10] <k> [10]                # Specifies dimensions in the i, j, and k 
parametric directions. 

index_method <x> [0] <y> [0] <z> [0]                # Index method for x, y, z. 

bounding_vol <minx> [0] <maxx> [1] <miny> [0] <maxy> [1] <minz> [0] <maxz> [1] 
# Specifies the minimum bounding volume of the dataset. 

transform    <a00> <a01> .. <a33>                          # Specifies the transformation matrix. 

num_dpoints <x> [0] <y> [0] <z> [0]                  # Begins the XYZ_Points group and specifies the 
number of x, y and z points. 

points_x <x0> <x1> <xn>                                                  # x coordinates.

points_y <y0> <y1> <yn>                                                  # y coordinates.

points_z <z0> <z1> <zn>                                                  # z coordinates.

attribute <name> <desc>                                                  # Begins the Attribute group. 

order <d> [1]                                                                                        # Specifies the number of attribute 
values per grid cell. 

data_type <type> [FLOAT]                                            # Specifies the attribute data type. 

field_flags <type> [0]                                                              # Specifies the attribute field type. 

multiplier <mult> [1.0]                                                            # Specifies the field multiplier. 

void_value <void> [0.0]                                                      # Specifies the field void value. 

units <units> [""]                                                                            # Specifies the attribute data units. 

data <data0> <data1> <datan>                              # Specifies the attribute data.    The number of data 
points is dims[x]*dims[y]*dims[z]*order. 

The following are real-world examples of MGVA_ASCII files.    These files are delivered in 
\voxel\samples\misc: 

EXAMPLE 2 (regular.asc): 



######### DATASET regular ########## 
dataset          "regular" "Regular Dataset Sample" VOLUME 
dimensions    3 3 3 
index_method        DELTA DELTA DELTA 
bounding_vol        0 1000 0 1000 0 1000 
transform      1 0 0 0 
                                    0 1 0 0 
                                    0 0 1 0 
                                    0 0 0 1 
num_dpoints          0 0 0 
points_x 

points_y 

points_z 

attribute      "oil" "Regular Oil" 
order              1 
data_type      FLOAT 
void_value    0 
multiplier    1 
field_flags          0 
units              "ppb" 
#### Minimum and maximum data values: 0, 10 
data 
0 1 3 
1 2 3 
2 3 4 
## 
3 4 5 
4 5 6 
5 6 7 
## 
6 7 8 
7 8 9 
8 9 10 
## 
  

EXAMPLE 3 (linear.asc): 

######### DATASET linear ########## 
dataset          "linear" "Rectilinear Dataset Sample" VOLUME 
dimensions    3 3 3 
index_method        K J I 
bounding_vol        0 1000 0 1000 0 1000 
transform      1 0 0 0 
                                    0 1 0 0 
                                    0 0 1 0 
                                    0 0 0 1 
num_dpoints          3 3 3 
points_x 
0 200 1000 
points_y 
0 400 1000 
points_z 
0 700 1000 



attribute      "linear" "Linear Resistivity" 
order              1 
data_type      FLOAT 
void_value    0 
multiplier    1 
field_flags          0 
units              "Om/cm" 
#### Minimum and maximum data values: 0, 10 
data 
0 1 3 
1 2 3 
2 3 4 
## 
3 4 5 
4 5 6 
5 6 7 
## 
6 7 8 
7 8 9 
8 9 10 
## 
  

EXAMPLE 4 (structured.asc): 

######### DATASET structured ########## 
dataset          "structured" "Sample of Fully Structured Dataset" VOLUME 
dimensions    3 3 3 
index_method        IJK IJK IJK 
bounding_vol        0 1000 0 1000 0 1000 
transform      1 0 0 0 
                                    0 1 0 0 
                                    0 0 1 0 
                                    0 0 0 1 
num_dpoints          27 27 27 
points_x 
0 1 2 
10 11 12 
20 21 22 
402 403 404 
411 412 414 
420 421 424 
1000 1000 1000 
1000 1000 1000 
1000 1000 1000 

points_y 
0 0 0 
300 300 300 
1000 1000 990 
0 0 0 
300 300 300 
1000 1000 980 
0 0 0 
300 300 300 
1000 1000 970 



points_z 
0 500 990 
1 510 990 
2 520 1000 
3 560 1000 
4 600 990 
5 620 1000 
6 640 990 
7 660 1000 
8 680 1000 

attribute      "density" "Structured Soil" 
order              1 
data_type      FLOAT 
void_value    0 
multiplier    1 
field_flags          0 
units              "g/cm3" 
#### Minimum and maximum data values: 0, 10 
data 
0 1 3 
1 2 3 
2 3 4 
## 
3 4 5 
4 5 6 
5 6 7 
## 
6 7 8 
7 8 9 
8 9 10 
## 
  



ADF File Formats
ASCII Data Format (ADF) files are designed to be flexible and to allow easy translation of 
different types of ASCII data.    This appendix describes the ADF records and formats used by 
Voxel Analyst for data input and output.    Examples of ADF input files supported by Voxel 
Analyst are provided for your reference. 

ADF Overview 
ADF provides a flexible, well-defined mechanism for formatting and inputting ASCII data from 
other Intergraph and third-party applications into Voxel Analyst.    The ADF output files produced 
by Voxel Analyst can be input to other Intergraph applications, such as MGE Terrain Analyst 
(MTA) and MGE Modeler (MGM). 

ADF Records and Formats 
Data in ADF files are divided into the following record types: 

· Data descriptors 

· Data records 
· Comment records 

Data descriptors 
Data descriptors describe some aspect of the data that follows. When a descriptor is specified, it 
affects all records that use the descriptor until another descriptor of the same type is specified. 

Each data descriptor has an individual data record.    You can define attributes and assign values 
within the data record.    For more information, see Data Records. 

Data descriptors are divided into the following categories: 

· Context descriptors provide information about the way the data in the ADF file relates to the 
real world.    Context descriptors are used to specify such things as the coordinate system and 
the units of measure. 

· Attribute descriptors allow you to construct user-defined attributes. 
· Format descriptors designate the format of data records in the ADF file. 

Data records 
Data records detail the location and attributes of spatial entities. A data record may contain one 
or more entries that contain the data for the one instance of the object that the data record 
represents. Entries must conform to the format specified by the format descriptor for that 
particular data record.    Entries consist of data fields that represent a specific quantity or attribute 
of an entry. These records compose the body of the data.    They may specify the coordinates and 
attributes of points in the scope of the spatially related data.    Voxel Analyst ADF files are not 
case sensitive and may contain both uppercase and lowercase data fields.    It is recommended 
that for ADF input files you use the conventions shown in the examples in Voxel Analyst ADF 
File Examples. 

Comment Records 
Comment records provide information about the data contained in the ADF file.    These records 
can be specified anywhere within the file except within fixed-format data records. 

A comment line begins with an asterisk (*).    When an asterisk is specified, the rest of the line is 
considered a comment.    Asterisks may not be specified in data fields.    The following is an 



example of a comment: 

*    This is a comment line.

Data Types 
Data in ADF files can be of the following types: 

· Keywords are specific strings that are used within ADF to describe the data contained in the 
file.    The spelling of a keyword is very important; a misspelled keyword is not interpreted.    
Keywords cannot be abbreviated. 

· Strings are used in ADF files to describe user-defined data.    A string cannot be longer 
than 80 characters in length.    Strings cannot contain any of the following special characters: 
        "      Double Quote 
        *      Asterisk 
        {      Left (Opened) Brace 
        }      Right (Closed) Brace 
        (      Left (Opened) Parenthesis 
        )      Right (Closed) Parenthesis 
        ^      Carat 
        @      At 
        ,      Comma 
        |      Vertical Bar 

· Numbers can be either real or integer values. The following are examples of legal numeric 
values: 

          723 
          82.2325

Spacing 
Spacing between fields within the data record can be either of the following: 

· Whitespace:    tabs or spaces 

IMPORTANT        Any amount of white space can exist between data fields.    However, if a 
data field is missing (that is, if two delimiters in a row are missing), the default value of the 
data field is assumed. 

· Delimiters:    commas ( , ) or vertical bars ( | ) 

Attribute Descriptors 
Attribute descriptors allow you to specify Voxel Analyst-specific information about the data.    
Voxel Analyst requires certain Attribute data records to be contained within the ADF file before 
any processing can be done.    These are specified in the following format: 

ATTRIBUTE    Voxel Analyst_TYPE    <file type>

where: 

file type is the type of input ADF file.    (Currently, GRID is the only file type that Voxel Analyst 
supports.) 

ATTRIBUTE    MGVA_I    <dimension> 
ATTRIBUTE    MGVA_J    <dimension> 
ATTRIBUTE    MGVA_K    <dimension> 

where: 



dimension defines the dimension in the I, J, K direction, respectively, of the data that follows. 

ATTRIBUTE        MGVA_MAJOR      <major type>

where: 

major type can be either ROW or COL. This indicates whether the data within a specific layer is 
listed row by row or column by column, respectively. 

ATTRIBUTE    MGVA_INDEX    <index number>

where: 

index number indicates the index along which the layers are listed.    Valid values are 0, 1, 2 for 
indices I, J, K, respectively. 

Attribute descriptors may also be used to specify the units for the data fields contained in the 
data that follows.    These descriptors are specified in the following format: 

ATTRIBUTE    <data field>    <data field unit>

where: 

data field indicates the name of the data field contained in the information that follows. 

data field unit indicates the unit abbreviation to be used when reporting any data field 
information. 

EXAMPLE: 

ATTRIBUTE        acetone      ppb                ppb used for acetone information

ATTRIBUTE        fuel_oil      ppmame        ppmame used for fuel_oil information

ATTRIBUTE        dioxin        ppm21            ppm21 used for dioxin information

Units Descriptors 
Units descriptors relate specific units to a given measure. Measurements include elevations and 
projected coordinates. 

Elevations 
Elevations represent the height above mean sea level.    ADF allows you to specify the units in 
which the elevation data occurs and the unit's corresponding conversion factor to meters.    These 
are specified in the following format: 

UNITS    ELEVATION    <unit>    <conversion factor>

where: 

unit indicates the unit abbreviation to be used when reporting the elevation information. 

conversion factor indicates the number of user-defined units per standard international meter. 

NOTE        If no elevation unit is specified, meters are assumed. 

Projected coordinates 
Projected coordinates are points that lie in a Cartesian coordinate system known as the map 
plane.    The values of projected coordinates correspond to the northing and easting fields of all 
data records. ADF allows for user-defined units to be assigned to projected coordinates.    These 
are specified in the following format: 



UNITS    PROJECTED_COORDINATES    <unit>    <conversion factor>

where: 

unit indicates the unit abbreviation to be used when reporting the coordinate information. 

conversion factor indicates the number of user-defined units per standard international meter. 

NOTE        If no projected coordinate unit is specified, meters are assumed.

Point Descriptors 

Point descriptors (keywords) 
Once the position of a field is defined with a keyword in the POINT_FORMAT descriptor 
record, it can be assigned values within POINTS records.    The respective positions of the active 
POINT_FORMAT record remain active until changed with another POINT_FORMAT 
descriptive record.    The valid field names or keywords that can be used to define the point data-
record format are the following: 

NORTHING EASTING ELEVATION    ---    These field names indicate that the points are 
represented by coordinates.    These fields may be assigned positive or negative real or integer 
values. 

Point format 
The POINT_FORMAT descriptor indicates the format of point records that follow.    In the 
point format statement, the field names and attributes preceding the left (opened) brace ( { ) are 
assigned a value once for each point record.    The value assigned is interpreted the same for 
every entry in the point record. 

EXAMPLE: 

POINT_FORMAT { 
EASTING      NORTHING          ELEVATION        stratum 
} 

This format record indicates that the points are listed with each point containing an easting value, 
a northing value, an elevation value, and finally a stratum data-field value. 

Point records 
A point record indicates that the entries in the record represent the point data as specified in the 
active POINT_FORMAT record.    Point-data items missing from an entry must use a carat (^) 
character as a place holder.    The list of point entries is surrounded by left (opened) and right 
(closed) braces ({ }). 

EXAMPLE: 

POINTS 
{ 
4780668.16      -2564339.04      -1900.00      2.996526 
4780668.16      -2563963.20      -1900.00      2.883303 
4780668.16      -2563587.36      -1900.00      2.743454 
} 

Voxel Analyst ADF Records 



The following list contains the ADF record types and record-format statements that are accepted 
by Voxel Analyst for Import ASCII Data and Export ASCII Data. 

NOTE        Comment lines beginning with asterisks (*) may be used as needed. 

ATTRIBUTE      MGVA_TYPE            <file type> 
ATTRIBUTE      MGVA_I                  <dimension> 
ATTRIBUTE      MGVA_J                  <dimension> 
ATTRIBUTE      MGVA_K                  <dimension> 
ATTRIBUTE      MGVA_MAJOR          <major type> 
ATTRIBUTE      MGVA_INDEX          <index number> 
ATTRIBUTE      <data field>      <data field unit> 
UNITS          ELEVATION                <unit>        <conversion factor> 
UNITS          PROJECTED_COORDINATES      <unit>          <conversion factor> 
POINT_FORMAT 
{ } 
POINTS { } 

Voxel Analyst ADF File Examples 
You can edit existing data files to conform to ADF standards by editing them the match the 
following examples, which are typical of the format used for ADF files.    The format statements 
must precede the records.    Blank lines, spaces, and tabs are permitted. 

NOTE       ADF format is nonrestrictive.    For every data descriptor in the format records, ADF 
reads a data record. If the data file does not contain all the data values on one line, then the next 
value on the next line is read.    If there is no value, a record holder is used to prevent an incorrect 
mapping of values.    Therefore, you must be careful when creating an input ADF file from 
scratch or when modifying an existing ASCII data file. 

EXAMPLE 1: 

* File: .\adf_ex0.adf 

VERSION 2.6 
ATTRIBUTE MGVA_TYPE GRID                      File contains gridded data. 

UNITS PROJECTED_COORDINATES m 1        The X,Y coordinates are in meters. 

UNITS ELEVATION ft 0.3048                    The Z coordinate is in feet.

ATTRIBUTE MGVA_I 2 
ATTRIBUTE MGVA_J 2                                  The dimensions of the data are 2 x 2 x 2.

ATTRIBUTE MGVA_K 2 
ATTRIBUTE MGVA_MAJOR ROW                      The data is listed in row major and has been 
extracted along index I (Z axis).

ATTRIBUTE MGVA_INDEX 0 
ATTRIBUTE att ""                                      The attribute att has no unit abbreviation associated with 
it.

POINT_FORMAT { 
EASTING NORTHING ELEVATION att          The points are listed by X,Y,Z, att value.

} 

POINTS { 
        0.000000              0.000000          0.000000        1.000000 
        0.000000      100.000000          0.000000        1.000000 
100.000000              0.000000          0.000000        1.000000 



100.000000      100.000000          0.000000        1.000000 
        0.000000              0.000000      10.000000        1.000000 
        0.000000      100.000000      10.000000        1.000000 
100.000000              0.000000      10.000000        1.000000 
100.000000      100.000000      10.000000        1.000000 
                    }

EXAMPLE 2: 

* File: .\adf_ex1.adf 

VERSION 2.6 
ATTRIBUTE MGVA_TYPE GRID                      File contains gridded data. 

UNITS PROJECTED_COORDINATES m 1        The X,Y coordinates are in meters. 

UNITS ELEVATION ft 0.3048                    The Z coordinates are in feet.

ATTRIBUTE MGVA_I 2 
ATTRIBUTE MGVA_J 2                                  The dimensions of the data are 2 x 2 x 2.

ATTRIBUTE MGVA_K 2 
ATTRIBUTE MGVA_MAJOR COLUMN                The data is listed in column major and has 
been extracted along index I (Z axis).

ATTRIBUTE MGVA_INDEX 0 
ATTRIBUTE att ""                                      The attribute unit abbreviation associated with it.

POINT_FORMAT { 
EASTING NORTHING ELEVATION att          The points are listed by X,Y,Z, att value.

} 

POINTS { 
        0.000000              0.000000            0.000000          1.000000 
100.000000              0.000000            0.000000          1.000000 
        0.000000      100.000000            0.000000          1.000000 
100.000000      100.000000            0.000000          1.000000 
        0.000000              0.000000        10.000000          1.000000 
100.000000              0.000000        10.000000          1.000000 
        0.000000      100.000000        10.000000          1.000000 
100.000000      100.000000        10.000000          1.000000 
                                  }



Interpolation Algorithms
Voxel Analyst provides a suite of interpolation algorithms or methods to assist you in interpreting 
3-D volume data.    This appendix describes the interpolation methods and their control 
parameters. Diagrams illustrating the behavior of the different methods with different control 
parameters are included. 

The interpolation algorithms are distance-based exact methods.    Distance-based algorithms use 
distance as the basic measure for interpolations.    Exact means that the interpolated values at the 
original input data points exactly match the original input values except for some small 
truncation errors. 

The interpolation methods are not physical modeling tools because they do not have direct 
correlations with real-world physical processes.    While the results of an interpolation depend on 
the input data and the methods that were used to interpolate it, the desired appearance of the 
interpolated data depends on your interpretation of the physics involved.    Therefore, it is not 
possible to have one interpolation method and one set of control parameters that fit different 
interpretations of different data. 

Convert Sparse Data to Volume Data converts sparsely sampled data to volume data based on the 
interpolation method you select and the control parameter values you define.    You should try 
different methods with different parameters to find the best result that fits your interpretation of 
your data. You can further modify the result to fit your interpretation by using Edit Attributes.

Algorithm Descriptions 
The following algorithms are implemented in Voxel Analyst:

Shepard Method 

Metric Method 

Multiquadric Method 

Thin-Plate Spline Method 

Volume Spline Method 

NOTE        The Multiquadric, Thin-plate Spline, and Volume Spline methods have a memory 
requirement based on the number of input source points.    Use the following formula to 
determine the number of bytes of memory you need: 

32 * n2 = bytes of memory 

where n is the number of source points. 

For example, 32 * 10002 = 32 megabytes (mb) 



Shepard Method
The Shepard method can be used for very rough and unevenly distributed input data.    This 
method is an inverse-distance weighted approximation.    That is, the contribution of each input 
point to a given output point is inversely proportional to its distance to the output point. 

This method satisfies the Maximum Principle, which states that the interpolated output values 
will not exceed the range of the original input data values.    That is, the interpolated output 
values will be no larger than the maximum value of the input values, and they will be no smaller 
than the minimum value of the input values.    This property guarantees the method not to 
generate negative values for non-negative physical measurements, such as concentration. 

The Shepard method is also bounded when extrapolating:    for an output region that is away 
from any input data points, the extrapolated values converge to the average of the input values 
(Figure C-1).    This is usually an undesired property.    Most of the time, a real physical quantity 
needs to be extrapolated into zero or some other reasonable value depending on the applications. 

To alleviate this problem, two parameters are provided.    The background parameter is the value 
to which the extrapolated values need to converge.    The influence range parameter is for 
determining the weighting distance for the convergence.    The weighting distance for the 
convergence is determined by multiplying the diameter of the minimum bounding sphere of the 
input data points by the influence range.    The influence range parameter is accepted as a 
positive number. 

The smaller the influence range, the faster the extrapolated values converge to the background 
value (Figure C-2).    When the influence range is too small, for example, 0.1, the output values 
will be mostly at the background value except where the output points are very close to an input 
data point.    Conversely, a large influence range causes the data to move toward the average 
value (Figure C-1) rather than the background.    This mechanism of adjusting the background 
value is turned off when the influence range parameter is set to zero.    (An influence range of 
zero is treated as infinite.) 

          Figure 3 - 1.    Shepard Method:    The effect of a large influence range. 



          Figure 3 - 2.    Shepard Method:    The effect of a small influence range. 



Metric Method
The Metric method can be used for very rough and unevenly distributed input data.    This 
method is an extension of the Shepard method.    Instead of directly using the inverse distance for 
the weighted approximation, the Metric method uses the powers of the inverse distance for the 
weight.    The contribution of each input point to a given output point is inversely proportional to 
the powers of its distance from the output point. 

The power parameter can be user defined.    This parameter defines how strong each intput data 
value affects the values of its nearby output points.    The larger the power is, the stronger the 
effect is (Figure C-3).    A very large power, for example, 20, would make the interpolated output 
values of the nearby region of each input point be the same as the individual input value.    
Conversely, a small power, for example, 0.1, would decrease the influence of the input data 
values.    The output volume would be filled mostly with the background value (Figure C-4).    
Small power (that is, anything less than one) is not recommended.    A power value of 2 causes 
the Metric method to produce the same results as the Shepard method.    (See the Maximum 
Principle defined in the Shepard Method .) 

          Figure 3 - 3.    Metric Method:    The effect of a large power. 



          Figure 3 - 4.    Metric Method:    The effect of a small power. 
The Metric method is also bounded when extrapolating:    for an output region that is away from 
any input data points, the extrapolated values converge to the average of the input values.    This 
is usually an undesired property.    Most of the time, a real physical quantity needs to be 
extrapolated into zero or some other reasonable value, depending on the applications. 
To alleviate this problem, two parameters are provided.    The background parameter is the value 
to which the extrapolated values need to converge.    The influence range parameter is for 
determining the weighting distance for the convergence.    The weighting distance for the 
convergence is determined by multiplying the diameter of the minimum bounding sphere of the 
input data points by the influence range.    The influence range parameter is accepted as a 
positive number. 

The smaller the influence range, the faster the extrapolated values converge to the background 
value (Figure C-4).    When the influence range is too small, for example, 0.01, the output values 
will be mostly at the background value except where the output points are very close to an input 
data point.    This mechanism of adjusting the background value is turned off when the influence 
range parameter is set to zero.    (An influence range of zero is treated as infinite.) 



Multiquadric Method
The Multiquadric method is used for input data that is relatively smooth and relatively evenly 
distributed.    This method tends to bubble around sample points. 

The Multiquadric method interpolates by defining an interpolating function first.    The 
interpolating function is derived from the input data.    It not only honors the input data values, 
but it also honors the spacial variations (the gradient) inherent in the input data. The interpolated 
output values follow the trend of the original input data (Figures C-5 and C-6). 

          Figure 3 - 5.    Multiquadric Method:    The effect of small variation. 

          Figure 3 - 6.    Multiquadric Method:    The effect of large variation. 
When extrapolating (that is, generating output values at places away from any input data points), 
this method stretches the output values to follow the trend in the input data.    This could cause 



overshot in the output values, and it may produce physically unrealistic output values, for 
example, negative concentrations.    When using Convert Sparse to Volume, it is highly 
recommended that you turn the Clip Min and Clip Max check boxes on (on the Convert Sparse 
Data to Volume Data dialog box) to clip the output values to a physically realistic range. 
The variation parameter is used to enhance the variations in the output data.    Valid input is any 
non-negative number.    However, it is not recommended to use any number that is larger than 
0.5.    A large number could make the interpolation unstable and could produce large errors. 



Thin-Plate Spline Method
The Thin-plate Spline method is used for relatively smooth and relatively evenly distributed 
input data.    This method is derived by minimizing the tension in a thin-plate spline. 
Mathematically, it minimizes the curvatures in the output data. 

When extrapolating, this method tries to keep the spatial derivatives constant to achieve the 
minimum curvature (Figure C-7).    This consequently could extrapolate the output values beyond 
the input value range.    Physically unrealistic output values, for example, negative 
concentrations, could be produced this way.    When this happens, it is highly recommended that 
you turn the Clip Min and Clip Max check boxes on (on the Convert Sparse Data to Volume Data 
dialog box) to clip the output values to a physically realistic range. 

          Figure 3 - 7.    Thin-plate Spline Method:    The effect of constant output values. 



Volume Spline Method
The Volume Spline method is used for input data that is relatively smooth and relatively evenly-
distributed.    This method is a generalization of the cubic splines.    Similar to the Multiquadric 
method, an interpolating function is derived from the input data first.    This function is composed 
of cubic polynomials.    Smooth volume is then generated from the interpolating function.    The 
resulting curve is the same as the curve produced by the Thin-plates Spline method, except that 
the curve is flatter near the source points. 

When extrapolating, this method could extend output values beyond the input-value range.    
Physically unrealistic output values, for example, negative concentrations, could be produced 
this way.    When this happens, it is highly recommended that you turn the Clip Min and Clip 
Max check boxes on (on the Convert Sparse Data to Volume Data dialog box) to clip the output 
values to a physically realistic range. 



Interpolation Restrictions
The following parameters (Figure 8) can be used to refine the selection of input source points for 
interpolating an output value: 

 
          Figure 3 - 8.    Restriction parameters. 
Restrictions                                                                    Selected Source Point
None                                                                                                                1    --    9
Use sparse pts. within MBV                                          2    --    9 
(Minimum Bounding Volume) only
Local                                                                                                                3    --    6
Symbolic local interpolation                                            4, 5

Symbolic without local interpolation                    4, 5, 7

If there is no source point left after applying various restrictions, the output node is assigned with 
the background values that you specified in the restriction parameters.    This background value 
should be the same as the one used in the Shepard and Metric methods. 

Local restriction 
Local restriction is very useful for creating regions with no source points filled with a 
background value. 

Symbolic restriction 
Symbolic restriction is useful for geologic applications in which source points in one geologic 



zone have no effect on the output values in another geologic zone. 

Variation enhancement 
One drawback of distance-based interpolations is that when producing volume data with flat 
geometry (that is, small Z range and large X,Y ranges), the output values show very little 
variation along the Z direction.    This is because the small Z range contributes less to the 
distance-based interpolations than the larger X,Y ranges.    To solve the problem, variation-
enhancement parameters are added to enhance the variation along the directions with small 
ranges. 

The Auto option on the Interpolation Parameters dialog box selects enhancement values such that 
X, Y, and Z contribute equally in the interpolation.    The Keyin option allows you to define your 
own values for variation enhancement. 

Summary 
All interpolation methods implemented in Voxel Analyst are distance-based exact methods.    The 
order of the related interpolating functions ranges from order one to order three as listed below: 

Shepard: ~ 1 
Metric: ~ 1 
Multiquadric: ~ 2 
Thin-plate spline: ~ 2.5 
Volume spline: 3 

Higher-order interpolating functions are more differentiable than lower-order ones; therefore, 
they generate smoother output values.    Higher-order interpolating functions may also stretch 
output values beyond the range of input values.    For interpolation methods with higher-order 
interpolating functions (Multiquadric, Thin-plate Spline, Volume Spline), it is highly 
recommended that you turn the Clip Min and Clip Max check boxes on (on the Convert Sparse 
Data to Volume Data dialog box) to clip the output values to a physically realistic range.    When 
sparse input data are relatively evenly distributed and relatively smooth, higher-order 
interpolation methods can be used.    When sparse input data are unevenly distributed and have 
highly varying values, lower-order interpolation methods, such as Shepard and Metric, are 
recommended. 

References 
Mathematical descriptions of Shepard and Metric interpolations can be found in Shepard's 
Method of Metric Interpolation to Bivariate and Multivariate Interpolation, by William J. Gordon 
and James A. Wixom, in Mathematics of Computation, Volume 32, Number 141, Jan. 1978, page 
253-264. 

Information on Multiquadric and Thin-plate Spline interpolations can be found in Visualization 
of Irregular Multivariate Data, by Thomas A. Foley and David A. Lane, in Proceedings of the 
First IEEE Conference on Visualization (1990). 

A complete discussion of the Multiquadric method is given by Rolland L. Hardy in Multiquadric 
Equations of Topography and Other Irregular Surfaces, in Journal of Geophysical Research, 
Volume 76, Number 8, March 10, 1971. 

The summary article by Gregory M. Nielson, Scattered Data Modeling, in IEEE Computer 
Graphics & Applications, January, 1993, presented the mathematical formula for Volume 
Splines, along with other interpolation methods mentioned in this appendix. 
 




