
TimeGuardianE



TimeGuardianE ii

COLLABORATORS

TITLE :

TimeGuardianE

ACTION NAME DATE SIGNATURE

WRITTEN BY October 27, 2024

REVISION HISTORY

NUMBER DATE DESCRIPTION NAME



TimeGuardianE iii

Contents

1 TimeGuardianE 1

1.1 TimeGuardianE.guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

1.2 TimeGuardianE.guide/Einleitung . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1

1.3 TimeGuardianE.guide/Was ist TimeGuardian? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2

1.4 TimeGuardianE.guide/Was bietet TimeGuardian für Fähigkeiten? . . . . . . . . . . . . . . . . . . . . . . . . . . 2

1.5 TimeGuardianE.guide/Was kann ich mit TimeGuardian machen? . . . . . . . . . . . . . . . . . . . . . . . . . . 3

1.6 TimeGuardianE.guide/Was benoetige ich um TimeGuardian nutzen zu koennen? . . . . . . . . . . . . . . . . . 3

1.7 TimeGuardianE.guide/Wie kann ich mich registrieren lassen? . . . . . . . . . . . . . . . . . . . . . . . . . . . . 4

1.8 TimeGuardianE.guide/Die Programme das Pakets TimeGuardian . . . . . . . . . . . . . . . . . . . . . . . . . . 5

1.9 TimeGuardianE.guide/Das Programm TimeGuardian . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

1.10 TimeGuardianE.guide/Die Menues des Programms TimeGuardian . . . . . . . . . . . . . . . . . . . . . . . . . 6

1.11 TimeGuardianE.guide/Der Menuepunkt Projekt=>Oeffnen . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7

1.12 TimeGuardianE.guide/Der Menuepunkt Projekt=>Speichern als . . . . . . . . . . . . . . . . . . . . . . . . . . 7

1.13 TimeGuardianE.guide/Der Menuepunkt Projekt=>Benutzer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

1.14 TimeGuardianE.guide/Der Menuepunkt Projekt=>Ikonifizieren . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

1.15 TimeGuardianE.guide/Der Menuepunkt Vorgaben=>auf zuletzt gespeichertes . . . . . . . . . . . . . . . . . . . 9

1.16 TimeGuardianE.guide/Der Menuepunkt Optionen=>Piktogramme erzeugen . . . . . . . . . . . . . . . . . . . . 9

1.17 TimeGuardianE.guide/Die Seite Über . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9

1.18 TimeGuardianE.guide/Die Seite Pfad Einstellung . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10

1.19 TimeGuardianE.guide/Das Eingabefeld Standard Pfad . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

1.20 TimeGuardianE.guide/Das Eingabefeld Neustarts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

1.21 TimeGuardianE.guide/Das Eingabefeld Rechenzeiten . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

1.22 TimeGuardianE.guide/Das Eingabefeld AnAus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 12

1.23 TimeGuardianE.guide/Das Eingabefeld Einmal am Tag . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

1.24 TimeGuardianE.guide/Das Eingabefeld Einmal im Jahr . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

1.25 TimeGuardianE.guide/Das Eingabefeld Zeituhr intervall . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

1.26 TimeGuardianE.guide/Das Eingabefeld Zeituhr fest . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15

1.27 TimeGuardianE.guide/Die Seite Zeit Einstellung . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18

1.28 TimeGuardianE.guide/Der Schieberegler Startzeit . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

1.29 TimeGuardianE.guide/Der Schieberegler Schrittweite . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20



TimeGuardianE iv

1.30 TimeGuardianE.guide/Der Schalter Datumsformat . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

1.31 TimeGuardianE.guide/Der Schalter Lokalisierung . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

1.32 TimeGuardianE.guide/Der Schalter Typ . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

1.33 TimeGuardianE.guide/Die Schieberegler Stunden- Minuten . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

1.34 TimeGuardianE.guide/Die Knoepfe Speichern- Benutzen . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

1.35 TimeGuardianE.guide/Die Knoepfe Voreinstellung- vorheriger Stand . . . . . . . . . . . . . . . . . . . . . . . . 22

1.36 TimeGuardianE.guide/Die Seite Hauptstatistik . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22

1.37 TimeGuardianE.guide/Die Seite Tagesstatistik . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23

1.38 TimeGuardianE.guide/Der Knopf Cron entfernen . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24

1.39 TimeGuardianE.guide/Der Knopf Ende . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24

1.40 TimeGuardianE.guide/Die Online-Hilfe . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25

1.41 TimeGuardianE.guide/Der AREXX-Port . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25

1.42 TimeGuardianE.guide/Was bedeuten die Fehlermeldungen (TimeGuardian) . . . . . . . . . . . . . . . . . . . . 25

1.43 TimeGuardianE.guide/Das Programm TGCron . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26

1.44 TimeGuardianE.guide/Was macht TGCron? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

1.45 TimeGuardianE.guide/Ausgabe von Informationen über TGCron . . . . . . . . . . . . . . . . . . . . . . . . . . 28

1.46 TimeGuardianE.guide/Wie kann ich TGCron starten? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29

1.47 TimeGuardianE.guide/Wie kann ich TGCron abbrechen? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

1.48 TimeGuardianE.guide/Was bedeuten die Fehlermeldungen (TGCron)? . . . . . . . . . . . . . . . . . . . . . . . 30

1.49 TimeGuardianE.guide/Wo bekomme ich die Zusatzprogramme? . . . . . . . . . . . . . . . . . . . . . . . . . . 31

1.50 TimeGuardianE.guide/Wo bekomme ich MUI? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

1.51 TimeGuardianE.guide/Wo bekomme ich den Installer? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

1.52 TimeGuardianE.guide/Wo bekomme ich den Amiga-Guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

1.53 TimeGuardianE.guide/Wie installiere ich TimeGuardian? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

1.54 TimeGuardianE.guide/Die Installation mit Installer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

1.55 TimeGuardianE.guide/Die Installation ohne Installer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35

1.56 TimeGuardianE.guide/Was ist MUI? . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36

1.57 TimeGuardianE.guide/Wo kann ich MUI registrieren lassen? . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37

1.58 TimeGuardianE.guide/Index . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37

1.59 TimeGuardianE.guide/Registrierungsformular . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39



TimeGuardianE 1 / 40

Chapter 1

TimeGuardianE

1.1 TimeGuardianE.guide

Documentation for TimeGuardian
Version 1.1, 17.8.94

written by Markus Matern

translated by Markus Matern and Gerri Körner

Programpackage TimeGuardian
(C)1994 Gerri Körner

This is the documentation for the package ‘TimeGuardian’
Version 1.1, 4.7.94.

The descriptions refers to the following programs:

* ‘TGCron’ Version 1.43, 24.7.1994

* ‘TimeGuardian’ Version 1.43, 2.8.94.

Introduction Introduction to ‘TimeGuardian’
Programs The program ‘TGCron’ and ‘TimeGuardian’

Supportprog. Where do I get the support programs?
Installation How can I install the package ‘TimeGuardian’?

‘MUI’ Informations about the Gui-System
‘MUI’ from Stefan Stunz

Index The Index

1.2 TimeGuardianE.guide/Einleitung

Introduction

************

Welcome to the documentation of the program package
‘TimeGuardian’.
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This package may be freely distributed, as long as no charges more
than reasonable copying and handling fees are collected. For any other
type of distribution, you must have the written permission of the
author. This package is shareware, when you want to use the programs
of this package permanently, you have to register, see how to register
for further information.

This program may be included in software collections, providing that
the previous conditions are respected.

This program package is provided without warranty of any kind. In no
event will the author be liable for direct, indirect, or incidental
damages resulting from any defect of the program or in its
documentation. The users are hereby warned of the possibility of such
damage occurences.

Description What is ‘TimeGuardian’?
Features The features of ‘TimeGuardian’
Usage What can I do with ‘TimeGuardian’?

Assumptions What do I need, to be able
to use ‘TimeGuardian’?

Registrating How can I register for ‘TimeGuardian’?

1.3 TimeGuardianE.guide/Was ist TimeGuardian?

What is ‘TimeGuardian’?
=======================

‘TimeGuardian’ is a program package with which you can
easily start events, that have to be done at certain times or dates on
your computer. You also can write log files to disk, where you can see
when your computer was switched on.

1.4 TimeGuardianE.guide/Was bietet TimeGuardian für Fähigkeiten?

The features of ‘TimeGuardian’
==============================

* easy to configure

* Alarm

* daily actions

* yearly actions

* events in time intervals

* localized gui
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* ‘Installer’

* ‘MUI’-GUI

* AREXX

* online help

1.5 TimeGuardianE.guide/Was kann ich mit TimeGuardian machen?

What can I do with ‘TimeGuardian’?
==================================

The package has two main functions, you can use seperately from each
other.

The first function it provides, is a function to save on disk every
time your computer was turned on and off. You get a complete log file
when anyone turned on your computer. When you want, you are able to log
different projects. That means, that you see in the log files, when you
wirked on a certain project, e.g. private work and business work. You
can analyse these log files easily with the graphical user interface,
so you get a quick overview when you spend time at your computer or at
certain projects.

The second function, that is provided by this package is a function
to start actions (commands or scripts) that you want to be executed
regularly or at specified dates or hours. Moreover you can start
programs or scripts once a day or once a year.

1.6 TimeGuardianE.guide/Was benoetige ich um TimeGuardian nutzen zu koen-
nen?

What do I need, to be able to use ‘TimeGuardian’?
=================================================

When you want to use all features of the package
‘TimeGuardian’, you need some other public domain or shareware
packages, which can’t be included in this package, because of different
reasons.

* OS version >= 2.0
You need a Workbench or Kickstart version greater or equal to 2.0

*by all means*. When you have not installed this two versions you
can’t install this package. When you want to know, which versions
you have installed, enter in a ‘Shell’: ‘version’. The result
should be like follows:
‘Kickstart version 37.175, Workbench version 37.XX’ or greater
numbers! You need a Workbench versioon >= 2.1 when you want to use
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the localized graphical user interface!

* ‘MUI’ >= 2.0
You need the program package ‘MUI’ to be able to use the graphical
user interface of the program ‘TimeGuardian’. You can use an
unregistered version of ‘MUI’ when you are testing the program
package. When you want to use ‘TimeGuardian’ regularely,
then please register for both packages ‘MUI’ and
‘TimeGuardian’. For further information on how to do this, see
registrating and ‘MUI’ .

* ‘Installer’
You need this program to install the package easily. Many other
program packages distribute this program. Where you can obtain
the program ‘Installer’, see ‘Installer’ .

* ‘Amiga-Guide’
You need this program, that you can use a feature of the graphical
user interface of ‘TimeGuardian’, the online help. When you
want to get information, on how to obtain this package, see
‘Amiga-Guide’.

1.7 TimeGuardianE.guide/Wie kann ich mich registrieren lassen?

How can I register for ‘TimeGuardian’?
======================================

That you are able to use the background program ‘TGCron’ as
long as you want, on a certain day, you need a certain file, you only
get, when you register. This file containd your name and is generated
for you personally. When this file is missing, you can use the program
only for about one and a half hour a day.

To obtain your personal key file, please send 20.- DM or 15.- US-$
in notes and the registration form (see Registration Form) to one of the
below adresses (please note, that only assigments from german users to a
german bank are accepted, because the fees for assignments from foreign
banks are as high as the registration fee). When you send the money, be
sure that you can’t see the notes inside! Put the notes inside the
registration form.

Gerri Körner
Kulturenweg 6

D-87642 Buching

Markus Matern
Max-Wieland-Straße 13

D-89134 Blaustein

You get your personal key file and the newest version of the program
package on disk.

You pay for the actual version of the program package
‘TimeGuardian’ and have neither the pretension to get newer, nor to get
enhanced program versions. You *don’t* have to register again for
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possible new versions of this package. The personal key files will stay
valid with new versions. Possible enhancements of the package will
depend on the number of registrations.

We both can’t be reached via telephone the next time, so when you
have questions, please send an *international reply coupon* to one of
the above adresses. The better way is to send an E-Mail to (other
forms of questions unfortunately can’t be answered.):

‘Gerri.Koerner@student.uni-ulm.de’ or
‘Markus.Matern@student.uni-ulm.de’.

1.8 TimeGuardianE.guide/Die Programme das Pakets TimeGuardian

The programs of the package ‘TimeGuardian’

******************************************

The package ‘TimeGuardian’ consists in general of two
programs, you need both to run properly. They will be described later
on. You need the preferences program ‘TimeGuardian’ only, when you
want to change the configuration of the "cron" (1), which is running in
the background. Or you have to start the first program, when you want
to analyze the files, the package writes on your disk. The second
program is the cron ‘TGCron’. You should start it every time your
computer is booting, when you want to use the package in a sensible
way. See Installation, for further information.

‘TimeGuardian’ The preferencesprogram
‘TGCron’ The cronprogram

---------- Footnotes ----------

(1) A cron is a programm, that starts user-specified programs or
scripts at certain user-specified moments.

1.9 TimeGuardianE.guide/Das Programm TimeGuardian

The program ‘TimeGuardian’
==========================

The preferences program ‘TimeGuardian’ is designed, to help the
user to modify the configuration of the background program easily. You
have a graphical user interface to do this. When you want to change the
configuration, just start ‘TimeGuardian’.

* From Workbench: Doubleclick on the corresponding icon. When you
followed the proposals of the installation, you find the icon in
your drawer ‘Prefs’ of your bootpartition.

* From CLI: Just enter ‘<path>/TimeGuardian’. Instead of
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‘<path>’ you have to enter the name of the drawer in which you
have installed the package ‘TimeGuardian’. When you
followed the proposals of the installation this is ‘Sys:Tools’.

Now follows a description of the different elements of the graphical
user interface and their functions. "Gadgets" are elements, that start
an action immediately. They can be activated by clicking on them with
the mouse or by pressing the underlined character of their name. You
always have to press a single key, even when a capital letter is
underlined. "Pages" are gadgets that activate more and other gadgets.
Depending on the preferences of ‘MUI’ you can see all the page-gadgets
together or one after the other by activating the visible page-gadget.

Menus The menustructure
‘About’ The page ‘About’

‘Path Setup’ The page ‘Path Setup’
‘Cron Setup’ The page ‘Cron Setup’
‘Save/Use’ The gadgets ‘Save’/ ‘Use’

‘Default/Restore’ The gadgets ‘Default’/ ‘Restore’
‘Global Statistics’ The page ‘Global Statistics’
‘Daily Statistics’ The page ‘Daily Statistics’

‘Remove Cron’ The gadget ‘Remove Cron’
‘Quit’ The gadget ‘Quit’

Online-help The online help
AREXX The AREXX-Port

Errormessages The description of the errors

1.10 TimeGuardianE.guide/Die Menues des Programms TimeGuardian

The menus of the program ‘TimeGuardian’
---------------------------------------

Some program-functions can be activated with gadgets and menus. The
menus are shown further on in this documentation. The functions, that
are available via gadget and menu will be described at the corresponding
gadgets. The menu structure of the preferences program looks like
follows:

* Project

- Open

- Save as

- --------------

- User

- Remove Cron

- Iconify
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- --------------

- Quit

* Edit
- Reset to Defaults

- Last Saved

- Restore

* Settings

- Create Icons?

* Pages
- About

- Path Setup

- Cron Setup

- Global Statistics

- Daily Statistics

‘Project=>Open’ The menu ‘Project=>Open’
‘Project=>Save as’ The menu ‘Project=>Save as’

‘Project=>User’ The menu ‘Project=>User’
‘Project=>Iconify’ The menu ‘Project=>Iconify’
‘Edit=>Last Saved’ The manu ‘Edit=>Last Saved’

‘Settings=>Create Icons?’ The menu ‘Settings=>Create Icons?’

1.11 TimeGuardianE.guide/Der Menuepunkt Projekt=>Oeffnen

The menu ‘Project=>Open’
........................

This menu opens a file-requester, with which you can select a
configuration file for loading. You can choose a file saved before,
with any name. If you don’t select a ‘TimeGuardian’-
config-file an errormessage will appear. Is the file loaded
succesfully, the gadgets and string gadgets will show the new
configuration. Now you are able to modify, save, use, these new
settings in the custom manner.

1.12 TimeGuardianE.guide/Der Menuepunkt Projekt=>Speichern als
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The menu ‘Project=>Save as’
...........................

When you activate this menu you have the possibility to save your
current settings under any name you choose. The configuration will not
be saved in a way, that it is used immediataly. You have to select the
gadget ‘Save’ or ‘Use’ when you want to do this. This menu is provided
to be able to change quickly between often used configuratons (e.g. one
configuration for private work and one for business work). Each
configuration has its own name, which easily can be associated with the
corresponding project it is desired for. When you have activated the
menu ‘Settings=>Create Icons?’ there will be generated an icon for
every configuration you save. When you want to use one of your saved
configurations you have to doubleclick on the corresponding icon. This
configuration is only used as long as you don’t boot. When you want to
use this configuration permanently, when you doubleclick the icon, then
you have to change the ‘Tool Types:’ of the icon to ‘ACTION=SAVE’. To
do this, activate the icon (don’t doubleclick it!) and select the menu
‘Icons=>Information..’ on the Workbench. Then change the line
‘ACTION=USE’ to ‘ACTION=SAVE’ and press ‘Save’.

When you have saved a configuration without an icon you have to activate
this configuration like follows: Either you load the configuration in the
preferences program and press ´Use’, or you enter the two following
lines in a shell or a script: ´copy Name.config env:TimeGuardian.config’
and ´setenv TimeGuardian.com config’. The configuration will be active
until you reboot. (For a permanent change you have to press the ´Save’
gadget or you enter this ´copy Name.config envarc:TimeGuardian.config’
and the two lines above.)

1.13 TimeGuardianE.guide/Der Menuepunkt Projekt=>Benutzer

The menu ‘Project=>User’
........................

When you activate this menu you are shown an information window, in
which you can read the message

This TimeGuardian is registered to:

*Firstname Lastname*
Street

Postcode Location
Country

when you are a registered user, or the message

This is a *unregistered* version of

TimeGuardian

you have to register after
an evaluation time of 14 days!!
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when you haven’t registered yet. When you want to know how to register
for ‘TimeGuardian’, see registration.

1.14 TimeGuardianE.guide/Der Menuepunkt Projekt=>Ikonifizieren

The menu ‘Project=>Iconify’
...........................

When you activate this menu, the program closes the window of the
graphical user interface and appears as an icon on the Workbench. When
you want to reactivate the window, you have to doubleclick the icon.
This menu has the similar effect like the third gadget from the right,
on the top window border.

1.15 TimeGuardianE.guide/Der Menuepunkt Vorgaben=>auf zuletzt gespeichertes

The menu ‘Edit=>Last Saved’
...........................

When you activate this menu, the configuration file that you saved
with the gadget ‘Save’ will be loaded. When the file is loaded
succesfully you can edit, use, save it in the common manner.

1.16 TimeGuardianE.guide/Der Menuepunkt Optionen=>Piktogramme erzeugen

The menu ‘Settings=>Create Icons?’
..................................

When this menu has a checkmark, each time you save a configuration
with the menu
‘Project=>Save As’, an icon for the configuration will be created.

1.17 TimeGuardianE.guide/Die Seite Über

The page ‘About’
----------------

This page shows the copyrights, the shareware reference and the
reference to ‘MUI’. It is shown when you start ‘TimeGuardian’ and
when you make one of the folowing actions on the graphical user
interface:

* Activate the gadget ‘About’
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* Select the menu ‘Pages=>About’

* Press the keys ‘Amiga 1’

* Press the keys ‘rAlt Space’, when you are on the page ‘Daily
Statistics’

* Press the keys ‘lAlt Space’, when you are on the page ‘Path Setup’

1.18 TimeGuardianE.guide/Die Seite Pfad Einstellung

The page ‘Path Setup’
---------------------

This page is shown, when you make one of the folowing actions on the
graphical user interface:

* Activate the gadget ‘Path Setup’

* Select the menu ‘Pages=>Path Setup’

* Press the keys ‘Amiga 2’

* Press the keys ‘rAlt Space’, when you are on the page ‘About’

* Press the keys ‘lAlt Space’, when you are on the page ‘Cron Setup’

On this page you can select all the files and paths ‘TGCron’
accesses. You see eight different string gadgets, in which you can
enter the values on different ways:

* Click with the mouse inside the frame of the desired string gadget.

* Press the underlined character of the desired string gadgt on the
keyboard.

* The string gadgets are concated, press the key that you selected in
the ‘MUI’ preferences program for concatenation (‘TAB’, when you
didn’t change this option). Press this key so many times, that the
cursor appears in the desired string gadget. Enter the desired

Command or Path on your keyboard now. In the first and the last four
string gadgets the entered values will be checked. When they don’t
exist they will be rejected.

* Press the gadget in the right of the string gadget. You then will
be able to select the path or command/ script with a file
requester.

When you start ‘TimeGuardian’ the first time, you will find some
values filled in, in some string gadgets. Otherwise you will see the
last saved configuration.

Log Path The path for the log files
Starts The file in which the resets are saved
Runtime The file in which the daily running time is saved
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OnOff The file in which is saved
when the computer was switched on

Once a day The file which is executed once a day
Once a year The file which is executed once a year

Timer interval The file which is executed
in a specified interval

Timer fixed The file in which is
saved which programs shall be started at a certain moment

Besides you see four gadgets, with which you can make different
changes to the configuration. For further information see Save/ Use
and Default/ Restore.

1.19 TimeGuardianE.guide/Das Eingabefeld Standard Pfad

The string gadget ‘Log Path’
............................

In this string gadget you have to enter the drawer or partition,
where the cron program shall save, when the computer has booted and how
long and when it was switched on. The names of these three files you
can enter in the following string gadgets.

When you want to change the path, activate the string gadget, like
described above, and enter the desired path. The path must already
exist, otherwise it is rejected. When you activate the string gadget
with the gadget in the right of it, a file requester pops up, where you
easily can select the path.

When you press the gadget ‘Default’ the path ‘Sys:Tools/’ appears.

1.20 TimeGuardianE.guide/Das Eingabefeld Neustarts

The string gadget ‘Starts’
..........................

Here you have to enter the name of the file, in which ‘TGCron’
shall save the time, when the computer has had a reset. The file will be
created in the drawer described above, when it doesn’t exists. The
suffix is automatically created by the program and is a period,
followed by the year (in the year 1994: ‘.94’).

When you select the gadget ‘Default’ the file name ‘Logfile’ appears.

The values in the file will only show your real boot times, when you
start the program ‘TGCron’ every time your computer is booting. How
you can reach this, see Installation.

When you start ‘TGCron’ manually, you can each time you work on
a certain project, start the program. You then have a protocol for this
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specific project. You can reach this in a second way. You start the
program ‘TGCron’ always and change the configuration for different
projects. You define a configuration for a certain project and save it
with the menu ‘Project=>Save As’. When you start working on the project
you use the menu ‘Project=>Open’ to load it. For further information,
see Open and Save As .

The file is saved in ASCII format and can be loaded with any editor
or text viewer. A sample file named ‘Logfile.94’, could look like this:

Wed 04-May-94 15:26
Thu 05-May-94 8:24
Thu 05-May-94 14:26
Thu 05-May-94 15:22
Thu 05-May-94 16:01

The date format can be changed, see date format for furher information.

1.21 TimeGuardianE.guide/Das Eingabefeld Rechenzeiten

The string gadget ‘Runtime’
...........................

Here you have to enter the file, in which ‘TGCron’ shall save
how long the computer was switched on at which dates. When the file
doesn’t exist, it will be created in the drawer or partition, you
selected in the first string gadget on this page. The suffix is
automatically created by the program and is a period, followed by the
year (in the year 1994: ‘.94’).

When you select the gadget ‘Default’ the file name ‘Uptime’ appears.

The entry for a day will be written the following day, you switch
your computer on. That means, when you look at this file the actual day
isn’t shown.

The file is saved in ASCII format and can be loaded with every
editor or text viewer. A sample file named ‘UpTime.94’, could look like
this:

Wed 04-May-94 Runtime: 2 h 47 min.
Thu 05-May-94 Runtime: 2 h 43 min.
Mon 09-May-94 Runtime: 3 h 11 min.

The date format can be changed, see date format for furher information.

1.22 TimeGuardianE.guide/Das Eingabefeld AnAus

The string gadget ‘OnOff’
.........................

Here you have to enter the file, in which ‘TGCron’ shall save
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the times when the computer was switched on and off. When the file
doesn’t exist, it will be created in the drawer or partition, you
selected in the first string gadget on this page. The suffix is
automatically created by the program and is a period, followed by the
year (in the year 1994: ‘.94’).

When you select the gadget ‘Default’ the file name ‘OnOff’ appears.

The entry for the current "switch on" will be written to the file,
the next time, the computer is switched on. When you look at the file,
the last time you switched the computer on, may be saved like follows:
‘System switched on: Th 05-May-94 14:26’.

The file is saved in ASCII format and can be loaded with any editor
or text viewer. A sample file named ‘UpTime.94’, could look like this:

System switched on: Wed 04-May-94 17:38
Resets: 0
System switched off: Wed 04-May-94 19:26

System switched on: Thu 05-May-94 8:24
Resets: 0
System switched off: Thu 05-May-94 9:25

System switched on: Thu 05-May-94 14:26
Resets: 2
System switched off: Thu 05-May-94 16:11

The date format can be changed, see date format for furher information.

The decision, whether the computer is switched on or had a reset, is
made depending on the settings of the slider ‘Startuptime’, see
Startuptime, for further information.

1.23 TimeGuardianE.guide/Das Eingabefeld Einmal am Tag

The string gadget ‘Once a day’
..............................

Here you can select a file that is executed once a day. The file is
executed only once a day independent of the time, the computer is
switched on. When the computer works at midnight, it will be executed
short after midnight. This entry is not fit for polling at your mailbox
once a day, because the time when this happens is not determined. It is
intended for commands which you don’t want to execute from your
‘Startup-Sequence’ every time your computer is booting. You can make a
backup once a day of important files or update your database for a fast
file search.

When you press the gadget in the right of the string gadget, a file
requester pops up, where you easily can select the desired file. You
can choose an executable or a script in ASCII format. When you want a
script to be executed, the ‘S-flag’ has to be set. For example the
script ‘Once_a_day’ in the drawer ‘S:’. Enter ‘protect S:Once_a_day s
add’ in a CLI to set this flag. You have to start commands inside
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scripts with their full path! You don’t need the path, when you use
intern commands or commands in the ‘C:’-directory.

A sample script may look like this:
;Skript once a day
dir all sys: > T:.directorytree ;for fast file search
copy T:.directorytree sys:
delete T:.directorytree

The comands will be automatically started in the background. You don’t
have to enter anything like ‘run < nil: > nil: Command’. Bevor adding a
command line to a script, you want to execute, try the command in a
‘Shell’ so that you can be sure it works the intended way. When this is
not successfull you can start the command from the script and redirect
the output to a file: ‘Command > Sys:.logfile’. You can read the file
‘Sys:.logfile’ with a text viewer or an editor to look what went wrong
(you can look at this file with ‘type Sys:.logfile’ in a ‘Shell’, too).

1.24 TimeGuardianE.guide/Das Eingabefeld Einmal im Jahr

The string gadget ‘Once a year’
...............................

Here you can select a file, that is executed once a year. The file is
executed only once a year, independent of the time, when the computer is
switched on the first time in a year. When the computer works at the
turn of the year, it will be executed short after midnight. You could
use this entry to copy the files, the cron program produced, to another
directory. In the drawer, you selected in the string gadget ‘Log Path’,
you will only find the actual files.

When you press the gadget in the right of the string gadget a file
requester pops up, where you easily can select the desired file. You
can choose an executable or a script in ASCII format. When you want a
script to be executed, the ‘S-flag’ has to be set. For example the
script ‘Once_a_year’ in the drawer ‘S:’. Enter ‘protect S:Once_a_year s
add’ in a CLI to set this flag. You have to start commands inside
scripts with their full path! You don’t need the path, when you use
intern commands or commands in the ‘C:’-directory.

An example script, that copies the files from the drawer ‘Sys:Tools’ to
a new drawer
‘Sys:Tools/Store’ could look like this (the drawer ‘Store’ will be
created, when the drawer ‘Sys:Tools’ already exists):

;Script once a year
copy Sys:Tools/LogFile.?? Sys:Tools/Store quiet
delete Sys:Tools/LogFile.?? quiet
copy Sys:Tools/UpTime.?? Sys:Tools/Store quiet
delete Sys:Tools/UpTime.?? quiet
copy Sys:Tools/OnOff.?? Sys:Tools/Store quiet
delete Sys:Tools/OnOff.?? quiet

The used names and paths, are the ones, that you get, when you press the
gadget ‘Default’. When you have chosen other names and want to use this
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script, then you have to modifiy the script to suit your needs.

1.25 TimeGuardianE.guide/Das Eingabefeld Zeituhr intervall

The string gadget ‘Timer interval’
..................................

Here you can select a file that is executed in regular time
intervals. This entry therefore can be used to save the project you are
working on at the moment every ten minutes. The moments when this
happens are always relative to the boot time, i.e. (boot time + n *
interval). To change the interval see change the interval.

When you press the gadget in the right of the string gadget, a file
requester pops up, with which you can select the desired file. You only
can change the entry in this string gadget, when you have selected
‘interval’ or ‘fixed & interval’ at the gadget ‘Type’ on the page ‘Cron
Setup’. Otherwise the gadget will be ghosted. You can select an
executeable or a script in ASCII format. When you want to use a script
the ‘S- flag’ has to be set. To set this flag for the script ‘Example’
in the directory ‘s:’ type in a ‘CLI’ window: ‘protect s:Example s add’.
You have to start commands inside scripts with their full path! You
don’t need the path, when you use intern commands or commands in the
‘C:’-directory.

1.26 TimeGuardianE.guide/Das Eingabefeld Zeituhr fest

The string gadget ‘Timer fixed’
...............................

Here you can select a "CronTab"(1) file in which is saved which
programs have to be started at certain moments. This file has to be an
ASCII file with a certain format, that will be described below. It is
possible to use samples in this file or certain days, months, etc.

When you press the gadget in the right of the string gadget, a file
requester pops up, where you easily can select the desired file. You can
only access this string gadget, when you have selected ‘fixed’ or
‘fixed & interval’ at the gadget ‘Type’ on the page ‘Cron Setup’.
Otherwise the string gadget is ghosted.

An example file could look like follows:
; TimeGuardian CronTable
;
;55 23 * * * RequestChoice TimerRequest "It is 23:55 " "What else ?!"
;
59 19 * * 1-5 s:News
;
0,15,30,45 * * * * "newshell con:82/175/550/90/UpTime from batch:saytime"
;
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When the 1st character of a line is ‘;’, the line will be ignored
completely. You can use this to add comments to the file or to stop
executing a program for some time. This was done in the third line.
The command ‘RequestChoice’ won’t be executed.

Shall a file be executed at a certain moment, the line in the file
must look like the folowing sample: ‘<Minute> <Hour> <Day> <Month>
<Day_of_week> <Path/<Command|Script>>’.

The decision, whether a command is executed or not, is made by a *AND*-
combination of the five time parameters. That means, that the command
is only executed, when all five parameters are true.

Now follows an exact description for the different samples, set in acute
parenthesis. Some characters have a certain meaning:

- ‘<>’:
The parameter in acute parenthesis has to be specified.

- ‘|’:
The vertical bar seperates alternative parameters, which can be
used either or.

- ‘[]’:
The parameter in angular parenthesis can be used when you want.

- ‘...’:
Three periods mean, that the parameter before can be used multiple
times.

* ‘<Minute>’
The complete sample looks like this:
‘<*|Min[[,Min]|[,Min-Min]...]|Min-Min[[,Min]|[,Min-Min]...]>’
The value for ‘Min’ has to be choosen in the range from 0 to 59.
It follows a description of all possibilities:

1. ‘*’:
When you use an asterisk for this parameter, th command is
executed every minute.

2. ‘Min’:
You can choose a moment, at which the command is executed.

3. ‘Min-Min’:
You can specify a range, whilst which the command is
executed. The first value for ‘Min’ has to be smaller or
equal than the second value for ‘Min’.

4. ‘<Min>,<Min-Min>,...,<Min>’:
You can specify multiple moments and ranges seperated by
colons. The command is executed at every specified moment and
whilst the ranges.

Example: ‘0,5,10,15-20,30,45-50 * * * * Command’
That would start the command every full hour, five, ten and 30
minutes after the full hour and in the range from 15 to 20 and
from 45 to 50 minutes every minute after the full hour. The
command is executed every day.
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* ‘<Hour>’
The complete sample looks like this:

‘<*|Hour[[,Hour]|[,Hour-Hour]...]|Hour-Hour[[,Hour]|[,Hour-Hour]...]>’
The value for ‘Hour’ has to be choosen in the range from 0 to 23.
For a more precise description of the parameter ‘Hour’ look at the
parameter ‘Minute’ above. Both parameters have the same sample.
Example: ‘* 0,3,6,9,12,15,18,21 * * * Command’
That would execute the command every three hours. As an asterisk
is used for the minutes, the command is executed every minute of
these hours.

* ‘<Day>’
The complete sample looks like this:
‘<*|Day[[,Day]|[,Day-Day]...]|Day-Day[[,Day]|[,Day-Day]...]>’
The value for ‘Day’ has to be choosen in the range from 1 to 31.
For a more precise description of the parameter ‘Day’ look at the
parameter ‘Minute’ above. Both parameters have the same sample.
Example: ‘* * 5-10,20-25 * * Command’
That would start the command at the fifth to 10. of a month and at
the 20. to 25. of a month. As asterisks are used for the other
parameters, the command will be executed every minute at these
days!

* ‘<Month>’
The complete sample looks like this:
‘<*|Mon[[,Mon]|[,Mon-Mon]...]|Mon-Mon[[,Mon]|[,Mon-Mon]...]>’
The value for ‘Mon’ has to be choosen in the range from 1 to 12.
For a more precise description of the parameter ‘month’ look at
the parameter ‘Minute’ above. Both parameters have the same sample.
Example: ‘* * * 1,5-7 * Command’
This would start the command in the months from January to May and
in July. It will be executed every minute in these months!

* ‘<Day_of_week>’
The complete sample looks like this:
‘<*|DoW[[,DoW]|[,DoW-DoW]...]|DoW-DoW[[,DoW]|[,DoW-DoW]...]>’
The value for ‘DoW’ has to be choosen in the range from 1 to 7. 1
corresponds to Monday, 7 corresponds to Sunday. For a more precise
description of the parameter ‘Day_of_Week’ look at the parameter
‘Minute’ above. Both parameters have the same sample.
Example: ‘* * * * 1-5 Command’
This would start the command from Monday to Friday every minute,
your computer is turned on.

* ‘<Path/<Command|Script>>’
Here you have to enter the command or script that shall be
executed. You always have to use the complete path. In the above
example in line seven the command ‘newshell’ needs no path,
because this is an *internal* command, which is not loaded from a
data media. System commands, which are located in the ‘C:’ drawer
likewise don’t need a path. All other commands do.

* examples:
1. ‘* * * * * "dir >> t:test sys:tools"’
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This command is executed every minute.

2. ‘0,30 8-16 * * 1-5 s:Gong’
This script is executed Mondays to Fridays from eight a.m. to
four o’clock p.m. every full hour and every half hour.

3. ‘0 15 24 12 * execute "s:12. 24."’
This script is execute at three o’clock p.m. the 24.th of
December.

4. ‘0 20 15,16 4 7 s:Example’
This script is executed the 15.th and 16.th of April at eight
o’clock p.m. (when this date is a Sunday). Of course two
successive days both can’t be Sundays, but this example shall
illustrate the *AND*- combination.

When you want to start scripts, the ‘S- flag’ of the files has to be
set (to do this with the script ‘News’, which is in the directory ‘S:’,
type the following in a ‘CLI’: ‘protect s:News s add’). The second way
to start a script is to use the command ‘execute’ like in the third
example (you don’t have to set the ‘S- flag’ here). You have to start
commands inside scripts with their full path! You don’t need the path,
when you use intern commands or commands in the ‘C:’-directory. When
you have problems with commands, not doing what you want them to do,
check the commands for spaces. Try quoting the part of the command
including spaces. Test the command you wish to use in a ‘Shell’, before
you use it in a script.

---------- Footnotes ----------

(1) The format is the Un*x format

1.27 TimeGuardianE.guide/Die Seite Zeit Einstellung

The page ‘Cron Setup’
---------------------

This page is shown, when you make one of the following actions on the
graphical user interface:

* Activate the gadget ‘Cron Setup’

* Select the menu ‘Pages=>Cron Setup’

* Press the keys ‘Amiga 3’

* Press the keys ‘rAlt Space’, when you are on the page ‘Path Setup’

* Press the keys ‘lAlt Space’, when you are on the page ‘Global
Statistics’

On this page you can modify the time values, that ‘TGCron’
accesses. Furthermore you can select the date format, the language, and
which type of alarm you want to use. You see three different gadgets
and four sliders. You can change the shown values in different ways:
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* Slider
- Click with the mouse on a slider and move the mouse, pressing

the mouse button, to the left or to the right, the knob
follows the mouse. When you reached the desired value,
release the mouse button.

- Press the underlined character on your keyboard: The knob
moves to the right.

- Press the underlined character on your keyboard together with
a Shift- key: The knob moves to the left.

* Gadgets
- Activate the gadget with a mouseclick and hold the mouse

button pressed: Select the desired entry (activation in the
text field).

- Activate the gadget with a mouseclick: the next entry is
selected (activation in the image field or in the text field)

- Press the underlined character on your keyboard: The next
entry is selected.

- Press the underlined character together with a Shift- key:
The previous entry is selected.

When you start ‘TimeGuardian’ the first time, you see the default
values. Otherwise you see the last saved configuration.

Startuptime The time your computer needs to boot
Increment The accuracy of the savings

Date format The selection of the date format
Locale The selection of the language
Type The selection of the alerm type
Hours The interval time

Minutes The interval time

1.28 TimeGuardianE.guide/Der Schieberegler Startzeit

The slider ‘Startuptime’
........................

With this slider you have to enter the time in minutes, your
computer needs to boot, rounded to the next full minute. When your
system needs for example two minutes and 30 seconds to start, you would
have to enter three here. This is necessary, so that the background
program can decide whether the computer is switched on or had a reset.
The program decides, that the computer was switched on, when the
difference between the last saved value and the actual time is greater
than the value that you entered with the slider. Otherwise a reset is
supposed.
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1.29 TimeGuardianE.guide/Der Schieberegler Schrittweite

The slider ‘Increment’
......................

This value is the time in minutes, when the background program
saves, that the computer was still working. The smaller you make this
value, the more accurate are the values in the three saved files which
you can select on the page ‘Path Setup’. When you enter two, for
example, every two minutes is saved, that the computer still is
working. The greatest error which may occur at this value is then two.
The greater the entered value, the inaccurate is the supposed switch
off moment, as the last saved value for a running system is taken.

1.30 TimeGuardianE.guide/Der Schalter Datumsformat

The gadget ‘Date Format’
........................

With this gadget you can enter nine different formats for the date,
that is used, when saving the time in the different files. The format,
that is used is the one, that is shown. The following formats can be
selected:

‘tt-mm-jj’, ‘tt.mm.jj’, ‘tt/mm/jj’,

‘mm-tt-jj’, ‘mm.tt.jj’, ‘mm/tt/jj’,

‘jj-mm-tt’, ‘jj-mm-tt’, ‘jj-mm-tt’.
Here stands ‘tt’ for the day of the month, ‘mm’ for the short form of

the month and ‘jj’ stands for the last two digits of the year. The
short form of the month is saved in the selected language.

1.31 TimeGuardianE.guide/Der Schalter Lokalisierung

The gadet ‘Locale’
..................

With this gadget you can select a language for the background program
‘TGCron’. The config program is *always* localized in the
language that you selected in the language preferences program
(certainly you need an approriate file ‘TimeGuardian.catalog’
installed in your drawer ‘Locale:Catalogs/language’). The program runs
in the default language english, when this file is missing, or when you
use a workbench version < 2.1. In this distribution only the default
language english and german are supported.

You can select six different settings:

* localized:
Use this when you have a localized workench and you want the files
for the time functions to be written in this language. You need
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the appropriate file for your language!

* english:
With this and the following selections, the text that is written
in the files, appears in the selected language.

* german, french, italian, spanish:
time functions: selected language

When you are intrested, in translating the text for the graphical user
interface into one of the above languages or into another, please
contact one of the adresses at which you can register for the package,
see adress. When you do this (you translate the complete graphical user
interface, the error messages and the text for the time functions) you
will get a registered version of the package ‘TimeGuardian’.
Please contact one of us *under any circumstances*, befor you start to
translate!

1.32 TimeGuardianE.guide/Der Schalter Typ

The gadget ‘Type’
.................

With this gadget you can select, which type of background actions
shall be executed. The program ‘TGCron’ executes the commands/
scripts ‘Once a year’ and ‘Once a day’ and writes the protocol files
always when its necessary. This happens not depending on the following
selectons. You have several possibilitys to choose:

* none:
That means, that neither the script in the string gadget ‘Timer
fixed’ nor the command/ script in the string gadget ‘Timer
interval’ is executed.

* fixed:
That means, that only the script in the string gadget ‘Timer
fixed’ is executed. You can use as many moments and commands in
this script as you want. See Timer fixed, for the contents of such
a script.

* interval:
Only the command/ script in the string gadget ‘Timer interval’
will be executed in the selected interval as long as the computer
is working.

* fixed & interrval:
The two above described commands/ scripts will be executed

1.33 TimeGuardianE.guide/Die Schieberegler Stunden- Minuten
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The sliders ‘Hours’/ ‘Minutes’
..............................

Here you can set the interval, in which the command/ script ‘Timer
interval’ will be executed regularly. You have to set the minutes and
hours seperately. When you set the slider ‘hours’ to 0 and the slider
‘Minutes’ to 15, the command/ script will be executed every quarter of
an hour. You can change these two values only, when you selected ‘timer
& interval’ or ‘interval’ at the gadget ‘Type’, otherwise the two
sliders will be ghosted (see select timer type).

1.34 TimeGuardianE.guide/Die Knoepfe Speichern- Benutzen

The gadgets ‘Save’/ ‘Use’
-------------------------

When you press the gadget ‘Save’ or the corresponding key on the
keyboard, the program saves the current preferences in a way so that
they are used immediately and after booting (The preferences are saved
in the directory ‘ENVARC:’ and ‘ENV:’ under the name
‘TimeGuardian.config’).

When you press the gadget ‘Use’ or its corresponding key- shortcut,
the preferences are saved in the drawer ‘ENV:’ under the same name like
above. The configuration will be used immediately, but is only active
as long as the computer has no reset. When the computer boots, the
configuration is used, that you saved with the gadget ‘Save’. In
contrast to the standard preferences programs ‘TimeGuardian’ is not
quit, when you press one of these two gadgets. When you want to leave
the program press the ‘Quit’- gadget.

1.35 TimeGuardianE.guide/Die Knoepfe Voreinstellung- vorheriger Stand

The gadgets ‘Default’/ ‘Restore’
--------------------------------

When you press the gadget ‘Default’, some default values will appear.
This are the settings, you see when you start the program the first time
after the installation.

With the gadget ‘Restore’ you can cancel the changes, that you have
made before. This works as long as you did not use one of the two
gadgets ‘Save’ or ‘Use’. You will get the settings back, that you have
activated with the gadget ‘Use’ the last time.

1.36 TimeGuardianE.guide/Die Seite Hauptstatistik
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The page ‘Global Statistics’
----------------------------

This page is shown, when you make one of the folowing actions on the
graphical user interface:

* Activate the gadget ‘Global Satistics’

* Select the menu ‘Pages=>Global Statistics’

* Press the keys ‘Amiga 4’

* Press the keys ‘rAlt Space’, when you are on the page ‘Cron Setup’

* Press the keys ‘lAlt Space’, when you are on the page ‘Daily
Statistics’

On this page you find a table on which you can see at which days of
the actual year the computer was working how long. When you control
different projects with different configurations the times and dates
shown correspond to the selected configuration. In the lower field you
see the total amout of hours and days for the year. In the upper field
you see single days with the times for this day. You can move around in
the upper field of the page like follows:

* Press the Tab key and use the keys Cursor up or Cursor down: Each
time you press one of the keys the bar moves up or down a day.

* Click with the mouse on the desired day.

* Move the proportional gadget on the right side of the field and
then click with the mouse on the desired day.

* Click with the mouse on the gadgets next to the proportional gadget
and click with the mouse on the dsired day.

When you have highlighted the day, about which you want more
information, with one of the above methods, you can activate the page
‘Daily Statistics’ in different ways:

* Enter the key Return (the highlighted day is shown)

* Doubleclick with the mouse on the desired day (this works with a
day, that isn’t selected yet, too)

1.37 TimeGuardianE.guide/Die Seite Tagesstatistik

The page ‘Daily Statistics’
---------------------------

This page is shown, when you make one of the folowing actions on the
graphical user interface:

* Activate the gadget ‘Daily Satistics’

* Select the menu ‘Pages=>Daily Statistics’
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* Press the keys ‘Amiga 5’

* Press the keys ‘rAlt Space’, when you are on the page ‘Global
Statistics’

* Press the keys ‘lAlt Space’, when you are on the page ‘About’

This page is devided into three areas. In the uppermost you can
select with a gadget, what you want to see from the selcted day in the
middle of the page:

- OnOff:
This shows, when the computer was switched on, how many resets it
had and when it was switched off. The accuracy of the switch off
time depends on the settings of the slider ‘Increment’, see
setting the Increment, for further information.

- Starts:
Here you can see the times, when your computer had a reset.

In the lowest area you see a summary of the selected day.

When you cannot see all entrys together, you can move the proportional
gadget the same way like on the page ‘Global Statistics’. To change
between the two views ‘OnOff’ an ‘Starts’ you can press the Space key.

1.38 TimeGuardianE.guide/Der Knopf Cron entfernen

The gadget ‘Remove Cron’
------------------------

With this gadget you can stop the background program ‘TGCron’.
You have to answer a requester, whether you want the program to quit or
not. When you select ‘Yes’ ‘TGCron’ is stopped within the next
minute. When you select ‘No’ nothing happens, the program continues.

1.39 TimeGuardianE.guide/Der Knopf Ende

The gadget ‘Quit’
-----------------

You can leave the program with this gadget. When you have changed the
preferences, but didn’t save them a requester pops up. When you select
‘Yes’ the program is left without saving. When you select ‘No’ or press
the Return key you’re back in the program. You can save the preferences
manually and leave the program afterwards.
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1.40 TimeGuardianE.guide/Die Online-Hilfe

The online help
---------------

The online help is a feature to get easily and fast help when you
use the graphical user interface. To use this feature the
‘amigaguide.library’ has to be installed correctly on your system
(located in the drawer ‘Libs:’). When this is not true you can’t use
this feature. Where you can obtain the library, see ‘Amiga-Guide’.

When the above described file is installed on your computer, you can
get help about an element of the graphical user interface by moving the
mouse pointer over the corresponding element (do not click it) and
pressing the Help key afterwards. The corresponding text for the
element from this documentation will appear.

1.41 TimeGuardianE.guide/Der AREXX-Port

The AREXX-Port
--------------

At the present version the program only supports the standard ‘MUI’
commands:

* QUIT

* HIDE

* SHOW

* INFO

* HELP

For more information see ‘MUI.guide’ from the distribution of ‘MUI’.

1.42 TimeGuardianE.guide/Was bedeuten die Fehlermeldungen (TimeGuardian)

What do the errormessages mean ?
--------------------------------

* ‘Cannot quit now, still
some asl popups opened.’
This message appears, when you have to close a file requester,
which was opened before, before you can leave the program

* ‘You changed the configuration without saving
Do you really want to quit?’
That remembers you, that you haven’t pressed the gadget ‘Save’
yet. Do this before you leave the program.
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* ‘TGCron is not running!’
The background program ‘TGCron’ is not running yet, therefore
the change of the configuration will have no effect! When you want
to use the new configuration, you have to start ‘TGCron’.

* ‘File already exists!
Do you want to replace it?’
A file you want to save, is already saved with this name. When you
select ‘Yes’ the old file is overwritten. When you select ‘No’ you
can save the file again and change the name.

* ‘Do you want to remove TimeGuardianCron?’
When you want to stop the background program ‘TGCron’ select
‘Yes’, otherwise ‘No’.

* ‘You have to define a Log File,
an empty string is not allowed!’
You have not entered anything in a string gadget, this is not
allowed her. You have to enter a name for the file.

* ‘Invalid config-file: *’
The file * is not a valid config file, please select an other file.

* ‘Could not load config-file: *
I will use defaults instead!’
The file * could not be opened correctly, while starting
‘TimeGuardian’. The program will use the values, you get, when you
press the gadget ‘Default’. Change the configuration to suit your
needs and press ‘Save’ to correct the error.

1.43 TimeGuardianE.guide/Das Programm TGCron

Das Programm ‘TGCron’
=====================

After setting up your preferences with ‘TimeGuardian’, you may
start ‘TGCron’. According to your setup the program executes the
appropriate programs and scripts and stores the runtime information of
your computer. Its CPU usage is very low. While waiting for the next
event it uses *no* CPU power, only when beeing started and each minute
during a short moment and when it looks for an event or writes some
information to disk.

Description What does ‘TGCron’ do?
Information How can I get information about ‘TGCron’

Start How can I start ‘TGCron’?
Stop How can I stop ‘TGCron’?
Errors What do the error messages mean?
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1.44 TimeGuardianE.guide/Was macht TGCron?

What does ‘TGCron’ do?
----------------------

‘TGCron’ is designed to stay in memory all the time and run as
a background task. It executes user defined events at predefined
moments. This means on the one hand that script files are executed, on
the other it stores by predefined precission information about the
runtime and when your computer has been booted. It is very important
to configure ‘TGCron’ for your personal environment, therewith it
is able to accomplish your events. How you can do that, see
configuration.

For further information on the files, refer to page ‘Path Setup’ and
page ‘Cron Setup’.

‘TGCron’ searches for the following files during startup:

* These files at every boot:
- ‘*ENV:TimeGuardian.config*’
‘TimeGuardian’ saves the current preferences to this
file, ‘TGCron’ reads them from it.

- ‘*s:TimeGuardian.key*’
This is your personal keyfile. You will get it when you
become a registered user. If this file does not exist or has
been modified, you will only be able to use ‘TGCron’
about 1½h a day. How to get your key, please refer to
register.

- ‘[Log path]*TG_private/LastBoot*’
The time of your last boot is stored here. Don’t change
anything here, when you want, that the values are correct in
‘[OnOff]’ and ‘[UpTime]’!

- ‘[Log path]*TG_private/UpTime*’
Here is stored the time in minutes, how long your computer
has been running on the current day. Don’t change anything
here, when you want, that the values are correct in
‘[UpTime]’!

- ‘[Log path]*TG_private/UpDate*’
This file contains the point of time, when your computer was
turned off for the last time. Don’t change anything here,
when you want, that the values are correct in ‘[UpTime]’ and
‘[OnOff]’!

- ‘[Log path]*TG_private/Resets*’
Here is the number of resets stored since your last startup.
Don’t change anything here, when you want, that the values
are correct in ‘[OnOff]’!

- ‘[Log path][LogFile].<yy>’
At every startup or reset the curent time is appended to this
file.
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* These files only at the first boot of a day or at midnight:
- ‘[Once a day]’

This file will be executed.

- ‘[Log path][UpTime].<yy>’
Once a day the full runtime of the previous day is stored
here.

* This file at a cold boot (not at a reset):
‘[Log path][OnOff].<yy>’
The information when the computer has been turned on and how long
is stored here during startup.

* This file only at the first boot of the year:
‘[Once a year]’
This file will be executed.

* These files only if selected:
- ‘[Timer fixed]’

If you selected this at the page ‘Cron Setup’, this file will
be read during startup and stored internally. Then it will be
checked every minute for a user event.

- ‘[Timer interval]’
If you selected this at the page ‘Cron Setup’, this file will
be executed at fixed intervals relative to the boottime.

Neither change any files in the ‘.../TG_private’ directory nor with a
‘.key’ or ‘.config’ suffix.

The marks have the following meaning:
- If a filename is marked like *this*, the filename or parts of the

filename cannot be influenced by the user.

- A filename marked like ‘[this]’, shows that the user is able to
configure the path/filename or path and filename at the ‘Path
Setup’ page. The string gadget in the configuartion program has
the same name.

- A mark like this ‘<yy>’ means, that a suffix is appended
automatically by program, generated from the last two digits of
the current year.

1.45 TimeGuardianE.guide/Ausgabe von Informationen über TGCron

How can I get information about ‘TGCron’
----------------------------------------

If you want to get further information about ‘TGCron’, please
enter the following from the CLI (replace ‘<path>’ by the directory
where you have installed the package to): ‘<Pfad>/TGCron’
There are two different possible messages, according to the fact you
have ‘TGCron’ already started or not.

1. ‘TGCron’ has already been started:



TimeGuardianE 29 / 40

‘TGCron v1.43 (24.7.1994) by G.Körner/J.Matern
use -r option to remove...’

2. ‘TGCron’ is not running:
‘TGCron v1.43 (24.7.1994) by G.Körner/J.Matern
use -i option to install...’

You can also get information about the revision and the compilation
date by using the ‘version’-command. Enter the following commandline:
‘version full <path>/TGCron’
You should get this result: ‘TGCron v1.43
(24.7.1994)’.
If you don’t get that, you are definitely reading the wrong
documentation.

1.46 TimeGuardianE.guide/Wie kann ich TGCron starten?

How can I start ‘TGCron’?
-------------------------

If you didn’t choose the automtic startup option during installation,
you have two different options to start ‘TGCron’ by hand:

1. Start from CLI
To start it from CLI please enter the following:
‘<path>/TGCron -i’
As ‘TGCron’ does not detach from your CLI, you have to use
the ‘run’ command to get your shell back after startup as follows:
‘run < nil: > nil: <path>/TGCron -i’.
Replace <path> by the directory you have the
‘TimeGuardian’ package installed to.

2. Workbench startup
If you want to start ‘TGCron’ from your Workbench, just
doubleclick its icon.

When you try to start the program, but it is already running, you will
get the following results:

- At the CLI:
You will get the message: ‘TGCron is already running’
This shows that ‘TGCron’ is already running and you cannot
restart it again.

- At the workbench
You will get a requester asking you: ‘Do you want to remove
TimeGuardianCron?’
If you want to remove it, click on ‘*Yes*’ or press Return.
Choosing ‘No’ or pressing Escape does not affect ‘TGCron’ and
it keeps on running. Regardless, what you choose, it won’t be
started again!
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1.47 TimeGuardianE.guide/Wie kann ich TGCron abbrechen?

How can I stop ‘TGCron’?
------------------------

If ‘TGCron’ is already running, you have three options to remove
it:

1. From CLI:
Please enter the following command: ‘<path>/TGCron -r’
Replace <path> by the directory you have the
‘TimeGuardian’ package installed to. Then you will get the
message: ‘TGCron will be removed after next time interval’.
The end of the time interval is normally the next full minute.

2. At the Workbench:
Just doubleclick its icon. You will get a requester asking you:
‘Do you want to remove TimeGuardianCron?’
If you want to remove it, click on ‘*Yes*’ or press Return.
Choosing ‘No’ or pressing Escape does not affect ‘TGCron’ and
it keeps on running. You won’t get any further messages, but as
similar as removing it from CLI it will quit after the next full
minute.

3. Start ‘TimeGuardian’ and press the ‘Remove Cron’ button,
refer to Remove Cron for detailed information.

1.48 TimeGuardianE.guide/Was bedeuten die Fehlermeldungen (TGCron)?

What do the error messages mean?
--------------------------------

You can get the following error messages from ‘TGCron’:

* ‘Invalid .config file. Use TimeGuardian to create a new one!’
‘TGCron’ reads data from the file ‘env:TimeGuardian.config’,
but it was changed or corrupted and is not valid any more. Start
‘TimeGuardian’, enter a new configuration and store it with
the ‘Save’ button.

* ‘Could not open env:TimeGuardian.config!
Use TimeGuardian to create it’
Start ‘TimeGuardian’, enter your configuration and store it
with the ‘Save’ button.

* ‘Could not open locale, please check configuration!
Using english instead’
You selected ‘localised’ at the ‘localisation’ switch, but the
program is not able to find the corresponding files in
‘Locale:languages/your_country/TimeGuardian.catalog’ (replace
‘your_country’ by the name of the locale your computer is running
with), therefore it will use english as a default. To get rid of
this message, install the needed .catalog file or select one of
the hard coded languages, ‘english’ for example.
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* ‘Your evaluation time has expired for today,
Please consider registering !!’
You have reached the end of your evaluation time for ‘TGCron’
as an unregistered user. You cannot restart it again on this day.
If you want to use the package unlimited, please become a
registered user, look at register for detailed information.

* ‘CronParser ERROR:
Wrong number of Arguments in CronTable line:
CronTab_line
Please correct it!’
The displayed ‘CronTab_line’ from the file that you have choosen
at the string gadget ‘Timer fixed’, contains too much or not
enough entries. Correct the line to get rid of this requester,
because it will be shown again and again. For detailed information
on the CronTab, refer to string gadget Timer fixed.

* ‘CronParser ERROR:
Bad entry ’*’ in CronTable line:
CronTab_line
Please correct it!’
The entry ’*’ in the ‘CronTab_line’ is not valid. Correct the line
to get rid of this requester, because it will be shown again and
again. For detailed information on the CronTab, refer to
string gadget Timer fixed.

* ‘CronParser ERROR:
Value * out of range (*...*)
Please search for commandline and fix it !’
The number after ‘Value’ is not in the range, that is shown in
paranthesis. For detailed information on the CronTab, refer to
string gadget Timer fixed.

* ‘CronParser ERROR:
Range *-* out of range (*...*)
Please search for commandline and fix it !’
The range after ‘Range’ has to be in the range that is shown in
parenthesis. For detailed information on the CronTab, refer to
string gadget Timer fixed.

1.49 TimeGuardianE.guide/Wo bekomme ich die Zusatzprogramme?

Where do I get the support programs?

************************************

‘MUI’ woher? Where do I get ‘MUI’?
‘Installer’ woher? Where do I get ‘Installer’?

‘Amiga-Guide’ woher? Where do I get ‘Amiga-Guide’?
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1.50 TimeGuardianE.guide/Wo bekomme ich MUI?

Where can I obtain ‘MUI’?
=========================

You can get ‘MUI’ directly from the author, where you get a
registered version, and can use all the features of the ‘MUI’ graphical
user interface (see registration for ‘MUI’). Or you obtain the
‘Fish-Disks 967/968’ from your local public domain dealer or the
‘Aminet’.

When you think, it is not worth to install ‘MUI’, because of one
single program, this may be correct. But the background program
‘TGCron’ doesn’t use ‘MUI’ at all. Only the preferences program uses it
for its graphical user interface. So ‘MUI’ is not started all the time
but only when you want to change the configuration. So you can install
this package even on computers with little menmory, because you don’t
need ‘MUI’ all the time.

When you have not installed ‘MUI’ yet, you have to do this before the
installation of ‘TimeGuardian’ by all means, as the
installation will be aborted otherwise. See Installation, for further
information.

1.51 TimeGuardianE.guide/Wo bekomme ich den Installer?

Where can I obtain ‘Installer’?
===============================

For the easy installation of the program package, you need the
program Installer from C*mm*d*re. When you have this program not
installed on your computer, you can obtain it on different ways.

* With the Workbench 2.0/2.1/3.0

* On the ‘Fish-Disk 870’

* On the distribution of ‘MUI’.

* On most distributions of commercial software

1.52 TimeGuardianE.guide/Wo bekomme ich den Amiga-Guide

Where can I obtain ‘Amiga-Guide’?
=================================

When you want to use the "online help", you need the
‘amigaguide.library’ in your ‘LIBS:’-drawer (see What is online help?).
You don’t need it to run the package ‘TimeGuardian’, but won’t
be able to use the online help feature.
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The ‘amigaguide.library’ is on the ‘Fish-Disk 870’ and is distributed
with Workbench version 3.0.

1.53 TimeGuardianE.guide/Wie installiere ich TimeGuardian?

How can I install ‘TimeGuardian’?

*********************************

This chapter describes the installation of the package
‘TimeGuardian’. When you want to install other packages, not included
in this distribution (see support programs), look in the corresponding
distributions for installing them.

You have two possibilities to install the package
‘TimeGuardian’. You should use the first one:

Installation with the program ‘Installer’
(‘Installer’ program has to be in the search path, e.g. ‘C:’)

Installation without the program ‘Installer’

1.54 TimeGuardianE.guide/Die Installation mit Installer

The installation with ‘Installer’
=================================

You have two choices to start the installation script:
1. Doubleclick with the mouse the icon ‘TG.install.deutsch’:

The installation starts. The text appears german. When you want to
use the geramn text please read the german documentation.

2. Doubleclick with the mouse the icon ‘TG.install.english’:
The installation starts. The text appears in english.

Now follows a step by step description of the installation:

* At the beginning you have the possibility to choose the user level
for the installation. When you select ‘Novice’ you won’t be able
to select anything more. You cannot control, where the package is
installed. All files which are necessary to work corretly will be
copied, and the preferences program will be started. At the end
you get a summary about what was saved to which location. To quit
the installation you have to leave the preferences program.

When you want to install the package press ‘Proceed With Install’.
With ‘Help...’ you get some information.

* When you select the user level ‘EXPERT’ you can choose whether you
want to install the package (‘Install for Real’) or whether you
just want to test the installation script (‘Pretend to Install’).
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Furthermore you can choose, whether all actions are logged or not.
You can write the file
‘Sys:TGInstall.e.log’ to disk (‘Log File’), you can print the
results (‘Printer’) or you can suppress a log file (‘None’).

The installation is continued with ‘Proceed’.

* The installation checks, whether ‘MUI’ is installed with the
correct version. When this is not true it is aborted.

* Now you can choose what you want to install.
The first gadget means, that only the necessary programs and
config files are copied.
The second gadget means the documentation. Here are three files at
the moment:

- The file ‘TimeGuardian.dvi’, that you can print or
view, when you have installed TeX.

- The file ‘TimeGuardian.guide’, that you can read with
‘AmigaGuide’. This file contains the information for the
online help. This file is always copied, when the file
‘Libs:amigaguide.library’ is installed on your system.

- The file ‘TimeGuardian.asc’, you can read with any
text viewer or editor, or that you can print.

* When you have activated the first gadget:
- You are asked, if the background program ‘TGCron’ should

be started every time the computer is booting.

- When you answered the last question with ‘Yes’, the program
checks whether this is possible on your system.

- When multiple possibilities exist, to start the background
program, you can select which of them you prefer. When you
select ‘From CLI (user-startup)’ the file ‘S:user-startup’
will be changed in an appropriate way. When you select ‘From
WB (WBStartup)’ the icon of the progam ‘TGCron’ is
copied to the drawer ‘Sys:WBStartup’. Users, that work mainly
on the workbench should use the second possibility.

- Now you can choose, where the programs shall be copied to. The
installation makes a proposal. When you want a new drawer for
the package created, select ‘Make New Drawer...’, otherwise
choose an existing one.

- You can continue with the button ‘Proceed’.

- Even if you did not select the documents to be installed the
file
‘TimeGuardian.guide’ will be copied, when the file
‘Libs:amigaguide.library’ is installed. When this is not true
a message appears, that you won’t be able to use the online
help.

* When you have selected the second gadget:
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- You now have to choose a drawer where the documents shall be
copied to. The program suggests a subdirectory, in the
drawer, where you copied the programs to.

- The file ‘TimeGuardian.guide’ is only copied, when
the file ‘Libs:amigaguide.library’ is installed on your
system. When this is not true a message appears, that you
won’t be able to use the online help.

* When you have installed the programs you now can decide, whether
you wish to start the preferences program ‘TimeGuardian’.
Start the program with selecting ‘Yes’. Change the configuration
to suit your needs and press the gadget ‘Save’ before you leave
the program with the gadget ‘Quit’. When you don’t start the
program, you have to answer a message, that you will have to start
the preferences program later on. Select ‘Proceed’ here to leave
the installation correctly.

* When you have left the preferences program or you answered the
message, the installation is complete and the last message appears.

1.55 TimeGuardianE.guide/Die Installation ohne Installer

The installation without ‘Installer’
====================================

To install the package without the ‘Installer’ please follow these
steps:

1. Open a ‘Shell’ window (doubleclick the icon ‘Shell’ in the drawer
‘System’ of your boot partition).

2. Please enter ‘version libs:muimaster.library’. You should get this
result:
‘libs:muimaster.library 7.973’. When you get a smaller number or
‘object not found’, you have to install ‘MUI’ version 2.0 or
greater before you can continue.

3. When you want to install the package in a drawer, that already
exists, please enter ‘cd drawer’ (instead of drawer please use the
name of the directory). When you want to copy the files to a new
drawer, then you have to create it with the command ‘makedir
drawer’, then change to this drawer with ‘cd drawer’ (please use
the name of the new directory instead of drawer in the two command
lines, e.g. TimeGuardian).

4. Now put the disk with the package into any drive (when you have
copied the files already to your hard disk then enter: ‘assign
TimeGuardian: sourcedrawer’, where
sourcedrawer is the drawer, where the files are on your hard disk).

5. To copy the programs enter: ‘copy TimeGuardian:bin/#? ""’.
Some messages appear, which files have been copied already.

6. When you want to copy the locale files (only german available at
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the moment) please enter: ‘copy
TimeGuardian:Catalogs/deutsch/#? Locale:Catalogs/deutsch’. You
should get a message about a copied file.

7. When you want to copy the english documentation files please enter
‘copy TimeGuardian:doc/english/#? Help:english’.

8. Please enter ‘copy TimeGuardian:env/#? envarc:’ and ‘copy
TimeGuardian:env/#? env:’ now.

9. Please enter ‘copy TimeGuardian:s/#? s:’.

10. When the background program shall be started, while booting, please
enter:

- start from Workbench:
‘copy TimeGuardian:bin/TGCron.info Sys:WBStartup’
Open the drawer ‘WBStartup’ on the Workbench and click at the
icon ‘TGCron’. Activate the menu ‘Icons=>Information...’
or press the keys Amiga i. A window should pop up. Now enter
in the string gadget ‘Default Tool:’: ‘path/TGCron’ (you
have to replace path with the full path, where you copied the
programs to). Leave the window with the gadget ‘Save’.
or:

- start from user-startup:
Add the following lines to the file ‘s:startup-sequence’ or
‘s:user-startup’: ‘run < nil: >nil: path/TGCron’ (you
have to replace path with the full path, where you copied the
programs to). You can do this with the help of an editor.

11. When you want to start the preferences program from the same
drawer as the standard preferences programs then enter: ‘copy
TimeGuardian:bin/TimeGuardian.info
Sys:Prefs’. You have to change the ‘Default Tool:’ like described
above at step 10 (from Workbench). Enter the name
‘path/TimeGuardian’ instead of ‘path/TGCron’!

12. To use your personal configuration start the program
‘TimeGuardian’ and leave it with the gadget ‘Save’.

It may be, that you run into problems with this above described
installation. This can be, when the assign ‘Help’ and the drawer
‘Help:english’ don’t exist. You can copy the documentation files to any
other drawer you want. You have to change the file
‘Envarc:AmigaGuide/path’ and ‘Env:AmigaGuide/path’ so, that the drawer,
where you copied the file ‘TimeGuardian.guide’ to, is
searched. E.g. add the line ‘dh0:docs’ when you copied the above file
to the drawer ‘dh0:docs’.

1.56 TimeGuardianE.guide/Was ist MUI?

What is ‘MUI’?

**************
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‘MUI’ is program package for users and developpers, that makes a
graphical user interface available to the programmer and user, with many
features. ‘TimeGuardian’ ist not able to run without ‘MUI’.
More precise, the preferences program ‘TimeGuardian’! Therefore
you have installed ‘MUI’ already or you have to do it before the
installation of ‘TimeGuardian’. Where you can obtain ‘MUI’,
see ‘MUI’ .

‘MUI’ (C) Registration for ‘MUI’ und (C)

1.57 TimeGuardianE.guide/Wo kann ich MUI registrieren lassen?

Where can I register for ‘MUI’?
===============================

This application uses
MUI - MagicUserInterface

(C) Copyright 1993/94 by Stefan Stuntz

‘MUI’ is a system to generate and maintain graphical user
interfaces. With the aid of a preferences program, the user of
an application has the ability to customize the outfit according
to his personal taste.

‘MUI’ is distributed as shareware. To obtain a complete package
containing lots of examples and more information about
registration please look for a file called ‘muiXXusr.lha’ (XX
means the latest version number) on your local bulletin boards or
on public domain disks.

If you want to register directly, feel free to send

DM 30.- or US-$ 20.-

to

Stefan Stuntz
Eduard-Spranger-Straße 7

80935 München
GERMANY

1.58 TimeGuardianE.guide/Index

Index

*****

MUI, about
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AREXX-Port
assumptions
Cron Setup, page
Daily Statistics, page
Date Format, gadget
Default, gadget
description of the installation
Description, TGCron
Error messages, TGCron
errormessages, TimeGuardian
Features
function, package
gadget Date Format
gadget Default
gadget Locale
gadget Quit
gadget Remove Cron
gadget Restore
gadget Save
gadget Type
gadget Use
Global Statistics, page
Hours, slider
Increment, slider
Informationen, TGCron
installation
Installation, with Installer
Installation, without Installer
Introduction
Locale, gadget
menu, Edit=>Last Saved
menu, Project=>Iconify
menu, Project=>Open
menu, Project=>Save as
menu, Project=>User
menu, Settings=>Create Icons?
menus TimeGuardian
Minutes, slider
Once a day, string gadget
Once a year, string gadget
online help
OnOff, string gadget
page About
page Cron Setup
page Daily Statistics
page Global Statistics
page Path Setup
Program, TimeGuardian
Programdescription
Programm, TGCron
programs, other
Quit, TimeGuardian
Quit, TGCron
Registrierung
Remove Cron, gadget
Restore, gadget
Runtime, string gadget
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Save, gadget
Sharewaregebühr
slider Hours
slider Increment
slider Minutes
slider Startuptime
start TimeGuardian
Start, TGCron
Starts, string gadget
Startuptime, slider
Stop, TGCron
string gadget Log Path
string gadget Starts
string gadget Once a day
string gadget Once a year
string gadget OnOff
string gadget Runtime
string gadget Timer fixed
string gadget Timer interval
Timer fixed, string gadget
Timer interval, string gadget
Type, gadget
Use, gadget

1.59 TimeGuardianE.guide/Registrierungsformular

Registration Form

*****************

To print the registration form from the program ‘Amiga-Guide’, do the
following:

* Select the menu ‘Edit=>Mark’, the mousepointer changes.

* Press the left mousebutton at the beginning of the registration
form and move the mouse to the bottom of the form. The selected
Text will change the background colour.

* Aktivate the menu ‘Edit=>Print Selected’.

--------8<-------------------------------------8<-----------------

REGISTRATIONS-FORM

Firm: ___________________________________________

First name, Name: ___________________________________________

Street: ___________________________________________

Location: ___________________________________________

Post code: ___________
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Country: ___________________________________________

Telephone: _____________

I want to become a registered user of the program package TimeGuardian
and therefore

o sent 20.- DM in notes.

o sent 15.- US-$ in notes.

Please send me the newest version of the above program package and my
personal key file to the above address.

____________________ ___________________________
Location, Date Signature

--------8<-------------------------------------8<-----------------
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